Agregar un campo a un formulario o informe

Puede agregar rápidamente campos a un formulario o informe mediante el panel Lista de campos. Cuando haga doble clic en un campo en el panel Lista de campos (o bien, si arrastra un campo desde la lista hasta el formulario o informe), Microsoft Office Access 2007 crea automáticamente el control apropiado para mostrar el campo, por ejemplo, una casilla o cuadro de texto y, a continuación, enlazar el control a ese campo.

Si no tiene un formulario o informe existente para agregar un campo para, vea crear un formulario mediante la herramienta formulario o crear un informe sencillo para ayudarle a empezar.

Sugerencia: En Access 2010, informes tienen buen aspecto y diseños de control, que ayuda a mantener las cosas alineadas!

¿Qué desea hacer?

Agregar un campo a un formulario o informe mediante el panel Lista de campos

Agregar un campo a un formulario o informe en la vista Diseño

Obtenga más información sobre el panel Lista de campos

Agregar un campo a un formulario o informe mediante el panel Lista de campos

  1. Abrir el informe en vista Diseño o la vista Diseño.

    Si no se muestra el panel Lista de campos, siga uno de estos procedimientos:

    • En la pestaña Formato, en el grupo Controles, haga clic en Agregar campos existentes Imagen del botón . Imagen del botón

    • Presione ALT+F8.

  2. En el panel Lista de campos, busque la tabla que contiene el campo que desea agregar. Para mostrar u ocultar la lista de campos de cada tabla, haga clic en el signo más (+) o signo menos (-) junto al nombre de tabla.

    Nota: Si la base de datos no contiene tablas, el panel Lista de campos está vacío.

  3. Cuando encuentre el campo que desea agregar, siga uno de estos procedimientos para agregar al formulario o informe:

    • Haga doble clic en el campo.

    • Arrastre el campo desde el panel Lista de campos hasta el formulario o informe.

    • Mantenga presionada la tecla CTRL y haga clic en varios campos y, a continuación, arrástrelos todos para el formulario o informe al mismo tiempo.

      Nota: Esta técnica puede usarse únicamente en los campos de la sección campos disponibles para esta vista del panel Lista de campos.

    • Agregue un intervalo de campos desde el panel Lista de campos hasta el formulario o informe haciendo lo siguiente:

    • Haga clic en el primer campo del intervalo.

    • Mantenga presionada la tecla MAYÚS y, a continuación, haga clic en el último campo del rango.

      Access selecciona los campos que haya hecho clic, así como todos los campos en entre.

    • Arrastre todos los campos seleccionados en el formulario o informe.

      Nota: Esta técnica sólo puede utilizarse en los campos de la sección campos disponibles para esta vista del panel Lista de campos.

  4. Office Access 2007 crea el control apropiado para mostrar cada campo y enlaza el control al campo. Además, Access crea una etiqueta adjunta para el control. Puede modificar la etiqueta haciendo clic en él para seleccionarlo y, a continuación, haciendo clic en nuevo para colocar el punto de inserción en la etiqueta. A continuación, puede modificar la etiqueta de la misma manera que desea editar texto en un documento.

  5. Si desea que el campo que aparece en un tipo de control distinto al que Access crea automáticamente diferente, puede cambiar el control a otro tipo. Sin embargo, solo puede cambiar a un tipo de control apropiado para ese campo. Por ejemplo, puede cambiar un cuadro combinado a un cuadro de texto o un cuadro de lista, pero no puede cambiar un cuadro combinado a un botón de comando.

    Cambiar el tipo de un control

    1. Abra el formulario o informe en la vista Diseño haciendo clic con botón secundario en el panel de navegación y, a continuación, haciendo clic en Vista Diseño Imagen del botón .

    2. Haga clic en el control que desee cambiar y, a continuación, haga clic en Cambiar a.

      Si el elemento de menú Cambiar a no está disponible, no hay ningún otro tipo de control que es adecuada para este campo. En caso contrario, Access muestra una lista de tipos de control.

    3. Haga clic en uno de los tipos de control disponibles para cambiar el control a ese tipo.

      El control permanece enlazado al campo, pero deberá configurar algunas propiedades para que el nuevo tipo de control funcione como desee. Para mostrar la hoja de propiedades para un control, haga clic en el control para seleccionarlo y, a continuación, presione F4.

Volver al principio

Agregar un campo a un formulario o informe en la vista Diseño

En general, con el panel Lista de campos es la manera más sencilla de agregar un campo a un formulario o informe. Sin embargo, también puede agregar un campo creando un control y, a continuación, se enlace a un campo. El procedimiento siguiente muestra cómo.

  1. Abra el formulario o informe en la vista Diseño haciendo clic con botón secundario en el panel de navegación y, a continuación, haciendo clic en La vista Diseño.

    Asistentes para controles    Puede utilizar a asistentes para controles para ayudarle a crear botones de comando, cuadros de lista, subformularios, cuadros combinados y grupos de opciones. Un Control de asistente le pida que una serie de preguntas acerca de cómo desea que el control de buscar y trabajar con y, a continuación, crea el control y establece las propiedades del control según sus respuestas. En la ficha Diseño, en el grupo controles, si no está resaltada la opción Utilizar asistentes para controles, haga clic en ella para resaltarla.

    Imagen del botón

    Si prefiere crear controles sin la Ayuda de los asistentes, haga clic en Utilizar asistentes para controles para que no está seleccionada.

    Imagen de botón

  2. En la ficha Diseño, en el grupo controles, haga clic en la herramienta para el tipo de control que desee agregar.

    Imagen de la cinta de Access

    Para determinar el nombre de una herramienta, coloque el puntero sobre él. Access muestra el nombre de la herramienta.

  3. Haga clic en la cuadrícula de diseño del formulario o informe donde desea colocar la esquina superior izquierda del control. Haga clic una vez para crear un control de tamaño predeterminado, o haga clic en la herramienta y, a continuación, arrastre en la cuadrícula de diseño del formulario para crear un control del tamaño que desee.

  4. Si seleccionó Utilizar asistentes para controles y el control que está colocando tiene asociado un asistente, el asistente se inicia y le guía a través de la configuración del control.

  5. Si no coloca el control perfectamente al primer intento, puede mover haciendo lo siguiente:

    1. Haga clic en el control para seleccionarlo.

    2. Sitúe el puntero sobre el control hasta que se convierta en un puntero de movimiento Puntero de desplazamiento .

    3. Haga clic y arrastre el control hasta la ubicación deseada.

Si utiliza a un asistente de control, el asistente puede contener pasos para ayudarle a enlazar el control a un campo. Si el asistente no enlaza el control a un campo y control es del tipo que puede mostrar datos (un cuadro de texto o un cuadro combinado, por ejemplo), debe escribir un nombre de campo o una expresión en la propiedad Origen del Control del control antes de que muestre los datos. Use el siguiente procedimiento para enlazar un control a un campo.

  1. Mostrar la hoja de propiedades del control haciendo clic en el control y, a continuación, presione F4.

  2. En la pestaña datos de la hoja de propiedades, haga clic en la flecha desplegable junto a la propiedad Origen del Control y seleccione el campo que desee mostrar en el control. También puede escribir una expresión en el cuadro Origen del Control.

    Para obtener más información sobre las expresiones, vea el artículo Crear una expresión.

Volver al principio

Obtenga más información sobre el panel Lista de campos

La siguiente lista contiene sugerencias sobre cómo trabajar con el panel Lista de campos que puede resultar útiles a la hora de agregar campos a un formulario o informe. Para mostrar el panel Lista de campos, abra un formulario o informe en vista Diseño o la vista Diseño y, a continuación, presione ALT+F8.

  • Si está vacía la propiedad Origen del registro del informe y arrastre un campo desde el panel Lista de campos hasta el formulario o informe, Access rellena automáticamente el formulario o la propiedad Origen del registro del informe para usted.

  • Si la propiedad formulario o informe Origen del registro es una instrucción SELECT o un nombre de tabla, puede alternar la presentación del panel Lista de campos entre los dos estados siguientes:

    • Todos los campos de base de datos    Muestra la sección campos disponibles para esta vista, la sección campos disponibles en tablas relacionadas (si existen esas tablas) y la sección campos disponibles en otras tablas (si existen esas tablas).

    • Solo los campos de origen de registro    Muestra únicamente la sección campos disponibles para esta vista.

      Para cambiar entre los dos modos, haga clic en Mostrar solo los campos en el origen del registro actual o Mostrar todas las tablas en la parte inferior del panel Lista de campos.

      Nota: Si ha establecido la propiedad formulario o del informe Origen de registros en una consulta guardada, el panel Lista de campos muestra únicamente la sección de campos disponibles para esta vista (no hay ninguna opción Mostrar todas las tablas en la parte inferior del panel Lista de campos ). Para modificar el origen de registros, haga clic en cualquiera de los campos y, a continuación, haga clic en Modificar origen del registro.

  • Si ha establecido la propiedad formulario o informe Origen del registro a una tabla y que, a continuación, arrastre un campo desde la sección campos disponibles en tablas relacionadas del panel Lista de campos al formulario o informe, Access cambia el Origen de registros del formulario o informe a una instrucción SELECT que incluya el campo va a agregar. Si Access no puede determinar cómo se relacionan las tablas, muestra el cuadro de diálogo Seleccionar relación para poder elegir la relación apropiada.

  • Si arrastra un campo desde la sección campos disponibles en otras tablas del panel Lista de campos hasta el formulario o informe, Access muestra el cuadro de diálogo Especificar relación. Debe utilizar este cuadro de diálogo para especificar una relación entre la otra tabla y el formulario o el origen del registro del informe. Si no está seguro de qué campos para escribir en este cuadro de diálogo, podría desea haga clic en Cancelar y, a continuación, examine las relaciones de tabla.

    Para obtener más información acerca de las relaciones, vea Guía de relaciones de tablas o crear, editar o eliminar una relación.

    Es posible que un campo en la sección campos disponibles en otras tablas del panel Lista de campos esté indirectamente relacionado con el origen de registros del formulario o informe a través de una de las tablas en la sección campos disponibles en tablas relacionadas. Si este es el caso, al arrastrar un campo de una de las tablas relacionadas al formulario o informe, puede que uno o más tablas a mover desde la sección campos disponibles en otras tablas a la sección de campos disponibles en tablas relacionadas.

  • Si el origen de registros del formulario o informe es una instrucción SELECT o una consulta guardada, puede ver y modificar el origen de registros en el generador de consultas haciendo clic en cualquier campo en el panel Lista de campos y, a continuación, haga clic en Modificar origen del registro. Si el origen de registros es una tabla, este comando invoca el generador de consultas en la tabla. Access le preguntará si desea crear una consulta basada en la tabla; Haga clic en para cambiar el origen de registros a una consulta o en No para salir de modificar el origen de registros.

  • Puede abrir una tabla en la vista Hoja de datos haciendo clic en Editar tabla junto al nombre de tabla, o haciendo clic en el nombre de tabla en el panel Lista de campos y, a continuación, haga clic en Abrir tabla en vista Hoja de datos.

  • Puede usar el panel Lista de campos para agregar una Campo de búsqueda a una tabla mediante el procedimiento siguiente:

    1. Haga clic en Editar tabla junto a la tabla en la que desea agregar el campo de búsqueda.

      La tabla se muestra en la vista Hoja de datos.

    2. Arrastre un campo desde el panel Lista de campos a la hoja de datos.

    3. Se inicia el Asistente para búsquedas. Siga las instrucciones del asistente. En la última página, haga clic en Finalizar.

  • Puede desacoplar el panel Lista de campos desde el lado derecho del área de trabajo de Access colocando el puntero en la barra de título del panel Lista de campos hasta que se convierta en un puntero de movimiento Puntero de desplazamiento y arrastrando el panel Lista de campos a la izquierda. La lista se puede colocar en cualquier lugar del área de trabajo o acoplar a la izquierda del área de trabajo arrastrándola a la izquierda.

Volver al principio

Notas: 

  • Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

  • Para su referencia, puede encontrar la versión en inglés de este artículo aquí. Todos los miembros de la comunidad de Microsoft pueden mejorar este artículo mediante el marco de colaboración en traducciones (CTF). Simplemente, mueva el puntero sobre cualquier frase del artículo y, a continuación, haga clic en "MEJORAR TRADUCCIÓN" en el widget CTF. Haga clic aquí para obtener más información acerca de CTF. Con el uso de CTF, el usuario acepta nuestras Condiciones del servicio.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×