Agregar o quitar complementos en Excel

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Los complementos proporcionan comandos y características opcionales para Microsoft Excel. De forma predeterminada, los complementos no están disponibles de forma inmediata en Excel, por lo que primero debe instalar y, en algunos casos, activar estos complementos para poder usarlos.

¿Busca información sobre los complementos de Office basados en HTML, CSS y JS? Si es así, vea obtener un complemento de Office para Excel.

Algunos complementos están integrados en Excel, como Solver y las herramientas para análisis. Otros complementos están disponibles en el centro de descarga y deben descargarse e instalarse en primer lugar. Por último, hay complementos creados por terceros, como un programador de su organización o un proveedor de soluciones de software. Pueden ser complementos del modelo de objetos componentes (COM), Complementos de Visual Basic para aplicaciones (VBA) y complementos de DLL. Estos complementos también deben instalarse para usarlos.

La mayoría de los complementos se pueden clasificar en tres tipos diferentes:

  • Complementos de Excel    Suelen incluir archivos de complemento de Excel (. XLAM), Excel 97-2003 (. xla) o complemento de DLL (. XLL) o son complementos de automatización. Es posible que algunos complementos de Excel, como Solver y las herramientas para análisis, estén disponibles después de instalar Excel o Microsoft Office. Por lo general, solo necesita activar estos complementos para usarlos.

  • Complementos descargables    Puede descargar Complementos adicionales para Excel desde descargas en Office.com.

  • Complementos personalizados    Los programadores y los proveedores de soluciones suelen diseñar complementos COM (modelo de objetos componentes) personalizados, Complementos de automatización, Complementos de VBA y complementos XLL. Debe instalarlos para poder usarlos.

Después de instalar o activar un complemento, es posible que el complemento y sus comandos estén disponibles en una de las siguientes ubicaciones:

  • Pestaña datos . Después de instalar y activar los complementos herramientas para análisis y Solver, los comandos análisis de datos y Solver están disponibles en el grupo análisis .

    Botón Análisis de datos en el grupo Análisis de datos

  • Pestaña fórmulas. Después de instalar y activar las herramientas para el euro, los comandos Euroconversión y formato de euro se muestran en el grupo soluciones .

    Conversión y formato del euro

  • Pestaña complementos. Se pueden agregar otros complementos a la pestaña Complementos . Esta pestaña se agrega a la cinta cuando se instala y activa el primer complemento que se muestra en la pestaña Complementos . Si no ve la pestaña Complementos , debe salir y reiniciar Excel.

Otros complementos, como la pestaña Introducción , están disponibles en otras ubicaciones de Excel, como una pestaña en la cinta de opciones, o a través de macros o menús personalizados.

Importante: Si es programador de software, puede usar este procedimiento para instalar o quitar un programa de automatización antes de diseñar los programas de instalación y desinstalación de su complemento.

Para activar un complemento de Excel    

  1. Haga clic en la pestaña Archivo, elija Opciones y después haga clic en la categoría Complementos.

  2. En el cuadro Administrar, haga clic en Complementos de Excel y después en Ir.

    Aparece el cuadro de diálogo complementos.

  3. En el cuadro complementos disponibles , active la casilla situada junto al complemento que desea activar y, a continuación, haga clic en Aceptar.

Si no puede encontrar el complemento que desea activar en el cuadro complementos disponibles , es posible que tenga que instalarlo.

Para instalar un complemento de Excel    

  • Para instalar un complemento que normalmente se instala con Excel, como Solver o las herramientas para análisis, ejecute el programa de instalación de Excel o Microsoft Office y elija la opción cambiar para instalar el complemento. Después de reiniciar Excel, el complemento debe aparecer en el cuadro complementos disponibles .

  • Algunos complementos de Excel se encuentran en su equipo y se pueden instalar o activar haciendo clic en examinar (en el cuadro de diálogo Complementos ) para ubicar el complemento y, a continuación, haciendo clic en Aceptar.

  • Algunos complementos de Excel requieren la ejecución de un paquete de instalación. Es posible que tenga que descargar o copiar el paquete de instalación en el equipo (un paquete de instalación suele ser un archivo con una extensión de nombre de archivo. msi) y, a continuación, ejecutarlo.

  • Otros complementos que no están disponibles en su equipo se pueden descargar e instalar a través de un explorador Web desde descargas o desde otros sitios de Internet o de un servidor de su organización. Siga las instrucciones de configuración para la descarga según sea necesario.

Para desactivar un complemento de Excel    

  1. Haga clic en la pestaña Archivo, elija Opciones y después haga clic en la categoría Complementos.

  2. En el cuadro Administrar, haga clic en Complementos de Excel y después en Ir.

  3. En el cuadro complementos disponibles , desactive la casilla situada junto al complemento que desea desactivar y, a continuación, haga clic en Aceptar.

    En muchos casos, cuando desactive un complemento, se eliminará de su grupo en la cinta de opciones. En otros casos, para quitar el complemento de la cinta de opciones, es posible que tenga que reiniciar Excel.

    Nota    Al desactivar un complemento, no se quita el complemento del equipo. Para quitar el complemento del equipo, debe desinstalarlo.

Para quitar un complemento de Excel    

Importante: Si originalmente instaló el complemento de Excel desde un servidor de archivos de red o desde una carpeta compartida, es posible que tenga que quitar el complemento de esa ubicación. Si ha instalado el complemento de Excel desde un CD y ha asignado la unidad de CD a una nueva letra de unidad después de instalar el complemento, tendrá que volver a instalar el complemento desde el CD. Si está ejecutando algún complemento de Excel desde el CD, debe desinstalar los complementos de Excel y, a continuación, reinstalarlos desde el CD.

  1. Haga clic en la pestaña archivo y, a continuación, en salir.

  2. En el panel de control, haga clic en programas y características (Windows 7 y Windows Vista) o en Agregar o quitar programas (Windows XP).

  3. Siga uno de estos procedimientos:

    • Si ha instalado Excel como parte de Microsoft Office, haga clic en Microsoft Office en la lista de programas instalados y, a continuación, haga clic en el botón cambiar .

    • Si ha instalado Excel de forma individual, haga clic en el nombre del programa en la lista de programas instalados y, a continuación, haga clic en el botón cambiar .

    • Si instaló el complemento desde el centro de descarga, haga clic en el nombre del programa en la lista de programas instalados y, a continuación, haga clic en el botón Desinstalar.

  4. Siga las instrucciones del programa de instalación.

Importante: Si es programador de software, puede usar este procedimiento para instalar o quitar un programa de automatización antes de diseñar los programas de instalación y desinstalación de su complemento. Si no es desarrollador, no es necesario que use este procedimiento. Póngase en contacto con el administrador del sistema que le proporcionó el complemento si desea instrucciones para instalar y quitar.

Agregar un complemento COM

  1. Haga clic en la pestaña Archivo, elija Opciones y después haga clic en la categoría Complementos.

  2. En el cuadro administrar , haga clic en Complementos comy, a continuación, haga clic en ir.

    Aparece el cuadro de diálogo complementos com .

  3. En el cuadro complementos disponibles , active la casilla situada junto al complemento que desea instalar y, a continuación, haga clic en Aceptar.

    Sugerencia    Si el complemento que desea usar no aparece en la lista del cuadro complementos disponibles , haga clic en Agregary, a continuación, busque el complemento.

Quitar un complemento COM

  1. Haga clic en la pestaña Archivo, elija Opciones y después haga clic en la categoría Complementos.

  2. En el cuadro administrar , haga clic en Complementos comy, a continuación, haga clic en ir.

    Aparece el cuadro de diálogo complementos com .

  3. En el cuadro complementos disponibles , desactive la casilla situada junto al complemento que desea quitar y, a continuación, haga clic en Aceptar.

    Nota    Esto quita el complemento de la memoria pero mantiene su nombre en la lista de complementos disponibles. No elimina el complemento del equipo.

  4. Para quitar un complemento COM de la lista de complementos disponibles y eliminar el complemento de su equipo, haga clic en su nombre en el cuadro complementos disponibles y, a continuación, haga clic en quitar.

Nota: Si es programador de software, puede usar este procedimiento para instalar o quitar un programa de automatización antes de diseñar los programas de instalación y desinstalación de su complemento. Si no es desarrollador, no es necesario que use este procedimiento. Póngase en contacto con el administrador del sistema que le proporcionó el complemento si desea instrucciones para instalar y quitar.

  1. Haga clic en la pestaña Archivo, elija Opciones y después haga clic en la categoría Complementos.

  2. En el cuadro Administrar, haga clic en Complementos de Excel y después en Ir.

    Aparece el cuadro de diálogo complementos.

  3. Para instalar un complemento de automatización, en el cuadro servidores de automatización disponibles , haga clic en automatizacióny, a continuación, haga clic en el complemento que desee.

    Sugerencia    Si el complemento que desea no está en la lista, haga clic en examinar, busque el complemento y, a continuación, haga clic en Aceptar.

  4. Para quitar un complemento de automatización, debe quitarlo del registro. Para obtener más información, consulta al administrador del sistema.

Algunos complementos están integrados en Excel, como Solver y las herramientas para análisis. Otros complementos están disponibles en el centro de descarga y deben descargarse e instalarse en primer lugar. Por último, hay complementos creados por terceros, como un programador de su organización o un proveedor de soluciones de software. Pueden ser complementos del modelo de objetos componentes (COM), Complementos de Visual Basic para aplicaciones (VBA) y complementos de DLL. Estos complementos también deben instalarse para usarlos.

La mayoría de los complementos se pueden clasificar en tres tipos diferentes:

  • Complementos de Excel    Suelen incluir archivos de complemento de Excel (. XLAM), Excel 97-2003 (. xla) o complemento de DLL (. XLL) o son complementos de automatización. Es posible que algunos complementos de Excel, como Solver y las herramientas para análisis, estén disponibles después de instalar Excel o Microsoft Office. Por lo general, solo necesita activar estos complementos para usarlos.

  • Complementos descargables    Puede descargar Complementos adicionales para Excel desde descargas en Office.com.

  • Complementos personalizados    Los programadores y los proveedores de soluciones suelen diseñar complementos COM (modelo de objetos componentes) personalizados, Complementos de automatización, Complementos de VBA y complementos XLL. Debe instalarlos para poder usarlos.

Después de instalar o activar un complemento, es posible que el complemento y sus comandos estén disponibles en una de las siguientes ubicaciones:

  • Pestaña datos . Después de instalar y activar los complementos herramientas para análisis y Solver, los comandos análisis de datos y Solver están disponibles en la pestaña datos de la cinta de opciones.

  • Pestaña Inicio . Se pueden agregar otros complementos a la pestaña Inicio .

Otros complementos, como la pestaña Introducción , están disponibles en otras ubicaciones de Excel, como una pestaña en la cinta de opciones, o a través de macros o menús personalizados.

Importante: Si es programador de software, puede usar este procedimiento para instalar o quitar un programa de automatización antes de diseñar los programas de instalación y desinstalación de su complemento.

Para activar un complemento de Excel preinstalado    

  1. En el menú herramientas , seleccione Complementos.

  2. En el cuadro complementos disponibles , active la casilla de verificación para el complemento que desea activar y, a continuación, haga clic en Aceptar.

Para instalar un complemento de Excel    

  • Algunos complementos de Excel se encuentran en su equipo y se pueden instalar o activar haciendo clic en examinar (en el cuadro de diálogo Complementos ) para ubicar el complemento y, a continuación, haciendo clic en Aceptar.

  • Algunos complementos de Excel requieren la ejecución de un paquete de instalación. Es posible que tenga que descargar o copiar el paquete de instalación en el equipo (un paquete de instalación suele ser un archivo con una extensión de nombre de archivo. msi) y, a continuación, ejecutarlo.

  • Otros complementos que no están disponibles en su equipo se pueden descargar e instalar a través de un explorador Web de descargas o de otros sitios de Internet, de un servidor de su organización o mediante la opción de almacenamiento integrado de Excel. Siga las instrucciones de configuración para la descarga según sea necesario.

    Para instalar complementos desde la tienda

    1. Haga clic en la pestaña Insertar en la cinta de opciones.

    2. Haz clic en el botón de tienda .

    3. Use el campo categorías o Buscar para buscar complementos.

    4. Haga clic en Agregar para instalar el complemento.

      Nota: Es necesario comprar algunos complementos.

Para quitar un complemento de Excel    

  1. Haga clic en la pestaña Insertar y, a continuación, haga clic en mis complementos.

  2. En los complementos de Office, haga clic en el menú de 3 puntos situado junto al complemento.

  3. Haga clic en Quitar.

  4. Lea el aviso que aparece en relación con otros dispositivos y haga clic en quitar.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×