Office
Iniciar sesión

Agregar los datos recolectados a través de los correos electrónicos a la base de datos de Access

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede recolectar o actualizar la información que recibe a través de correos electrónicos si utiliza Microsoft Access 2010 con Microsoft Outlook 2010. Access le guiará para crear un formulario de recolección de datos y enviarlo en un mensaje de correo electrónico. Cuando los destinatarios de correo electrónico devuelvan los formularios completados, puede hacer que los datos recolectados se procesen automáticamente y se almacenen en una base de datos de Access especificada. Este método de recolección de datos puede ahorrar el tiempo y esfuerzo normalmente empleados en las operaciones de copiado y pegado o en un proceso de entrada de datos manual. A continuación, se muestran algunos escenarios en los que este proceso se puede usar para recolectar datos:

Encuestas   : puede realizar una encuesta y compilar los resultados en primer lugar creando una base de datos de Access con las tablas necesarias para almacenar los resultados, y usar el Asistente para generar un formulario de encuesta y, a continuación, enviarlo por correo electrónico a los participantes de la encuesta. Al responder a los participantes, los datos de la encuesta se almacenan automáticamente en la base de datos.

Informes de estado   : ya sea el último estado de nivel de inventario o la información actualizada sobre asuntos pendientes, su equipo puede mantenerle informado mediante el envío de mensajes que contienen la información actual a intervalos regulares de correo electrónico.

Administración de eventos   : al organizar una conferencia o formación o los otros eventos, puede enviar una o más formularios como un correo electrónico para recopilar preferencias de contacto, información de viaje y hotel del mensaje y así sucesivamente. Si opta por que procesar automáticamente las respuestas, los participantes pueden cambiar sus preferencias en cualquier momento sin tener que le notifique y siempre tendrá acceso a los datos más recientes para tomar una decisión.

Este artículo explica todo lo necesario para utilizar el proceso, cómo comenzar a usar el asistente y, además, ofrece información adicional sobre los distintos pasos para poder realizar una selección más fundamentada mientras se sigue el asistente.

Nota: No podrá agregar los datos recopilados si el destinatario utiliza Hotmail o Yahoo para enviar el formulario de la colección de datos.

Antes de empezar

Si es la primera vez que recolecta datos mediante mensajes de correo electrónico, siga estos pasos:

  1. Asegúrese de que estén instaladas las siguientes aplicaciones en el equipo:

    • Access 2007 o Access 2010.

    • Outlook 2007 u Outlook 2010. Outlook debe estar instalado y configurado en el equipo que se utilizará para enviar los mensajes de correo electrónico. Si Outlook está instalado pero aún no se ha configurado, inicie esta aplicación y siga las instrucciones del Asistente para inicio de Outlook. Si desea obtener ayuda referente al asistente, vea la Ayuda de Outlook.

    • Si tiene pensado usar un formulario de InfoPath, asegúrese de que esté instalado InfoPath 2007 o una versión posterior y que InfoPath también esté instalado en los equipos de sus destinatarios.

    • Para poder ver y editar el formulario, sus destinatarios de correo electrónico deben tener InfoPath o un cliente de correo electrónico que sea compatible con el formato HTML instalado en los equipos.

      El formulario usado para recopilar datos mediante mensajes de correo electrónico no es un formulario de Access. El asistente genera un formulario especial en formato HTML o de InfoPath.

      Identifique la base de datos de destino. La base de datos puede tener formato .mdb o .accdb. Se admiten también los archivos .mde y .accde. Si no desea usar una base de datos existente, deberá crear una nueva.

  2. Identifique o cree las tablas que desee rellenar con los datos de las respuestas de correo electrónico. Si va a recopilar datos de las tablas existentes, asegúrese de que las tablas no son de solo lectura y que tiene los permisos necesarios para agregar o actualizar su contenido.

Nota: Los datos adjuntos, autonumeración, OLE y un campo multivalor tipos no se pueden recopilar mediante mensajes de correo electrónico

Si la operación de recopilación de datos rellena dos o más tablas, debe crear una consulta de selección y usarlo como origen de registros del formulario. Asegúrese de que la consulta incluye todos los campos necesarios de las tablas subyacentes. Si está utilizando una consulta existente, asegúrese de que la consulta no es de solo lectura y que tiene los permisos necesarios para agregar o actualizar su contenido. Para obtener más información acerca de cómo crear una consulta basada en dos o más tablas, vea el artículo Introducción a las consultas.

Almacene los datos como nuevos registros en las siguientes situaciones:

  • Si los datos rellenan varias tablas.

  • Si la tabla de destino no tiene un campo de clave principal. Los valores de clave principal son necesarios para asignar cada respuesta a un registro existente. Si la tabla de destino no tiene ningún campo de clave principal, agréguelo o asigne un campo existente que tenga valores únicos como clave principal.

  • Si la tabla de destino no tiene registros. Si la tabla está vacía, el asistente supone que desea agregar registros.

  • Si las direcciones de correo electrónico de los destinatarios no están almacenadas como un campo en la base de datos. Cuando recolecte datos para actualizar los registros, no podrá escribir manualmente las direcciones en el mensaje generado por el asistente. El campo de dirección debe estar presente en la tabla de destino o en una tabla que guarde relación con la tabla de destino.

Volver al principio

Introducción

  1. Abra la base de datos en la que se guardarán los datos recolectados.

  2. Para agregar los datos a una sola tabla, selecciónela en el panel de navegación. Para rellenar varias tablas relacionadas, seleccione la consulta enlazada a estas tablas.

  3. Siga cualquiera de estos procedimientos para iniciar el asistente:

    • En el grupo Recopilar datos de la ficha Datos externos, haga clic en Crear correo electrónico.

    • Haga clic con el botón secundario en la tabla o consulta y, a continuación, haga clic en Recopilar y actualizar datos a través de correo electrónico.

      Nota: Si la tabla no contiene todos los campos o sólo tiene la autonumeración, objeto OLE, datos adjuntos o tipos de campos de búsqueda multivalor, Access muestra el siguiente mensaje: seleccionado tabla o consulta no tiene ningún campo compatible con la recopilación de datos mediante correo electrónico .

Si la tabla contiene los campos que admiten la recopilación de datos, se inicia el asistente. Si la tabla de destino admite agregar y actualizar los datos, el asistente le guiará por los pasos necesarios para recopilar datos mediante mensajes de correo electrónico.

Use las siguientes secciones como referencia para las preguntas que es posible que tenga a través de los siguientes siete pasos principales del proceso.

  1. Elija el tipo de formulario de entrada de datos que desea enviar

  2. Elija si desea recopilar datos nuevos o actualizar los datos existentes

  3. Especificar los datos que desee recopiladas

  4. Especificar el procesamiento de datos automático o manual

  5. Seleccione cómo desea especificar las direcciones de correo electrónico de los destinatarios

  6. Revise y especifique la lista de destinatarios

  7. Crear y enviar el mensaje de correo electrónico

Volver al principio

Elija el tipo de formulario de entrada de datos que desea enviar

Seleccione el tipo de formulario en función de la facilidad de uso para el remitente y los destinatarios.

Formulario HTML seleccione    Un formulario HTML puede ver y editar cualquier usuario cuyo cliente de correo electrónico compatible con HTML

Seleccione Microsoft InfoPath formulario    Verá esta opción que InfoPath únicamente si está instalado en su equipo. Seleccione esta opción únicamente si los destinatarios que todos tengan InfoPath y Outlook instalado en sus equipos. Un formulario de InfoPath ofrece una mejor entrada de datos y el entorno de edición

La siguiente página del asistente que se muestre depende de si el objeto de destino admite la actualización de los datos. Si el objeto es una consulta basada en dos o más tablas o si es una tabla que no tiene un campo de clave principal o que no contiene registros, el asistente supone que desea agregar registros nuevos e indica que seleccione los campos del formulario. En todos los demás casos, el asistente indica que especifique si desea agregar o actualizar los datos antes de pedir que seleccione los campos del formulario.

Volver al principio

Elegir si desea recolectar nuevos datos o actualizar los datos existentes

Especifique lo que desea hacer con los datos. El tipo de formulario que usa afecta al número de registros nuevos que le puede enviar un destinatario en una sola respuesta. En el caso de la actualización de datos, el número de registros que debe actualizar un destinatario identifica el número de formularios previamente completados que se van a incluir en un mensaje.

Nota: Para agregar nuevos registros, escriba las direcciones de correo electrónico en el cuadro Dirección de correo electrónico cuando se cree el mensaje. Para actualizar los datos existentes, las direcciones de correo electrónico de los destinatarios deben estar almacenadas como un campo en la tabla o consulta subyacente o en una tabla relacionada.

Volver al principio

Especificar los datos que desea recolectar

Al elegir los campos que se van a incluir en el formulario, no es necesario insertar todos los campos existentes en la tabla o consulta subyacente. No obstante, se deben cumplir las siguientes condiciones:

  • Campos requeridos:    Campos marcados con un símbolo de asterisco (*) son necesarios. Si está recopilando registros nuevos, el asistente incluirá automáticamente todos los campos cuya propiedad requerido está establecida en . Si cualquier registro de campos obligatorios están en blanco, Access no puede agregar el registro a la tabla.

  • No admite tipos de campo:    No podrá incluir determinados tipos de campo en el formulario como Autonumeración, datos adjuntos, objeto OLE o campos de búsqueda multivalor.

  • Campo de clave principal:    El usuario podrá escribir un valor en el campo al agregar registros la respuesta no se procesará si el valor especificado ya está en uso.

    Nota: Para cada campo que incluya, en Propiedades de campo, especifique una etiqueta y haga clic en sólo lectura si no desea que el usuario para cambiar los datos de ese campo.

Volver al principio

Especificar el procesamiento de datos automático o manual

Puede seleccionar un procesamiento automático o manual de las respuestas. El procesamiento automático significa que, cuando recibe las respuestas, Outlook y Access trabajan juntos para exportar los datos a las tablas de destino en la base de datos. El procesamiento automático le puede ahorrar tiempo y esfuerzo. El procesamiento manual solo significa que inicia la operación de exportación para transferir los datos desde la carpeta especificada de Outlook, a la tabla de destino de Access.

Las respuestas se exportan correctamente a la tabla de destino siempre y cuando se cumplan las siguientes condiciones en el momento en que llegan al buzón:

  • Outlook ya debe estar ejecutándose en el equipo. Si no es así, el procesamiento comenzará la próxima vez que se inicie Outlook.

  • Access no puede estar protegido mediante contraseña y no debe estar abierto en modo exclusivo. No se debe modificar el nombre ni la ubicación de la base de datos después de enviar el mensaje de correo electrónico.

  • Los nombres de las tablas y consultas y las propiedades de los campos incluidos en el formulario no pueden haber cambiado desde el envío del mensaje de correo electrónico.

  • Debe disponer de los permisos necesarios para agregar o actualizar el contenido de la consulta y las tablas subyacentes.

    Nota: Si el procesamiento automático tiene errores, intente solucionar los problemas y, a continuación, exporte manualmente las respuestas que hayan generado un error. Las respuestas que lleguen a la bandeja de entrada después de que se han resuelto los problemas seguirán procesándose automáticamente.

Definir propiedades para controlar el procesamiento automático de las respuestas

Si desea especificar otra carpeta de Outlook para almacenar las respuestas, en la página del asistente Especifique cómo desea procesar las respuestas, haga clic en el nombre de la carpeta. En el cuadro de diálogo Seleccionar carpeta, seleccione otra carpeta o haga clic en Nuevo para crear una nueva carpeta.

Si hace clic en Definir propiedades para controlar el procesamiento automático de las respuestas para modificar o ajustar las opciones de importación, vea la tabla siguiente para obtener información sobre las opciones disponibles:

Opción

Resultado

Descartar las respuestas de aquellos a quienes no se ha enviado el mensaje   

Active esta casilla de verificación si desea que se procesen de manera automática únicamente las respuestas enviadas por los destinatarios originales del mensaje. Las respuestas de otros usuarios se almacenan en la carpeta de destino pero no se procesan automáticamente.

Aceptar varias respuestas de cada destinatario   

Active esta casilla de verificación si desea que se procese de manera automática únicamente la primera respuesta de cada destinatario. La segunda respuesta y las subsiguientes se almacenan en la carpeta de destino pero no se procesan automáticamente.

Nota: Esta configuración controla únicamente el número de respuestas y no el número de registros en una sola respuesta que se procesen. En otras palabras, si envía un formulario de InfoPath, un usuario podrá enviar varios registros en una sola respuesta y Access procesará automáticamente todos los registros en la respuesta, incluso si no está activada esta casilla de verificación.

Solo permitir actualizaciones a los datos existentes   

Cuando los destinatarios usan un formulario de InfoPath para actualizar los datos, pueden enviar nuevos registros además de actualizaciones de los registros existentes. Active esta casilla de verificación si desea procesar únicamente las actualizaciones de los registros existentes.

Número de respuestas que deben procesarse   

Escriba el número total de respuestas (de todos los destinatarios) que desee procesar automáticamente. Si desea que se procesen automáticamente todas las respuestas, especifique un valor alto, como 5000, en el cuadro de texto. Las respuestas que se reciban después de alcanzarse el valor especificado se almacenarán en la carpeta de destino pero no se procesarán automáticamente.

Fecha y hora en que detener   

Especifique cuándo debe detenerse el procesamiento automático de las respuestas para este mensaje de correo electrónico. Las respuestas que se reciban después de la hora y la fecha especificadas se almacenarán en la carpeta de destino, pero no se procesarán automáticamente.

Para cambiar estas opciones más adelante, en la ficha Datos externos, en el grupo Recopilar datos, haga clic en Administrar respuestas. En el cuadro de diálogo Administrar mensajes de recopilación de datos, seleccione el mensaje para el que desee cambiar la configuración y, a continuación, haga clic en Opciones de mensajes. Los cambios que realice en el cuadro de diálogo afectarán a todas las respuestas subsiguientes que reciba a ese mensaje.

Procesar manualmente las respuestas

Para controlar qué respuestas se procesan y cuándo se procesan, no seleccione la opción de procesamiento automático. Las respuestas se almacenarán en una carpeta especificada de Outlook hasta que las seleccione y haga clic con el botón secundario en cada respuesta en la carpeta, y luego haga clic en Exportar datos a Microsoft Access en el menú contextual.

En algunos casos, es posible que tenga que procesar manualmente las respuestas que no se hayan procesado automáticamente.

Antes de exportar los datos recuerde lo siguiente

  • La base de datos de Access no debe estar abierta en modo exclusivo y no se debe modificar el nombre ni la ubicación de la base de datos después de que se envía el mensaje de correo electrónico.

  • Los nombres de las tablas y consultas y las propiedades de los campos incluidos en el formulario no pueden haber cambiado desde el envío del mensaje de correo electrónico.

  • Debe disponer de los permisos necesarios para agregar o actualizar el contenido de la consulta y las tablas subyacentes.

Volver al principio

Seleccionar cómo desea especificar las direcciones de correo electrónico de los destinatarios

Si está recolectando solo información nueva, puede especificar las direcciones de correo electrónico de dos maneras:

  • Escriba cada una de las direcciones en el mensaje de correo electrónico de Outlook o seleccione las direcciones de una libreta de direcciones.

  • Use el campo de dirección de correo electrónico en la tabla o consulta de la base de datos de Access actual.

    Nota: Cuando está recolectando datos para actualizar los registros existentes, no aparece este cuadro de diálogo porque las direcciones de correo electrónico de los destinatarios deben estar primero disponibles como campo de la base de datos.

Escribir las direcciones de correo electrónico directamente en Outlook

Si especifica los destinatarios en Outlook, puede obtener la vista previa del mensaje y personalizarlo antes de enviarlo. El cuerpo del mensaje incluye una breve introducción y un formulario. Se recomienda no realizar ningún cambio en el formulario. Si se altera la estructura del formulario, puede que no se procese la respuesta.

Usar las direcciones de correo electrónico almacenadas en un campo de la base de datos

La opción para seleccionar un asociado tabla hace referencia a tablas relacionadas. Para ver o editar las relaciones de tabla en la base de datos, en la ficha Herramientas de base de datos., en el grupo relaciones, haga clic en relaciones

Para obtener más información acerca de las relaciones, vea el artículo Guía de relaciones de tabla.

Volver al principio

Revisar y especificar la lista de destinatarios

El último paso principal supone obtener la vista previa del mensaje de correo electrónico y personalizarlo, ajustar la lista de destinatarios y enviar el mensaje de recolección de datos.

Crear y enviar el mensaje de correo electrónico

Cuando el asistente indica que ya puede crear el mensaje de correo electrónico y también le muestra cómo ver el estado de un mensaje de correo electrónico mediante el comando Administrar respuestas, pueden aparecer algunos mensajes de advertencia. En la siguiente tabla, se describen cada una de las advertencias y las acciones que se pueden realizar para resolverlas:

Mensaje de advertencia mensaje

Descripción

S solución

Algunos registros no contienen una dirección válida en el campo especificado de dirección de correo electrónico. No se devolverán datos para estas filas.

El campo de dirección de correo electrónico seleccionado contiene valores nulos.

Si desea recopilar datos para cada registro, salga del asistente y reemplace los valores nulos por direcciones de correo electrónico. A continuación, reinicie el asistente.

La base de datos está abierta en un estado de bloqueo exclusivo. Hasta que se libere el bloqueo exclusivo, no se podrá ejecutar el procesamiento automático de los mensajes de correo electrónico.

La base de datos está abierta en modo exclusivo.

Si optó por procesar automáticamente las respuestas, el procesamiento no se llevará a cabo porque Access no puede agregar ni actualizar una base de datos que esté abierta en un estado de bloqueo exclusivo. Cierre la base de datos y vuelva a abrirla de modo no exclusivo inmediatamente después de enviar el mensaje.

Estos mensajes de correo electrónico pueden contener datos de carácter confidencial.

Está recopilando datos para actualizar registros existentes, y el formulario que está a punto de enviar se completará previamente con datos existentes.

Si algunos campos del formulario incluyen datos confidenciales, vaya al paso del asistente donde seleccionó los campos y quite los campos que contienen datos confidenciales del formulario.

Después de obtener la vista previa del mensaje y de personalizarlo, puede filtrar el campo de direcciones de correo electrónico y seleccionar los destinatarios. Elija las direcciones de correo electrónico que desee usar activando las correspondientes casillas de verificación. Si ve un cuadro de diálogo en que aparecen direcciones de correo electrónico no válidas, tome nota de las direcciones de la lista y haga clic en Salir. Compruebe las direcciones no válidas, realice las correcciones necesarias e intente volver a enviar el mensaje.

Volver al principio

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×