Adjuntar archivos y gráficos a los registros de una base de datos

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Usar la característica de datos adjuntos en Microsoft Office Access 2007 para agregar uno o más elementos de datos: Microsoft Office Word 2007 documentos, presentaciones Microsoft Office PowerPoint 2007, imágenes y así sucesivamente, a los registros de la base de datos. En este artículo se proporciona información básica y los pasos necesarios para configurar una base de datos para usar datos adjuntos y para adjuntar y administrar datos.

En este artículo

¿Por qué usar datos adjuntos?

Agregar un campo de datos adjuntos a una tabla

Adjuntar archivos directamente a tablas

Usar datos adjuntos con formularios e informes

Guardar archivos adjuntos en otras ubicaciones

Quitar archivos adjuntos

Utilizar datos adjuntos sin mouse u otro dispositivo señalador

Referencia de datos adjuntos

¿Por qué usar datos adjuntos?

Puede usar los datos adjuntos para almacenar varios archivos en un solo campo e incluso puede almacenar varios tipos de archivos en ese campo. Por ejemplo, supongamos que usted es propietario de una base de datos de contactos de trabajo. Ahora puede adjuntar uno o varios currículos al registro de cada contacto, además de una foto del contacto.

Los datos adjuntos también sirven para almacenar datos de manera más práctica. En versiones anteriores de Access, se empleaba una tecnología denominada vinculación e incrustación de objetos (OLE) para almacenar imágenes y documentos. De manera predeterminada, OLE creaba un equivalente a la imagen o al documento con formato de mapa de bits. Dichas imágenes podía tornarse demasiado grandes, hasta diez veces más grandes que el archivo original. Cuando se quería ver una imagen o un documento desde la base de datos, OLE mostraba la imagen de mapa de bits en lugar del archivo original. Con los datos adjuntos, se pueden abrir documentos y otros archivos que no sean de imágenes en los programas que les corresponden, de modo que, desde Access, se pueden realizar búsqueda en estos archivos y editarlos.

Además, OLE precisa programas denominados servidores OLE para funcionar. Por ejemplo, si almacena archivos de imagen con formato JPEG en una base de datos de Access, cada equipo en el que se use la base de datos requerirá otro programa que esté registrado como servidor OLE para imágenes JPEG. Por el contrario, Office Access 2007 almacena los archivos adjuntos en sus formatos nativos sin imágenes auxiliares y no necesita instalar software adicional para poder ver las imágenes desde la base de datos.

Los datos adjuntos y reglas de diseño de base de datos

De forma predeterminada, cada campo de una base de datos relacional contiene solo una parte de los datos. Por ejemplo, si un campo de dirección contiene más de una dirección, sería difícil si no imposible búsqueda de direcciones. Por lo tanto, la primera vista los datos adjuntos parecen romper las reglas de diseño de base de datos, porque puede adjuntar más de un archivo: un dato: a un campo. Sin embargo, datos adjuntos no rompe las reglas de diseño, porque como adjuntar archivos a un registro, Office Access 2007 crea una o más tablas de sistema y usa esas tablas en segundo plano para normalizar los datos. No puede ver o trabajar con esas tablas.

Para obtener información sobre cómo ver tablas de otro sistema, vea el artículo Guía del panel de navegación. Para obtener información acerca del diseño de base de datos, vea el artículo conceptos básicos del diseño de base de datos.

Formas de usar archivos adjuntos

Recuerde estas instrucciones cuando trabaje con archivos adjuntos:

  • Puede adjuntar archivos solo a las bases de datos que cree en Office Access 2007 y que usan el formato de archivo .accdb nuevo. No puede compartir datos adjuntos entre una base de datos de Office Access 2007 (.accdb) y una base de datos en el formato de archivo anterior (.mdb).

  • Debe crear un campo en una tabla y establecer ese campo en el tipo de datos datos adjuntos. Después de establecer el tipo de datos como datos adjuntos, no se puede cambiar.

  • Se pueden almacenar varios archivos en un solo registro. Por ejemplo, se pueden almacenar imágenes y archivos creados con programas de procesamiento de texto y de hoja de cálculo.

  • Puede adjuntar un máximo de dos gigabytes de datos (el tamaño máximo para una base de Access). El tamaño de cada archivo no puede sobrepasar 256 megabytes.

  • Utilice el cuadro de diálogo Datos adjuntos para agregar, editar y administrar los datos adjuntos. Para abrir el cuadro de diálogo directamente desde el campo de datos adjuntos de una tabla, haga doble clic en el campo. Si desea administrar los datos adjuntos desde un formulario o verlos desde un informe, agregue el control de datos adjuntos al formulario o al informe y, a continuación, enlace el control al campo de la tabla de datos adjuntos subyacente.

  • De manera predeterminada, el control de datos adjuntos representa imágenes y muestra el icono de programa que corresponde a otros tipos de archivo. Por ejemplo, supongamos que tiene una foto, un currículum vítae y un dibujo de Microsoft Office Visio 2007 adjuntos a un registro. Si se desplaza por los datos adjuntos, el control representa la imagen y muestra los iconos de programa correspondientes al documento y al dibujo.

  • Cuando abre el cuadro de diálogo datos adjuntos desde una tabla o un formulario, puede agregar, quitar, editar y guardar archivos adjuntos. Cuando se abre el cuadro de diálogo datos adjuntos desde un informe, puede guardar los archivos adjuntos solo a otra ubicación.

  • Access comprimirá los archivos adjuntos, excepto si ya lo están en su formato nativo. Por ejemplo, los archivos JPEG se comprimen con el programa gráfico que los crea y, por lo tanto, Access no los comprime.

  • Si el programa que se utilizó para crear el archivo adjunto está instalado en el equipo, podrá abrir y editar dicho archivo con ese programa.

  • Los archivos adjuntos se pueden guardar en ubicaciones del disco duro o en la red. Posteriormente, puede editar los datos adjuntos y comprobar si le gustan los cambios antes de volver a guardarlos en la base de datos.

  • Los datos adjuntos se pueden manipular mediante programación.

En las siguientes secciones se explica cómo agregar y administrar los datos adjuntos.

Parte superior de la página

Agregar un campo de datos adjuntos a una tabla

Para usar datos adjuntos en Office Access 2007, primero debe agregar un campo de datos adjuntos al menos una de las tablas en la base de datos. Office Access 2007 proporciona dos formas de agregar un campo de datos adjuntos a una tabla. Puede agregar el campo en la vista Hoja de datos, o puede agregar en la vista Diseño. En esta sección se explica cómo usar ambas técnicas.

Agregar un campo de datos adjuntos en la vista Hoja de datos

  1. Con la tabla abierta en la vista Hoja de datos, haga clic en la primera columna vacía disponible. Para buscar una columna en blanco, busque las palabras Agregar nuevo campo en el encabezado de columna.

  2. En la ficha hoja de datos, en el grupo formato y tipo de datos, haga clic en la flecha abajo situada junto a Tipo de datos y, a continuación, haga clic en datos adjuntos.

    Access establecerá el tipo de datos del campo en Datos adjuntos y colocará un icono en la fila de encabezado del campo. La siguiente figura muestra un nuevo campo Datos adjuntos. Observe el icono del clip de la fila de encabezado del campo. De forma predeterminada, no se puede escribir texto en la fila de encabezado de los campos Datos adjuntos.

    Un nuevo campo de tabla establecido al tipo de datos Datos adjuntos

  3. Guarde los cambios.

    Recuerde que no se puede convertir el nuevo campo a otro tipo de datos, pero puede eliminar el campo si cree que ha realizado un error.

Agregar un campo de datos adjuntos en la vista Diseño

  1. En el panel de navegación, haga clic en la tabla que desea cambiar y haga clic en Vista Diseño Imagen de botón en el menú contextual.

  2. En la columna Nombre de campo, seleccione una fila vacía y escriba un nombre para el campo Datos adjuntos.

  3. En la misma fila, bajo Tipo de datos, haga clic en Datos adjuntos.

  4. Guarde los cambios.

    Recuerde que no se puede convertir el nuevo campo a otro tipo de datos, pero puede eliminar el campo si cree que ha realizado un error.

  5. En la ficha Diseño, en el grupo Vistas, haga clic en la flecha que está debajo del botón Vista y, a continuación, elija Vista Hoja de datos para abrir la tabla que desea usar.

    Imagen de la cinta de Access

    -o bien-

    Haga clic con el botón secundario en la pestaña de documento de la tabla y haga clic en Vista Hoja de datos en el menú contextual.

    -o bien-

    En el panel de navegación, haga clic con el botón secundario en la tabla y haga clic en Abrir en el menú contextual.

  6. Continúe con los siguientes pasos.

Parte superior de la página

Adjuntar archivos directamente a tablas

Después de agregar un campo de datos adjuntos a una tabla, puede adjuntar los archivos a los registros de la tabla sin necesidad de crear un formulario de entrada de datos. También puede ver datos adjuntos sin usar un formulario, pero recuerde que al ver datos adjuntos directamente desde tablas, debe hacerlo en los programas que se utilizaron para crear los archivos o en un programa que admita ese tipo de archivo. Por ejemplo, si abre un documento de Word que está conectado a una tabla, también se inicia Word y ver el documento desde Word, Access no. Si Word no está instalado en su equipo, un cuadro de diálogo aparece y le pide que seleccione un programa para ver el archivo.

Agregar datos adjuntos a una tabla

  1. Con la tabla que contiene el campo de datos adjuntos abierta en la vista Hoja de datos, haga doble clic en el campo de datos adjuntos.

    Aparece el cuadro de diálogo datos adjuntos. La figura siguiente muestra el cuadro de diálogo.

    Cuadro de diálogo Datos adjuntos

  2. Haga clic en Agregar.

    Aparecerá el cuadro de diálogo Elegir archivo.

  3. Utilice la lista Buscar en para desplazarse al archivo o archivos que desea adjuntar al registro, selecciónelos y, a continuación, haga clic en Abrir.

    Puede seleccionar varios archivos de cualquier tipo de datos compatible. Para obtener una lista de los tipos de datos compatibles, vea Referencia de datos adjuntos más adelante en este artículo.

  4. En el cuadro de diálogo Datos adjuntos, haga clic en Aceptar para agregar los archivos a la tabla.

    Access agrega los archivos al campo e incrementará el número que indica los datos adjuntos como corresponda. La siguiente ilustración muestra un campo con dos imágenes adjuntadas:

    Un campo de datos adjuntos con dos datos

  5. Repita estos pasos según proceda para agregar archivos al campo activo o a otros campos de la tabla.

Abrir los archivos adjuntos desde una tabla

  1. Con la tabla abierta en la vista Hoja de datos, haga doble clic en la celda del campo de datos adjuntos.

  2. En el cuadro de diálogo Datos adjuntos, haga doble clic en el archivo que desea abrir.

    - o -

    Seleccione el archivo y haga clic en Abrir.

    Se iniciará el programa asociado al archivo y se abrirá el archivo adjunto (los archivos de Excel se abrirán en Excel, etc.).

    Es posible que algunos archivos de imagen se abran con el Visor de imágenes y fax de Microsoft Windows. Si desea hacer algo más que ver la imagen, haga clic con el botón secundario en la imagen y, a continuación, seleccione Editar. De este modo, se iniciará el programa utilizado para crear el archivo si está instalado en el equipo.

Guardar los cambios en un archivo adjunto

  1. Según proceda, utilice el programa de origen para editar el archivo.

  2. Guarde los cambios que realice en el archivo y cierre el programa de origen. Tenga en cuenta que, siempre que modifique un archivo adjunto, los cambios se guardarán en la carpeta temporal de Internet en la unidad de disco duro del equipo. Vea las notas al final de esta sección para obtener más información acerca de esa carpeta.

  3. Para guardar los cambios permanentemente, vuelva a Access y, en el cuadro de diálogo Datos adjuntos, haga clic en Aceptar.

    Aparece un mensaje similar al siguiente:

    Un mensaje que indica que se guarden los cambios realizados en los datos adjuntos

  4. Haga clic en para guardar los cambios.

    Notas: 

    • Cuando abre un archivo adjunto en su programa de origen para verlo o editarlo, Access crea una copia temporal del archivo en una carpeta temporal. Si modifica el archivo y guarda los cambios desde el programa de origen, Access guarda los cambios en la copia temporal. Cuando vuelva a Access y haga clic en Aceptar para cerrar el cuadro de diálogo Datos adjuntos, Access le pedirá que guarde otra vez el archivo adjunto. Haga clic en para copiar el archivo modificado a la base de datos, o bien en No para dejar el archivo intacto en la base de datos.

    • Para buscar la ubicación de la carpeta de archivos temporales, siga estos pasos:

      1. Inicie Windows Internet Explorer.

      2. En el menú Herramientas, haga clic en Opciones de Internet.

      3. En la pestaña General, haga clic en configuración.

        Aparece el cuadro de diálogo de configuración. La ruta de acceso de la carpeta aparece en la sección de la carpeta de archivos temporales de Internet.

Parte superior de la página

Usar datos adjuntos con formularios e informes

Cuando necesite utilizar datos adjuntos con un formulario o un informe, use el control de datos adjuntos. Este control representa automáticamente los archivos de imágenes a medida que se va moviendo por los registros de una base de datos. Si adjunta otros tipos de archivos, como documentos o dibujos, el control de datos adjuntos muestra el icono correspondiente al tipo de archivo. Por ejemplo, cuando se adjunta una presentación, aparece el icono de PowerPoint. El control también permite examinar todo tipo de archivos adjuntos y abrir el cuadro de diálogo Datos adjuntos. Si abre el cuadro de diálogo desde un formulario, puede agregar, quitar, editar y guardar los datos adjuntos. Si lo abre desde un informe, solo puede guardar los datos adjuntos en el disco duro o en una ubicación de red, ya que los informes son de solo lectura por diseño.

Los pasos descritos en las secciones siguientes explican cómo agregar un control de imagen a un formulario o informe, cómo desplazarse por registros, adjuntar archivos y ver datos adjuntos. Recuerde que solo se puede desplazar por los datos adjuntos cuando un registro determinado contiene más de un archivo de datos adjuntos.

Agregar el control de datos adjuntos a un formulario o informe

En esta sección se explica cómo agregar el control de datos adjuntos a un formulario o informe y, a continuación, enlazar el control a un campo de datos adjuntos de una tabla subyacente. Siga los mismos pasos al agregar el control de datos adjuntos a un formulario o informe. Antes de empezar, recuerde que al menos una de las tablas de la base de datos debe tener un campo datos adjuntos. Para obtener información sobre cómo agregar un campo datos adjuntos, vea Agregar un campo de datos adjuntos a una tabla más adelante en este artículo.

Como diseño de formularios e informes puede ser procesos complejos, los pasos en estas secciones se supone que ya tiene una base de datos con al menos una tabla y un formulario o informe. Para obtener información sobre la creación de tablas, formularios o informes, consulte los artículos siguientes:

Agregar el control de datos adjuntos

  1. En el panel de navegación, haga clic con el botón secundario en el formulario o informe que desee cambiar y haga clic en Vista Diseño en el menú contextual.

  2. En la ficha Diseño, en el grupo Herramientas, haga clic en Agregar campos existentes.

    Aparecerá el panel Lista de campos, que incluye los campos de la tabla que proporcionan los datos para el formulario o informe. La lista representa los campos de datos adjuntos como expansibles (es decir, se puede hacer clic en el signo más o menos situado junto al campo).

    La siguiente ilustración muestra un campo de datos adjuntos típico en el panel Lista de campos.

    Un campo de datos adjuntos en el panel Lista de campos

  3. Arrastre todo el campo de datos adjuntos desde la lista hasta el formulario (los elementos principal y secundario) y colóquelo en la ubicación que desee del formulario.

    Access se ocupa de colocar un control de datos adjuntos en el formulario y de enlazar el control al campo de la tabla.

  4. Si es preciso, haga clic con el botón secundario en el control y, a continuación, seleccione Propiedades para mostrar la hoja de propiedades del control. Establezca o cambie las propiedades del control para que se correspondan con el resto del formulario o informe.

  5. Guarde los cambios y, a continuación, haga clic con el botón secundario en la pestaña de documento y haga clic en Vista Formulario o Vista Informe para abrir el formulario o el informe y verlo.

    Si el campo subyacente contiene archivos de imágenes, el control representa esos archivos. Si el campo contiene otro tipo de archivo, como un documento de Word o una presentación de PowerPoint, el control muestra el icono correspondiente al tipo de archivo.

Administrar datos adjuntos mediante un formulario

Después de agregar un control de datos adjuntos a un formulario, puede agregar, quitar, editar y guardar los archivos adjuntos directamente desde el formulario. Si un registro contiene varios datos adjuntos, también puede desplazarse por los archivos adjuntos, lo que no es posible cuando se trabaja con una tabla.

Nota: La persona que haya diseñado el formulario puede haberlo configurado como de solo lectura. En ese caso, el cuadro de diálogo Datos adjuntos se podrá usar únicamente para guardar los archivos adjuntos en el disco duro o en una ubicación de red.

Adjuntar un archivo

  1. Abra el formulario que muestra los datos adjuntos y busque el registro al que desea adjuntar un archivo.

  2. Seleccione el control de datos adjuntos : el control que está enlazado al campo Datos adjuntos.

    Aparecerá la minibarra de herramientas: Minibarra de herramientas Datos adjuntos

    Nota: Si agregó el control de datos adjuntos a la sección de hoja de datos de un formulario dividido, no aparecerá la minibarra de herramientas. Para obtener más información sobre los formularios divididos, vea el artículo crear un formulario dividido.

  3. Haga clic en el botón Ver datos adjuntos (el icono de clip) para abrir el cuadro de diálogo Datos adjuntos.

  4. En el cuadro de diálogo, haga clic en Agregar.

    Aparecerá el cuadro de diálogo Elegir archivo.

  5. Utilice la lista Buscar en para desplazarse al archivo que desea adjuntar y, a continuación, haga clic en Abrir.

  6. Repita los pasos 4 y 5 si necesita adjuntar más archivos.

Desplazarse por los archivos adjuntos

Nota: Los pasos descritos en esta sección hacen referencia a formularios e informes.

  1. Abra el formulario o informe que muestra los datos adjuntos.

  2. Desplácese al registro que contiene los archivos adjuntos.

  3. Haga clic en el control de imagen que muestra los archivos adjuntos.

    Aparece la minibarra de herramientas.

  4. Haga clic en la flecha Atrás (izquierda) o Adelante (derecha) para desplazarse por los archivos adjuntos. Si desea conocer los nombres de los archivos, haga clic en el botón Ver datos adjuntos para abrir el cuadro de diálogo Datos adjuntos. Los nombres de los archivos adjuntos aparecen en la lista Datos adjuntos.

Parte superior de la página

Guardar archivos adjuntos en otras ubicaciones

Los pasos descritos en esta sección hacen referencia a tablas, formularios e informes. Puede guardar uno de los archivos que se han adjuntado a un registro determinado, o todos ellos, en ubicaciones del disco duro o en la red. Recuerde que, cuando elija guardar todos los archivos, no podrá guardar algunos de ellos; deberá guardarlos todos. Para guardar solamente algunos archivos determinados, tendrá que hacerlo de uno en uno.

  • Abra la tabla, el formulario o el informe que contiene los datos adjuntos y, a continuación, abra el cuadro de diálogo Datos adjuntos.

Abrir el cuadro de diálogo datos adjuntos desde una tabla

  • Abra la tabla en la vista Hoja de datos y, a continuación, haga doble clic en el campo que contiene los datos adjuntos que desea guardar.

Abrir el cuadro de diálogo datos adjuntos desde un formulario o informe

  1. Abra el formulario o informe que muestra los datos adjuntos.

  2. Desplácese al registro que contiene los archivos adjuntos.

  3. Haga clic en el control de imagen que muestra los archivos adjuntos.

    Aparece la minibarra de herramientas.

  4. Haga clic en el botón Ver datos adjuntos.

Guardar un solo archivo de datos adjuntos

  1. En el cuadro de diálogo Datos adjuntos, haga clic en Guardar como.

    Aparecerá el cuadro de diálogo Guardar datos adjuntos.

  2. Utilice la lista Guardar en para desplazarse a la nueva ubicación del archivo y, a continuación, haga clic en Guardar.

Guardar todos los datos adjuntos

  1. En el cuadro de diálogo Datos adjuntos, haga clic en Guardar todos.

    Aparecerá el cuadro de diálogo Guardar datos adjuntos.

  2. Utilice la lista Buscar en para desplazarse a la nueva ubicación de los archivos y, a continuación, haga clic en Guardar.

Parte superior de la página

Quitar archivos adjuntos

Los pasos descritos en esta sección hacen referencia a tablas y formularios.

Quitar un archivo de datos adjuntos

  1. Haga doble clic en el campo de datos adjuntos de la tabla para abrir el cuadro de diálogo Datos adjuntos.

    - o -

    En el formulario (en la vista Diseño o en la vista Formulario), desplácese al registro que contiene los datos adjuntos que desea quitar y haga clic en el botón Ver datos adjuntos de la minibarra de herramientas para abrir el cuadro de diálogo.

  2. En el cuadro de diálogo Datos adjuntos, seleccione el archivo que desea eliminar y haga clic en Quitar.

Parte superior de la página

Usar datos adjuntos sin mouse u otro dispositivo señalador

En la sección siguiente, se explica cómo utilizar el teclado para colocar el foco en el panel de navegación y abrir la tabla, el formulario o el informe que contiene archivos adjuntos. También se explica cómo examinar archivos adjuntos y abrir el cuadro de diálogo Datos adjuntos.

Abrir una tabla, un formulario o un informe desde el panel de navegación

  1. Presione F11.

    Nota: Si el panel de navegación está cerrado, al presionar F11, se abre y se coloca el foco en el panel. Si el panel está abierto, al presionar F11, se cierra. Presione F11 otra vez para abrir el panel y cambiar el foco a él.

  2. Utilice las teclas FLECHA ARRIBA y FLECHA ABAJO para seleccionar la tabla, el formulario o el informe que desea abrir.

  3. Presione ENTRAR para abrir el objeto seleccionado.

    Si abre una tabla, Access coloca el cursor en el primer campo de la tabla. Si abre un formulario o informe, Access coloca el foco en el primer campo.

Ver datos adjuntos de tablas

  1. Utilice las teclas de dirección según sea preciso para mover el cursor al campo de datos adjuntos que desee.

  2. Presione la BARRA ESPACIADORA.

    Aparecerá el cuadro de diálogo Datos adjuntos.

  3. Presione la tecla TAB para moverse entre los botones del cuadro de diálogo y desde los botones hasta la lista de archivos adjuntos en Datos adjuntos.

    Nota: Los registros pueden contener más de un archivo de datos adjuntos. Si necesita seleccionar un archivo de datos adjuntos en una lista que contiene al menos dos, presione la tecla TAB para desplazarse a la lista de archivos y, a continuación, use las teclas de dirección para seleccionar el archivo que desee. Después, presione la tecla TAB para volver a los botones y seleccione la acción que desee.

  4. Cuando seleccione el archivo y el botón que desee, presione ENTRAR.

  5. Cuando termine, presione la tecla TAB o utilice las teclas FLECHA ARRIBA y FLECHA ABAJO para seleccionar Aceptar y, a continuación, presione ENTRAR.

Desplazarse por datos adjuntos desde un formulario o informe

Estos pasos se aplican únicamente si tiene un teclado Microsoft Natural Keyboard y cuando un registro contiene más de un dato adjunto.

  1. Presione la tecla TAB cuantas veces sea preciso para mover el foco al control de datos adjuntos. De forma predeterminada, Access resalta el control y la etiqueta asociada al control, si es que la hay.

  2. Presione la tecla de aplicación.

    Aparece un menú contextual.

  3. Presione la tecla TAB o utilice las teclas de dirección para seleccionar adelante o Atrás y, a continuación, presione ENTRAR.

  4. Repita el paso 2 cuantas veces sea preciso para desplazarse entre los archivos adjuntos.

Abrir el cuadro de diálogo Datos adjuntos desde un formulario o informe

Estos pasos se aplican únicamente si tiene un teclado Microsoft Natural Keyboard.

  1. Presione la tecla TAB cuantas veces sea preciso para mover el foco al control de datos adjuntos. De forma predeterminada, Access resalta el control y la etiqueta asociada al control, si es que la hay.

  2. Presione la tecla de aplicación.

    Aparece un menú contextual.

  3. Presione la tecla TAB o utilice las teclas de dirección para seleccionar Ver datos adjuntos y, a continuación, presione ENTRAR.

    Aparecerá el cuadro de diálogo Datos adjuntos.

  4. Presione la tecla TAB para moverse entre los botones del cuadro de diálogo y desde los botones hasta la lista de archivos adjuntos en Datos adjuntos (Haga doble clic para modificar).

    Los registros pueden contener más de un archivo de datos adjuntos. Si necesita seleccionar un archivo de datos adjuntos en una lista que contiene al menos dos, presione la tecla TAB para desplazarse a la lista de archivos y, a continuación, use las teclas de dirección para seleccionar el archivo que desee. Después, presione la tecla TAB para volver a los botones y seleccione la acción que desee.

  5. Cuando seleccione el archivo y el botón que desee, presione ENTRAR.

  6. Cuando termine, presione la tecla TAB o utilice las teclas de dirección para seleccionar Aceptar y, a continuación, presione ENTRAR.

Parte superior de la página

Referencia de datos adjuntos

En las secciones siguientes, se facilita información de referencia acerca de datos adjuntos, incluidos los formatos de archivo de imágenes y documentos que admiten los datos adjuntos, convenciones de nomenclatura de archivos e información sobre cómo adjuntar archivos a registros mediante programación.

Formatos de archivo de imagen admitidos

Office Access 2007 es compatible con los siguientes formatos de archivo gráfico de forma nativa, lo que significa que el control de datos adjuntos los representa sin necesidad de software adicional.

BMP (mapa de bits de Windows)

RLE (mapa de bits de codificación en longitud de recorrido)

DIB (mapa de bits independiente del dispositivo)

GIF (formato de intercambio de gráficos)

JPEG, JPG, JPE (Joint Photographic Experts Group)

EXIF (formato de archivo intercambiable)

PNG (Portable Network Graphics)

TIFF, TIF (Tagged Image File Format)

ICON, ICO (icono)

WMF (Windows Metafile Format)

EMF (metarchivo mejorado)

Formatos admitidos para los documentos y otros archivos

En general, puede adjuntar cualquier archivo que se creó con uno de los programas de 2007 Microsoft Office system. También puede adjuntar archivos de registro (. log), archivos de texto (.text, .txt) y archivos .zip comprimidos.

Convenciones de nomenclatura

Los nombres de los archivos adjuntos pueden incluir cualquier carácter Unicode admitido por el sistema de archivos NTFS utilizado en Microsoft Windows NT (NTFS). Por otra parte, los nombres de archivo deben seguir estas directrices:

  • Los nombres no deben superar los 255 caracteres, incluyendo las extensiones de nombre de archivo.

  • Los nombres no pueden contener los caracteres siguientes: signos de interrogación (?), comillas ("), barras diagonales o diagonales inversas (/ \), corchetes de apertura o de cierre (< >), asteriscos (*), barras verticales (|), dos puntos (:) o marcas de párrafo (¶).

Tipos de archivos que comprime Access

Si adjunta cualquiera de los siguientes tipos de archivo a una base de datos, Access lo comprime excepto si ya lo está en su formato nativo.

Extensión de archivo

¿Se comprime?

Motivo

.jpg, .jpeg

No

Ya está comprimido

.gif

No

Ya está comprimido

.png

No

Ya está comprimido

.tif, .tiff

.exif

.bmp

.emf

.wmf

.ico

.zip

No

Ya está comprimido

.cab

No

Ya está comprimido

.docx

No

Ya está comprimido (archivo Metro)

.xlsx

No

Ya está comprimido (archivo Metro)

.xlsb

No

Ya está comprimido (archivo Metro)

.pptx

No

Ya está comprimido (archivo Metro)

Formatos de archivo bloqueados

Office Access 2007 bloquea los siguientes tipos de archivos adjuntos. En este momento, no puede desbloquear ninguno de los tipos de archivo que se enumeran.

.ade

.ins

.mda

.scr

.adp

.isp

.mdb

.sct

.app

.its

.mde

.shb

.asp

.js

.mdt

.shs

.bas

.jse

.mdw

.tmp

.bat

.ksh

.mdz

.url

.cer

.lnk

.msc

.vb

.chm

.mad

.msi

.vbe

.cmd

.maf

.msp

.vbs

.com

.mag

.mst

.vsmacros

.cpl

.mam

.ops

.vss

.crt

.maq

.pcd

.vst

.csh

.mar

.pif

.vsw

.exe

.mas

.prf

.ws

.fxp

.mat

.prg

.wsc

.hlp

.mau

.pst

.wsf

.hta

.mav

.reg

.wsh

.inf

.maw

.scf

Adjuntar archivos a registros mediante programación

Office Access 2007 expone un modelo de objetos e interfaces de programación para adjuntar archivos a registros mediante programación utilizando Visual Basic para aplicaciones (VBA). Para obtener información sobre cómo adjuntar archivos mediante programación, vea los artículos "LoadFromFile" y "SaveToFile", en Microsoft Developer Network: http://msdn.microsoft.com.

Parte superior de la página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!