Actualizar los datos de una base de datos

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

En este artículo se explica cómo actualizar datos existentes. Microsoft Office Access 2007 proporciona varias herramientas para actualizar los registros existentes, incluidas las hojas de datos, formularios, consultas, buscar y reemplazar y la nueva característica de recopilación de datos.

Durante el proceso, recuerde que la actualización de datos no es el mismo proceso que introducir nuevos datos. Para obtener información sobre cómo introducir nuevos datos en una base de datos, vea el artículo Agregar uno o varios registros a una base de datos.

En este artículo...

Cómo afecta el diseño de la base de datos a la actualización

¿Cómo afectan los tipos de datos a la actualización

¿Cómo afectan a la actualización de propiedades de campo de tabla

Usar un formulario para actualizar los datos

Use una hoja de datos para actualizar los datos

Usar una consulta de actualización para cambiar datos existentes

Usar una consulta de datos anexados para agregar registros a tablas

Use la recopilación de datos para actualizar los registros

Use las actualizaciones en cascada para cambiar los valores de clave principales y externos

Cómo afecta el diseño de la base de datos a la actualización

Lea esta sección si es nuevo en Access o no está familiarizado con los conceptos de bases de datos relacionales. Actualizaciones de gran tamaño se hacen mucho más fáciles de realizar si conoce algunos de los principios básicos de diseño de base de datos.

Una base de datos de Access no es un archivo en el mismo sentido como un documento de Microsoft Office Word 2007 o un conjunto de diapositivas de Microsoft Office PowerPoint 2007. En su lugar, una base de datos de Access típica es un conjunto de tablas, además de un conjunto de objetos que se genera sobre esas tablas, formularios, informes, consultas y así sucesivamente.

Además, estos objetos deben cumplir con un conjunto de principios de diseño o la base de datos se deficiencias o incluso no funcionar. A su vez, estos principios de diseño afectan a cómo introducir datos. Recuerde los siguientes puntos acerca de los objetos de base de datos y diseño durante el proceso.

  • Con algunas excepciones (como un tipo de lista llamado lista de valores), Access almacena todos los datos en una o más tablas. El número de tablas depende del diseño y la complejidad de la base de datos. Aunque se pueden ver o actualizar los datos en un formulario, un informe, o en los resultados devueltos por una consulta, Access almacena los datos únicamente en tablas.

  • Cada tabla debe almacenar datos para un único problema, categoría o finalidad. Por ejemplo, una tabla de información de contacto de la empresa no debe contener información de ventas. Si es así, puede resultar difícil, si no imposible encontrar la información correcta.

  • Cada uno de los campos de una tabla debe aceptar únicamente un tipo de datos. Por ejemplo, no debe almacenar notas en un campo definido para aceptar números. Si intenta escribir texto en ese campo, Access muestra un mensaje de error.

  • Con una excepción, los campos en un registro deberían aceptar un único valor. Por ejemplo, una base de datos correctamente diseñada impedirá introducir más de una dirección en un campo de dirección. Esto difiere Microsoft Office Excel 2007, que, de forma predeterminada, permite escribir cualquier número de nombres, direcciones o imágenes en una sola celda, a menos que establezca la celda de modo que acepte tipos limitados de datos.

    Sin embargo, Office Access 2007 también proporciona una nueva característica denominada campo multivalor. Campos multivalor sirven para adjuntar varios fragmentos de datos a un único registro y para crear listas que acepten varios valores. Por ejemplo, puede adjuntar un archivo de texto, un conjunto de diapositivas Office PowerPoint 2007 y cualquier número de imágenes a un registro en la base de datos. También puede crear una lista de nombres y seleccionar tantos de esos nombres según sea necesario. El uso de campos multivalor puede parecer interrumpir las reglas de diseño de base de datos que puede almacenar más de un elemento de datos por campo de tabla, pero no es así, porque Access aplica las reglas "entre"bastidores, almacenando los datos en tablas ocultas especiales.

Los siguientes vínculos le llevan a artículos que ofrecen más información sobre los temas y las características descritas en esta sección.

Volver al principio

¿Cómo afectan los tipos de datos a la actualización

Lea esta sección si es nuevo en Access o no está familiarizado con los conceptos de bases de datos relacionales. Actualizaciones de gran tamaño se hacen mucho más fáciles de realizar si conoce algunos de los principios básicos de diseño de base de datos.

Al diseñar una tabla de base de datos, seleccione un tipo de datos para cada uno de los campos de la tabla, un proceso que ayuda a garantizar la entrada de datos más precisa. Por ejemplo, suponga que especifique el tipo de datos número para un campo porque necesita calcular cifras de ventas. Si alguien intenta escribir texto en ese campo, Access muestra un mensaje de error y no permite que el usuario guarde el registro modificado, un paso que le ayuda a proteger los datos.

Mostrar cómo ver los tipos de datos

Access ofrece ahora dos formas de ver los tipos de datos para un campo de tabla. Puede usar los comandos en la ficha hoja de datos o puede abrir la tabla en la vista Diseño. Los siguientes conjuntos de pasos explican cómo usar ambas técnicas.

Ver los tipos de datos usando comandos en la ficha Hoja de datos

  1. En el panel de navegación, haga doble clic en la tabla que desee usar.

  2. Haga clic en el campo que desea investigar.

  3. En la ficha hoja de datos, en el grupo formato y tipo de datos, haga clic en la flecha abajo de la lista Tipo de datos ver el tipo de datos establecido para el campo.

Ver los tipos de datos en la vista Diseño

  • En el panel de navegación, haga clic con el botón secundario en la tabla y haga clic en Vista Diseño en el menú contextual.

    Access abre la tabla en la cuadrícula de diseño y la sección superior de la cuadrícula muestra el nombre y tipo de datos de cada campo de tabla.

    Campos en la vista Diseño

El tipo de datos establecido para cada campo de tabla proporciona el primer nivel de control sobre qué puede o no se puede escribir en un campo. En algunos casos, un tipo de datos impide que entren cualquier información en absoluto. La siguiente tabla enumeran los tipos de datos que Office Access 2007 proporciona y describe cómo afectan a la entrada de datos.

Tipo de datos

Efecto en la entrada de datos

Texto

Campos de texto aceptan caracteres de texto o numéricos, incluidos delimitadas listas de elementos. Un campo de texto acepta un número más pequeño de caracteres que un campo Memo: de 0 a 255 caracteres. En algunos casos, puede usar funciones de conversión para realizar cálculos con los datos en un campo de texto.

Memo

Puede introducir grandes cantidades de texto y datos numéricos en este tipo de campo. Además, si el Diseñador de base de datos establece el campo para que admita el formato de texto enriquecido, puede aplicar los tipos de formato que se encuentran normalmente en los programas de procesamiento de texto, como Office Word 2007. Por ejemplo, puede aplicar diferentes fuentes y tamaños de fuente a caracteres específicos del texto y que estén en negrita o cursiva y así sucesivamente. También puede agregar etiquetas de lenguaje de marcado de hipertexto (HTML) a los datos.

Para obtener más información sobre cómo usar el formato de texto enriquecido en un campo Memo, vea el artículo formato de datos en filas y columnas.

Como campos de texto, también puede ejecutar funciones de conversión con los datos en un campo Memo.

Número

Puede introducir números solo en este tipo de campo y puede realizar cálculos con los valores de un campo numérico.

Fecha y hora

Puede escribir solo fechas y horas en este tipo de campo. Según cómo el Diseñador de base de datos del campo, puede encontrarse con las siguientes condiciones:

  • Si el Diseñador de base de datos establece una máscara de entrada para el campo (una serie de caracteres literales y marcadores de posición que aparecen cuando se selecciona el campo), debe escribir datos en los espacios y el formato de la máscara. Por ejemplo, si ve una máscara DD_MMM_AAAA, debe escribir una fecha en ese formato en los espacios proporcionados, por ejemplo, 11 de Oct de 2006. No puede escribir un nombre completo del mes (por ejemplo, julio) o un valor de año de dos dígitos.

  • Si el diseñador no ha creado una máscara de entrada para controlar cómo introducir una fecha u hora, puede especificar el valor con formato de hora o fecha válida. Por ejemplo, puede escribir 11 de octubre de 2006, 11/10/06 o 11 de octubre de 2006.

  • El Diseñador de base de datos puede aplicar un formato de presentación para el campo. En ese caso, si no máscara de entrada hay, puede escribir un valor en casi cualquier formato, pero Access muestra las fechas de acuerdo con el formato de presentación. Por ejemplo, puede escribir 11/10/2006, pero puede establecer el formato de presentación para que muestre el valor como 11-Oct-2006.

    Para obtener más información acerca de las máscaras de entrada, vea el artículo formato de datos en filas y columnas.

Moneda

Puede escribir solo los valores de moneda en este tipo de campo. Además, no tiene que introducir manualmente un símbolo de moneda. De forma predeterminada, Access aplica el símbolo de moneda (¥, £, $ etc.) especificado en la configuración regional de Windows.

Autonumeración

No puede especificar o cambiar los datos de este tipo de campo en cualquier momento. Access incrementa los valores de un campo Autonumeración cuando se agrega un nuevo registro a una tabla.

Sí/no

Al hacer clic en un campo que se establece en este tipo de datos, Access muestra una casilla de verificación o una lista desplegable, según el formato del campo. Si se da formato el campo para mostrar una lista, puede seleccionar en la lista, en función del formato aplicado al campo o No, Verdadero o Falso, o en o desactivado . No puede especificar valores en la lista o cambiar los valores de la lista directamente desde un formulario o una tabla.

Objeto OLE

Use este tipo de campo al que desea mostrar los datos de un archivo creado en otro programa. Por ejemplo, puede mostrar un archivo de texto, un gráfico de Excel o un grupo de diapositivas de PowerPoint en un campo objeto OLE.

Datos adjuntos proporcionan una manera rápida, más fácil y más flexible para ver los datos de otros programas. Consulte la entrada de datos adjuntos, más adelante en esta tabla, para obtener más información.

Hipervínculo

Puede introducir los datos en este tipo de campo y, a continuación, Access lo convertirá en una dirección Web. Por ejemplo, si escribe un valor en el campo, Access coloca el texto con el localizador uniforme de recursos (URL) de este modo: http://www..comde texto del usuario. Si escribe una dirección Web válida, el vínculo funcionará; de lo contrario, se mostrará un mensaje de error. Además, modificar hipervínculos existentes puede ser difícil porque haciendo clic en un campo de hipervínculo con el mouse se inicia el explorador Web y abre el sitio especificado en el vínculo. Para editar un campo de hipervínculo, seleccione un campo adyacente, use las teclas TAB o flecha para mover el foco al campo de hipervínculo y, a continuación, presione F2 para habilitar la edición.

Datos adjuntos

Puede adjuntar datos de otros programas a este tipo de campo, pero no puede escribir o en caso contrario, escriba el texto o datos numéricos.

Para obtener información sobre cómo usar un campo datos adjuntos, vea el artículo Adjuntar archivos y gráficos a los registros de la base de datos.

Asistente para búsquedas

El Asistente para búsquedas no es un tipo de datos. En su lugar, use el Asistente para crear dos tipos de listas desplegables: listas de valores y campos de búsqueda. Una lista de valores usa una lista delimitada de elementos que se especifican manualmente al usar el Asistente para búsquedas. Estos valores pueden ser independientes de cualquier otro dato u objeto en la base de datos.

En cambio, un campo de búsqueda usa una consulta para recuperar datos de una o varias de las tablas en una base de datos o en otra ubicación, como un servidor que ejecuta Windows SharePoint Services 3.0. El campo de búsqueda, a continuación, muestra los datos en una lista desplegable. De forma predeterminada, el Asistente para búsquedas establece el campo de tabla en el tipo de datos número.

Puede trabajar con campos de búsqueda directamente en las tablas y también en formularios e informes. De forma predeterminada, los valores de un campo de búsqueda aparecen en un tipo de control de lista denominado cuadro combinado: una lista con una flecha desplegable: Lista de búsqueda en blanco . Dependiendo de cómo ha configurado el Diseñador de base de datos del campo de búsqueda y el cuadro combinado, puede modificar los elementos de la lista y agregar elementos a la lista. Para ello, el Diseñador de base de datos debe establecer una propiedad para el campo de búsqueda (la propiedad se denomina Limitar a la listay el diseñador tiene que desactivarla).

Si no puede editar directamente los valores de una lista de búsqueda, debe agregar o cambiar los datos en la lista de valores predefinida, o en la tabla que sirve como el origen del campo de búsqueda. Para obtener información sobre cómo hacerlo, vea la sección titulada "Editar los elementos de un campo de búsqueda" en el artículo Agregar uno o varios registros a una base de datos.

Por último, cuando se crea un campo de búsqueda, si lo desea puede establecer que admiten varios valores. Cuando lo haga, la lista resultante muestra una casilla de verificación junto a cada elemento de lista, y puede activar o desactivar todos los elementos según sea necesario. Esta ilustración muestra una lista con varios valores típica:

Lista de casillas de verificación.

Para obtener información sobre cómo crear campos de búsqueda multivalor y usar las listas resultantes, vea los artículos usar una lista que almacene varios valores y Guía de campos multivalor.

Volver al principio

¿Cómo afectan a la actualización de propiedades de campo de tabla

Lea esta sección si es nuevo en Access o no está familiarizado con los conceptos de bases de datos relacionales. No puede realizar correctamente actualizaciones a gran escala a menos que entender cómo afectan a la actualización de las propiedades del conjunto de campos de tabla.

Al diseñar una base de datos, normalmente comenzará diseñando una o más tablas. Decidir qué tipos de datos que contendrá cada tabla, definir claves principales: un campo que identifica inequívocamente cada registro (fila), para cada tabla y crear las relaciones entre las tablas.

Como parte de ese proceso, Establece propiedades de los campos en cada tabla. Por ejemplo, puede establecer un campo de texto para aceptar no más de 50 caracteres, y puede establecer un campo numérico para aceptar únicamente los valores de moneda.

Puede establecer la mayoría de propiedades de campo mediante la vista Diseño. Sin embargo, también puede establecer algunas propiedades mediante los comandos de los grupos en la cinta de opciones, parte de la interfaz de usuario de Microsoft Office Fluent. Por ejemplo, puede definir formatos visuales para los campos texto y Memo mediante los comandos del grupo fuente en la pestaña Inicio. Para obtener más información sobre el uso de los comandos, vea el artículo formato de datos en filas y columnas.

Mostrar cómo establecer o cambiar las propiedades de un campo de tabla.

Access ofrece ahora dos formas de ver las propiedades de un campo de tabla, puede usar los comandos en la ficha hoja de datos o puede abrir la tabla en la vista Diseño. Los siguientes conjuntos de pasos explican cómo usar ambas técnicas.

Ver propiedades de tabla usando comandos en la ficha Hoja de datos

  1. En el panel de navegación, haga doble clic en la tabla que desee usar.

  2. Haga clic en la ficha hoja de datos y use los comandos del grupo formato y tipo de datos para ver las propiedades de cada campo de tabla.

Ver propiedades de tabla en la vista Diseño

  1. En el panel de navegación, haga clic en la tabla y haga clic en Vista Diseño.

    Access abre la tabla en la cuadrícula de diseño.

  2. En la parte inferior de la cuadrícula, en Propiedades de campo, haga clic en la pestaña General, si aún no está seleccionada.

    O bien:

    Para ver las propiedades de un campo de búsqueda, haga clic en la pestaña búsqueda.

    Un campo de búsqueda es un campo de tabla que utiliza una lista codificada de valores o una consulta que recupera los valores de una o más tablas en una base de datos. De forma predeterminada, el campo de búsqueda presenta esos valores en el formulario de una lista. Según cómo un diseñador de base de datos del campo de búsqueda, puede seleccionar uno o varios elementos de esa lista.

    Campos de búsqueda suelen confunden los nuevos usuarios de Access porque aparece una lista de elementos en una ubicación (la lista que Access crea a partir de los datos en el campo de búsqueda), pero los datos pueden encontrarse en otra ubicación (la tabla que contiene los datos). Recuerde que cuando actualiza los datos en un campo de búsqueda, debe actualizar la tabla de origen (la segunda ubicación). No puede actualizar un campo de búsqueda de la lista.

La siguiente tabla enumera las propiedades de la tabla que tienen el mayor efecto en la entrada de datos y explica su impacto.

Propiedad

Ubicación en la cuadrícula de diseño de tabla

Valores posibles

Comportamiento al intentar escribir datos

Tamaño del campo

Pestaña General

0 y 255

El límite de caracteres se aplica solo a los campos establecidos en el tipo de datos de texto. Si intenta introducir más el número especificado de caracteres, el campo los corta.

Requerido

Pestaña General

Sí/no

Cuando activado, esta propiedad obliga a escribir un valor en un campo y Access no permite guardar nuevos datos hasta que se complete el campo. Cuando se desactiva, el campo aceptará valores nulos, lo que significa que el campo puede estar en blanco.

Nota: Un valor nulo no es lo mismo que un cero. Cero es un dígito y Access puede usar en los cálculos. Un valor nulo es un valor que falta, no definido o desconocido.

Permitir cadenas de longitud cero

Pestaña General

Sí/no

Cuando activa, puede especificar cadenas de longitud cero, cadenas que no contienen caracteres. Para crear una cadena de longitud cero, escriba un par de comillas dobles sin espacio entre ellas ("") y presione ENTRAR.

Indizado

Pestaña General

Sí/no

Cuando el índice de un campo de tabla, Access impide que se agreguen valores duplicados.

Máscara de entrada

Pestaña General

Conjuntos predefinidos o personalizados de caracteres literales y marcadores de posición

Una máscara de entrada obliga a escribir datos en un formato predefinido. Las máscaras aparecen al seleccionar un campo en una tabla o un control en un formulario. Por ejemplo, suponga que haga clic en un campo de fecha y ve este conjunto de caracteres: MMM-DD-YYYY. Este conjunto de caracteres se conoce como una máscara de entrada. Obliga a escribir los valores de mes como abreviaturas de tres letras, como OCT y el valor de año como cuatro dígitos, en lugar de dos. Así que si ve esa máscara, escriba una fecha como 15-OCT-2006.

Nota: Recuerde que las máscaras de entrada sólo controlan cómo se escriben datos, no cómo Access muestra estos datos. Por ejemplo, puede introducir una fecha como 15-OCT-2006, pero Access podría almacenar el valor como 10152006, es decir, con n caracteres de formato. A continuación, cuando se ve la fecha en una tabla, formulario o informe, Access se pueden establecer para que se muestre como 15/10/2006.

Para obtener más información sobre cómo crear y usar las máscaras de entrada, vea el artículo formato de datos en filas y columnas.

Control de pantalla

Ficha búsqueda

Valores dependen del tipo de datos establecido para el campo

Para campos de texto y número, puede elegir entre un cuadro de texto, un cuadro de lista o un control de cuadro combinado. Sí/no haya campos, puede elegir entre una casilla de verificación, un cuadro de texto o un control de cuadro combinado.

Nota: Si selecciona un valor distinto de Cuadro de lista o Un cuadro a combinado, Access oculta las propiedades restantes en la pestaña búsqueda.

Tipo de origen de la fila

Ficha búsqueda

Tabla o consulta
lista de valores
lista de campos

Si establece el cuadro de propiedad Control de pantalla en El cuadro de lista o Un cuadro a combinado, puede establecer esta propiedad a Tabla o consulta, Lista de valores o Lista de campos. A su vez, esta propiedad controla el tipo de valor que puede usar en la propiedad Origen de fila. Ver la entrada siguiente.

Origen de la fila

Ficha búsqueda

Depende de la propiedad Tipo de origen de fila.

Si establece la propiedad Tipo de origen de fila a Tabla o consulta, este campo de propiedad puede contener el nombre de una tabla o consulta. Si establece la propiedad a la Lista de valores, esta propiedad contiene una lista de valores separados por punto y coma (;). Si establece la propiedad Tipo de origen de fila a la Lista de campos, esta propiedad contiene el nombre de una tabla, consulta o instrucción de lenguaje de consulta estructurado (SQL).

Limitar a la lista

Ficha búsqueda

Sí/no

Cuando se establece en , Access busca valores coincidentes cuando los usuarios escriben texto en un control de cuadro combinado. Dicho de otro modo, la opción habilita con escritura anticipada. La opción también impide que los usuarios modifiquen los elementos de una lista directamente desde el control de cuadro combinado o de lista. En su lugar, los usuarios deben modificar los elementos en el cuadro de propiedad Origen de la fila o en el caso de los campos de búsqueda, modificar los elementos de la tabla que contienen los datos de origen del campo de búsqueda. Para obtener más información sobre el uso de campos de búsqueda, vea la sección titulada "Editar los elementos de un campo de búsqueda" en el artículo Agregar uno o varios registros a una base de datos.

Permitir ediciones de lista de valores

Ficha búsqueda

Sí/no

Habilita o deshabilita el comando Editar elementos de lista para listas de valores, pero no para los campos de búsqueda. Para habilitar este comando para los campos de búsqueda, escriba un nombre de formulario válido en la propiedad Formulario de edición de elementos de lista . Aparece el comando Permitir ediciones de lista de valores en un menú contextual que se abre haciendo clic en un control de cuadro combinado o cuadro de lista. Cuando se ejecuta el comando, aparece el cuadro de diálogo Editar elementos de lista. Como alternativa, si se especifica el nombre de un formulario en el cuadro de propiedad Formulario de edición de elementos de lista, Access inicia ese formulario en lugar del cuadro de diálogo.

Puede ejecutar el comando Editar elementos de lista del cuadro de lista y controles de cuadro combinado situados en los formularios y desde los controles de cuadro combinado situados en las tablas y el resultado de la consulta se establece. Formularios deben estar abiertos en la vista Diseño o vista Examinar; tablas y conjuntos de resultados de la consulta deben estar abiertos en la vista Hoja de datos.

Formulario de edición de elementos de lista

Ficha búsqueda

Nombre de un formulario de entrada de datos

Si especifica el nombre de un formulario de entrada de datos en esta propiedad de tabla, ese formulario se abre cuando un usuario ejecuta el comando Editar elementos de lista. En caso contrario, el cuadro de diálogo Editar elementos de lista aparece cuando los usuarios ejecuten el comando.

Para obtener más información sobre cómo diseñar tablas de base de datos y establecer las propiedades, consulte los artículos siguientes.

  • Conceptos básicos del diseño de base de datos se explican los conceptos básicos, como el diseño de una base de datos, diseñar los datos y la normalización, el proceso de dividir los datos en tablas relacionadas y eliminar los datos redundantes.

  • Crear tablas en una base de datos se explica cómo crear tablas, agregar claves principales (campos que identifican inequívocamente cada fila o registro de la tabla) y cómo establecer las propiedades de tabla y tipos de datos.

Volver al principio

Usar un formulario para actualizar los datos

Usar un formulario para actualizar pequeñas cantidades de datos. En este caso, "pequeña" significa cualquier número de registros que desea actualizar de forma manual. Formularios pueden proporcionar una manera más fácil, más rápida y más precisa para editar y actualizar pequeñas cantidades de datos.

Cómo usar un formulario para editar datos depende del diseño del formulario. Los formularios pueden contener cualquier número de controles , como listas, cuadros de texto, botones y hojas de datos : cuadrículas con el aspecto de las hojas de cálculo de Excel. A su vez, cada uno de los controles en el formulario lee los datos desde o escribe datos en un campo de tabla subyacente. Qué hacer con un control determinado depende del tipo de datos establecido para el campo de tabla subyacente, las propiedades establecidas para ese campo y posiblemente de varias propiedades que el Diseñador de base de datos se establece para cada control. Para obtener más información sobre cómo los tipos de datos y las propiedades de campo afectan a la entrada de datos, vea cómo afectan los tipos de datos la manera de introducir datos y cómo propiedades de campo de tabla afectan a la entrada de datos, más adelante en este artículo.

Las siguientes secciones explican cómo usar los controles de entrada de datos más comunes. Si tiene preguntas sobre la base de datos específica, póngase en contacto con el administrador del sistema o el Diseñador de base de datos.

Agregar o editar texto en un cuadro de texto

Access proporciona un control de texto para su uso con campos texto y Memo. Normalmente, puede saber si el campo subyacente es texto o memo por el tamaño del control, que suele refleja el tamaño del campo de tabla subyacente. Por ejemplo, si enlazar el control a un campo de texto que acepta no más de 50 caracteres, el tamaño del control se según corresponda. Por el contrario, si enlazar el control a un campo Memo, puede cambiar el tamaño del control para mostrar uno o dos párrafos de texto sin tener que desplazarse.

Además, puede establecer un campo Memo para que admita formato de texto enriquecido. A continuación, puede aplicar diferentes fuentes, tamaños, estilos y colores al texto.

Editar texto en un cuadro de texto

  • Coloque el cursor en el cuadro de texto y cambiar los datos. Recuerde que no puede realizar cálculos con los números de un campo de texto o Memo.

Aplicar formato de texto enriquecido

Nota: Puede seguir estos pasos únicamente cuando un cuadro de texto enlazado a un campo Memo. Consulte los pasos de Ver las propiedades de un campo de tabla, más adelante en este artículo.

  1. Con la tabla abierta en la vista Hoja de datos, seleccione el campo Memo. Normalmente, puede buscar un campo denominado "Comentarios", notas,"o"Descripción".

  2. En la ficha Inicio, en el grupo fuente, use los botones y menús para dar formato al texto.

    Puede aplicar fuentes y tamaños diferentes, poner el texto en negrita o cursiva, cambiar los colores y así sucesivamente.

Volver al principio

Use una hoja de datos para actualizar los datos

Puede cambiar los datos directamente en la vista Hoja de datos (una fila y columna de cuadrícula similar a una hoja de cálculo de Excel). Puede cambiar datos en tablas, conjuntos de resultados de consulta y formularios que se muestran las hojas de datos.

Normalmente, se utilizan hojas de datos cuando tenga que cambiar solo un pequeño número de registros o partes de un único registro. Si está familiarizado con Excel, hojas de datos deben ser relativamente fáciles de entender y puede realizar cambios sin ningún conocimiento más profundo de acceso, como la capacidad de crear y ejecutar consultas.

Recuerde los siguientes puntos durante el proceso.

  • No es necesario guardar explícitamente los cambios. Access los valida en la tabla cuando se mueve el cursor a un nuevo campo en la misma fila o cuando se mueve el puntero a otra fila.

  • De forma predeterminada, los campos en una base de datos de Access se deben establecer para aceptar un tipo específico de datos, como texto o números. Debe escribir el tipo de datos que el campo está configurado para Aceptar. Si no lo hace, Access muestra un mensaje de error.

  • Un campo puede tener aplicada una máscara de entrada. Una máscara de entrada es un conjunto de caracteres literales y marcadores de posición que obligan a escribir datos en un formato específico. Por ejemplo, una máscara de entrada para un código postal puede requerir que cumple el formato francés, mientras que una máscara de entrada para un número de teléfono puede requerir que escriba números en el formato alemán.

    Para obtener más información acerca de las máscaras de entrada, vea el artículo formato de datos en filas y columnas.

  • Con la excepción de los datos adjuntos y las listas multivalor, puede escribir un único valor en la mayoría de los campos. Si no sabe si un campo acepta datos adjuntos, póngase en contacto con el Diseñador de base de datos o el administrador del sistema. Siempre puede identificar una lista multivalor porque Access muestra una casilla de verificación junto a cada elemento de lista.

Cambiar los datos de una hoja de datos

  1. En el panel de navegación, haga doble clic en la tabla o consulta que contiene los datos que desea cambiar.

    De forma predeterminada, Access abre la tabla o consulta en la vista Hoja de datos: una cuadrícula que se parece a una hoja de cálculo de Excel.

  2. Haga clic en o en caso contrario, sitúe el foco en el primer campo que desea cambiar y editar los datos.

  3. Para desplazarse al campo siguiente, presione la tecla TAB, utilice una de las teclas de flecha o haga clic en el campo next.

    Al presionar TAB, de forma predeterminada, Access usa la configuración regional de Windows para determinar si se mueve el cursor a la izquierda o hacia la derecha. Si el equipo está configurado para usar un idioma que se lee de izquierda a derecha, el cursor se mueve a la derecha al presionar la tecla TAB. Si el equipo está configurado para un idioma que se lee de derecha a izquierda, el cursor se mueve a la izquierda.

Aplicar formato de texto enriquecido a los datos de un campo Memo

  1. Con el resultado de tabla o consulta abierto en la vista Hoja de datos, seleccione el campo Memo.

    Normalmente, puede buscar un campo denominado "Comentarios", "Notas" o "Descripción". Si aún no puede encontrar el campo Memo, vea los pasos de Ver las propiedades de un campo de tabla, más adelante en este artículo.

  2. En la ficha Inicio, en el grupo fuente, use los botones y menús para dar formato al texto.

    Puede aplicar fuentes y tamaños diferentes, poner el texto en negrita o cursiva, cambiar los colores y así sucesivamente.

Volver al principio

Usar una consulta de actualización para cambiar datos existentes

Usar consultas de actualización para agregar, cambiar o eliminar elemento (pero no todas) de uno o varios de los registros existentes. Puede considerar que las consultas de actualización como un formulario eficaz del cuadro de diálogo Buscar y reemplazar. Escriba un criterio de selección (el equivalente aproximado de una cadena de búsqueda) y un criterio de actualización (el equivalente aproximado de una cadena de reemplazo). A diferencia del cuadro de diálogo, las consultas de actualización pueden aceptar varios criterios, permiten actualizar un gran número de registros de una sola vez y permiten cambiar registros en más de una tabla.

Recuerde que no puede usar las consultas de actualización para agregar registros completos. Para ello, use una consulta de datos anexados.

Para obtener más información, vea el artículo Agregar registros a una tabla mediante una consulta de datos anexados.

Nota: La forma más segura de usar una consulta de actualización es crear una consulta de selección que pruebe los criterios de selección. Por ejemplo, suponga que desea actualizar Sí/No de una serie de campos de No a para un cliente determinado. Para ello, agregue criterios a la consulta de selección hasta que devuelva todos los registros No deseados para que el cliente. Cuando esté seguro de que tiene los registros correctos,, a continuación, convertir la consulta de selección en una consulta de actualización, introduzca los criterios de actualización y, a continuación, ejecute la consulta para actualizar los valores seleccionados. En esta sección se explica cómo crear una consulta de selección y luego convertirla en una consulta de actualización.

Crear una consulta de selección

  1. Abra la base de datos que contenga los registros que desee actualizar.

  2. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

    Se abre el Diseñador de consultas, aparece la ficha Diseño y se abre el cuadro de diálogo Mostrar tabla.

  3. Seleccione la tabla o las tablas que contienen los registros que desea actualizar y haga clic en Agregar y, a continuación, haga clic en Cerrar.

    La tabla o tablas aparecen como una o varias ventanas en la sección superior de la cuadrícula de diseño de consulta y, a continuación, todos los campos de cada tabla de la lista de las ventanas. La figura siguiente muestra el Diseñador de consultas con una tabla típica.

    Una tabla en el Diseñador de consultas.

  4. Haga doble clic en los campos que desea actualizar. Los campos seleccionados aparecen en la fila campo en la sección inferior del Diseñador de consultas.

    Puede agregar un campo de tabla por columna en la sección inferior o puede agregar rápidamente todos los campos de una tabla haciendo doble clic en el asterisco (*) en la parte superior de la lista de campos de tabla. La figura siguiente muestra el Diseñador de consultas con todos los campos agregados.

    Una consulta con todos los campos de tabla agregados.

  5. También tiene la opción de especificar uno o varios criterios en la fila Criterios de la cuadrícula de diseño. En la siguiente tabla, se muestran algunos criterios de ejemplo y se explica cómo afectan a las consultas.

Criterios

Efecto

> 234

Devuelve todos los números mayores que 234. Para buscar todos los números menores que 234, use < 234.

>= "Díaz"

Devuelve todos los registros desde Díaz hasta el final del alfabeto.

Entre #2/2/2006# y #1/12/2006#

Devuelve las fechas de 2-Feb-06 1-dic-06 (ANSI-89). Si la base de datos usa los caracteres comodín ANSI-92, use comillas simples (') en lugar de los signos de número. Ejemplo: Entre ' 2/2/2006' y ' 12/1/2006 '

Sin "Alemania"

Encuentra todos los registros en los que el contenido exacto del campo no es exactamente igual a "Alemania". El criterio devolverá registros que contienen caracteres además de "Alemania," como "Alemania (euro)" o "Europa (Alemania)".

Sin "T*"

Busca todos los registros, salvo los que empiezan por T. Si la base de datos usa los caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco.

Sin "*t"

Busca todos los registros que no terminen en t. Si la base de datos utiliza el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco.

En(Canadá,Reino Unido)

En una lista, busca todos los registros que contengan Canadá o Reino Unido.

Como "[A-D]*"

En un campo de texto, busca todos los registros que comienzan con las letras A D. Si la base de datos usa los caracteres comodín ANSI-92, use el signo de porcentaje (%) en lugar del asterisco.

Como "*ar*"

Busca todos los registros que incluyan la secuencia de letras "ar". Si la base de datos usa el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco.

Como "Casa Dewe?"

Busca todos los registros que empiecen por "Casa" y contengan una segunda cadena de 5 letras, cuyas cuatro primeras letras son "Dewe" y cuya última letra se desconoce. Si la base de datos usa el juego de caracteres comodín ANSI-92, use el carácter de subrayado (_) en vez del signo de interrogación.

#02/02/2006#

Busca todos los registros del 2 de febrero de 2006. Si la base de datos usa el juego de caracteres comodín ANSI-92, incluya la fecha entre comillas simples en vez de usar signos de almohadilla ('02/02/2006').

< Fecha() - 30

Devuelve todas las fechas con una antigüedad de más de 30 días.

Fecha()

Devuelve todos los registros que contienen la fecha actual.

Entre Fecha() Y AgregFecha("M", 3, Fecha())

Devuelve todos los registros entre la fecha actual y tres meses a partir de la fecha actual.

Es Nulo

Devuelve todos los registros que contengan un valor nulo (en blanco o sin definir).

No es Nulo

Devuelve todos los registros que contienen un valor.

""

Devuelve todos los registros que contienen una cadena de longitud cero. Las cadenas de longitud cero se utilizan cuando es necesario agregar un valor a un campo obligatorio, pero aún no se conoce el valor. Por ejemplo, un campo puede requerir un número de fax, pero puede que algunos clientes no tengan fax. En ese caso, se incluye un par de comillas dobles sin espacios entre ellas ("") en lugar de un número.

  1. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Compruebe que la consulta devuelve sólo los registros que desea actualizar. Según sea necesario, puede seleccionar los campos que no desee y presione la tecla SUPRIMIR para quitarlos, puede arrastrar campos adicionales a la cuadrícula de diseño y puede cambiar los criterios hasta que esté satisfecho con los resultados de la consulta.

  2. Vaya a los pasos siguientes.

Actualizar los registros

  1. En la pestaña Diseño, en el grupo Tipo de consulta, haga clic en Actualizar.

    Esto cambia la consulta de selección a una consulta de actualización. Access agrega la fila actualizar a de la sección inferior del Diseñador de consultas.

    Una consulta de actualización con un solo criterio de actualización.

  2. Busque el campo que contiene los datos que desea cambiar y escriba la expresión (que cambiará los datos) en la fila actualizar a de ese campo.

    En esta tabla se muestran algunas expresiones de ejemplo y una explicación de cómo cambian los datos.

Expresión

Resultado

"Vendedor"

En un campo de texto, cambia un valor de texto a Vendedor.

n.º 8/10/06 #

En un campo de fecha y hora, cambia un valor de fecha a 10-Ago-06.

En un campo de tipo Sí/No, cambia el valor No a .

"NP" & [NúmeroPieza]

Agrega "NP" al principio de cada número de pieza especificado.

[PrecioUnidad] * [Cantidad]

Multiplica los valores de los campos PrecioUnidad y Cantidad.

[Transporte] * 1,5

Aumenta los valores de un campo denominado Transporte en un 50 por ciento.

DSuma("[Cantidad] * [PrecioUnidad]",
"Detalles de pedidos", "[IdProducto]=" & [IdProducto])

Donde los valores de IdProducto de la tabla actual coinciden con los valores de IdProducto de la tabla denominada detalles de pedidos, esta expresión actualiza los totales de ventas por multiplicar los valores de un campo denominado cantidad por los valores de un campo denominado PrecioUnidad.

Derecha([CódigoPostalEnvío], 5)

Trunca los caracteres situados en un texto o una cadena numérica y deja los cinco caracteres situados.

SiInm(Es Nulo([PrecioUnidad]), 0, [PrecioUnidad])

Cambia un valor nulo (desconocido o sin definir) a cero (0) en un campo denominado PrecioUnidad.

  1. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Aparece un mensaje de alerta. La figura siguiente muestra el mensaje:

    Mensaje de alerta de la consulta de actualización

  2. Haga clic en para ejecutar la consulta.

    Nota: Puede desactivar los mensajes de alerta. Para ello, haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office , haga clic en Opciones de Access, haga clic en Avanzadas y en Confirmar, desactive la casilla de verificación consultas de acción.

  3. Para ver los resultados de la consulta de actualización en ambos el Inicio pestaña o en la ficha Diseño, en el grupo vistas, haga clic en vista y, a continuación, haga clic en Vista Hoja de datos. También puede hacer clic en el botón de Vista Hoja de datos que se encuentra en la barra de estado de Access.

    Nota: Cuando se ejecuta la consulta, observará que faltan algunos campos del conjunto de resultados. Si la consulta contiene campos que no se actualizan, Access quita esos campos de forma predeterminada. Por ejemplo, puede incluir campos de identificador de dos tablas para ayudar a asegurar la consulta devuelve y funciona en los registros correctos. Si no actualiza esos campos Id., Access los quita.

Volver al principio

Usar una consulta de datos anexados para agregar registros a tablas

Uno de los usos más frecuentes de una consulta de datos anexados es agregar un grupo de registros de una o más tablas en una base de datos de origen a una o más tablas en una base de datos de destino. Por ejemplo, suponga que adquirir nuevos clientes y una base de datos que contiene una tabla de información acerca de los clientes. Para evitar introducir manualmente los nuevos datos, puede anexar a la tabla o tablas correspondientes en la base de datos. También puede usar las consultas de datos anexados:

  • Anexar registros basándose en los criterios. Por ejemplo, que desea anexar sólo los nombres y direcciones de los clientes con pedidos pendientes.

  • Anexar registros cuando algunos de los campos en una tabla no existen en la otra tabla. Por ejemplo, suponga que la tabla clientes tiene 11 campos y los campos de la tabla de clientes en otra base de datos coinciden con 9 de los 11 campos. Puede usar una consulta de datos anexados para agregar solo los datos en los campos coincidentes y omitir las demás.

El proceso de creación de una consulta de datos anexados para anexar datos desde una base de datos a otra base de datos sigue estos pasos básicos:

  • Abra la base de datos de origen (la base de datos que contiene los registros que desea anexar) y crear una consulta de selección que devuelva solamente los registros que desea anexar.

  • Convertir esa consulta de selección en una consulta de datos anexados.

  • Agregue los campos y las tablas de destino a la consulta de datos anexados. Si va a anexar registros a otra base de datos, se abre por primera vez dicha base de datos y, a continuación, seleccione las tablas.

  • Ejecute la consulta para anexar los registros.

Nota: Hacer copia de seguridad de sus datos antes de empezar. Si comete un error, puede eliminar los registros anexados de la tabla de destino, pero eliminar manualmente una gran cantidad de registros puede resultar bastante larga. Tener una copia de seguridad a mano puede ayudarle a corregir los errores en menos tiempo.

Crear una consulta de selección

  1. Abra la base de datos de origen, la base de datos que contiene los registros que desea anexar.

  2. En el grupo Otros de la pestaña Crear, haga clic en Diseño de consulta.

    Aparece la cuadrícula de diseño de consulta y aparece el cuadro de diálogo Mostrar tabla.

  3. Seleccione la tabla que contiene los registros que desea anexar, haga clic en Agregar y, a continuación, haga clic en Cerrar.

    La tabla aparece como una ventana en la sección superior de la cuadrícula de diseño de consulta. La ventana enumera todos los campos de la tabla. Esta ilustración muestra una tabla típica en el Diseñador de consultas:

    Una tabla en el Diseñador de consultas.

  4. Arrastre los campos que desea anexar desde la tabla hasta la fila campo en la sección inferior de la cuadrícula de diseño de consulta.

    Puede agregar un campo de tabla por columna en la sección inferior. Para agregar rápidamente todos los campos, haga clic en el asterisco (* ) en la parte superior de la lista de campos de tabla. Esta ilustración muestra el Diseñador de consultas con varios campos de tabla agregados:

    Consulta con tres campos en la cuadrícula de diseño

    Esta ilustración muestra el diseñador con todos los campos agregados:

    Una consulta con todos los campos de tabla

  5. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Compruebe que la consulta devuelve los registros que desea anexar. Según sea necesario, puede desactivar la casilla de verificación Mostrar o presione SUPRIMIR para eliminar los campos. También puede arrastrar campos adicionales a la cuadrícula de diseño hasta que esté satisfecho con los resultados de la consulta.

  6. Continúe con los siguientes pasos.

Convertir la consulta en una consulta de datos anexados

  1. En la pestaña Diseño, en el grupo Tipo de consulta, haga clic en Anexar.

    Aparece el cuadro de diálogo Anexar.

  2. En este momento, puede anexar registros de una tabla a otra en la misma base de datos o anexar registros a una tabla en otra base de datos.

    • Anexar registros a una tabla en la misma base de datos

      1. En el cuadro de diálogo Anexar, haga clic en Base de datos activa (si aún no está seleccionada) y, a continuación, seleccione la tabla de destino de la lista Nombre de tabla.

      2. Haga clic en Aceptar.

        En el paso 4 de la sección anterior, agregó parte o todos los campos de la tabla de origen a la cuadrícula de diseño de consulta. Si agregó la tabla completa en ese paso, Access agrega ahora la tabla completa de destino a la fila Anexar a, como se muestra aquí:

        Una consulta de datos anexados que incluye todos los campos de dos tablas

        O bien:

        Si agregó campos individuales en el paso 4 en la sección anterior y los nombres de campo de las tablas de origen y de destino coinciden, Access agrega automáticamente los nombres de campo de destino en la fila Anexar a, como se muestra aquí:

        Una consulta de datos anexados con campos coincidentes

        O bien:

        Si agregó campos individuales, y algunos o todos los nombres de las tablas de origen y destino no coinciden, Access deja en blanco los campos no coincidentes en la fila Anexar a. Haga clic en cada campo en blanco y seleccione el campo de origen que desee en la lista resultante, como se muestra aquí.

        Seleccionar los campos de destino para una consulta de datos anexados

      3. Para obtener una vista previa de los cambios, haga clic en Ver.

      4. Vuelva a la vista Diseño y, a continuación, haga clic en Ejecutar para anexar los registros.

    • Anexar registros a una tabla en otra base de datos

      1. En el cuadro de diálogo Anexar, haga clic en Otra base de datos.

      2. En el campo Nombre de archivo, escriba la ubicación y el nombre de la base de datos de destino.

      3. En el campo Nombre de la tabla, escriba el nombre de la tabla de destino y, a continuación, haga clic en Aceptar.

        O bien:

        Haga clic en Examinar y use el segundo cuadro de diálogo Anexar para buscar la base de datos de destino. Después de buscar y seleccionar la base de datos de destino, haga clic en Aceptar. Cierra el segundo cuadro de diálogo. En el primer cuadro de diálogo, en el campo Nombre de la tabla, escriba el nombre de la tabla de destino y, a continuación, haga clic en Aceptar.

        Escriba el nombre de la tabla de destino y, a continuación, haga clic en Aceptar para cerrar el primer cuadro de diálogo Anexar.

        En el paso 4 de la sección anterior, agregó parte o todos los campos de la tabla de origen a la fila campo en la cuadrícula de diseño de consulta. Si agregó la tabla completa en ese paso, Access agrega ahora la tabla completa de destino a la fila Anexar a, como se muestra aquí:

        Una consulta de datos anexados que incluye todos los campos de dos tablas

        O bien:

        Si agregó campos individuales en el paso 4 y los nombres de campo de las tablas de origen y destino coinciden, Access agrega automáticamente los nombres de campo de destino en la fila Anexar a, así:

        Una consulta de datos anexados con campos coincidentes

        O bien:

        Si agregó campos individuales, y algunos o todos los nombres de las tablas de origen y destino no coinciden, Access deja en blanco los campos no coincidentes en la fila Anexar a. Haga clic en cada campo en blanco y seleccione el campo de destino que desee en la lista resultante, así:

        Seleccionar los campos de destino para una consulta de datos anexados

      4. Para obtener una vista previa de los cambios, haga clic en Ver.

      5. Cambie a la vista Diseño y, a continuación, haga clic en Ejecutar para anexar los registros.

Volver al principio

Use la recopilación de datos para actualizar los registros

Office Access 2007 proporciona una nueva característica denominada recopilación de datos. Puede configurar un formulario de entrada de datos en Microsoft Office Outlook 2007, recopilar información y almacenar los datos en una base de datos de Access. Explica cómo usar la característica de recopilación de datos está fuera del ámbito de este artículo.

Para obtener información sobre el uso de recopilación de datos, vea el artículo titulado recopilar datos mediante mensajes de correo electrónico.

Volver al principio

Usar el cuadro de diálogo Buscar y reemplazar para cambiar datos

El cuadro de diálogo Buscar y reemplazar proporciona otra forma de cambiar pequeñas cantidades de datos en menos tiempo y con menos esfuerzo. Explica cómo usar el cuadro de diálogo está fuera del ámbito de este artículo.

Para obtener información sobre cómo usar el cuadro de diálogo, vea el artículo usar el cuadro de diálogo Buscar y reemplazar para cambiar datos.

Volver al principio

Use las actualizaciones en cascada para cambiar los valores de clave principales y externos

A veces, tendrá que actualizar un valor de clave principal. Si utiliza esa clave principal como clave externa, puede actualizar automáticamente los cambios a través de todas las instancias secundarias de la clave externa.

Un aviso, una clave principal es un valor que identifica inequívocamente cada fila (registro) en una tabla de base de datos. Una clave externa es una columna que coincida con la clave principal. Normalmente, las claves externas residen en otras tablas y permiten crear una relación (un vínculo) entre los datos de las tablas.

Por ejemplo, suponga que utiliza un número de identificador de producto como clave principal. Un número de ID identifica un producto. También usar ese número identificador como una clave externa de una tabla de datos del pedido. De este modo, puede encontrar todos los pedidos correspondientes a cada producto, porque cada vez que alguien realiza un pedido de ese producto, el identificador se convierte en parte del pedido.

A veces, los números de identificación (u otros tipos de claves principales) cambiarán. Cuando lo hacen, puede modificar el valor de clave principal y hacer que ese cambio automáticamente en cascada a través de todos los registros secundarios relacionados. Habilitar este comportamiento activando la integridad referencial y las actualizaciones entre las dos tablas en cascada.

Recuerde estas reglas durante el proceso:

  • Puede habilitar las actualizaciones en cascada solo para establecer los tipos de datos de texto o el número de campos de clave principal. No puede usar las actualizaciones en cascada para los campos con el tipo de datos autonumeración.

  • Puede habilitar las actualizaciones en cascada entre tablas con una relación uno a varios.

Los siguientes pasos explican cómo crear una relación y habilitar las actualizaciones en cascada para esa relación.

Crear la relación

  1. En la ficha Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en relaciones.

  2. En la ficha Diseño, en el grupo relaciones, haga clic en Mostrar tabla.

    Aparece el cuadro de diálogo Mostrar tabla.

  3. Si no está seleccionada, haga clic en la ficha tablas, seleccione las tablas que desea cambiar, haga clic en Agregar y, a continuación, haga clic en Cerrar.

    Puede presionar la tecla MAYÚS para seleccionar varias tablas, o puede agregar cada tabla de forma individual. Seleccionar sólo las tablas de los lados "uno" y "varios" de la relación.

  4. En la ventana relaciones, arrastre la clave principal de la tabla del lado "uno" de la relación y colóquela en el campo de clave externa de la tabla del lado "varios" de la relación.

    Aparece el cuadro de diálogo Modificar relaciones. La figura siguiente muestra el cuadro de diálogo:

    Cuadro de diálogo Modificar relaciones

  5. Seleccione la casilla de verificación Exigir integridad referencial y haga clic en crear.

  6. Vaya al siguiente conjunto de pasos.

Habilitar las actualizaciones en cascada en claves principales

  1. Si no ha seguido los pasos de la sección anterior, abra la base de datos que contiene la relación que desea cambiar.

  2. En la ficha Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en relaciones.

    Aparece la ventana relaciones y muestra las uniones (se muestra líneas de conexión como) entre las tablas de la base de datos. La figura siguiente muestra una relación típica:

    Relación entre dos tablas

  3. Haga clic en la línea de combinación entre las tablas principal y secundario y haga clic en Modificar relación.

    Aparece el cuadro de diálogo Modificar relaciones. La figura siguiente muestra el cuadro de diálogo:

    Cuadro de diálogo Modificar relaciones con una relación existente

  4. Seleccione Actualizar en cascada los campos relacionados, asegúrese de que está seleccionada la casilla de verificación Exigir integridad referencial y, a continuación, haga clic en Aceptar.

Para obtener más información sobre la creación de relaciones. Consulte los artículos siguientes:

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×