Actualizar los datos de un gráfico existente

Después de crear un gráfico, debe cambiar su origen de datos en el hoja de cálculo. Para incorporar los cambios en el gráfico, Microsoft Office Excel proporciona varias formas para actualizar un gráfico. Puede actualizar un gráfico al instante con valores que han cambiado o puede cambiar dinámicamente el origen de datos subyacente. También puede actualizar un gráfico de agregar, cambiar o quitar datos.

Cambiar los datos subyacentes que se basa un gráfico

Cuando actualiza los datos subyacentes de un gráfico, datos y la apariencia del gráfico también cambia. El grado de esos cambios depende de cómo definir el origen de datos del gráfico. Puede actualizar automáticamente los valores de hoja de cálculo modificada en un gráfico, o bien puede usar formas de cambiar dinámicamente el origen de datos subyacente de un gráfico.

Actualizar automáticamente los valores de hoja de cálculo modificada de un gráfico existente

Los valores de un gráfico están vinculados a los datos de hoja de cálculo desde la que se creó el gráfico. Con opciones de cálculo definidos como automático (fichafórmulas, grupo cálculo, el botón Opciones de cálculo ), los cambios que realice automáticamente a los datos de hoja de cálculo aparecen en el gráfico.

Nota: En Excel 2007, haga clic en el botón de Microsoft Office Imagen del botón de Office > Opciones de Excel > fórmulas > cálculos > Opciones de cálculo.

  1. Abra la hoja de cálculo que contiene los datos que se trazan en el gráfico.

  2. En la celda que contiene el valor que desea cambiar, escriba un nuevo valor.

  3. Presione ENTRAR.

Cambiar dinámicamente el origen de datos subyacente de un gráfico existente

Si desea dinámicamente el origen de datos del gráfico para aumentar, existen dos enfoques que puede usar. Puede basar un gráfico de datos en una tabla de Excel, o puede basar en un nombre definido.

Basar el gráfico en una tabla de Excel

Si crea un gráfico basado en un rango de celdas, las actualizaciones de datos en el intervalo original se reflejan en el gráfico. Pero, para expandir el tamaño del rango, mediante la adición de filas y columnas y cambiar los datos y la apariencia del gráfico, debe cambiar manualmente el origen de datos en el gráfico al cambiar el rango de celdas que se basa un gráfico.

Si desea cambiar los datos y la apariencia del gráfico cuando se expande el origen de datos, puede usar una tabla de Excel como origen de datos subyacente.

  1. Haga clic en el gráfico que desea cambiar el rango de celdas del origen de datos.

    De este modo, se muestran las Herramientas de gráficos, y se agregan las fichas Diseño, Presentación y Formato.

  2. En la ficha Diseño, en el grupo Datos, haga clic en Seleccionar datos.

    Imagen de la cinta de Excel

  3. En el cuadro de diálogo Seleccionar origen de datos, anote la ubicación del rango de datos y, a continuación, haga clic en Aceptar.

  4. Vaya a la ubicación del rango de datos y haga clic en cualquier celda del rango de datos.

  5. En la ficha Insertar, en el grupo Tablas, haga clic en Tabla.

    Imagen de la cinta de Excel

    Método abreviado de teclado: presione CTRL+L o CTRL+T.

Basar el gráfico en un nombre definido

Otra dinámicamente cambiar datos del gráfico y la apariencia cuando el origen de datos se expande consiste en usar un nombre definido con la función DESREF. Este enfoque es útil cuando necesita una solución que también funciona con versiones anteriores de Excel.

Para obtener más información, vea cómo usar nombres definidos para actualizar automáticamente un rango de gráfico en Excel.

Agregar datos a un gráfico existente

Puede usar una de las diversas maneras para incluir datos de origen adicionales en un gráfico existente. Puede agregar otra serie de datos, arrastre los controladores de tamaño de los intervalos que desea incluir datos en un gráfico incrustado en la misma hoja de cálculo o copiar datos adicionales de la hoja de cálculo en un gráfico incrustado o en una independiente hoja de gráfico.

Agregar una serie de datos a un gráfico

  1. Haga clic en el gráfico al que desea agregar otra serie de datos.

    De este modo, se muestran las Herramientas de gráficos, y se agregan las fichas Diseño, Presentación y Formato.

  2. En la ficha Diseño, en el grupo Datos, haga clic en Seleccionar datos.

    Imagen de la cinta de Excel

  3. En el cuadro de diálogo Seleccionar origen de datos, Las entradas de leyenda (Series), haga clic en Agregar.

  4. En el cuadro de diálogo Editar serie, haga lo siguiente:

    • En el cuadro nombre de la serie, escriba el nombre que desea usar para la serie o seleccione el nombre de la hoja de cálculo.

    • En el cuadro valores de la serie, escriba la referencia del rango de datos de la serie de datos que desea agregar o seleccione el rango en la hoja de cálculo.

      Puede haga clic en el Cuadro de diálogo contraer botón Botón Contraer , en el extremo derecho del cuadro nombre de la serie o valores de la serie y, a continuación, seleccione el rango que desea usar para la tabla en la hoja de cálculo. Cuando haya terminado, haga clic en el botón Contraer diálogo nuevo para mostrar el cuadro de diálogo completo.

      Si usa las teclas de flecha para colocar el puntero escriba la referencia, puede presionar F2 para asegurarse de que está en modo de edición. Al presionar F2 de nuevo cambia al modo de punto. Puede comprobar el modo actual en la barra de estado.

Arrastre los controladores de tamaño de intervalos para agregar datos a un gráfico incrustado

Si ha creado un gráfico incrustado de las celdas adyacentes de la hoja de cálculo, puede agregar datos arrastrando los controladores de tamaño de los rangos de datos de origen. El gráfico debe estar en la misma hoja de cálculo, como los datos que se usan para crear el gráfico.

  1. En la hoja de cálculo, escriba los datos y etiquetas que desea agregar al gráfico en celdas adyacentes a los datos de hoja de cálculo existente.

  2. Haga clic en el gráfico para mostrar los controladores de tamaño alrededor de los datos de origen en la hoja de cálculo.

  3. En la hoja de cálculo, siga uno de los procedimientos siguientes:

    • Para agregar nuevas categorías y series de datos al gráfico, arrastre un controlador de tamaño azul para incluir los nuevos datos y rótulos en el rectángulo.

    • Para agregar nuevos datos serie solo, arrastre un controlador de tamaño verde para incluir los nuevos datos y rótulos en el rectángulo.

    • Para agregar nuevas categorías y puntos de datos, arrastre un controlador de tamaño púrpura para incluir los nuevos datos y categorías en el rectángulo.

Copiar datos de la hoja de cálculo a un gráfico

Si ha creado un gráfico incrustado de selecciones no adyacentes, o si el gráfico está en una hoja de gráfico independiente, puede copiar datos adicionales de la hoja de cálculo en el gráfico.

  1. En la hoja de cálculo, seleccione las celdas que contienen los datos que desea agregar al gráfico.

    Si desea que la etiqueta de columna o fila de los nuevos datos aparezca en el gráfico, incluya la celda que contiene la etiqueta en la selección.

  2. En la pestaña Inicio, en el grupo Portapapeles, haga clic en Copiar Imagen del botón .

    Imagen de la cinta de Excel

    Método abreviado de teclado: presione CTRL+C.

  3. Haga clic en la hoja de gráfico o el gráfico incrustado al que desea pegar los datos copiados.

  4. Realice una de las acciones siguientes:

    • Para pegar los datos en el gráfico, en la ficha Inicio, en el grupo Portapapeles, haga clic en Pegar Imagen de botón .

      Método abreviado de teclado: presione CTRL+V.

    • Para especificar cómo se deben trazan los datos copiados en el gráfico, en la ficha Inicio, en el grupo Portapapeles, haga clic en la flecha situada junto al botón Pegar, haga clic en Pegado especial y, a continuación, seleccione las opciones que desee.

Cambiar los datos de un gráfico existente

Puede cambiar un gráfico existente cambiando el rango de celdas que se basa el gráfico o editando la serie de datos individuales que se muestra en el gráfico. También puede cambiar las etiquetas de eje en el eje horizontal (categorías).

Cambiar el rango de celdas que se basa un gráfico

  1. Haga clic en el gráfico que desea cambiar el rango de celdas del origen de datos.

    De este modo, se muestran las Herramientas de gráficos, y se agregan las fichas Diseño, Presentación y Formato.

  2. En la ficha Diseño, en el grupo Datos, haga clic en Seleccionar datos.

    Imagen de la cinta de Excel

  3. En el cuadro de diálogo Seleccionar origen de datos, asegúrese de que está seleccionada la referencia toda en el cuadro rango de datos del gráfico.

    Puede haga clic en el Cuadro de diálogo contraer botón Botón Contraer , en el extremo derecho del cuadro rango de datos del gráfico y, a continuación, seleccione el rango que desea usar para la tabla en la hoja de cálculo. Cuando haya terminado, haga clic en el botón Contraer diálogo nuevo para mostrar el cuadro de diálogo completo.

  4. En la hoja de cálculo, seleccione las celdas que contienen los datos que desea que aparezcan en el gráfico.

    Si desea que las etiquetas de columna y fila aparezca en el gráfico, se incluyen las celdas que contienen en la selección.

    Si usa las teclas de flecha para colocar el puntero escriba la referencia, puede presionar F2 para asegurarse de que está en modo de edición. Al presionar F2 de nuevo cambia al modo de punto. Puede comprobar el modo actual en la barra de estado.

Cambiar el nombre o modificar una serie de datos que se muestra en un gráfico

Puede modificar el nombre y los valores de la serie de datos existente sin que ello afecte a los datos en la hoja de cálculo.

  1. Haga clic en el gráfico que contiene la serie de datos que desea cambiar.

    De este modo, se muestran las Herramientas de gráficos, y se agregan las fichas Diseño, Presentación y Formato.

  2. En la ficha Diseño, en el grupo Datos, haga clic en Seleccionar datos.

    Imagen de la cinta de Excel

  3. En el cuadro de diálogo Seleccionar origen de datos, en Las entradas de leyenda (Series), seleccione la serie de datos que desea cambiar y, a continuación, haga clic en Editar.

  4. Para cambiar el nombre de la serie de datos, en el cuadro nombre de la serie, escriba el nombre que desea usar para la serie o seleccione el nombre de la hoja de cálculo. El nombre que escriba aparece en la leyenda de gráfico, pero no se agrega a la hoja de cálculo.

  5. Para cambiar el rango de datos de la serie de datos, en el cuadro valores de la serie, escriba la referencia del rango de datos de la serie de datos que desea agregar, seleccione el rango en la hoja de cálculo o escriba los valores en los cuadros. Los valores que escribe no se agregan a la hoja de cálculo.

    Si el gráfico xy (Dispersión), los cuadros X de la serie de valores y valores Y de serie aparecen para poder cambiar el rango de datos con esos valores. Si el gráfico es un gráfico de burbujas, los cuadros X de la serie de valores, valores y tamaños de burbuja de la serie aparecen para poder cambiar el rango de datos con esos valores.

Para cada uno de los cuadros de la serie, puede haga clic en el Cuadro de diálogo contraer botón Botón Contraer , en el extremo derecho del cuadro nombre de la serie o valores de la serie y, a continuación, seleccione el rango que desea usar para la tabla en la hoja de cálculo. Cuando haya terminado, haga clic en el botón Contraer diálogo nuevo para mostrar el cuadro de diálogo completo.

Si usa las teclas de flecha para colocar el puntero escriba la referencia, puede presionar F2 para asegurarse de que está en modo de edición. Al presionar F2 de nuevo cambia al modo de punto. Puede comprobar el modo actual en la barra de estado.

Cambiar el orden de la serie de datos

  1. Haga clic en el gráfico que contiene la serie de datos que desea cambiar.

    De este modo, se muestran las Herramientas de gráficos, y se agregan las fichas Diseño, Presentación y Formato.

  2. En la ficha Diseño, en el grupo Datos, haga clic en Seleccionar datos.

    Imagen de la cinta de Excel

  3. En el cuadro de diálogo Seleccionar origen de datos , en Las entradas de leyenda (Series), seleccione la serie de datos que desea mover a otra ubicación en la secuencia.

  4. Haga clic en las flechas Subir o Bajar para mover la serie de datos.

  5. Repita el paso 3 y 4 para todas las series de datos que desea mover.

Cambiar la horizontal (categoría) rótulos del eje

Al cambiar la horizontal (categoría) se cambiará etiquetas del eje, todas las etiquetas del eje horizontal. No puede cambiar los rótulos del eje horizontal, individuales.

  1. Haga clic en el gráfico que contiene los rótulos del eje horizontal que desee cambiar.

    De este modo, se muestran las Herramientas de gráficos, y se agregan las fichas Diseño, Presentación y Formato.

  2. En la ficha Diseño, en el grupo Datos, haga clic en Seleccionar datos.

    Imagen de la cinta de Excel

  3. En Etiquetas del eje Horizontal (categoría), haga clic en Editar.

  4. En el cuadro rango de rótulos del eje, escriba la referencia del rango de datos de la serie de datos que desea usar para las etiquetas del eje horizontal o seleccione el rango en la hoja de cálculo.

    Puede haga clic en el Cuadro de diálogo contraer botón Botón Contraer , en el extremo derecho del cuadro nombre de la serie o valores de la serie y, a continuación, seleccione el rango que desea usar para la tabla en la hoja de cálculo. Cuando haya terminado, haga clic en el botón Contraer diálogo nuevo para mostrar el cuadro de diálogo completo.

    Si usa las teclas de flecha para colocar el puntero escriba la referencia, puede presionar F2 para asegurarse de que está en modo de edición. Al presionar F2 de nuevo cambia al modo de punto. Puede comprobar el modo actual en la barra de estado.

Quitar datos de un gráfico

Con opciones de cálculo definidos como automático, los datos que se eliminarán de la hoja de cálculo se eliminarán automáticamente del gráfico. También puede quitar datos del gráfico sin afectar a los datos de origen en la hoja de cálculo.

Eliminar datos de origen en la hoja de cálculo

  • En la hoja de cálculo, seleccione la celda o rango de celdas que contiene los datos que desea quitar del gráfico y, a continuación, presione la tecla SUPR.

    • Si eliminar datos de las celdas seleccionadas, se trazan las celdas vacías en el gráfico. Puede cambiar la manera en que se trazan las celdas vacías, haga clic con el botón del gráfico y seleccione celdas ocultas y vacías.

    • Si elimina una columna, se quita la serie de datos completa del gráfico. Si elimina una fila, recibirá un mensaje de error. Al hacer clic en Aceptar, el gráfico puede mostrar uno o varios puntos de datos de la serie de datos que elimina. Puede haga clic en los puntos de datos y, a continuación, presione la tecla Suprimir.

Quitar una serie de datos del gráfico

  1. Haga clic en el gráfico o la serie de datos que desea quitar o, siga este procedimiento para seleccionar la serie de datos o el gráfico de una lista de elementos del gráfico:

    1. Haga clic en un gráfico.

      Se mostrarán las Herramientas de gráficos con las fichas Diseño, Presentación y Formato.

    2. En la ficha formato, en el grupo Selección actual, haga clic en la flecha situada junto al cuadro Del área del gráfico y, a continuación, haga clic en el elemento de gráfico que desea usar.

      Grupo Selección actual en la ficha Formato (Herramientas de gráficos)

  2. Realice una de las acciones siguientes:

    1. Si el gráfico seleccionado, haga lo siguiente:

      1. En la pestaña Diseño, en el grupo Datos, haga clic en Seleccionar datos.

        Imagen de la cinta de Excel

      2. En el cuadro de diálogo Seleccionar origen de datos, en Las entradas de leyenda (Series), seleccione la serie de datos que desea quitar y, a continuación, haga clic en Quitar.

    2. Si selecciona una serie de datos en el gráfico, presione la tecla Suprimir.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en la Comunidad de tecnología de Excel, obtener soporte técnico de la Comunidad de respuestaso sugerir una característica o mejora nueva en Voz de usuario de Excel.

Inicio de la página

Notas: 

  • Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

  • Para su referencia, puede encontrar la versión en inglés de este artículo aquí. Todos los miembros de la comunidad de Microsoft pueden mejorar este artículo mediante el marco de colaboración en traducciones (CTF). Simplemente, mueva el puntero sobre cualquier frase del artículo y, a continuación, haga clic en "MEJORAR TRADUCCIÓN" en el widget CTF. Haga clic aquí para obtener más información acerca de CTF. Con el uso de CTF, el usuario acepta nuestras Condiciones del servicio.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×