Activar o desactivar la mensajes de confirmación de consulta de acción

De forma predeterminada, Access le pide que confirme que desea ejecutar una consulta de acción. Puede desactivar estos mensajes de confirmación si prefiere no se le pida. Si no aparecen los mensajes y desea que se le solicite, usted puede activarlos.

En este artículo

Información general

Controlar los mensajes de confirmación de consulta de acción para un equipo

Desactivar mensajes de confirmación de consulta de acción en una base de datos

Desactivar mensajes de confirmación de consulta de acción para un conjunto específico de tareas

Utilice una macro para desactivar los mensajes y hacer copias de

Información general

Consultas de acción son una manera de cambiar los datos de la base de datos. Una consulta de acción puede anexar, eliminar, o actualizar datos o crear una nueva tabla con los datos existentes. Consultas de acción son muy eficaces, pero que power implica algunos riesgos de cambios en los datos no deseados. Debido a la posibilidad de pérdida de datos, de forma predeterminada Access le pide su confirmación cuando se ejecuta una consulta de acción. Esto le permite mitigar la posibilidad de cambios en los datos no deseados.

Sugerencia: Para ver qué datos se efecto de una consulta de acción, antes de ejecutar la consulta, en la ficha Inicio, en el grupo vistas, haga clic en vista y, a continuación, haga clic en Vista Hoja de datos.

Si prefiere que Access no pida que confirme las consultas de acción, o si Access no pedir confirmación pero desea, puede activar los mensajes o desactivar.

  • Controlar los mensajes de confirmación de consulta de acción para un equipo   
    puede usar una configuración en el cuadro de diálogo Opciones de Access para establecer el comportamiento predeterminado para bases de datos de Access abierta en un equipo específico. Si use esta opción para activar los mensajes desactivar, Access no mostrará los mensajes en modo alguno. Si usa esta opción para activar los mensajes, Access mostrará los mensajes a menos que están desactivados mediante una macro o VBA.

  • Desactivar mensajes de confirmación de consulta de acción en una base de datos   
    elegir este método para desactivar las advertencias de una base de datos cuando se abre. Use la acción EstablecerAdvertencias dentro de una macro AutoExec para desactivar los mensajes. El archivo de base de datos debe ser de confianza para esta acción de macro funcionan; Para obtener más información acerca de las bases de datos de confianza, vea el artículo decidir si debe confiar en una base de datos.

  • Desactivar mensajes de confirmación de consulta de acción para un conjunto específico de tareas   
    elegir este método para desactivar advertencias para la duración de un conjunto de tareas y, a continuación, volver a activarlas; Por ejemplo, puede desactivar los mensajes mientras se ejecuta la consulta Crear tabla y, a continuación, volver a activarlas. Puede usar la acción de macro EstablecerAdvertenciasy también puede usar el método de VBA DoCmd.SetWarnings. El archivo de base de datos debe ser de confianza para esta acción de macro trabajar; Para obtener más información acerca de las bases de datos de confianza, vea el artículo decidir si debe confiar en una base de datos.

Volver al principio

Controlar los mensajes de confirmación de consulta de acción para un equipo

Importante: Si usa esta opción para activar los mensajes de confirmación de consulta de acción desactivar, Access no mostrará los mensajes en ese equipo, incluso para una base de datos que contiene una macro o módulo que activa los mensajes.

  1. En la pestaña Archivo, haga clic en Opciones.

  2. En el lado izquierdo del cuadro de diálogo Opciones de Access, haga clic en Configuración de cliente.

  3. En el lado derecho del cuadro de diálogo Opciones de Access, en la sección Edición, bajo Confirmar, desactive la casilla de verificación de las consultas de acción y, a continuación, haga clic en Aceptar.

Volver al principio

Desactivar mensajes de confirmación de consulta de acción en una base de datos

Puede usar la acción EstablecerAdvertencias en una macro AutoExec para desactivar los mensajes de confirmación de consulta de acción en una base de datos.

Importante: Si la base de datos que contiene la macro no es de confianza, no ejecuta la acción EstablecerAdvertencias. Para obtener más información acerca de confianza y bases de datos, vea el artículo decidir si debe confiar en una base de datos.

Nota: Es posible omitir si ya hay una macro denominada AutoExec, abra la macro en la vista Diseño y, a continuación, realice los pasos del 2 al 4 del procedimiento siguiente.

  1. En la ficha crear, en el grupo Macros y código, haga clic en macros.

    Imagen de la cinta

  2. En la lista desplegable en la parte superior del generador de macros, seleccione la acción EstablecerAdvertencias.

    • Si no ve la acción EstablecerAdvertencias en la lista, en la ficha Diseño, en el grupo Mostrar u ocultar, asegúrese de que está seleccionado Mostrar todas las acciones.

  3. En la acción EstablecerAdvertencias, haga clic en la flecha situada junto a Activar advertencias y seleccione la opción que desee.

  4. Haga clic en Guardar.

  5. En el cuadro de diálogo Guardar como, escriba AutoExec.

  6. Haga clic en Aceptar y luego cierre el Generador de macros. La nueva macro se ejecutará la próxima vez que abra la base de datos.

Para obtener más información sobre cómo crear macros, vea el artículo crear una macro de interfaz de usuario.

Volver al principio

Desactivar mensajes de confirmación de consulta de acción para un conjunto específico de tareas

Hay dos formas básicas para desactivar los mensajes de confirmación de consulta de acción en un conjunto de tareas: mediante una macro y mediante un módulo VBA. En ambos casos, utilice código para desactivar las advertencias, realizar el conjunto de tareas y, a continuación, volver a activar las advertencias. Adjuntar el código a un evento, como el Evento clic un botón de comando o el Evento Open , de un formulario.

Adjuntar un módulo a un evento y, cuando se produce el evento, se ejecuta el módulo. Por ejemplo, puede adjuntar un módulo para el evento Al abrir un formulario. Cuando se abre el formulario, se ejecuta el módulo. El siguiente procedimiento explica cómo usar el método de DoCmd.SetWarnings en el evento al abrir un formulario de.

  1. Abra el formulario en la vista Diseño.

  2. Si la hoja de propiedades no está visible, presione F4 para mostrarla.

  3. Haga clic en el cuadrado en la parte superior izquierdo del formulario, justo debajo de la pestaña de objeto del formulario.

  4. En la hoja de propiedades, en la pestaña otras, asegúrese de que Tiene el módulo está establecida en .

  5. En la pestaña evento, haga clic en el evento Al abrir y, a continuación, haga clic en el botón Generar (los puntos suspensivos junto a la flecha).

  6. En el cuadro de diálogo Elegir generador, siga uno de estos procedimientos:

  7. Escriba DoCmd.SetWarnings (WarningsOff) y, a continuación, presione ENTRAR.

  8. Escriba el código necesario para realizar las tareas que desee realizar con los mensajes de confirmación desactivados.

  9. En una nueva línea, escriba DoCmd.SetWarnings (activaradvertencias).

  10. Cierre el Editor de VBA y guarde el formulario.

Utilice una macro para desactivar los mensajes y hacer copias de

  1. En la lista desplegable en la parte superior del generador de macros, seleccione la acción EstablecerAdvertencias.

    • Si no ve la acción EstablecerAdvertencias en la lista, en la ficha Diseño, en la Mostrar u ocultar grupo, asegúrese de que está seleccionado Mostrar todas las acciones.

  2. En la acción EstablecerAdvertencias, haga clic en la flecha junto a Advertencias y seleccione No.

  3. Especifique las acciones de macro necesarios para llevar a cabo las tareas que desee listo mensajes de confirmación desactivados.

  4. Debajo de la última acción de la tarea, seleccione la acción EstablecerAdvertencias y, a continuación, haga clic en la flecha situada junto a Activar advertencias y seleccione .

  5. Cierre el generador de macros, guarde la macro y, a continuación, guarde el formulario.

Volver al principio

Notas: 

  • Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

  • Para su referencia, puede encontrar la versión en inglés de este artículo aquí. Todos los miembros de la comunidad de Microsoft pueden mejorar este artículo mediante el marco de colaboración en traducciones (CTF). Simplemente, mueva el puntero sobre cualquier frase del artículo y, a continuación, haga clic en "MEJORAR TRADUCCIÓN" en el widget CTF. Haga clic aquí para obtener más información acerca de CTF. Con el uso de CTF, el usuario acepta nuestras Condiciones del servicio.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×