Acción de Macro ImportExportData

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede usar la acción de macro ImportExportData a importar o exportar datos entre la base de datos actual de Access (.mdb o .accdb) o el proyecto de Access (.adp) y la otra base de datos. Bases de datos de escritorio Access, también puede vincular una tabla a la base de datos de Access actual desde otra base de datos. Con una tabla vinculada, tiene acceso a los datos de la tabla mientras la propia tabla permanece en la otra base de datos.

Nota: A partir de Access 2010, la acción de macro TransferirBaseDatos se cambió el nombre a ImportExportData.

Nota: Esta acción no se permitirá si la base de datos no es de confianza.

Configuración

La acción de macro ImportExportData tiene los siguientes argumentos.

Argumento de la acción

Descripción

Tipo de transferencia

El tipo de transferencia que desea realizar. Seleccione Importar, Exportar o vincular en el cuadro Tipo de transferencia en la sección Argumentos de acción de la ventana de diseño de la macro. El valor predeterminado es Importar.

Nota: El tipo de transferencia de vínculo no se admite proyectos de Access (.adp).

Tipo de base de datos

El tipo de base de datos para importar, exportar o vincular a. Puede seleccionar Microsoft Access o uno de los otros tipos de base de datos en el cuadro Tipo de base de datos. El valor predeterminado es Microsoft Access.

Nombre de la base de datos

El nombre de la base de datos para importar, exportar o vincular a. Incluir la ruta completa. Este es un argumento requerido.

Tipos de bases de datos que usan archivos independientes para cada tabla, como FoxPro, Paradox y dBASE, escriba el directorio que contiene el archivo. Escriba el nombre de archivo en el argumento origen (para importar o vincular) o el argumento de destino (para exportar).

Bases de datos ODBC, escriba la completa de conectividad abierta de base de datos (ODBC) cadena de conexión.

Para ver un ejemplo de una cadena de conexión, vincule una tabla externa a Access:

  1. En la pestaña Datos externos, en el grupo Importar, haga clic en Access.

  2. En el cuadro de diálogo Obtener datos externos, escriba la ruta de acceso de la base de datos de origen en el cuadro nombre de archivo.

  3. Haga clic en Vincular al origen de datos creando una tabla vinculada y a continuación, haga clic en Aceptar.

  4. Seleccione una tabla en el cuadro de diálogo Vincular tablas y haga clic en Aceptar.

Abra la tabla recién vinculada en vista Diseño y ver la propiedades de tabla haciendo clic en Hoja de propiedades en la ficha Diseño, en Herramientas. El texto de la propiedad Descripción es la cadena de conexión para esta tabla.

Para obtener más información sobre las cadenas de conexión ODBC, vea el archivo de Ayuda u otra documentación del controlador ODBC de este tipo de base de datos ODBC.

Tipo de objeto

El tipo de objeto a importar o exportar. Si selecciona Microsoft Access para el argumento Tipo de base de datos , puede seleccionar tabla, consulta, formulario, informe, Macro, módulo, Página de acceso a datos, Vista de servidor, diagrama, Procedimiento almacenado o función en el cuadro Tipo de objeto. El valor predeterminado es tabla. Si selecciona cualquier otro tipo de base de datos, o si se selecciona un vínculo en el cuadro Tipo de transferencia, se omite.

Si va a exportar una consulta de selección a una base de datos de Access, seleccione tabla en este argumento para exportar el conjunto de resultados de la consulta y a continuación, seleccione consulta para exportar la propia consulta. Si va a exportar una consulta de selección a otro tipo de base de datos, se omite y se exporta el conjunto de resultados de la consulta.

Origen

El nombre de la tabla, una consulta de selección o un objeto de Access que desea importar, exportar o vincular. Para algunos tipos de bases de datos, como FoxPro, Paradox o dBASE, esto es un nombre de archivo. Incluya la extensión de nombre de archivo (como .dbf) en el nombre de archivo. Este es un argumento requerido.

Destino

El nombre de la tabla importada, exportada o vinculada, la consulta de selección o el objeto de Access en la base de datos de destino. Para algunos tipos de bases de datos, como FoxPro, Paradox o dBASE, esto es un nombre de archivo. Incluya la extensión de nombre de archivo (como .dbf) en el nombre de archivo. Este es un argumento requerido.

Si selecciona Importar en el argumento Tipo de transferencia y tabla en el argumento Tipo de objeto , Access crea una nueva tabla que contiene los datos de la tabla importada.

Si importa una tabla u otro objeto, Access agrega un número al nombre si entra en conflicto con un nombre existente. Por ejemplo, si importa a empleados y empleados ya existe, Access cambia el nombre de la tabla importada u otro objeto Empleados1.

Si exporta a una base de datos de Access o en otra base de datos, Access reemplazará automáticamente cualquier tabla existente u otro objeto que tiene el mismo nombre.

Estructura solamente

Especifica si se va a importar o exportar sólo la estructura de una tabla de base de datos sin ninguno de sus datos. Seleccione o No. El valor predeterminado es No.

Observaciones

Puede importar y exportar tablas entre Access y otros tipos de bases de datos. También puede exportar consultas de selección de Access a otros tipos de bases de datos. Access exporta el conjunto de resultados de la consulta en el formulario de una tabla. Puede importar y exportar cualquier objeto de base de datos de Access si ambas bases de datos son bases de datos de Access.

Si importa una tabla de otra base de datos Access (.mdb o .accdb) que es una tabla vinculada en la base de datos, seguirá vinculada después de importarla. Es decir, se importa el vínculo, no la tabla.

Si la base de datos que tiene acceso requiere una contraseña, aparece un cuadro de diálogo cuando ejecute la macro. Escriba la contraseña en este cuadro de diálogo.

La acción ImportExportData es similar a los comandos de la ficha Datos externos, en Importar o Exportar. Puede usar estos comandos para seleccionar un origen de datos, como una base de datos u otro tipo de base de datos, una hoja de cálculo o un archivo de texto. Si selecciona una base de datos, uno o varios cuadros de diálogo aparecen en el que seleccionar el tipo de objeto a importar o exportar (para bases de datos de Access), el nombre del objeto y otras opciones, dependiendo de la base de datos está importando desde o exportar o vincular a. Los argumentos de la acción ImportExportData reflejan las opciones de estos cuadros de diálogo.

Si desea proporcionar información de índice para una tabla vinculada de dBASE, primero vincule la tabla:

  1. En la pestaña Datos externos, en el grupo Importar, haga clic en más.

  2. Haga clic en archivo de dBASE.

  3. En el cuadro de diálogo Obtener datos externos, escriba la ruta de acceso del archivo de dBASE en el cuadro nombre de archivo.

  4. Haga clic en Vincular al origen de datos creando una tabla vinculada y, a continuación, haga clic en Aceptar.

  5. Especifique los índices en los cuadros de diálogo para este comando. Access almacena la información de índice en un archivo de información especial (.inf), ubicado en la carpeta de Microsoft Office.

  6. Puede eliminar el vínculo a la tabla vinculada.

La próxima vez que use la acción ImportExportData para vincular esta tabla de dBASE, Access usa la información de índice que especificó.

Nota: Si consulta o filtra una tabla vinculada, la consulta o filtro distingue mayúsculas de minúsculas.

Para ejecutar la acción ImportExportData en un módulo Visual Basic para aplicaciones (VBA), use el método de TransferirBaseDatos del objeto DoCmd .

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×