¿Qué ha ocurrido con las plantillas, menús y características de modelo de base de datos?

No todas las ediciones de Microsoft Office Visio incluyen características de modelo de base de datos. Si no encuentra las que busca, compruebe lo siguiente:

¿Qué edición está utilizando?    

Para saber qué edición de Visio tiene, haga clic en la opción Acerca de Microsoft Office Visio del menú Ayuda. El nombre de la edición aparece en la línea de texto situada sobre el cuadro de diálogo.

  • Los estándares de Microsoft Office Visio no incluyen la plantilla Diagrama de modelo de base de datos.

  • Microsoft Office Visio Professional admite las características de ingeniería inversa de la plantilla Diagrama de modelo de base de datos (es decir, utilizar una base de datos existente para crear un modelo en Visio), pero no admite la ingeniería directa (es decir, utilizar un modelo de base de datos de Visio para generar código SQL).

  • En Visio para Arquitectos profesionales, puede buscar el conjunto completo de las características de modelado de base de datos, incluidas tanto la ingeniería inversa como la directa. Esta versión de Visio está incluida con la suscripción a MSDN Premium, disponible en las ediciones basadas en funciones de Visual Studio Professional y Visual Studio Team System.

¿Está trabajando en la plantilla Diagrama de modelo de base de datos?    

Tal vez haya abierto una plantilla de diagrama de base de datos Express-G u ORM, o una plantilla que no sea de base de datos. Estas plantillas no admiten las características de modelado de base de datos, como el menú Base de datos; sólo la plantilla Diagrama de modelo de base de datos las admite. Para abrir la plantilla Diagrama de base de datos, elija la opción Nuevo del menú Archivo, elija Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

¿Aparece el menú Base de datos?    

El menú Base de datos puede desaparecer si Visio encuentra un error imprevisto de un origen interno o externo. Para recuperar el menú, pruebe lo siguiente:

  1. Si Visio se cierra de forma imprevista, reinícielo.

  2. En el menú Herramientas, haga clic en Opciones.

  3. En la ficha Seguridad, seleccione Habilitar eventos de automatización y, a continuación, haga clic en Aceptar.

El menú de base de datos se restaura después de reiniciar Visio y volver a abrir la plantilla Diagrama de modelo de base de datos.

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×