¿Cómo puedo cambiar la configuración de Windows para poder compartir la base de datos de Business Contact Manager con usuarios de otros equipos?

Síntomas

Usted o un administrador debe cambiar algunas partes de la configuración de Microsoft Windows en el equipo antes de compartir la base de datos de Business Contact Manager con los usuarios en otros equipos. En caso contrario, los usuarios no pueden conectarse a base de datos compartida en el ordenador.

Nota  Cuando utiliza Windows XP Home, solo puede compartir la base de datos con usuarios en el mismo equipo, porque esta versión no admite compartir a través de una red.

Importante  Los cambios siguientes solo los puede realizar un administrador.

Causa

Las características de Windows, como, por ejemplo, Firewall de Windows y el uso compartido simple de archivos, están diseñadas para ayudar a proteger los datos en el equipo. Para permitir que otros usuarios obtengan acceso a datos en el equipo, cambie la configuración para estas características.

Solución

Nota  Todos estos cambios los puede realizar por usted el asistente para administrar el uso compartido. Estos procedimientos rara vez serán necesarios.

Inicie sesión como administrador y realice los siguientes cambios. (Si no es administrador, proporcione la siguiente información al administrador para que se realicen los cambios por usted.)

Realizar cambios en la configuración de Windows

Las siguientes instrucciones le ayudan a usted o a un administrador a comprender el impacto de los cambios, y a revisar la configuración actual antes de realizar cambios adicionales manualmente.

Windows XP

  • Cambiar configuraciones de firewall de Windows

    Para permitir a los usuarios el acceso a base de datos compartida desde equipos remotos, debe permitir una conexión (denominada una excepción) a través del firewall de Windows. Además, debe agregar Uso compartido de impresoras y archivos a la lista de excepciones.

    Nota  No puede compartir una base de datos de Business Contact Manager con usuarios en otro equipo cuando la casilla No permitir excepciones está seleccionada en la pestaña General del cuadro de diálogo Firewall de Windows del Centro de seguridad de Microsoft. De forma predeterminada, las excepciones no están permitidas. Al cambiar la configuración del firewall, Business Contact Manager para Outlook desactiva automáticamente esta casilla para permitir a los usuarios obtener acceso a la base de datos compartida. En contadas ocasiones, la configuración existente del firewall de Windows evita que esta casilla se desmarque automáticamente, y es posible que tenga que desactivar la casilla No permitir excepciones manualmente.

    De forma predeterminada, solo se configuran las excepciones del firewall para la subred local (un número utilizado con la dirección IP de un equipo para dividir una gran red en redes pequeñas) a la que pertenece su equipo. Esto permite solo a los usuarios y equipos que pertenezcan a la subred tener acceso a la base de datos compartida.

    Para permitir a un usuario de un equipo que no pertenece a la subred tenga acceso a la base de datos compartida, haga lo siguiente:

    1. En el menú Inicio, haga clic en Panel de control.

    2. En Panel de control, cambie a Vista clásica.

    3. Haga doble clic en Firewall de Windows.

    4. En el cuadro de diálogo Firewall de Windows, haga clic en la pestaña Excepciones.

    5. Haga clic en Microsoft Pequeña Empresa, y, a continuación, haga clic en Editar.

    6. Haga clic en Cambiar ámbito.

    7. Seleccione una de las siguientes opciones:

      • Haga clic en Lista personalizada, y, a continuación, escriba una o más direcciones IP, separadas por comas.

      • Seleccione Cualquier equipo (incluidos los de Internet).

    8. Haga clic en Aceptar para cerrar todos los cuadros de diálogo.

      Información adicional sobre firewall

      Si el equipo utiliza un firewall distinto al que se suministra con Microsoft Windows (como un firewall de un enrutador de red o escáner de virus), y comparte datos con un equipo que se encuentra fuera del firewall, es posible que Business Contact Manager para Outlook no sea capaz de abrir los puertos necesarios para que funcione el uso compartido de la base de datos. Si tiene dificultades para compartir la base de datos con usuarios fuera del firewall, debe abrir puerto TCP 5356 para compartir la base de datos. Para obtener más información sobre cómo abrir este puerto, consulte la documentación del firewall.

      Si elimina todas las bases de datos compartidas, los cambios hechos en el firewall del equipo y los protocolos de red de Microsoft SQL Server Native Client seguirán en efecto cuando decida compartir las bases de datos. Si desea restaurar el firewall y los protocolos de red de SQL Server Native Client a la configuración predeterminada, primero deje de compartir cada base de datos, y, a continuación, elimínelas. Para obtener más información, consulte la sección Dejar de compartir la base de datos en Compartir los datos de Business Contact Manager con otros usuarios y Quitar o eliminar una base de datos de Business Contact Manager.

  • Cambiar configuración de Uso compartido de impresoras y archivos

    En contadas ocasiones, Business Contact Manager para Outlook no puede configurar automáticamente la configuración necesaria del firewall de Windows. En este caso, debe comprobar manualmente que el Uso compartido de impresoras y archivos esté seleccionado como excepción permitida.

    Seleccione la casilla Uso compartido de impresoras y archivos.

    1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

    2. En Panel de control, haga clic en Firewall de Windows.

    3. En el cuadro de diálogo Firewall de Windows, haga clic en la pestaña Excepciones.

    4. En la pestaña Excepciones, seleccione la casilla Uso compartido de impresoras y archivos, y, a continuación, haga clic en Aceptar.

  • Cambiar configuración de Uso compartido simple de archivos

    El uso compartido simple de archivos controla todos los usuarios remotos como usuarios invitados. Para controlar quién tiene acceso a la base de datos, necesita permitir el acceso a los usuarios individuales, y para ello, debe desactivar la casilla Utilizar uso compartido simple de archivos.

    Desactive la casilla Uso compartido simple de archivos.

    1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

    2. En Panel de control, haga clic en Opciones de carpeta.

    3. En el cuadro de diálogo Opciones de carpeta, haga clic en la pestaña Vista.

    4. En la pestaña Vista, desactive la casilla Utilizar uso compartido simple de archivos (recomendado).

    5. Haga clic en Aceptar para cerrar todos los cuadros de diálogo.

Windows Vista

  • Cambiar configuraciones de firewall de Windows

    1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

    2. En Panel de control, cambie a Vista clásica.

    3. Haga doble clic en Firewall de Windows.

    4. En el cuadro de diálogo Firewall de Windows, junto a Firewall de Windows activado, haga clic en Cambiar la configuración.

    5. En el cuadro de diálogo Configuración del firewall de Windows, haga clic en la pestaña Excepciones.

    6. Haga clic en Microsoft Pequeña Empresa, y, a continuación, haga clic en Propiedades.

    7. Haga clic en Cambiar ámbito.

    8. Siga uno de los siguientes procedimientos:

      • Haga clic en Cualquier equipo (incluidos los de Internet).

      • Haga clic en Lista personalizada, y, a continuación, escriba una o más direcciones IP, separadas por comas.

    9. Haga clic en Aceptar para cerrar todos los cuadros de diálogo.

      Nota  No puede ejecutar Business Contact Manager para Outlook cuando la casilla Bloquear todas las conexiones entrantes está seleccionada en la pestaña General del cuadro de diálogo Configuración del Firewall de Windows. De forma predeterminada, las excepciones no están permitidas. Al cambiar la configuración del firewall, Business Contact Manager para Outlook desactiva automáticamente esta casilla para permitir a los usuarios obtener acceso a la base de datos compartida. En contadas ocasiones, la configuración existente del firewall de Windows evita que esta casilla se desmarque automáticamente, y es posible que tenga que desactivar la casilla Bloquear todas las conexiones entrantes manualmente.

  • Cambiar configuración de Uso compartido de impresoras y archivos

    En contadas ocasiones, Business Contact Manager para Outlook no puede configurar automáticamente la configuración necesaria del firewall de Windows. En este caso, debe comprobar manualmente que el Uso compartido de impresoras y archivos esté seleccionado como excepción permitida.

    Seleccione la casilla Uso compartido de impresoras y archivos.

    1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

    2. En Panel de control, cambie a Vista clásica.

    3. Haga doble clic en Firewall de Windows.

    4. En el cuadro de diálogo Firewall de Windows, en el panel de la izquierda, haga clic en Permitir un programa a través del firewall de Windows.

    5. En la pestaña Excepciones, seleccione la casilla Uso compartido de impresoras y archivos, y, a continuación, haga clic en Aceptar.

Windows 7

  • Cambiar configuraciones de firewall de Windows

    1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

    2. Haga clic en Sistema y seguridad y, a continuación, haga clic en Firewall de Windows.

    3. En el panel de la izquierda, haga clic en Configuración avanzada.

      Nota  Si aparece un mensaje de Control de cuentas de usuario, haga clic en .

    4. En el panel izquierdo de la ventana Firewall de Windows con seguridad avanzada, haga clic en Reglas de entrada.

    5. En el panel central, en Reglas de entrada, haga doble clic en Microsoft Pequeña Empresa.

    6. En el cuadro de diálogo Propiedades de Microsoft Pequeña Empresa, haga clic en la pestaña Ámbito.

    7. Siga uno de los siguientes procedimientos:

      • En Dirección IP local y en Dirección IP remota, haga clic en Cualquier dirección IP.

      • En Dirección IP local y en Dirección IP remota, haga clic en Estas direcciones IP, y agregue una o más direcciones IP.

    Nota  Para obtener más información sobre estas opciones de configuración, haga clic en Más información sobre la configuración del ámbito.

    1. Haga clic en Aceptar.

  • Cambiar configuración de Uso compartido de impresoras y archivos

    1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

    2. Haga clic en Sistema y seguridad y, a continuación, haga clic en Firewall de Windows.

    3. En el panel de la izquierda, haga clic en Permitir un programa o función con el firewall de Windows.

    4. Haga clic en el botón Cambiar la configuración.

      Nota  Si aparece un mensaje de Control de cuentas de usuario, haga clic en .

    5. En la lista Programas y características permitidos, active la casilla junto a Uso compartido de impresoras y archivos, y, a continuación, haga clic en Aceptar.

Volver a configurar Microsoft SQL Server Express

Volver a configurar Microsoft SQL Server Express 2008 para permitir que los usuarios de equipos remotos accedan a la base de datos compartida

De manera predeterminada, cuando Business Contact Manager para Outlook instala SQL Server Express 2008, está configurado para restringir las conexiones solo a los usuarios en el equipo local.

Cuando la base de datos de Business Contact Manager se comparte, Business Contact Manager para Outlook activa automáticamente funciones de red para permitir a los usuarios en otros equipos que se conecten a la base de datos compartida al permitir el protocolo TCP/IP y el protocolo de canalizaciones con nombre.

Para activar manualmente la compatibilidad de red para permitir a los usuarios conectarse a esta base de datos desde un equipo remoto, lleve a cabo el siguiente procedimiento.

  1. Haga clic en Inicio, y, a continuación, elija Todos los programas.

  2. Haga clic en Microsoft SQL Server 2008.

  3. Haga clic en Herramientas de configuración, y, a continuación, haga clic en Administrador de configuración de SQL Server.

  4. En el panel izquierdo de la ventana Administrador de configuración de SQL Server, expanda Configuración de red de SQL Server, y luego seleccione Protocolos para MSSMLBIZ.

  5. En el panel derecho, haga clic con el botón secundario en Canalizaciones con nombre, y a continuación, haga clic en Habilitar.

  6. En el panel derecho, haga clic con el botón secundario en TCP/IP, y, a continuación, haga clic en Habilitar.

Cierre la ventana Administrador de configuración de SQL Server.

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Se aplica a: Outlook 2013, Outlook 2016 Preview, Outlook 2010



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