¿Qué es la ventana Relaciones?

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

La ventana Relaciones permite definir la Relación entre los elementos almacenados en varias tablas de Access. Puede visualizarla haciendo clic en Herramientas de base de datos > Relaciones.

Botón Relaciones de la pestaña Herramientas de base de datos

Relaciones son similares a las reglas que determinan cómo se conectan los datos en la base de datos. En una base de datos de procesamiento de pedidos bien normalizado, por ejemplo, probablemente tendrá información del cliente en una tabla y la información del pedido en otra tabla. ¿Desea asegurarse de que los clientes no obtener separados de los pedidos, derecha? Y no quiere que un pedido que se cree que no tiene un cliente válido conectado a ella. La ventana Relaciones es donde vaya a configurar estas reglas para que se aplican a lo largo de la base de datos.

Si antes había creado una consulta de Access, habrá observado que la ventana Relaciones es muy parecida a la parte superior del generador de consultas:

La ventana Relaciones de Access

En la ventana Relaciones, use los comandos de la pestaña Diseño para agregar tablas a la vista y arrastre campos entre las tablas para configurar las relaciones. En este ejemplo, la relación permite conectar varios pedidos a cada cliente, pero no permite crear un pedido para un cliente que no existe. Cuando estas reglas estén configuradas en la ventana Relaciones, se aplicarán a toda la base de datos (por ejemplo, si crea una nueva consulta, las combinaciones se configurarán automáticamente de acuerdo con las reglas de la relación).

Nota: Eliminar una tabla de la ventana Relaciones no la eliminará de la base de datos, ni tampoco eliminará las relaciones ya establecidas.

Cosas que se pueden hacer

Tarea

Cómo hacerla

Agregar una tabla o una consulta a la ventana

Haga clic en Diseño > Mostrar tabla, seleccione la tabla o la consulta que desee y haga clic en Agregar.

Eliminar una tabla o una consulta de la ventana

Seleccione la tabla o la consulta y presione SUPR.

Ocultar una tabla o una consulta

Haga clic con el botón secundario en la tabla o en la consulta y después haga clic en Ocultar tabla.

Crear una relación

Arrastre un campo de una tabla o de una consulta al campo correspondiente de la otra tabla o consulta.

Establecer las propiedades de una relación

Haga clic con el botón secundario en la línea de relación entre dos tablas (puede necesitar varias pruebas para acertar) y después haga clic en Modificar relación.

Eliminar una relación

Haga clic con el botón secundario en la línea de relación entre dos tablas (puede necesitar varios intentos para acertar) y después haga clic en Eliminar.

Mostrar todas las relaciones

Haga clic en Diseño > Todas las relaciones.

Visualizar las relaciones de una tabla concreta

Seleccione la tabla y después haga clic en Diseño > Mostrar relaciones directas.

Visualizar las relaciones de una tabla sin visualizar las relaciones de otras tablas

Haga clic en Diseño > Herramientas > Borrar diseño. Agregue la tabla cuyas relaciones desee visualizar (Diseño > Relaciones > Mostrar tabla) y después haga clic en Diseño > Relaciones > Mostrar relaciones directas.

Ahora que está bien informado sobre la ventana Relaciones, aprenda a crear, editar o eliminar una relación.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×