Función SI

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

La función si es una de las funciones más populares de Excel y le permite realizar comparaciones lógicas entre un valor y lo esperado. En su forma más sencilla, la función si dice:

  • SI(Algo es Verdadero, hacer algo; de lo contrario hacer algo diferente)

Para que una instrucción IF puede tener dos resultados. El primer resultado es si la comparación es True, el segundo si la comparación es False.

Si desea ir directamente al trabajar con varias instrucciones IF, consulte: funciones si avanzadas - trabajar con fórmulas anidadas y evitar los errores.

Use la función SI, una de las funciones lógicas, para devolver un valor si una condición es verdadera y otro si es falsa.

Sintaxis

SI(prueba_lógica; valor_si_verdadero; [valor_si_falso])

Por ejemplo:

  • =SI(A2>B2,"Presupuesto excedido";"Correcto")

  • =SI(A2=B2,B4-A4,"")

Nombre del argumento

Descripción

prueba_lógica    (requerido)

El valor que quiere probar.

valor_si_verdadero    (requerido)

El valor que desea devuelto si el resultado de prueba_lógica es VERDADERO.

valor_si_falso    (opcional)

El valor que desea devuelto si el resultado de prueba_lógica es FALSO.

Ejemplos sencillos de SI

La celda D2 contiene la fórmula =SI(C2="SÍ";1;2)
  • =SI(C2="Sí",1,2)

En el ejemplo anterior, la celda D2 dice: SI(C2 = Sí, entonces devolver un 1, en caso contrario devolver un 2)

La celda D2 contiene la fórmula =SI(C2=1,"SÍ","NO")
  • =SI(C2=1,"Sí","No")

En este ejemplo, la fórmula de la celda D2 dice: SI(C2 = 1, entonces devolver Sí, en caso contrario devolver No)

Como verá, la función si puede usarse para evaluar valores y el texto. También puede utilizarse para evaluar errores. No están limitados a sólo comprobar si un elemento es igual a otra y devolver un resultado único, también puede usar operadores matemáticos y realizar cálculos adicionales en función de los criterios. También puede anidar varias funciones si juntos para realizar comparaciones múltiples.

Nota: Si va a usar texto en las fórmulas, debe ajustar el texto entre comillas (por ejemplo, "texto"). La única excepción a la está utilizando verdadero o falso, que Excel comprende automáticamente.

Primeros pasos

La mejor manera de empezar a escribir una instrucción IF es pensar en lo está intentando llevar a cabo. ¿Qué comparación intenta hacer? Muchas veces, escribir una instrucción IF puede ser tan sencillo como a pensar en la lógica en mente: "¿qué ocurrirá si esta condición se cumple frente a lo que ocurrirá si no está?" Siempre que desee para asegurarse de que sus pasos siguen una progresión lógica, o bien la fórmula no es lo que cree que debería. Esto es especialmente importante al crear complejas instrucciones IF (anidadas).

Más ejemplos de SI

La fórmula de la celda D2 es =SI(C2 > B2,"Presupuesto excedido","Dentro de presupuesto")
  • =SI(C2>B2,"Presupuesto excedido","Dentro de presupuesto")

En el ejemplo anterior, la función en D2 dice SI(C2 es mayor que B2, devolver "Presupuesto excedido"; de lo contrario, devolver "Dentro de presupuesto")

La fórmula de la celda E2 es =SI(C2>B2;C2-B2;"")
  • =SI(C2>B2;C2-B2;0)

En la ilustración anterior, en lugar de devolver un resultado de texto, vamos a devolver un cálculo matemático. Por lo que dice que la fórmula en E2 Si (real es mayor que el presupuestado y, a continuación, resta la cantidad de presupuestado desde la cantidad real, en caso contrario devuelve nada).

La fórmula de la celda F7 es SI(E7="Sí";F5*0,0825,0)
  • =SI(E7="Sí";F5*0,0825;0)

En este ejemplo, la fórmula en F7 dice lo siguiente: SI(E7 = "Sí", calcula la cantidad total con F5 * 8,25 %; en caso contrario, no hay ningún impuesto sobre las ventas, por lo que se devuelve 0)

Procedimientos recomendados: Constantes

En el ejemplo anterior, verá "Sí" tanto la tasa de impuesto sobre las ventas (0.0825) escritos directamente en la fórmula. Generalmente no es una buena costumbre colocar constantes literales (valores que tal vez deba cambiar de vez en cuando) directamente en las fórmulas, porque puede ser difíciles de encontrar y cambiar en el futuro. Es mucho mejor colocar constantes en sus propias celdas, dónde se encuentran en el abrir y fácilmente encontrado y cambiado. En este caso, es Aceptar, porque hay solo una función si y la tasa de impuestos cambiarán con poca frecuencia. Aunque lo hace, es fácil cambiar de la fórmula.

Operadores de cálculo

Si desea obtener más información sobre los operadores de cálculo diferentes que puede usar en las fórmulas, (< menor que, igual a mayor => , <> no es igual a, etc.), consulte este artículo: cálculo operadores y prioridad.

Usar SI para comprobar si una celda está en blanco

A veces es necesario comprobar si una celda está en blanco (normalmente, para que una fórmula no muestre un resultado sin datos de entrada).

La fórmula de la celda E2 es =SI(D2=1,"Sí",IF(D2=2,"No","Es posible"))

En este caso, usaremos SI con la función ESBLANCO:

  • =SI(ESBLANCO(D2);"En blanco";"No está en blanco")

Es decir, IF(D2 is blank, then return "Blank", otherwise return "Not Blank"). Puede utilizar fácilmente su propia fórmula también la condición "no en blanco". En el siguiente ejemplo usaremos "" en lugar de ESBLANCO. La "" básicamente significa "nada".

Comprobar si una celda está en blanco: la fórmula de la celda E2 es =SI(ESBLANCO(D2);"En blanco";"No está en blanco")
  • =SI(D3="";"En blanco";"No está en blanco")

Esta fórmula indica Si (D3 nada, a continuación, volver a "En blanco", en caso contrario "no está en blanco"). Aquí es un ejemplo de un método muy común de utilizar "" para evitar que una fórmula de cálculo si una celda dependiente está en blanco:

  • =SI(D3="";"";SuFórmula())

    SI(D3 equivale a nada, no se devuelve nada; en caso contrario, calcula la fórmula).

Ejemplo de función SI anidada

Mientras que una función SI sencilla solo contiene dos resultados (verdadero o falso), las funciones SI anidadas pueden tener de 3 a 64 resultados.

Usar "" para comprobar si una celda está en blanco: la fórmula de la celda E3 es =SI(D3="";"En blanco";"No está en blanco")
  • =SI(D2=1,"Sí",SI(D2=2,"No","Es posible"))

En la ilustración anterior, la fórmula de E2 dice lo siguiente: SI(D2 es igual a 1, devuelve "Sí"; en caso contrario, SI(D2 es igual a 2, devuelve "No"; en caso contrario, devuelve "Es posible")). Tenga en cuenta que hay dos paréntesis de cierre al final de la fórmula. Son necesarios para completar ambas funciones SI y, si intenta escribir la fórmula sin los dos paréntesis de cierre, Excel intentará corregirlo por usted.

Advertencia

Aunque Excel le permitirá anidar hasta 64 funciones si diferentes, no es aconsejable hacerlo. ¿Por qué?

  • Varias instrucciones IF requieren una gran cantidad de ideas para crearlas correctamente y asegúrese de que su lógica puede calcular correctamente a través de cada condición hasta el final. Si no anida su instrucciones IF 100% con precisión, a continuación, una fórmula puede 75% de la hora de trabajar, pero devolver resultados inesperados 25% del tiempo. Desgraciadamente, la probabilidad de que la detección de 25% es mínima.

  • Mantener varias instrucciones SI puede resultar muy difícil, especialmente si, pasado un tiempo, intenta averiguar lo que usted (o, peor todavía, otra persona) estaba intentando hacer.

  • Varias instrucciones SI requieren varios paréntesis de apertura y cierre (), lo cual puede ser difícil de administrar según la complejidad de la fórmula.

Problemas comunes

Problema

Qué ha fallado

0 (cero) en la celda

No había argumento para valor_si_verdadero ni para valor_si_falso. Para que se devuelva un valor correcto, agregue texto de argumento a los dos argumentos, o agregue VERDADERO o FALSO al argumento.

#¿NOMBRE? en la celda

Normalmente, esto significa que la fórmula se ha escrito mal.

¿Tiene alguna pregunta sobre una función específica?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la próxima versión de Excel? Si es así, vea los temas en el sitio de UserVoice de Excel

Vea también

Vídeo: Funciones si avanzadas

Función de IFS (Office 365, Excel 2016 y posterior)

Funciones si avanzadas - trabajar con fórmulas anidadas y evitar los errores

Vídeos de aprendizaje: funciones si avanzadas

La función contar.Si contar valores basándose en un criterio determinado

La función contar.Si contar valores basándose en varios criterios.

La función SUMAR.Si le sumar valores según un criterio determinado

La función SUMAR.Si.conjunto suma valores basados en varios criterios.

Función AND

Función o

Función CONSULTAV

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en las fórmulas con la comprobación de errores

Funciones lógicas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×