What's new in Excel 2019 for Windows

If you're upgrading to Excel 2019 for Windows from an earlier Excel version, you'll still have all the features you're used to—and you'll notice a few new ones as well!

We continue to make improvements with Excel, and its native functions.

CONCAT

This new function is like CONCATENATE, but better. First of all, it's shorter and easier to type. But it also supports range references, in addition to cell references. Learn more about CONCAT.

IFS

Tired of typing complicated, nested IF functions? The IFS function is the solution. With this function, conditions are tested in the order that you specify. If passed, the result is returned. You can also specify an else "catch all" if none of the conditions are met. Learn more about IFS.

MAXIFS

This function returns the largest number in a range, that meets a single or multiple criteria. Learn more about MAXIFS.

MINIFS

This function is similar to MAXIFS, but it returns the smallest number in a range, that meets a single or multiple criteria. Learn more about MINIFS.

SWITCH

This function evaluates an expression against a list of values in order, and returns the first matching result. If no results match, the "else" is returned. Learn more about SWITCH.

TEXTJOIN

This function combines text from multiple ranges, and each item is separated by a delimiter that you specify. Learn more about TEXTJOIN.

Map charts

You can create a map chart to compare values and show categories across geographical regions. Use it when you have geographical regions in your data, like countries/regions, states, counties or postal codes. Watch a quick map chart video here.

Excel MapChart with Value data

Funnel charts

Funnel charts show values across multiple stages in a process. For example, you could use a funnel chart to show the number of sales prospects at each stage in a sales pipeline. Typically, the values decrease gradually, allowing the bars to resemble a funnel.

Funnel chart showing sales pipeline; stages listed in the first column, values in the second

Scalable Vector Graphics (SVG)

Bring visual interest to your documents, worksheets, and presentations by inserting Scalable Vector Graphics (SVG) that have filters applied to them.

Slide with examples of SVG filters

Convert SVG icons to shapes

Transform all SVG pictures and icons into Office shapes so you can change their color, size, or texture.

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Insert 3D models to see all the angles

Use 3D to increase the visual and creative impact of your workbooks. Easily insert a 3D model, then you can rotate it through 360 degrees.

Download a template and give it a try!

3D model showing rotation handles

We introduced Inking features in Office 2016, but we're constantly improving, and adding features.

New ink effects

Express your ideas with flair using metallic pens and ink effects like rainbow, galaxy, lava, ocean, gold, silver, and more.

Pen dropdown showing Ink Effects

Digital Pencil

Write or sketch out ideas with our new pencil texture.

Blue pencil

Customizable, portable pen set

Create a personal set of pens to suit your needs. Office remembers your pen set in Word, Excel, and PowerPoint across all your Windows devices.

Pen gallery

Ink equations

Including math equations has gotten much easier. Now, you can go to Insert > Equation > Ink Equation, any time you want to include a complex math equation in your workbook. If you have a touch device, you can use your finger or a touch stylus to write math equations by hand, and Excel will convert it to text. (If you don't have a touch device, you can use a mouse to write, too). You can also erase, select, and correct what you've written as you go.

Equation button on the Excel 2016 ribbon

Show ink equation pane in PowerPoint

New Ink Replay button

Using ink in your spreadsheets? Now you can replay or rewind your ink to better understand the flow of it. Or your peers can replay it to get step-by-step instructions. You'll find Ink Replay on the Draw tab. Give it a try!

Lasso Select at your fingertips

Excel now has Lasso Select The Lasso Select button on the Draw tab in PowerPoint , a free-form tool for selecting ink. Drag with the tool to select a particular area of an ink drawing, and then you can manipulate that object as you wish. For more information, see Draw and annotate with ink in Office.

Convert ink drawing to shapes

The Draw tab lets you select inking styles and start making ink annotations on your touch-enabled device. However, you can also convert those ink annotations to shapes. Just select them, and then select Convert to Shapes. That way, you get the freedom of freeform drawing with the uniformity and standardization of Office graphic shapes. To learn more about inking in Office, see Draw and annotate with ink in Office.

Use your Surface pen to select and change objects

In Excel, with a Surface pen, you can select an area without even tapping the selection tool on the ribbon. Just press the barrel button on the pen and draw with the pen to make a selection. Then you can use the pen to move, resize, or rotate the ink object. For more information, see Draw and annotate with ink in Office.

One-click fixes for accessibility issues

The Accessibility Checker is better than ever with updated support for international standards, and handy recommendations to make your documents more accessible.

Computer screen with document on the left and Accessibility visual with a check mark on the right

Helpful sounds improve accessibility

Turn on audio cues to guide you as you work.

Partial view of Excel's Ease of Access Settings

Insert recent links

Easily attach hyperlinks to recent cloud-based files or websites, and create meaningful display names for people using screen readers. To add a link to a recently used file, on the Insert tab, choose Link and select any file from the displayed list.

Insert recent links

View and restore changes in workbooks that are shared

Quickly view who has made changes in workbooks that are shared, and easily restore earlier versions. For more information, see View historical versions of Office files.

Quickly save to recent folders

This feature was highly requested by our customers: Go to File > Save As > Recent, and you’ll see a list of recently accessed folders that you can save to.

Precision selecting

Ever selected too many cells or the wrong ones? You can now deselect extraneous cells without having to start over.

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Quick access to superscript and subscript

Keep the superscript and subscript commands at your fingertips by adding them to the Ribbon or Quick Access Toolbar.

Quick Access Toolbar showing superscript and subscript commands

Improved autocomplete

Excel autocomplete isn't as picky as it was before. For example, let's say you want to use the NETWORKDAYS function, but you can't remember how it is spelled. If you just type =DAYS, the autocomplete menu will bring back all of the functions that contain "DAYS," including, NETWORKDAYS. Before, you had to spell the function name exactly.

New Themes

There are now three Office Themes that you can apply: Colorful, Dark Gray, and White. To access these themes, go to File >Options > General, and then click the drop-down menu next to Office Theme.

Black Theme

The highest-contrast Office theme yet has arrived. To change your Office theme, go to File > Account, and then click the drop-down menu next to Office Theme. The theme you choose will be applied across all your Office apps. To learn more about Office themes, see Change the look and feel of Office for Windows with Office themes.

Break the language barrier

Translate words, phrases, or sentences to another language with Microsoft Translator. You can do this from the Review tab in the ribbon.

Translator button, and one word in English and its translation in French

No warnings when saving a CSV file

Remember this warning? "This file may contain features that are not compatible with CSV..." Well, you asked for it! We will no longer show this when saving a CSV file.

CSV (UTF-8) support

You asked for it on our Excel User Voice forum: You can now open and save CSV files that use UTF-8 character encoding. Go to File > Save As > Browse. Then click the Save as type menu, and you'll find the new option for CSV UTF-8 (Comma delimited). CSV UTF-8 is a commonly used file format that supports more characters than Excel’s existing CSV option (ANSI). What does this mean? Better support for working with non-English data, and ease of moving data to other applications.

Data Loss Protection (DLP) in Excel

Data Loss Protection (DLP) is a high-value enterprise feature that is well loved in Outlook. We are introducing DLP in Excel to enable real time scan of content based on a set of predefined policies for the most common sensitive data types (e.g., credit card number, social security number, and US bank account number). This capability will also enable the synchronization of DLP policies from Office 365 in Excel, Word, and PowerPoint, and provide organizations with unified policies across content stored in Exchange, SharePoint and OneDrive for Business.

Excel is known for its flexible and powerful analysis experiences, through the familiar PivotTable authoring environment. With Excel 2010 and Excel 2013, this experience was significantly enhanced with the introduction of Power Pivot and the Data Model, bringing the ability to easily build sophisticated models across your data, augment them with measures and KPIs, and then calculate over millions of rows with high speed. Here are some of the enhancements we made, so that you can focus less on managing your data and more on uncovering the insights that matter.

Personalize the default PivotTable layout   

Set up a PivotTable the way you like. Choose how you want to display subtotals, grand totals, and the report layout, then save it as your default. The next time you create a PivotTable, you will start with that layout.

Automatic relationship detection   

Discovers and creates relationships among the tables used for your workbook’s data model, so you don’t have to. Excel knows when your analysis requires two or more tables to be linked together, and notifies you. With one click, it does the work to build the relationships, so you can take advantage of them immediately.

Creating, editing, and deleting custom measures   

Can now be done directly from the PivotTable fields list, saving you a lot of time when you need to add additional calculations for your analysis.

Automatic time grouping   

Helps you to use time-related fields (year, quarter, month) in your PivotTable more powerfully, by auto-detecting, and grouping them on your behalf. Once grouped together, simply drag the group to your PivotTable in one action, and immediately begin your analysis across the different levels of time with drill-down capabilities.

PivotChart drill-down buttons   

Allow you to zoom in and out across groupings of time, and other hierarchical structures within your data.

Search in the PivotTable   

Field list helps you get to the fields that are important to you across your entire data set.

Smart rename   

Gives you the ability to rename tables and columns in your workbook’s data model. With each change, Excel automatically updates any related tables, and calculations across your workbook, including all worksheets and DAX formulas.

Multiple usability improvements   

Have also been made. For example, delayed updating allows you to perform multiple changes in Power Pivot without the need to wait until each is propagated across the workbook. The changes will be propagated at one time, once the Power Pivot window is closed.

PivotTable with callouts showing the new features in Excel 2016

Multi-select Slicer   

You can select multiple items in an Excel Slicer on a touch device. This is a change from prior versions of Excel, where only one item in a Slicer could be selected at a time using touch input. You can enter Slicer multi-select mode by using the new button located in the Slicer’s label.

Slicer choices with the multi-select button highlighted

Faster OLAP PivotTables!   

If you work with connections to OLAP servers, your PivotTables are now faster. The June 2016 update contains query and cache improvements in this powerful feature’s performance. You could benefit from this work, whether you use PivotTables to answer one-off questions, or build complicated workbooks with dozens of PivotTables. It doesn’t matter if your PivotTables are connected to a tabular or multi-dimensional model, Any PivotTable connected to Microsoft SQL Server Analysis Services, 3rd party OLAP providers, or the Power Pivot Data Model will likely give you fresh data, faster. Additionally, now if you disable Subtotals and Grand Totals, PivotTables can be much faster when refreshing, expanding, collapsing, and drilling into your data. The bigger the PivotTable, the bigger the potential improvement. Specifically, we have made improvements in three major areas while querying OLAP servers:

  • Improved query efficiency: Excel will now query for Subtotals and Grand Totals only if they’re required to render the PivotTable results. This means you wait less for the OLAP server to finish processing the query, and you wait less while waiting for the results to transfer over your network connection. You simply disable Subtotals and Grand Totals from the PivotTable Design tab just like you would normally. See: Show or hide subtotals and totals in a PivotTable.

  • Reduced the number of queries: Excel is smarter when refreshing your data. Queries will now only refresh when they’ve actually changed and need to be refreshed.

  • Smarter caches: When the PivotTable schema is retrieved, it is now shared across all of the PivotTables on that connection, further reducing the number of queries.

Save relationship diagram view as picture   

Save the data model diagram view as a high resolution image file that can then be used for sharing, printing or analyzing the data model. To create the image file, in the Power Pivot pane, click File > Save View as Picture.

Enhanced Edit Relationship dialog creates faster and more accurate data relationships   

Power Pivot users can manually add or edit a table relationship while exploring a sample of the data—up to five rows of data in a selected table. This helps create faster and more accurate relationships, without the need to go back and forth to the data view every time you wish to create, or edit a table relationship.

Power Pivot - Enhanced Edit Relationship dialog

Table selection using keyboard navigation   

In the Edit Relationship dialog, type the first letter of a table name to move the first column name starting with the selected letter.

Column selection using column navigation   

In the Edit Relationship dialog, type the first letter of a column name to move the first column starting with the selected letter. Retype the same letter moves to the next column starting with the selected letter.

Auto column suggestion for same column name in both tables   

After selecting the first table and column, on the selection of the second table, if a column with the same name exists, it is auto-selected (works both ways).

Fixes that improve your overall modeling user experience   

1) The Power Pivot data model is no longer lost when working with hidden workbooks; 2) You can now upgrade an earlier workbook with a data model to Excel 2016 and later; and 3) You can add a calculated column in Power Pivot, unless it contains a formula.

If you have a Power BI subscription, you can now publish files that are stored locally to Power BI. To get started, first save your file to your computer. Then click File > Publish > Publish to Power BI. After you upload, you can click the Go To Power BI button to see the file in your web browser.

This section contains improvements made to Get & Transform (also known as Power Query).

New and improved connectors

We have new connectors in Excel 2019. For example, there's the new SAP HANA connector. We also have improved many of our existing connectors so that you can import data from a variety of sources with efficiency and ease. For more information on our connectors, see Import data from external data sources.

Data > Get & Transform > Get Data options

Improved transformations

In Excel 2019 we have significantly improved many of the data transformation features in the Power Query Editor. For example: Splitting columns, inserting custom columns, and adding columns from an example are improved. Plus, merge and append operations, and filtering transforms are enhanced as well.

Power Query combine columns with example option on teh Add Column tab

General improvements

Excel 2019 also has some general improvements across the Get & Transform area in Excel 2019. One notable improvement is the new Queries & Connections side pane, which lets you manage queries and connections easily . There are also many improvements to the Power Query Editor as well, including “select-as-you-type” drop-down menus, date picker support for date filters and conditional columns, the ability to reorder query steps via drag-and-drop, and the ability to keep the layout in Excel when refreshing. For general information about how to get started with Get & Transform, see the article, Unified Get & Transform experience.

For more information on updates to Get & Transform, check out the Excel Blog.

Grow your Office skills

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×