View and update task dependencies (links) across projects

When a task in one project has an external dependency on a task in another project, you should review and update that dependency periodically to make sure that the dependent task isn't affecting your project's critical path. After dependencies are updated, you can filter your tasks to show only those that have external dependencies.

Note: Your project schedule is not updated automatically when external dependencies change, so it is important to review and update dependencies regularly. Viewing and updating external dependencies on tasks in other projects is not the same as viewing and updating inter-project dependencies. Inter-project dependencies are not associated with specific tasks.

What do you want to do?

View and update external dependencies

Show only tasks that have external dependencies

View and update external dependencies

  1. Choose View > Gantt Chart.

  2. If any filters are turned on, turn them off: On the View tab, in the Data group, select No Filter in the Filter list.

    (In Project 2007, choose AutoFilter Button image to turn them off.)

    When AutoFilters are turned on, an arrow is displayed to the right of each field heading. Turning off AutoFilters displays all tasks.

  3. Choose Project > Links Between Projects.

    (In Project 2007, choose Tools > Links Between Projects.)

  4. View external predecessor tasks or successor tasks:

    • To see a list of tasks that are linked to external predecessor tasks, select the External Predecessors tab.

    • To see a list of tasks that are linked to external successor tasks, select the External Successors tab.

  5. For changes to external predecessors that affect the successor tasks in your project, review the Differences column.

    Differences usually include a new start or finish date for the external predecessor or external successor. The new date is typically the result of a changed duration, constraint, tracked progress, or other parameter. Changes to a task's name are also shown in the Differences column.

  6. Review and accept changes to external links:

    • To selectively accept changes to external predecessors, in the Task column, select each external predecessor or successor that has changes that you want to accept, and then choose Accept.

    • To accept all changes, choose All.

Notes: 

  • You cannot undo acceptance of the changes after you choose OK — however, you are assured that the project is synchronized with all external files.

  • Be careful to remember which changes you do not accept, because your project will not be synchronized with the external files that contain any changes that you reject. There will be no record of the rejected changes.

  • By default, you are notified whenever data in an externally linked task changes. When you open a plan that has external links, the external predecessors, external successors, and effects on your schedule are displayed, and you can choose to accept any or all changes. If you do not want to be notified of such changes, choose File > Options > Advanced (in Project 2007, choose Tools > Options > View). Under Cross project linking options for, clear the Show Links Between Projects dialog on open check box. To automatically accept changes each time that you open the plan, select the Automatically accept new external data check box.

  • If you want to hide external tasks, choose File > Options > Advanced (in Project 2007, choose Tools > Options > View), and then select the View tab. Clear the Show external successors and Show external predecessors check boxes.

Top of Page

Show only tasks that have external dependencies

  1. Choose View > Gantt Chart.

  2. If any filters are turned on, turn them off: On the View tab, in the Data group, select No Filter in the Filter list.

    (In Project 2007, choose AutoFilter Button image to turn them off.)

    When AutoFilters are turned on, an arrow is displayed to the right of each field heading. Turning off AutoFilters displays all tasks.

  3. On the View tab, in the Data group, choose New Filter from the Filter list.

    (In Project 2007, choose Project > Filtered for > More Filters, select Task, and then choose New.)

  4. Type a new name for the filter in the Name box.

    For example, you can type Tasks with external dependencies.

  5. In the first row of the Field Name column, select Predecessors.

  6. In the first row of the Test column, select contains.

  7. In the first row of the Values column, type a backslash (\) to indicate that you are adding a link to an external predecessor.

    Next, create the test string for successor tasks:

  8. In the second row of the And/Or column, select Or.

  9. In the second row of the Field Name column, select Successors.

  10. In the second row of the Test column, select contains.

  11. In the second row of the Values column, type a backslash (\).

  12. Choose Save (in Project 2007, choose OK) to close the dialog box, and then choose Apply.

  13. On the View tab, in the Data group, select your new filter rom the Filter list to show only those tasks that have external predecessor tasks or successor tasks.

    (In Project 2007, the new filter is automatically applied.)

Top of Page

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×