Supported browsers for Outlook Web App

Not all web browsers support the standard version of Outlook Web App. If you're using a browser that doesn't support the standard version of Outlook Web App, you'll automatically be directed to the light version.

This article is for Outlook Web App, which is used by organizations that manage email servers running Exchange Server 2013 or 2010. If you're using Office 365 or Exchange Server 2016, your email program is Outlook on the web. For help with Outlook on the web, see Get help with Outlook on the web.

The list below is of the minimum browser versions that fully support the standard version of Outlook Web App. Earlier versions might display the standard version, but some features might not be available depending on the operating system you're using. Whenever possible, it's best to use the latest version of your web browser.

Tip: When using one of these browsers, you can select the light version of Outlook Web App if you prefer. See Outlook Web App Light for instructions.

  • Internet Explorer 10

  • Microsoft Edge

  • Firefox 17

  • Chrome 24

  • Safari 6

  • Internet Explorer prior to version 10

  • Firefox prior to version 17

  • Chrome prior to version 24

  • Safari prior to version 6

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×