Publish a workbook to a SharePoint site in Excel for Windows

You can publish a workbook to a Microsoft SharePoint library so that people can view or edit it in a web browser without needing Excel installed on their computers. Publishing is essentially the same as saving, but with some built-in options that let you control what people can see when they open the workbook in a browser.

Adopting an organization-wide practice of saving or publishing a workbook to a central SharePoint site can help you ensure that slightly different versions of the same workbook don't start popping up all over your organization when it's sent around in email.

By setting some publish options, you can emphasize specific parts of your workbook, such as charts, or exclude other parts from being viewed in the browser. For example, you can show a chart but not its underlying data. Or, you can show only certain worksheets to those people who need to see them and hide the other worksheets.

This article shows you how to publish a workbook from Excel for Windows and does not cover connecting a workbook or workbook data to an Excel Web Access Web Part on a SharePoint page.

When you publish a workbook to a SharePoint site, the entire workbook is saved to SharePoint. A user with the needed SharePoint permissions can view and work with the entire workbook either in the browser or in the Excel desktop program.

If Office Online is deployed on SharePoint, viewing and working with your data in the browser can be very much like working with your data in the Excel desktop program. In fact, unlike the Excel desktop program, multiple users can simultaneously edit a workbook in the browser grid. When you view a workbook in the browser, if the Edit in Excel Online button is visible, you'll know that Office Online is ready to use.

Edit in Excel Online on the Edit Workbook menu

Prepare the workbook

Before you publish the workbook, you can choose to select only the worksheets or items that you want visible in the browser. Just remember that although you can limit what is viewable in this mode, the entire contents of the workbook are still saved to the SharePoint server.

If you want to include entire worksheets as an item in addition to other items, such as charts or PivotTables, define the entire worksheet as a named range. Select the entire worksheet, and then define a named range. This named range will then appear as an available item in the Publish Options dialog box when you are ready to publish.

To let users enter a value in a cell to work with a formula in another cell, set that cell as a defined name in Excel before you publish the workbook. You can then add that defined name as a parameter on the Parameters tab in the Browser View Options dialog box.

For example, the following shows a cell D2, that has the defined name "Rate." In the browser, a user enters a value of 5.625 in the Rate box in the Parameters pane, and then clicks Apply. That value then appears in cell D2, and the formula in A2 uses the value in D2. The result of the formula is recalculated, and shown in A2: $1,151.31.

Entering a parameter in the pane uses it in cell D2

Note: If you create slicers for an Excel table and define a name for the range of cells containing the table and slicers, you won't be able to use the slicers to filter the table in the browser if you publish the defined range. If you publish the table or the entire worksheet or its workbook, the slicers will work as expected in the browser.

Publish the workbook

  1. Click the File tab, click Save As, and then click SharePoint.

  2. If you see your SharePoint folder under Current, Recent, or Older, click the folder you want.

    The Save As dialog box appears.


    Otherwise, click Browse, enter the web address for the SharePoint site, and then browse to the folder where you want to publish the workbook.

    Click a SharePoint folder or click Browse
  3. To select individual worksheets or items to publish from the workbook, click Browser View Options.

    In the Save As dialog box, click Browser View Options

    You'll see the Show tab and the Parameters tab.

  4. If you just want to publish the entire workbook, click Save. Otherwise, do one of the following:

    • To show the entire workbook in the browser, on the Show tab, select Entire Workbook in the list box.

    • To show only specific worksheets in the browser, on the Show tab, select Sheets in the list box, and then clear the check boxes for the sheets you don't want hidden in the browser.

      By default, all sheets are selected. To quickly make all sheets viewable after you unselected some of the check boxes, select the All Sheets check box.

    • To show only specific items in the browser (such as named ranges, charts, tables, or PivotTables), on the Show tab, select Items in the Workbook in the list box, and then select the check boxes for the items that you want to show.

    • On the Parameters tab, add any defined names you want to use to specify cells that are editable when users view the workbook in the browser, and then click OK.

  5. Save the workbook.

Notes: 

  • If you select items that have the same name (such as a chart and its underlying table of data), only one of these items will be available in the browser. To show all the items, make sure that each item in the workbook has a unique name.

  • You can rename tables on the Design tab in the Properties group, rename PivotTables on the Options tab in the PivotTable group, and rename charts or PivotCharts on the Layout tab in the Properties group. Rename other duplicate items, such as named ranges on the Formulas tab in the Defined Names group.

If Office Online is deployed on SharePoint, viewing and working with your data in the browser can be very much like working with your data in the Excel desktop program. In fact, unlike the Excel desktop program, multiple users can simultaneously edit a workbook in the browser grid. When you view a workbook in the browser, if the Edit in Excel Online button is visible, you'll know that Office Online is ready to use.

Edit in Excel Online on the Edit Workbook menu

For more information, see the article Differences between using a workbook in Excel and Excel Services.

Prepare the workbook

Before you publish the workbook, you can choose to select only the worksheets or items that you want visible in the browser. Just remember that although you can limit what is viewable in this mode, the entire contents of the workbook are still saved to the SharePoint server.

If you want to include entire worksheets as an item in addition to other items, such as charts or PivotTables, define the entire worksheet as a named range. Select the entire worksheet, and then define a named range. This named range will then appear as an available item in the Publish Options dialog box when you are ready to publish.

To let users enter a value in a cell to work with a formula in another cell, set that cell as a defined name in Excel before you publish the workbook. You can then add that defined name as a parameter on the Parameters tab in the Browser View Options dialog box.

For example, the following shows a cell D2, that has the defined name "Rate." In the browser, a user enters a value, 5.625, in the box in the Parameters pane and clicks Apply. That value then appears in cell D2, and the formula in A2 uses the value in D2. The result of the formula is recalculated, and shown in A2: $1,151.31.

See Excel Help for information about how to define ranges.

Entering a parameter in the pane uses it in cell D2

Note: If you create slicers for an Excel table and define a name for the range of cells containing the table and slicers, you won't be able to use the slicers to filter the table in the browser if you publish the defined range. If you publish the table or the entire worksheet or its workbook, the slicers will work as expected in the browser.

Publish the workbook

  1. Click File > Save As >SharePoint.

  2. If you see your SharePoint folder underCurrent Folder or Recent Folders, click the folder you want. Otherwise, click Browse and enter the web address for the SharePoint site. Then, browse to the folder where you want to publish the workbook. The Save As dialog box appears.

  3. To select individual worksheets or items to publish from the workbook, click Browser View Options. You'll see a Show tab and a Parameters tab. If you just want to publish the entire workbook, click Save. Otherwise, do one of the following:

    • To show the entire workbook in the browser, on the Show tab, select Entire Workbook in the list box.

    • To show only specific worksheets in the browser, on the Show tab, select Sheets in the list box, and then uncheck the boxes for the sheets you don't want hidden in the browser.

      By default, all sheets are selected. To quickly make all sheets viewable again after you uncheck some of the boxes, select the All Sheets check box.

    • To show only specific items in the browser (such as named ranges, charts, tables, or PivotTables), on the Show tab, select Items in the Workbook in the list box, and then check the boxes for the items that you want to show.

    • On the Parameters tab, add any defined names you want to use to specify cells that are editable when users view the workbook in the browser. Then click OK to close the dialog box.

  4. Save the workbook.

Notes: 

  • If you select items that have the same name (such as a chart and its underlying table of data), only one of these items will be available in the browser. To show all the items, make sure that each item in the workbook has a unique name.

  • If you select items that have the same name (such as a chart and its underlying table of data), only one of these items will be available in the browser. To show all the items, make sure that each item in the workbook has a unique name.

  • You can rename tables on the Design tab in the Properties group, rename PivotTables on the Options tab in the PivotTable group, and rename charts or PivotCharts on the Layout tab in the Properties group. Rename other duplicate items, such as named ranges on the Formulas tab in the Defined Names group.

  • You can rename tables on the Design tab in the Properties group, rename PivotTables on the Options tab in the PivotTable group, and rename charts or PivotCharts on the Layout tab in the Properties group. Rename other duplicate items, such as named ranges on the Formulas tab in the Defined Names group.

For more information about Excel Web Access web parts, see the article Display a workbook in an Excel Web Access web part.

When you publish a workbook to a SharePoint server, the entire contents of the workbook are saved to the server and can be viewed and worked with if you open the workbook in the Excel desktop program. If Office Web Apps are deployed on the SharePoint server, viewing and working with your data in the web browser can be very much like working with your data in the Excel desktop program. In fact, simultaneous editing of a workbook is possible in the browser grid when Office Web Apps are deployed. When you view a workbook in the browser, if the Edit in Browser button is visible, this means that Office Web Apps are available.

Edit in Browser button

For more information, see the article Differences between using a workbook in Excel and Excel Services.

Prepare the workbook

Before you publish the workbook, you have the opportunity (in the Publish Options dialog box) to select the worksheets or items that you want visible in the browser when editing has not been enabled by clicking the Edit in Browser button. Just remember that although you can select what is viewable in this mode, the entire contents of the workbook are still saved to the SharePoint server.

If you want to include entire worksheets as an item in addition to other items, such as charts or PivotTables, define the entire worksheet as a named range. Select the entire worksheet, and then define a named range. This named range will then appear as an available item in the Publish Options dialog box when you are ready to publish.

If you want to allow users to provide a parameter to a formula when viewing a worksheet in a browser, set a cell as a defined name. You can then add that defined name as a parameter on the Parameters tab in the Publish Options dialog box.

For example, in the following graphic that shows a worksheet in the browser, cell D2 has the defined name Rate. In the browser, a user has entered a value, 5.625, in the box in the Parameters pane and then clicked Apply. That value then appears in cell D2, and the formula in A2 uses the value in D2. The result of the formula is recalculated, and shown in A2: $1,151.31.

Using a parameter in the browser

See Excel Help for information about how to define ranges.

Publish the workbook

  1. Click the File tab, and then click Save & Send.

  2. Click Save to SharePoint.
    Note     If the Save to SharePoint command is unavailable, you can still save the workbook to a SharePoint site by using the Save As command. The Publish Options dialog box will not be available. You can also directly upload the workbook from a SharePoint library. Users can view and edit the contents of the workbook in the browser by going directly to the site where the workbook is saved.

    The Save As command

  3. If you want to select individual worksheets or items to publish in the workbook, click the Publish Options button. Otherwise, if you want to publish the entire workbook, skip directly to step 4.
    On the Show tab, do the following:

    • To show the entire workbook in the browser, select Entire Workbook in the list box.

    • To show only specific worksheets in the browser, select Sheets in the list box, and then clear the check boxes for the sheets that you do not want to make visible.
      Note     By default, all sheets are selected. To quickly make all sheets viewable again after you clear some of the check boxes, you can select the All Sheets check box.

    • To show only specific items in the browser (such as named ranges, charts, tables, or PivotTables), select Items in the Workbook in the list box, and then select the check boxes of the items that you want to show.
      Note  If you select items that have the same name (such as a chart and its underlying table of data), only one of these items will be available in the browser. To show all the items, you must make sure that each item in the workbook has a unique name. You can rename tables on the Design tab in the Properties group, rename PivotTables on the Options tab in the PivotTable group, and rename charts or PivotCharts on the Layout tab in the Properties group. Duplicate items, such as named ranges, can be renamed on the Formulas tab in the Defined Names group.
      Selecting worksheets or items

    • On the Parameters tab, add any defined names that you want to use to specify cells that are editable when users view the workbook in the browser. Then click OK to close the dialog box.
      Setting parameters

  4. Choose a location in which to publish your workbook.
    There may already be saved server locations under Current Location, Recent Locations, or Locations from which you can choose. If there are no such locations, or you want to save to a new location, under Locations, double-click Browse for a location.

  5. In the Save As dialog box, enter the web address for the SharePoint site, and then browse to the site or library in which you want to save your workbook.

  6. If you haven't already selected individual worksheets or items or set parameters, click the Publish Options button.

  7. In the File name box, accept the suggested name for the workbook, or type a new name if you want.

  8. To display the workbook contents in a browser window immediately after the publish operation has completed, make sure the Open with Excel in the browser check box is selected.

  9. Click Save.

Expand your Office skills
Explore training
Got It
Get instant Excel help
Connect to an expert now
Subject to Got It terms and conditions

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×