Mail merge with envelopes

Step 1: Set up your mailing list

The mailing list is your data source. For more info, see Data sources you can use for a mail merge.

Tips

  • If you don’t have a mailing list, you can create one during mail merge. Collect all of your address lists, and add them to your data source.

  • If you're using an Excel spreadsheet, format the ZIP Codes or postal codes column as text to preserve any zeros. For more info see Format mail merge numbers, dates, and other values in Excel.

  • If you want to use your Outlook contacts, make sure Outlook is your default email program.

If necessary, run a test on a small test batch of envelopes before you do a real mail merge.

  1. Go to File > New > Blank document.

  2. Go to Mailings > Envelopes.

    Print envelopes

  3. In the Delivery address box, type a sample address to test how an envelope looks when printed.

  4. Type your address in the Return address box.

    Return address box

  5. Select Options > Envelope Options and do the following:

    • Choose the size that matches your envelope or choose Custom size to set size.

      Envelope options tab for setting envelope size and address fonts

    • If needed, choose a font and the left and top offset position for Delivery address and Return address.

  6. On the Printing Options tab, confirm the correct Feed method is selected, load the envelope to match the illustration, and then choose OK.

    Feed options diagram for feeding envelopes into the printer

  7. Choose Print, and then choose Yes to save the return address as the default address.

  1. Go to Mailings > Start Mail Merge > Envelopes.

    Start Mail Merge menu

  2. In the Envelope Options dialog box, check your options, and then choose OK.

  3. If you'd like to add a return address, or logo, to your envelope now is a good time to add that.

  4. Choose File > Save.

  1. Go to Mailings > Select Recipients.

    Type a New List command

  2. Choose a data source. For more info, see Data sources you can use for a mail merge.

  3. Choose File > Save.

If you need to edit your mailing list, see Mail merge: Edit recipients.

The address block is a mail merge field that you place where you want addresses to appear on the envelope. To better see where, press CTRL+SHIFT+8 to turn on paragraph marks (¶).

  1. Place your cursor were you want the address block to go.

  2. Go to Mailings > Address Block and choose a format. For more info, see Insert Address Block.

    Address block options

  3. Choose a format in the Insert Address Block dialog box, for the recipient's name as it will appear on the envelope.

  4. If you want, choose Next Next record button for mail merge preview results or Previous Previous record button for mail merge preview results to move through a few records in your data source to see how they look.

  5. Choose OK.

  6. Go to File > Save to save your merge document.

If any part of your address is missing, see Mail merge: Match Fields to fix.

Do a final check before you print the envelopes.

  1. Choose Next Next record button for mail merge preview results or Previous Previous record button for mail merge preview results to move through a few records in your data source to see how they look.

  2. Choose Finish & Merge > Print Documents.

    Screenshot of the Mailings tab in Word, showing the Finish & Merge command and its options.

When you save the mail merge envelope document, it stays connected to your mailing list for future use.

To reuse your envelope mail merge document, open the document and choose Yes when Word prompts you to keep the connection. To change addresses in the envelope mail merge document, open the document and choose Edit Recipient List to sort, filter, and choose specific addresses.

Step 1: Set up your mailing list

The mailing list is your data source. For more info, see Data sources you can use for a mail merge.

Tips: 

  • If you don’t have a mailing list, you can create one during mail merge. Collect all of your address lists, and add them to your data source.

  • If you're using an Excel spreadsheet, format the ZIP Codes or postal codes column as text to preserve any zeros. For more info see Format mail merge numbers, dates, and other values in Excel.

  • If you want to use your Outlook contacts, make sure Outlook is your default email program.

    Tip: To make Outlook your default email program, open Apple Mail, and go to Mail > Preferences. Go to General and choose Microsoft Outlook.

  1. Go to Mailings > Start Mail Merge > Envelopes.

    On the Mailings tab, select Envelopes from the Start Mail Merge list

  2. In the Envelope dialog box, under Return Address, choose an option.

  3. In the Envelope dialog box, under Printing Options, choose Page Setup.

  4. In the Page Setup dialog box, in the Paper Size list, choose the option that matches the size of your envelope.

    If none of the options match your envelope's size do the following:

  5. In the Page Setup dialog box, choose Landscape > OK.

  6. Choose OK to close the Envelope dialog box.

  7. Go to File > Save.

  1. On the Mailings tab, choose Select Recipients.

    On the Mailings tab, Select Recipients is highlighed with a list of options

  2. Choose a data source. For more info, see Data sources you can use for a mail merge.

  3. If needed, edit your recipient list. For more info, see Mail merge: Edit recipients.

  4. Choose File > Save.

  1. In your document, choose the Drag fields into this box or type text box, and then click or tap the text to remove it.

  2. Go to Mailings > Insert Merge Field, and choose the field you want to add.

    On the Mailings tab, Insert Merge Field is highlighted

  3. Add and format the fields you want to be included on the envelope, and choose OK.

  1. Go to Mailings > Preview Results to see how the envelopes will look.

    On the Mailings tab, Preview Results is highlighted

    Note: Use the left and right arrows on the Mailings tab, to scroll through each envelope.

  2. To make additional formatting changes, select Preview Results again to edit merge fields.

  3. When done, go to Mailings tab, choose Finish & Merge > Print Documents to complete the mail merge.

    On the Mailings tab, Finish & Merge and the Print Documents option are highlighted

    Tip: To review and update each envelope individually before printing, go to Mailings > Finish & Merge > Edit Individual Documents. When done, go to File > Print to print the envelopes.

Step 1: Prepare your main document

The mailing list is your data source. For more info, see Data sources you can use for a mail merge.

  1. Go to File > New Blank Document.

  2. Go to View > Print Layout.

  3. Go to Tools > Mail Merge Manager.

  4. Under 1. Select Document Type, choose Create New > Envelopes.

  5. In the Return address box, type your address.

  6. Under Printing Options, confirm the correct print settings for your envelopes are selected.

  7. Choose OK when finished.

Step 2: Select the mailing list

  1. Go to Tools > Mail Merge Manager.

  2. Under 2. Select Recipients List, choose Get List, and then select the source for the mailing list.

  3. Under 3. Insert Placeholders, choose Contacts.

  4. Drag a field name from the Contacts list to the envelope's address box.

  5. Repeat Step 4 for all the fields that you want to appear on your envelopes.

  6. In your main document, edit the envelope's address box to add spaces and carriage returns where you want them.

  7. To finish creating your envelopes, do one of the following:

    • To print immediately, in Mail Merge Manager, under 6. Complete Merge, choose Merge to Printer  Merge to Printer button .

    • To create a document to save, in Mail Merge Manager, under 6. Complete Merge, choose Merge to New Document  Complete Mail Merge button .

See also

Do you have a question about Word mail merge that we didn't answer here?

Post a question in the Word community forum

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×