Filter tasks or resources

With Project, you can filter your view so that you only see the critical tasks, milestones, and other information that’s most important to you. There are three ways to filter the tasks or resources in your project provides predefined filters for viewing specific aspects of tasks and resources. If none of these filters meet your needs, you can create a new filter or modify an existing filter.

  • Predefined filters    These are filters that ship with Project. These are used to quickly filter for tasks or resources, such as tasks that are incomplete, or resources that are overallocated.

  • Custom filters    These are filters that you design for you own project needs.

  • AutoFilters    When these are turned on, they appear as arrows at the top of each column in a sheet view. Use these to quickly filter the items in a column.

In this article

Filter tasks or resources

Use AutoFilters

Filter tasks or resources

There are times when you want to view only a particular type of information in your project. For example, you may want to view only the milestones of your project or see tasks that haven't started. If your project has many tasks and involves many resources, filters can be very useful for viewing a specific range of information. Filters allow you to display only the information you are interested in and hide the rest.

You can filter task or resource data using the pre-defined Project filters. If none of the filters meet your needs, you can create a new filter or modify an existing filter.

Apply or remove a filter

  1. On the View tab, in the Data group, choose a filter in the filter list.

    Filter command

    To apply a filter that isn't on the list, choose More Filters, and then do one of the following:

    • To select a task filter, choose Task, choose a filter name in the Filters list, and then choose Apply.

    • To select a resource filter, choose Resource, choose a filter name in the Filters list, and then choose Apply.

      Note: You cannot apply task filters to resource views or resource filters to task views.

  2. If you apply an interactive filter, type the requested values, and then choose OK.

  3. To turn off a filter, choose No filter in the list of filters.

Apply a color to filtered tasks using a highlight

When filtering tasks or resources, you can apply a highlight. Highlighted tasks or resources appear with non-filtered tasks, but with a different color.

  1. On the View tab, in the Data group, select a filter in the filter list., and then choose More Filters.

  2. Select a filter in the filter list, and then choose Highlight.

Tip:  To apply a different color to the highlighted tasks, use a different text style. Choose the Format tab, and then choose Text Styles. In the Item to Change list, select Highlighted Tasks, and then select formatting options.

Create a custom filter

  1. On the View tab, in the Data group, choose the arrow next to Filter, and then choose More Filters.

    The Project ribbon, showing how to create a custom filter.

  2. Select Task or Resource (depending on which type of filter you want to create), and then choose New.

  3. Type a name for your new filter. Select Show in menu if you want to include this filter in the Data group list.

  4. In the And/Or column, choose And to show results that meet more than one of your filter criteria. Choose Or to show rows that meet one or the other.

    Choose And or Or, depending on the type of results you want from your filter.

  5. In the Field Name column, choose which field you want to filter.

  6. In the Test column, decide how you want to match what you chose for the Field Name column to the Value(s) column in the next step.

  7. In the Value(s) column, choose the value you want, or type a new one.

    If you chose Equals or Does Not Equal in the Test column, you can type a wildcard character in the Values column (instead of choosing an option from the list). For example, typing a question mark (?) would find single characters. Typing an asterisk (*) finds any number of characters. If you use wildcards, be sure that your choice for the Field Name column involves text (like Name), instead of numbers (like Duration).

  8. To add another row to your filter (and to choose another field name to filter on), choose Insert Row. You can group rows by adding a blank row. Add an And or Or in the blank row to filter one group against another.

  9. When you’re done, choose Save.

Tip: To quickly remove all of your filters, use the F3 key. Keep in mind that task filters only work with task views, and resource filters only work with resource views.

Modify an existing filter

  1. On the View tab, in the Data group, select the filter list, and then choose More Filters.

  2. Do one of the following:

    • To modify a task filter, choose Task, choose the filter you want to modify, and then choose Edit.

    • To modify a resource filter, choose Resource, choose the filter you want to modify, and then choose Edit.

  3. Modify the settings for the filter using the controls in the Filter Definition dialog box.

Use AutoFilters

You can apply an AutoFilter to fields in any sheet view. In addition to standard filters, project provides AutoFilters, visible at the top of each column in sheet views.

Apply and remove AutoFilters

  1. On the View tab, in the Data group, choose the arrow for the filter list, and then choose Display AutoFilter.
    Filter command

  2. Choose the AutoFilter arrow next to the column heading that contains the information you want to display, and then choose a value to filter the table.
    The AutoFilter arrow and field heading turn blue.

  3. To apply an additional condition based on a value in another column, repeat step 2 for the other column.

  4. To remove the filtering on a specific row, choose Clear All Filters in the AutoFilter list for that field.

  5. To turn off AutoFilters, choose Display AutoFilter again.

    Note:  If information changes in one of the rows in your view, you can refresh your AutoFilter settings by choosing the arrow and re-selecting the filtering values.

Create a custom AutoFilter

  1. Display AutoFilters.

  2. Choose an AutoFilter arrow, point to Filter, and then choose Custom.

  3. Choose the operator you want to use in the first box, and then type or select the value you want to match in the second box.

    For example, to match a specific date in a date field, choose the equals operator in the first box, and then select the date you want to match in the second box.

  4. To apply two conditions to the AutoFilter, do one of the following:

    • To display rows in your view that meet both conditions, choose the operator and value you want in the second row of boxes, and then choose And.

    • To display rows in your view that meet either one condition or another condition, choose the operator and value you want in the second row of boxes, and then choose Or.

  5. To save your AutoFilter settings, choose Save.

    If your view already has a predefined filter applied, then the conditions you set for the AutoFilter are included as additional conditions to the current filter. When you save an AutoFilter setting, the filter is saved with other filters in your file and is available only through the More Filters dialog box.

Turn on AutoFilters automatically for new projects

  1. On the File tab, choose Options.

  2. Choose Advanced, and then in the General section, select the Set AutoFilter on for new projects check box.

Top of Page

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×