File formats supported by Project

Project can open and save files in the following file formats. Some formats allow you to save all the information in your project, and some formats allow you to save only the data contained in Project fields.

File Format

Description

Project Plan (MPP)

The standard file format for a project which uses the .mpp extension.

Project 2010 or Project 2013 file

Project 2010, Project 2013, and Project 2016 all use the same file format. A project created in Project 2016 can be opened in Project 2013 or Project 2010 without saving the project to a different format.

Microsoft Project 2007 file

Project supports opening from and saving to the file format used by Project 2007.

Microsoft Project 2000-2003 file

Project supports opening from the file format used by Project 2000-2002 and Project 2003 but does not support saving to this format.

Microsoft Project Template (MPT)

This is a template file in which you can save boilerplate information. This format uses the .mpt extension. The global file (Global.mpt) is a master template file that contains formatting information for all projects, but it cannot store tasks, resources, or assignments.

Microsoft Excel (.xls, .xlsx, .xlsb, and .xlsm formats)

Formats used by the Microsoft Excel spreadsheet program. This format uses the .xls, .xlsx, and .xlsb extensions. Project cannot open or save to Excel spreadsheets with the .xlsm extension. You can export field data to these formats, but you cannot export an entire project.

Text-only or ASCII

Text-only or ASCII format is a generic text format used by word-processing and other programs. This format uses the .txt extension and is tab delimited. You can export field data from a single Project table to this format, but you cannot open or export an entire project.

Comma-separated values (CSV)

Comma-separated values (CSV) is a generic text format used with word-processing and other programs. This format uses the .csv extension and is comma delimited, where values are separated by the system list separator. You can export field data from a single Project table to this format, but you cannot open or export an entire project.

Extensible Markup Language (XML)

Extensible Markup Language (XML) is a format used to deliver rich, structured data in a standard, consistent way. This format uses the .xml extension. You can export and import project data with this format. The XML format can be used to interchange project data between Project and other programs.

XML Paper Specification (XPS)

XPS is an electronic file format that preserves document formatting and enables file sharing.

Portable Document Format (PDF)

PDF is a fixed-layout electronic file format that preserves document formatting. Project can save to the PDF format, but it cannot open PDF files.

What formats will not work with Project?

  • Microsoft Project 98. Project cannot open or save to the Project 98 file format.

  • Microsoft Project Exchange (MPX). Project cannot open or save to the MPX file format.

  • Microsoft Project Database (MPD). Project cannot open or save to the MPD format.

  • Microsoft Access Database (MDB). Project cannot open or save projects stored in MDB files.

  • Open Database Connectivity (ODBC). Project cannot open or save projects stored in ODBC files.

File Format

Description

Project Plan (MPP)

The standard file format for a project which uses the .mpp extension.

Microsoft Project 2007 file

Project 2010 supports opening from and saving to the file format used by Project 2007.

Microsoft Project 2000-2003 file

Project 2010 and Project 2007 support opening from and saving to the file format used by Project 2000-2002 and Project 2003.

Microsoft Project 98 file

Project 2010 and Project 2007 cannot save to the Project 98 file format, but support opening from the Project 98 file format.

Microsoft Project Template (MPT)

This is a template file in which you can save boilerplate information. This format uses the .mpt extension. The global file (Global.mpt) is a master template file that contains formatting information for all projects, but it cannot store tasks, resources, or assignments.

Microsoft Project Exchange (MPX)

An ASCII format used with project management and various other programs that support MPX 4.0 that uses the .mpx extension. Microsoft Project 4.0, Microsoft Project 4.1, and Microsoft Project 98 use the MPX 4.0 file format.

In Project 2010 and Project 2007, you cannot save project information to this file format.

Microsoft Excel (.xls, .xlsx, .xlsb, and .xlsm formats)

Formats used by the Microsoft Excel spreadsheet program. This format uses the .xls, .xlsx, and .xlsb extensions. Project cannot open or save to Excel spreadsheets with the .xlsm extension. You can export field data to these formats, but you cannot export an entire project.

Microsoft Project Database (MPD)

A database format used by Project for storing entire projects. This format uses the .mpd extension.

You cannot save to the MPD format using Project 2010 or Project 2007, but you can open projects that are stored in MPD files.

Microsoft Access Database (MDB)

A database format used by the Microsoft Office Access database program, which uses the .mdb extension.

You cannot save to the MDB format using Project 2010 or Project 2007, but you can open projects that are stored in MDB files.

Open Database Connectivity (ODBC)

A format used by ODBC-compliant Microsoft SQL Server databases. You cannot save to the ODBC format using Project 2010 or Project 2007, but you can open projects that are stored in ODBC files.

Text-only or ASCII

Text-only or ASCII format is a generic text format used by word-processing and other programs. This format uses the .txt extension and is tab delimited. You can export field data from a single Project table to this format, but you cannot open or export an entire project.

Comma-separated values (CSV)

Comma-separated values (CSV) is a generic text format used with word-processing and other programs. This format uses the .csv extension and is comma delimited, where values are separated by the system list separator. You can export field data from a single Project table to this format, but you cannot open or export an entire project.

Extensible Markup Language (XML)

Extensible Markup Language (XML) is a format used to deliver rich, structured data in a standard, consistent way. This format uses the .xml extension. You can export and import project data with this format. The XML format can be used to interchange project data between Project and other programs.

XML Paper Specification (XPS)

XPS is an electronic file format that preserves document formatting and enables file sharing.

Project 2007 cannot open or save projects stored in XPS files.

Portable Document Format (PDF)

PDF is a fixed-layout electronic file format that preserves document formatting.

Project 2010 can save to the PDF format but cannot open PDF files.

Project 2007 cannot open or save projects stored in PDF files.

How do I tell which version am I currently using?

  • For Project Online Desktop Client, Project 2019, Project 2016, and Project 2013, choose File > Account.

  • For Project 2010, on the File tab, choose Help.

  • For Project 2007, on the Help menu, choose About Microsoft Office Project.

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×