Create a UML database notation diagram

You can create a UML database notation diagram in Visio to define the structure of a relational database.

While UML doesn't have specifications for data modeling, it can be a useful tool for diagraming, especially since data from databases can be used in object-oriented programming. The Visio UML database shapes are very similar to the UML class diagram shapes that are used to model object-oriented classes, and they give you a consistent notation for your entire system.

First, you open the UML Database Notation diagram, which comes with a database notation stencil that has shapes that conform to the UML 2.5 or 2.0 standard, depending on your version of Visio.

  1. Start Visio. Or if you have a file open already, click File > New.

  2. In the Search box, type UML database notation.

  3. Select the UML Database Notation template.

  4. In the dialog box, select either Metric Units or US Units.

  5. Select Create.

  6. The diagram opens. You should see the Shapes window next to the diagram. If you don’t see it, go to View > Task Panes and make sure that Shapes is selected. If you still don’t see it, click the Expand the Shapes window button on the left.

  7. On the View tab, make sure the check box next to Connection Points is selected. This will make connection points appear when you start connecting shapes.

  8. You're ready to begin drawing your diagram. Select the stencil, then drag an Entity shape from it onto your diagram to start.

    Entity shape.

  1. Open Visio for the web.

  2. In the Gallery, select Blank Drawing at the top.

    To create a new, starter drawing, select Blank Drawing.

    The blank diagram opens in your browser.

  3. In the Shapes, pane, in the Search for shapes box, find the right stencil for your drawing. Type UML database.

  4. Select the best match from the list that's offered.

  5. Select UML Database Notation in the results list to see a preview of the stencil.

  6. Select Add to add the stencil as a tab in the Shapes pane.

  7. You're ready to begin drawing your diagram. Select the stencil, then drag an Entity shape from it onto your diagram to start.

    Entity shape.

See Also

UML diagrams in Visio

Expand your Office skills
Explore training
Get new features first
Join Office Insiders