Check spelling and grammar in Office

All Microsoft Office programs can check spelling, and most can check grammar. 

If you find that spelling or grammar checking isn't working as you'd expect see The spelling and grammar checker isn't working as expected. If you'd like to check spelling or grammar in a language other than your default language see Check spelling and grammar in a different language.

Using Office 365? You may be interested in checking out the powerful new Editor feature in Word! See Editor - your writing assistant for more information.

Run the spelling and grammar checker manually

To start a check of the spelling and grammar in your file just press F7 or follow these steps:

  1. Open most Office programs, click the Review tab on the ribbon. In Access or InfoPath you can skip this step. In Project you'll go to the Project tab.

  2. Click Spelling or Spelling & Grammar.

    Spelling and grammar button on the Review ribbon

  3. If the program finds spelling mistakes, a dialog box appears with the first misspelled word found by the spelling checker.

  4. After you decide how to resolve the misspelling (ignoring it, adding it to the program’s dictionary, or changing it), the program moves to the next misspelled word.

Click a heading below for more information

Most Office programs automatically check for potential spelling and grammatical errors as you type, so you don't need to do anything to show errors while you work. 

Notes: 

  • Automatic spelling and grammar checking is not available in Access, Excel, or Project. You can manually start a spell check by pressing F7.

  • Automatic grammar checking is available only in Outlook, Word, and PowerPoint 2013 (or newer).

Office marks potential spelling errors with a red squiggly line:

Spelling error marked with a red squiggly line

Potential grammatical errors are marked with a blue squiggly line:

Possible grammatical error indicated by blue squiggly line

If spelling or grammatical errors aren't marked, automatic checking might be turned off. You can turn on the automatic spelling and grammar checker.

When you see a spelling or grammatical error that you want assistance fixing, right-click on the underlined word or phrase and choose one of the options to fix the error.

If Office is flagging words as misspelled but you have it spelled the way you want it, select Add to Dictionary to teach Office not to flag that word as misspelled in the future. For more information on this see: Add or edit words in a spell check dictionary.

If you don't want Office to mark potential errors with squiggly lines while you are working, you can turn automatic spelling and grammar checking off:

  1. Open the spelling and grammar options:

    • In OneNote, PowerPoint, Publisher, Visio, and Word: On the File menu, click Options, and then click Proofing.

    • In InfoPath: On the Home tab, click the arrow next to or under Spelling, and then click Spelling Options.

    • In Outlook: On the File menu, click Options, and click Mail, and then click Spelling and Autocorrect.

  2. Select or clear the Check spelling as you type check box. In programs that have automatic grammar checking, you may also select or clear the Mark grammar errors as you type check box.

    The Check Spelling As You Type check box

    Note: In Word, you can turn the spelling checker on or off for the document you're working with or for all new documents. Select an option in the Exceptions for list, and then select or clear the Hide spelling errors in this document only and Hide grammar errors in this document only check boxes.

If you don't want Office to check grammar at all (either when running a spell check or automatically as you type), you can turn it off:

  1. Open the spelling and grammar options:

    • In OneNote, PowerPoint, Publisher, Visio, and Word: On the File menu, click Options, and then click Proofing.

    • In InfoPath: On the Home tab, click the arrow next to or under Spelling, and then click Spelling Options.

    • In Outlook: On the File menu, click Options, and click Mail, and then click Spelling and Autocorrect.

  2. Clear the Mark grammar errors as you type and Check grammar with spelling check boxes.

    Grammar check boxes

    Note: Not every Office program will have both of these options.

In Word, Outlook, PowerPoint 2013 (or newer), you can force a recheck of the words and grammar that you previously skipped by doing the following:

  1. Open the document or item that you want to check.

  2. On the File menu, click Options > Proofing> Recheck Document. In Outlook you'll find this under File > Options > Mail > Spelling and Autocorrect

  3. Click Yes when you see the warning message about resetting the spelling and grammar checker.

  4. Click OK in the dialog box to get back to the document, and then run the spelling and grammar checker again.

We're listening!

This article was last updated by Ben on October 28th, 2019. If you found it useful, and especially if you didn't, please use the feedback controls below to leave us some constructive suggestions as to how we can make it better.

See Also

Test your document's readability

The spelling and grammar checker isn't working as expected

Select grammar and writing style options in Office 2013 and earlier

Add words to your spell check dictionary

The spelling or grammar checker isn't checking words in a different language correctly

Choose AutoCorrect options for capitalization, spelling, and symbols

Check spelling before sending a message in Outlook

Office for Mac applications automatically check for potential spelling and grammatical errors as you type. If you’d rather wait to check spelling and grammar until you're done writing, you can turn off automatic checking, or you can check spelling and grammar all at once.

Word

Check spelling and grammar automatically as you type

Word automatically checks for and marks potential spelling errors with a red squiggly line.

Spelling error marked with a red squiggly line

Word also checks for and marks potential grammatical errors with a green squiggly line.

Grammatical error marked by a green squiggly line

Tip: If spelling or grammatical errors aren't marked, you might need to turn on automatic spelling and grammar checking, which is explained in the next procedure.

When you see a spelling or grammatical error, Control click the word or phrase and choose one of the options.

Grammatical error with contextual menu showing options for correcting it

If Word has incorrectly flagged a word as misspelled and you want to add that word to your dictionary so that Word will properly recognize it in the future see Add or edit words in a spell check dictionary

  1. On the Word menu, click Preferences > Spelling & Grammar.

  2. In the Spelling & Grammar dialog box, under Spelling, check or clear the Check spelling as you type box.

  3. Under Grammar, check or clear the Check grammar as you type box.

  4. Close the dialog box to save your changes.

  1. On the Review tab, click Spelling & Grammar.

  2. If Word finds a potential error, the Spelling & Grammar dialog box will open, spelling errors will be shown as red text, and grammatical errors will be shown as green text.

  3. To fix an error, do one of the following:

    • Type the correction in the box and then click Change.

    • Under Suggestions, click the word you want to use, and then click Change.

    To skip the error, do one of the following:

    • Click Ignore to skip only that instance of the error.

    • Click Ignore All to skip all instances of the error.

    • For a grammatical error, click Next Sentence to skip that instance of the error and move to the next error.

    To skip a misspelled word in all documents, click Add to add it to the dictionary. This only works for misspelled words. You can’t add custom grammar to the dictionary.

  4. After you correct, ignore, or skip an error, Word moves to the next one. When Word finishes reviewing the document, you’ll see a message that the spelling and grammar check is complete.

  5. Click OK to return to your document.

You can clear or reset the list of Ignored Words and Grammar so Word will check for spelling and grammar issues you previously told it to ignore.

Note: When you reset the list of Ignored Words and Grammar, the list is cleared only for the currently open document. Any spelling or grammar issues you told Word to ignore in other documents won't be affected.

  1. Open the document that needs to be checked.

  2. On the Tools menu, point to Spelling and Grammar, and then click Reset Ignored Words and Grammar.

    To clear the lists of words and grammar that Word ignores, click Reset Ignored Words and Grammar.

    Word displays a warning about the operation resetting the spelling checker and the grammar checker.

    Cause Word to check for spelling and grammar that you told Word to ignore earlier by clicking Yes.
  3. Click Yes to proceed.

  4. Click the Review tab, and then click Spelling & Grammar to check spelling and grammar.

Outlook

Check spelling and grammar automatically as you type

By default, Outlook checks for spelling errors as you type. Outlook uses a dashed red underline to indicate possible spelling errors and a dashed green line to indicate possible grammatical errors.

Spelling error marked with dashed red underline

  1. When you see a word with a dashed underline, Control click the word or phrase and choose one of the options.

    Spelling error with menu showing options for correcting it

  2. On the shortcut menu, do one of the following:

    • Click one of the guesses at the top of the shortcut menu.

    • Click Ignore Spelling to ignore one instance of the word.

    • Click Learn Spelling to add the word to the spelling dictionary.

After opening an email message:

  • To have Outlook correct spelling mistakes automatically, on the Outlook menu, click Preferences. Click on Spelling and Grammar under Personal Settings. Click box next to Checkspelling as you type.

  • To turn automatic grammar checking on or off, on the Outlook menu, click Preferences. Click on Spelling and Grammar under Personal Settings. Click box next to Check grammar as you type.

Check spelling as your type preference

You can correct all the spelling and grammar issues at the same time after you finish composing a message or other items.

  1. On the Edit menu, point to Spelling and Grammar, and then click Spelling and Grammar...

  2. Do any of the following:

    • In the list of suggestions, click the word that you want to use, or enter a new spelling in the box at the top, and then click Change.

    • Click Ignore to ignore this word and move on to the next misspelled word.

    • Click Add to add the word to the spelling dictionary.

Tip: The keyboard shortcut for skipping to the next spelling or grammar error is COMMAND + ; .

PowerPoint

You can check spelling in PowerPoint, but you can't check grammar.

Check spelling automatically as you type

PowerPoint automatically checks for and marks potential spelling errors with a wavy, red underline:

Spelling error marked with a red squiggly line

Tip: If spelling errors aren't marked, you might need to turn on automatic spell checking, which is explained in the next procedure.

When you see a spelling error, Ctrl+click or right-click the word or phrase and choose one of the suggested options.

  1. On the PowerPoint menu, click Preferences > Spelling.

  2. In the Spelling dialog box, select or clear the Check spelling as you type box.

  1. On the Review tab, click Spelling.

  2. If PowerPoint finds a potential error, the Spelling pane opens and spelling errors are shown.

  3. To fix an error, do one of the following:

    • Correct the error on your slide.

    • Click one of the suggested words in the Spelling pane, and then click Change.

    To skip the error, do one of the following:

    • Click Ignore to skip only that instance of the error.

    • Click Ignore All to skip all instances of the error.

    • click Add to skip a misspelled word in all documents and add it to the dictionary.

  4. After you correct, ignore, or skip an error, PowerPoint moves to the next one. When PowerPoint finishes reviewing the presentation, you’ll see a message that the spelling check is complete.

  5. Click OK to return to your presentation.

Excel

You can check spelling in Excel, but you can't check grammar.

Check spelling all at once

  1. On the Review tab, click Spelling.

    Note: The Spelling dialog box will not open if no spelling errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following.

    To

    Do this

    Change the word

    Under Suggestions, click the word that you want to use, and then click Change.

    Change every occurrence of this word in this document

    Under Suggestions, click the word that you want to use, and then click Change All.

    Ignore this word and move on to the next misspelled word

    Click Ignore Once.

    Ignore every occurrence of this word in this document and move on to the next misspelled word

    Click Ignore All.

See also

Check spelling and grammar in a different language

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×