Change the task bars in the Calendar view

The Calendar view is like the calendar in your office; no two are alike. You can rearrange the tasks as they appear in the Calendar view to help highlight specific tasks or to reduce clutter.

Note: This topic discusses how to change the task bars in the Calendar view. It does not discuss how to change resource or task calendars used to schedule your project work.

In this article

Change the bar type, pattern, or color of all bars in the Calendar view

Display specific task bars in the Calendar view

Arrange task bars in the Calendar view

Change the bar type, pattern, or color of all bars in the Calendar view

To call attention to all tasks of a certain type, you can change the format of the bars that represent that type of task in the Calendar view. You can also add specific project information such as task names, resource names, completion percentages, and durations to your task bars.

  1. Choose View > Calendar.

  2. On the Format tab, choose Bar Styles.

    (In Project 2007, on the Format menu, choose Bar Styles.)

  3. In the Task type list, select the taskbar type for which you want to change the formatting.

  4. Under Bar shape, choose a bar type, pattern, color, and split pattern for the task type.

    • If you want to add a shadow effect behind the bar, select the Shadow check box.

    • If you want to extend (or round up) the task bar to the nearest full day, select the Bar rounding check box.

  5. In the Field(s) box, type or select the field that you want to appear within the bar.

    If you want more than one field to appear in one position on the task bar, type a comma (,) after a field name, and then type or select another field name.

  6. In the Align box, seelct the alignment you want to use to position the text.

  7. To see the text continue on another line, select the Wrap text in bars check box.

Tip: Under Sample, you can review the changes you make to bar type, pattern, color, and shadow.

Display specific task bars in the Calendar view

Only a limited number of task bars can be displayed or printed on a single day in the Calendar view (the number of tasks displayed depends on the row height). One way you can control which tasks display is by filtering for specific tasks.

  1. Choose View > Calendar.

  2. On the View tab, in the Data group, select the Filter list and choose the filter you want to apply.

    (In Project 2007, on the Project menu, point to Filtered for and choose the filter you want to apply.)

    If you want to see a particular resource's work in the Calendar view, choose Using Resources, and then in the Show tasks using list, select the resource whose tasks you want to see in the Calendar view.

You can also prioritize the types of tasks that display by excluding specific task categories.

  1. Choose View > Calendar.

  2. On the Format tab, choose Bar Styles.

    (In Project 2007, on the Format menu, choose Bar Styles.)

  3. In the Task type list, select the task category you don't want to display, and then select None in the Bar type list.

    Repeat this step for each task category you don't want to display.

    Notes: 

    • You can hide individual task bars by selecting the task bar you want to hide, choosing Information on the Format tab (Task Information Button image in Project 2007), selecting the General tab, and then selecting the Hide bar check box.

    • You can display more calendar rows (or weeks) in a smaller format to see an overview of your project or to display fewer rows in a larger format by focusing on a specific portion of your project. Drag the horizontal line between any two rows up or down to decrease or increase the height of the rows. To adjust the height to fit the greatest number of tasks scheduled on a single day, double-click the horizontal line separating one row from another.

Arrange task bars in the Calendar view

You can change the vertical order in which tasks appear on a per-week row in the Calendar view.

  1. Choose View > Calendar.

  2. On the Format tab, in the Layout group, select the dialog box launcher Dialog box button .

    (In Project 2007, on the Format menu, choose Layout.)

  3. To arrange tasks in the current sort order, under Method, select Use current sort order.

    If you want to display as many tasks as possible in one row without overlapping task bars, under Method, choose Attempt to fit as many tasks as possible.

  4. To show split tasks in the task bars, select the Show bar splits check box.

  5. To adjust the task layout automatically when you add or delete tasks, select the Automatic layout check box.

    If you did not select the Automatic layout check box, choose Layout Now on the Format tab (Format menu in Project 2007) to rearrange the task bars.

Note: You can specify which tasks appear near the top and bottom of each week by sorting the tasks. On the View tab, in the Data group, choose Sort (in Project 2007, choose Project > Sort), and then choose a sort command or choose Sort By for more options.

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×