Add, change, or remove error bars in a chart

Error bars in charts you create can help you see margins of error and standard deviations at a glance. They can be shown on all data points or data markers in a data series as a standard error amount, a percentage, or a standard deviation. You can set your own values to display the exact error amounts you want. For example, you can show a 10 percent positive and negative error amount in the results of a scientific experiment like this:

Line chart with 10 percent error bars

You can use error bars in 2-D area, bar, column, line, xy (scatter), and bubble charts. In scatter and bubble charts, you can show error bars for x and y values.

  1. Click anywhere in the chart.

  2. Click the Chart Elements button Chart Elements button next to the chart, and then check the Error Bars box. (Clear the box to remove error bars.)

  3. To change the error amount shown, click the arrow next to Error Bars, and then pick an option.

    Error Bar options

    • Pick a predefined error bar option like Standard Error, Percentage or Standard Deviation.

    • Pick More Options to set your own error bar amounts, and then under Vertical Error Bar or Horizontal Error Bar, choose the options you want. This is also where you can change the direction, end style of the error bars, or create custom error bars.

      Format Error Bars pane

Note: The direction of the error bars depends on the type of chart you’re using. Scatter charts can show both horizontal and vertical error bars. You can remove either of these error bars by selecting them, and then pressing Delete.

People often ask how Excel calculates error amounts. Excel uses the following equations to calculate the Standard Error and Standard Deviation amounts that are shown on the chart.

This option

Uses this equation

Standard Error

Equation

Where:

s = series number

i = point number in series s

m = number of series for point y in chart

n = number of points in each series

yis = data value of series s and the ith point

ny = total number of data values in all series

Standard Deviation

Equation

Where:

s = series number

i = point number in series s

m = number of series for point y in chart

n = number of points in each series

yis = data value of series s and the ith point

ny = total number of data values in all series

M = arithmetic mean

In Excel, you can display error bars that use a standard error amount, a percentage of the value (5%), or a standard deviation.

Standard Error and Standard Deviation use the following equations to calculate the error amounts that are shown on the chart.

This option

Uses this equation

Where

Standard Error

Equation

s = series number

i = point number in series s

m = number of series for point y in chart

n = number of points in each series

yis = data value of series s and the ith point

ny = total number of data values in all series

Standard Deviation

Equation

s = series number

i = point number in series s

m = number of series for point y in chart

n = number of points in each series

yis = data value of series s and the ith point

ny = total number of data values in all series

M = arithmetic mean

  1. On 2-D area, bar, column, line, xy (scatter), or bubble chart, do one of the following:

    • To add error bars to all data series in the chart, click the chart area.

    • To add error bars to a selected data point or data series, click the data point or data series that you want, or do the following to select it from a list of chart elements:

      1. Click anywhere in the chart.

        This displays the Chart Tools, adding the Design, Layout, and Format tabs.

      2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

        excel ribbon image

  2. On the Layout tab, in the Analysis group, click Error Bars.

    Excel Ribbon Image

  3. Do one of the following:

    1. Click a predefined error bar option, such as Error Bars with Standard Error, Error Bars with Percentage, or Error Bars with Standard Deviation.

    2. Click More Error Bar Options, and then under Vertical Error Bars or Horizontal Error Bars, click the display and error amount options that you want to use.

      Note: The direction of the error bars depends on the chart type of your chart. For scatter charts, both horizontal and vertical error bars are displayed by default. You can remove either of these error bars by selecting them, and then pressing DELETE.

  1. On a 2-D area, bar, column, line, xy (scatter), or bubble chart, click the error bars, the data point, or the data series that has the error bars that you want to change, or do the following to select them from a list of chart elements:

    1. Click anywhere in the chart.

      This displays the Chart Tools, adding the Design, Layout, and Format tabs.

    2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

      excel ribbon image

  2. On the Layout tab, in the Analysis group, click Error Bars, and then click More Error Bar Options.

    Excel Ribbon Image

  3. Under Display, click the error bar direction and end style that you want to use.

  1. On a 2-D area, bar, column, line, xy (scatter), or bubble chart, click the error bars, the data point, or the data series that has the error bars that you want to change, or do the following to select them from a list of chart elements:

    1. Click anywhere in the chart.

      This displays the Chart Tools, adding the Design, Layout, and Format tabs.

    2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

      excel ribbon image

  2. On the Layout tab, in the Analysis group, click Error Bars, and then click More Error Bar Options.

    Excel Ribbon Image

  3. Under Error Amount, do one or more of the following:

    1. To use a different method to determine the error amount, click the method that you want to use, and then specify the error amount.

    2. To use custom values to determine the error amount, click Custom, and then do the following:

      1. Click Specify Value.

      2. In the Positive Error Value and Negative Error Value boxes, specify the worksheet range that you want to use as error amount values, or type the values that you want to use, separated by commas. For example, type 0.4, 0.3, 0.8.

        Tip: To specify the worksheet range, you can click the Collapse Dialog button Collapse button , and then select the data that you want to use in the worksheet. Click the Collapse Dialog button again to return to the dialog box.

        Note: In Microsoft Office Word 2007 or Microsoft Office PowerPoint 2007, the Custom Error Bars dialog box may not show the Collapse Dialog button, and you can only type the error amount values that you want to use.

  1. On a 2-D area, bar, column, line, xy (scatter), or bubble chart, click the error bars, the data point, or the data series that has the error bars that you want to remove, or do the following to select them from a list of chart elements:

    1. Click anywhere in the chart.

      This displays the Chart Tools, adding the Design, Layout, and Format tabs.

    2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

      excel ribbon image

  2. Do one of the following:

    1. On the Layout tab, in the Analysis group, click Error Bars, and then click None.

      Excel Ribbon Image

    2. Press DELETE.

Tip: You can remove error bars immediately after you add them to the chart by clicking Undo on the Quick Access Toolbar or by pressing CTRL+Z.

Do any of the following:

  1. In the chart, select the data series that you want to add error bars to.

    For example, in a line chart, click one of the lines in the chart, and all the data marker of that data series become selected.

  2. On the Chart Design tab, click Add Chart Element

    On the Chart Design tab, select Add Chart Element

  3. Point to Error Bars, and then do one of the following:

Click

To

Standard Error

Apply the standard error, using the following formula:

Standard error formula

s = series number
I = point number in series s
m = number of series for point y in chart
n = number of points in each series
y is = data value of series s and the I th point
n y = total number of data values in all series

Percentage

Apply a percentage of the value for each data point in the data series

Standard Deviation

Apply a multiple of the standard deviation, using the following formula:

Standard deviation formula

s = series number
I = point number in series s
m = number of series for point y in chart
n = number of points in each series
y is = data value of series s and the I th point
n y = total number of data values in all series
M = arithmetic mean

  1. In the chart, select the data series that you want to add error bars to.

  2. On the Chart Design tab, click Add Chart Element, and then click More Error Bars Options.

  3. In the Format Error Bars pane, on the Error Bar Options tab, under Error Amount, click Custom, and then click Specify Value.

  4. Under Error amount, click Custom, and then click Specify Value.

    Shows the Format Error Bars pane with Custom selected for Error Amount

  5. In the Positive Error Value and Negative Error Value boxes, type the values that you want for each data point, separated by commas (for example, 0.4, 0.3, 0.8), and then click OK.

    Note: You can also define error values as a range of cells from the same Excel workbook. To select the range of cells, in the Custom Error Bars dialog box, clear the contents of the Positive Error Value or Negative Error Value box, and then select the range of cells that you want to use.

  1. In the chart, select the data series that you want to add up/down bars to.

  2. On the Chart Design tab, click Add Chart Element, point to Up/Down Bars, and then click Up/down Bars.

    Depending on the chart type, some options may not be available.

Error bars in a chart

Do any of the following:

  1. This step applies to Word for Mac 2011 only: On the View menu, click Print Layout.

  2. In the chart, select the data series that you want to add error bars to, and then click the Chart Layout tab. 

    For example, in a line chart, click one of the lines in the chart, and all the data marker of that data series become selected.

  3. Under Analysis, click Error Bars.

    Chart Layout tab, Analysis group

  4. Do one of the following:

Click

To

Error Bars with Standard Error

Apply the standard error, using the following formula:

Standard error formula

s = series number
I = point number in series s
m = number of series for point y in chart
n = number of points in each series
y is = data value of series s and the I th point
n y = total number of data values in all series

Error Bars with Percentage

Apply a percentage of the value for each data point in the data series

Error Bars with Standard Deviation

Apply a multiple of the standard deviation, using the following formula:

Standard deviation formula

s = series number
I = point number in series s
m = number of series for point y in chart
n = number of points in each series
y is = data value of series s and the I th point
n y = total number of data values in all series
M = arithmetic mean

  1. This step applies to Word for Mac 2011 only: On the View menu, click Print Layout.

  2. In the chart, select the data series that you want to add error bars to, and then click the Chart Layout tab.

     For example, in a line chart, click one of the lines in the chart, and all the data marker of that data series become selected.

  3. Under Analysis, click Error Bars, and then click Error Bars Options.

    Chart Layout tab, Analysis group

    If you see the Add Error Bars dialog box, select the series that you want to add error bars to.

  4. In the navigation pane, click Error Bars.

  5. Under Error amount, click Custom, and then click Specify Value.

  6. Switch to Excel.

    When you switch to Excel, the Custom Error Bars dialog box appears.

  7. In the Positive Error Value and Negative Error Value boxes, type the values that you want for each data point, separated by commas (for example, 0.4, 0.3, 0.8), and then click OK.

    Note: You can also define error values as a range of cells from the same Excel workbook. To select the range of cells, in the Custom Error Bars dialog box, clear the contents of the Positive Error Value or Negative Error Value box, and then select the range of cells that you want to use.

  8. Switch back to the Office program you are using (Word for Mac 2011/PowerPoint for Mac 2011/Excel for Mac 2011).

  9. In the Format Error Bars dialog box, click OK.

  1. This step applies to Word for Mac 2011 only: On the View menu, click Print Layout.

  2. In the chart, select the data series that you want to add up/down bars to, and then click the Chart Layout tab. 

    For example, in a line chart, click one of the lines in the chart, and all the data marker of that data series become selected.

  3. Under Analysis, click Up/Down Bars, and then click the up/down bar that you want.

    Chart Layout tab, Analysis group

    Depending on the chart type, some options may not be available.

See Also

Create a chart

Change the chart type of an existing chart

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×