Use a custom dictionary in Office for Mac

A custom dictionary is useful if, for example, your work relies on a particular terminology, such as legal terms. Alternatively, you could create a custom dictionary that includes the names of your work contacts so that you know you're always spelling their names correctly.

When you use the spelling checker, it compares the words in your document with those in the main dictionary. The main dictionary contains the most common words, but it might not include proper names, technical terms, or acronyms. In addition, some words might be capitalized differently in the main dictionary than in your file. Adding such words or capitalization to a custom dictionary prevents the spelling checker from flagging them as mistakes. You can create additional custom dictionaries to complement the default dictionary that is included with the Office for Mac applications.

Note: Any custom dictionary setting that you change in one Office for Mac application affects all the other applications. For example, you set many of the custom dictionary settings in Word, and then see the changes the next time you open PowerPoint or Excel.

Add a word from your document to a custom dictionary

  1. In the document, select the word that you want to add.

  2. On the Tools menu, click Spelling and Grammar.

    Note: The Spelling and Grammar dialog box won't open if no spelling or grammar errors are detected, or if the word you are trying to add already exists in the dictionary.

  3. In the Add words to menu, select the dictionary you want to add your word to.

  4. Click Add.

Create a new custom dictionary in Word

You can save a new custom dictionary in any location on your computer. Or, to give other users access to your dictionary, you can save it to a network folder

Note: Any custom dictionary that you create in Word is used by other Office for Mac applications.

  1. Make sure that a document is open.

    If no document is open, the next step won't work.

  2. On the Word menu, click Preferences.

  3. Under Authoring and Proofing Tools, click Spelling and Grammar.

  4. Under Spelling, click Dictionaries.

  5. Click New.

    Important: If the Convert File or File Conversion dialog boxes open, don't make any changes—just click OK. (The correct text encoding setting is Other encoding: Unicode 5.1 (Little-Endian).)

  6. In the Save As box, type a name for the custom dictionary.

    Note: When you create a new custom dictionary, Office for Mac automatically begins using it to check spelling.

  7. Click Save, and then click OK again to close the Spelling and Grammar dialog box.

Import a custom dictionary in Word

The Custom Dictionaries dialog box in Word lists the available custom dictionaries the application can use to check spelling. If the dictionary that you want to use — for example, one that you purchased from a third-party company — is installed on your computer but not listed in the Dictionary list box, you can add it.

  1. Make sure that a document is open.

    If no document is open, the next step won't work.

  2. On the Word menu, click Preferences.

  3. Under Authoring and Proofing Tools, click Spelling and Grammar.

  4. Under Spelling, click Dictionaries.

  5. Click Add, and then locate and double-click the custom dictionary that you want to import.

    If the custom dictionary doesn't have a file name extension of .dic, on the Enable pop-up menu, click All Files.

Add, delete, or edit words in a custom dictionary in Word

You can edit a custom dictionary in Word. You can change words that are in the dictionary, or add more words. When you edit a custom dictionary, however, Word does not automatically begin using it; you must select it. The revised version of the dictionary is available in all Office applications.

  1. Make sure that a document is open.

    If no document is open, the next step won't work.

  2. On the Word menu, click Preferences.

  3. Under Authoring and Proofing Tools, click Spelling and Grammar.

  4. Under Spelling, click Dictionaries.

  5. Click the name of the dictionary that you want to edit, and then click Edit.

    If you see a message that Word stops checking spelling when you edit the dictionary, click OK, and then if you see the File Conversion - Custom Dictionary dialog box, click OK.

    Important: If the Convert File or File Conversion dialog boxes open, don't make any changes—just click OK. (The correct text encoding setting is Other encoding: Unicode 5.1 (Little-Endian).)

  6. In the dictionary file, make any changes that you want, and then on the File menu, click Save

    Note: You must type each word that you add on a separate line.

  7. On the File menu, click Close.

Change the language that is associated with a custom dictionary

By default, when you create a new custom dictionary, the application sets the dictionary to All Languages, which means that the dictionary is used when you check the spelling of text in any language. However, you can associate a custom dictionary with a particular language so that the application uses the dictionary only when you check the spelling of text in a particular language.

  1. Make sure that a document is open.

    If no document is open, the next step won't work.

  2. On the Word menu, click Preferences.

  3. Under Authoring and Proofing Tools, click Spelling and Grammar.

  4. Under Spelling, click Dictionaries.

  5. Click the name of the dictionary that you want to edit, and then on the Language pop-up menu, click the language you want to associate with the custom dictionary.

Notes: If you installed Office 2016 for Mac to run side-by-side with Office for Mac 2011, any custom dictionaries that you added and enabled in Office for Mac 2011 will be automatically copied to Office 2016 for Mac. If Office finds previously created custom dictionaries in any location other than the default dictionary location, you may be prompted for additional permissions to grant access to the files. If you see this message, simply select the file or files and click Select to grant access to custom dictionaries.

For more information about installing Office 2016 for Mac, including information about running Office 2016 for Mac on the same computer with Office for Mac 2011, see Download and install Office 2016 for Mac.

See also

Add or edit automatic corrections

Check spelling and grammar in a different language

The spelling checker is not recognizing words in a custom dictionary

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×