Use Visio with other 2007 Microsoft Office system programs

You can use Microsoft Office Visio 2007 in conjunction with other 2007 Microsoft Office system programs to share information with others and to import and export information instead of manually reentering it. Here are some of the ways that you can integrate Visio with other 2007 Office release programs:

  • Insert Visio diagrams into other Office programs     Emphasize and clarify important points in everyday business communications by inserting Visio diagrams into Microsoft Office Excel 2007 worksheets, Microsoft Office Word 2007 documents, and Microsoft Office PowerPoint 2007 presentations, or by creating Visio diagrams directly within those programs.

    To insert or create a Visio drawing in another program, open the file in which you want the drawing. On the Insert tab, in the Text group, click Object. In the Object dialog box, do one of the following:

    • To create a drawing within the program, click the Create New tab, and under Object type, click Microsoft Office Visio Drawing.

    • To insert an existing drawing, click the Create from File tab, and under File name, click Browse to locate the file.

  • Preview Visio diagrams in Outlook    If you have Microsoft Office Outlook 2007, you can preview Visio diagrams that are attached to e-mail. You do not have to install Visio. You do not even need to download the free Visio Viewer. Outlook 2007 comes with several attachment previewers so that you can preview many kinds of Office files, including Visio diagrams. For more information, see the article Preview Visio diagrams in Outlook 2007 even if you don't have Visio.

  • Use colors and formatting that match your PowerPoint presentations     Create a Visio diagram within PowerPoint 2007 or Office Visio 2007, and use matching color themes so your presentations and diagrams look professional when used together. For more information, see the article Apply a professional look to your drawings with themes.

  • Create a calendar     In Office Visio 2007, generate a calendar from Outlook data, and then use Visio tools to customize the look and feel. For more information, see the article Import appointments from Outlook into a Visio calendar.

  • Create project timelines and Gantt Charts     Generate timelines and Gantt Charts by importing project tasks and milestones from Microsoft Office Project 2007. Also, data stored in Visio timelines and Gantt Charts can be exported to Project. Use Visio to create a work breakdown structure from your Project data. For more information, see the articles Import data from Project into a Visio timeline and Import data from Project into a Visio Gantt Chart.

  • Visualize and track business and technical data     Connect your Visio diagrams to external data sources, such as Excel worksheets, Windows SharePoint Services lists, and Microsoft Office Access 2007 databases to integrate information sources and display even more information about the shapes associated with data in your diagrams. For more information, see the article Import data from Excel, SQL Server, SharePoint sites, and other external sources.

  • Generate PivotDiagrams and drill down into data     Generate PivotDiagrams within Visio to visualize business data. Or generate visual reports — in PivotDiagram form — from Windows SharePoint Services and Office Project. From SharePoint lists, you can report on issues and tasks and track workflow. From Project, you can report on resource and task data. For more information, see the article Create a PivotDiagram.

  • Save diagrams in various formats to easily share them with others     Save diagrams as Web pages, GIF files, JPG files, PDF files, and more to share your Visio diagrams over the Web or to insert them as graphics in other documents. On the File menu, click Save As, and in the Save As dialog box, select the format from the Save As Type list. For more information, see the articles Save a drawing as a Web page and Save a file in PDF format.

Top of Page

Applies To: Visio Standard 2007, Visio 2007



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language