The spelling and grammar checker isn't working as expected

Sometimes you may want the spelling and grammar checker in your Office program to ignore certain spellings or grammatical constructions. In other situations, you may not know why the grammar or spelling checker is flagging, or not flagging, some text. Here are some suggestions to try when the spelling and grammar checker isn't working as expected or you want to customize your results.

If you want the spelling checker to ignore certain proper names, technical terms, acronyms, or specialized capitalization, you can add such words or capitalization to a custom dictionary to prevent them from being flagged during spell checking.

To learn how to use and manage custom dictionaries, see Add words to your spell check dictionary.

If the Do not check spelling and grammar check box is selected, the spelling in your documents is not checked.

To clear the Detect language automatically check box in Word, do the following:

  1. On the Review tab, in the Language group, click Language > Set Proofing Language.

    (In Word 2007, click Set Language in the Proofing group.)

  2. In the Language dialog box, clear the Do not check spelling or grammar check box.

    Language dialog box

The Do not check spelling and grammar setting may be applied to an entire document or just parts of it. To make sure that an entire document is being checked for spelling and grammar, select all (CTRL+A) before clearing the check box.

If spelling is being flagged for a language you didn't intend or aren't using, you can change the proofing or dictionary language that Office uses. To learn how, see Check spelling and grammar in a different language.

If the spelling and grammar isn't flagging words or phrase that you know are incorrect, you may have chosen to ignore them during a previous spell check. In Word, Outlook, PowerPoint 2013, and PowerPoint 2016, you can force a recheck of the words and grammar that you previously choose to ignore. To learn how, see Recheck spelling and grammar that you previously chose to ignore.

If the spelling and grammar checker is skipping certain sections of a document, those sections may be marked to ignore. To learn how to clear this setting, see Clear text marked as do not check spelling below.

If the grammar checker flags errors you don't want to fix, you can customize the grammar and writing style rules to be less restrictive. For more information on how to turn off rules for specific grammar or writing styles, see Select grammar and writing style options. In certain programs, you can also simply turn off grammar checking.

To turn off grammar checking completely:

  1. Open the spelling and grammar options:

    • In Word 2010 and later, PowerPoint 2013, and PowerPoint 2016: On the File menu, click Options, and then click Proofing.

    • In Outlook 2010 and later: On the File menu, click Options, click Mail, and then click Spelling and Autocorrect.

    • In Word 2007: Click the Microsoft Office Button Office button image > Word Options > Proofing.

    • In Outlook 2007: On the Tools menu, click Options, click the Spelling tab, and then click Spelling and AutoCorrection.

  2. Clear the Check grammar with spelling check box.

In Word, Outlook, and PowerPoint, you can make the spelling and grammar checker ignore text. For example, say you insert some text from an informal e-mail message that contains sentence fragments and slang terms, and you want the spelling and grammar checker to ignore all mistakes in this block of text.

In Office 2010, Office 2013, and Office 2016

  1. Select the text that you want the spelling and grammar checker to ignore.

  2. On the Review tab, in the Language group, click Language, and then click Set Proofing Language.

  3. Select the Do not check spelling or grammar check box.

In Office 2007

  1. Select the text that you want the spelling and grammar checker to ignore.

  2. Open the Language dialog box:

    • In Word: On the Review tab, in the Proofing group, click Set Language.

    • In Outlook: In the Spelling drop-down list, in the Proofing group, click Set Language.

    • In PowerPoint: On the Review tab, in the Proofing group, click Language.

  3. Select the Do not check spelling or grammar check box.

In Word, Outlook, and PowerPoint, if the spelling and grammar checker is skipping certain text that you want it to check, you can change this setting and then run the spelling and grammar checker again.

In Office 2010, Office 2013, and Office 2016

  1. Select the entire document by pressing CTRL+A.

  2. On the Review tab, in the Language group, click Language, and then click Set Proofing Language.

  3. Clear the Do not check spelling or grammar check box.

In Office 2007

  1. Select the entire document by pressing CTRL+A.

  2. Open the Language dialog box:

    • In Word: On the Review tab, in the Proofing group, click Set Language.

    • In Outlook: In the Spelling drop-down list, in the Proofing group, click Set Language.

    • In PowerPoint: On the Review tab, in the Proofing group, click Language.

  3. Clear the Do not check spelling or grammar check box.

If, for example, certain words aren't being flagged as misspelled, you may have custom settings—such as ignoring words in uppercase or words that include numbers—selected that you want to change. See Ignore uppercase words, numbers, or Internet addresses when checking spelling to learn about the settings that you can review and change.

If you're using Word or Outlook, and you're not sure why the grammar checker flagged some text as grammatically incorrect, you can learn more by doing the following:

To learn more about the possible grammar error:

  • While using the automatic the spelling and grammar checker     Right-click the word, and then click About This Sentence.

    Right-clicking a grammar error

  • While running the spelling and grammar checker     Click Explain in the Spelling and Grammar dialog box.

In Outlook, you can specify that the original text of a message not be checked for spelling when you reply to or forward the message.

In Outlook 2010, Outlook 2013, and Outlook 2016

  1. Click the File tab, click Options, and then click Mail.

  2. Under Compose Messages, select the Ignore original message text in reply or forward check box.

In Outlook 2007

  1. On the Tools menu, click Options, and then click the Spelling tab.

  2. Select the Ignore original message text in reply or forward check box.

Some tables in Access contain data that should not be included when checking spelling.

  1. While you view the data in a table, query, form, or report, select the field that you want to exclude.

  2. Open the Spelling dialog box:

    • In Access 2010, Access 2013, and Access 2016: On the Home tab, in the Records group, click Spelling.

    • In Access 2007: On the Data tab, in the Editing group, click Check Spelling.

  3. Click Ignore 'Field Name' Field.

If you have feedback or suggestions about the spelling and grammar feature, please post them here.

See also

Check spelling and grammar

Add words to your spell check dictionary

Check spelling and grammar in a different language

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×