Take control of your Web site with Visio

If you manage a Web site's day-to-day operations, you know it's vital to have a clear picture of the site's overall structure and flow, track development changes, and monitor and repair broken hyperlinks. You can do all these tasks and more with the Web Site Map tools in Microsoft Office Visio Professional.

What do you want to do?

Map the contents of your site

Automatically check your site for errors

Keep track of changes to your site

Map the contents of your site

Managing your site starts with analyzing its current state. When you map your site, you create an up-to-date, graphical representation of the site's structure and contents.

A Web site map showing actual hierarchical structure of links in the site

Each shape in the site map represents a link on your Web site, and each shape includes information about the link type and location. By right-clicking a shape, you can browse directly from the shape to its Web location.

  1. In Visio, on the File menu, point to New, point to Software and Database, and then click Web Site Map.

  2. In the Generate Site Map dialog box, enter a site address for one of the following:

    • For an HTTP server, in the Address box, enter the address of the Web site you want to map.

    • For a network server or a local hard drive, click Browse, navigate to the file you want at the root of your site map, and then click Open.

  3. In the Generate Site Map dialog box, click Settings to review the settings for the maximum number of levels and the number of links that will be discovered.

  4. To change the settings, do any of the following:

    • On the Layout tab, change the layout style of the Web site map, such as number of how many levels you want discovered or whether the drawing shows a Compact tree or a Flowchart.

    • On the Extensions tab, select the type of files (such as a .doc, .jpg, or .exe) that you want to map.

    • On the Protocols tab, select the protocols (such as mailto, ftp, or NNTP) that you want to map.

    • On the Attributes tab, select the HTML attributes (such as HREF, SRC, or CODE) that you want to search for links.

    • On the Advanced tab, select options that further refine your search criteria.

    • Click OK.

  5. In the Generate Site Map dialog box, click OK.

  6. To save the site map, on the File menu, click Save.

Top of Page

Automatically check your site for errors

Keeping your site's links active and error-free is the most critical Web site management task.

When you map your site, Visio follows each link within the parameters you've specified and tracks any errors it encounters. The links with errors appear on the site map, in the Filter window, and in the List window as shapes with red Xs through them. If you can't see these windows, on the Web Site Map menu, point to Windows, and then click either List Window or Filter Window. You can quickly generate a list of the broken links with their associated errors to help you keep track of your work and make the necessary repairs.

A Web site map showing structure of site; any shape with a red X denotes a broken link

Create a report of links with errors on your site

  1. Open the site map for which you want to create an error report.

  2. On the Web Site Map menu, point to Reports, click Web Site Map Links with Errors, and then click Run.

  3. Select what kind of file (such as Excel or XML) you want the information saved to, and then click OK.

    Visio creates a report listing all the links that have hyperlink errors.

  4. If your report opens in a program outside of Visio, such as Microsoft Office Excel, name and save the report.

Fix broken links

Some broken links are caused by timeout errors. To resolve those errors, right-click the link, and then click Refresh or Refresh Parent.

Other broken links are caused by Site Not Found, Access Denied, or Password Required, or by incorrect file names, incorrect file locations, and missing files, which can trigger a 404 or File Not Found error message. Any of these will need to be fixed in your Web site.

Your Web site and the Web site map are not dynamically linked; changing one does not automatically affect the other. After you fix a broken link on the Web site, you can update the site map by right-clicking the shape representing the broken link, and then clicking Refresh Hyperlink. The red X disappears.

Top of Page

Keep track of changes to your site

If you have several developers working on your site, tracking their work can quickly become a full-time task. Using the Web Site Map comparison report, you can compare two versions of your site to quantify the changes made over a given period of time. The report compares the two versions and generates a list of differences. It not only identifies the links that appear in only one of the maps, but also lists the following link changes in both maps:

  • Error status

  • File title

  • File size

  • File modification date

For example, suppose you want to quantify the work done on the site each week. Simply map the site at the start of the week and again at the end. Then compare the two maps to generate a report of the changes. You can also measure the report against a schedule of work planned for the week to see if your Web site project is on target.

Compare Web site maps

  1. Open the most recent map of your Web site.

  2. On the Web Site Map menu, click Compare to previous document.

  3. Browse to the Web site map you want to compare with, select the file, and then click Open.

    Visio compares the two maps and generates an HTML report listing the differences.

  4. Name and save the report.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!