Show the Developer tab

The Developer tab is not displayed by default, but you can add it to the ribbon when you want to do or use the following:

  • Write macros.

  • Run macros that you previously recorded.

  • Use XML commands.

  • Use ActiveX controls.

  • Create applications to use with Microsoft Office programs.

  • Use form controls in Microsoft Excel.

  • Work with the ShapeSheet in Microsoft Visio.

  • Create new shapes and stencils in Microsoft Visio.

After you show the tab, it stays visible, unless you clear the check box or have to reinstall a Microsoft Office program.

Show the Developer tab in your Office application

  1. Click the File tab.

  2. Click Options.

  3. Click Customize Ribbon.

  4. Under Customize the Ribbon and under Main Tabs, select the Developer check box.

Top of page

Show the developer tab in Excel, PowerPoint, or Word

  1. Click the Microsoft Office Button Office button image , and then click Excel Options, PowerPoint Options, or Word Options.

  2. Click Popular, and then select the Show Developer tab in the Ribbon check box.

    Note: The Ribbon is part of the Microsoft Office Fluent user interface

Show the developer tab in Outlook

  1. On the Tools menu, click Options.

  2. On the Other tab, click Advanced Options, and then select the Show Developer tab in the Ribbon check box.

Run in developer mode in Visio

  1. On the Tools menu, click Options.

  2. On the Advanced tab, under Advanced Options, select the Run in developer mode check box.

Top of page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×