Share your file in Word for Mac

You can share documents from anywhere that you have a connection to the web.

To share a Word document, you can:

  • Invite people to view or edit a document you saved to the cloud.

  • Send a link to a document you saved to the cloud, using any email program.

  • Send a copy of your document as an email attachment.

Send an invitation to share your document

Save your file to an online location, such as OneDrive or SharePoint, and then invite people to view or edit it. That way, whenever you update your file, everyone you share with will have the latest version.

  1. In the upper-right corner, click the Share icon and then click Invite People.

    The Sharing Options menu

    If you haven't saved your document to the cloud, you'll be asked to do that first.

    Save to the cloud before inviting people

  2. To invite people, add their email addresses and a short message. When you add a name for the first time, Word might prompt you to access your Contacts.

    The Invite People dialog box

    If you want people to edit your document, check the Can Edit box.

  3. Click Share. Everyone you invite will get an email with a link to the shared file.

Note: To change your default email app, open Outlook, see Set the default email app or web browser on your Mac, or Make Outlook your default email application.

Send a link to your document

After you save your document to the cloud, you can share your document by copying and pasting a link to it and sharing it, using any email program or an online location.

  1. In the upper-right corner, click the Share icon and then click Copy Link.

    The Sharing Options menu

    If you haven't saved your document to the cloud, you'll be asked to do that first.

    Save to the cloud before inviting people

  2. Paste the link provided into an email or an online location to share it with others.

Send your document as an email attachment

If you don't want to save your document to the cloud, you can share it as an email attachment.

  1. In the upper-right corner, click the Share icon and then click Send Attachment.

    The Sharing Options menu

  2. Click Document or PDF.

    Share attachments is highlighted

  3. Word will open your default email application and attach your file to a new message. Just fill in the details, like email addresses and a short message, and click Send.

Note: To change your default email app, open Outlook, see Set the default email app or web browser on your Mac, or Make Outlook your default email application.

You can share documents in Word for Mac 2011 by using Office Online and OneDrive, the free online storage service from Windows Live.

Important: You can use Office Online programs in any browser, but they are designed to work best in Microsoft Internet Explorer 7 or later, Mozilla Firefox 3.5 or later, and Safari 4 or later.

To get started creating, editing, or sharing documents in OneDrive:

  1. Open a web browser, and then in the address bar, type http://onedrive.live.com.

  2. If prompted, sign in with your Windows Live ID.

    If you do not have a Windows Live ID, click Sign up, and then enter the required information.

Create a new document in OneDrive

  1. In OneDrive, click New, and then click the type of document that you want to create: Word document, Excel workbook, PowerPoint presentation, or OneNote notebook.

    New menu in OneDrive

  2. The document opens for editing in the appropriate Office Online program.

  3. Although Office Online saves your changes automatically, you may want to save your file with a new name. You can do this at any time by clicking File > Save As > Rename.

Share documents using OneDrive

  1. In OneDrive, select the document that you want to share by checking the circle in the upper-right corner of the document tile (or to the left of the document name in the file list, depending on the file view you're using the OneDrive).

  2. Click Share, and do any of the following:

    • To invite others to co-author your document, select the Allow editing check box.

    • To email a copy of the document, click Email, enter the email address and a message, and click Share.

    • If you want to create a link to your document, click Get a link, select the URL that appears, click Copy, and then paste the link anywhere you like.

    • To see more sharing options, such as Facebook or LinkedIn, click More.

Can't open a document on OneDrive?

If you are using Mac OS X Lion and cannot open documents on OneDrive, you can change a Safari or Firefox browser setting that will allow you to open documents. Do the following steps:

  1. Quit Safari or Firefox.

  2. In the Finder, click Applications, and then select the application icon for Safari or Firefox

  3. On the File menu, click Get Info.

  4. Select the Open in 32-bit mode check box.

  5. Close and reopen Safari or Firefox.

Connect with an expert
Contact us
Expand your skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×