Review the progress of your schedule

As your project progresses, you can review how work on its tasks is affecting the overall project schedule.

What do you want to do?

Review schedule differences

View project work over time

Identify tasks that are behind schedule

Find slack in my schedule

Review schedule differences

As you track progress through your project, you can review the differences between planned, scheduled, and actual work. This helps you assess whether work on your project is progressing as expected. You can compare work amounts for tasks as a whole, or for resources and their individual assignments.

The easiest way to compare work amounts with your original plan is to apply the Work table to a sheet view, such as the Gantt Chart view or Resource Usage view. The value in the Work field represents the current scheduled work value, showing the total of actual and remaining work for tasks that have started, and showing the latest projected work value for tasks that have not yet started.

If you saved a baseline, then your original planned work amounts are stored in the Baseline field. With this field, you can compare work amounts in your original plan to currently scheduled work amounts. The Variance field shows the calculated variance between planned and scheduled work, that is, the difference between the Baseline and Work fields.

You can also review actual work amounts in the Actual fields. For completed tasks, the Work and Actual fields contain the same value.

Compare...

Description

How?

Current task work with your original plan

You can examine whether your tasks are using more or less work than planned by using the Gantt Chart with the Work table applied.

On the View menu, click Gantt Chart. On the View menu, point to Table, and then click Work. Compare the values in the Work and Baseline fields.

To see the variance between the Work and Baseline fields, review the Variance field. For finished tasks, this variance represents the difference between actual and planned work. For tasks currently in progress, the Work field is the total of Actual Work and Remaining Work. For tasks not yet started, the Work field is the current projection, and is often the same as the Baseline.

The Variance field compares just the Work and Baseline fields; it does not compare other baseline fields (such as Baseline1, Baseline2, and so on).

Current task and assignment work with your original plan

You can examine whether tasks and their assigned resources are using more or less work than planned by using the Task Usage view with the Work table applied.

On the View menu, click Task Usage. On the View menu, point to Table, and then click Work.

Review total work values in the sheet portion of the view. In addition to the Task Name field, the table shows the Work, Baseline, Variance, Actual, Remaining, and % W. Comp. (percent work complete) fields. The summary rows show the total work values for each task while the italicized entries show the individual work values for each assignment.

Review timephased values of work for each task and assignment in the timesheet portion of the view under each time period.

Current resource and assignment work with your original plan

You can examine whether resources and assignments are using more or less work than planned by using the Resource Usage view with the Work table applied.

On the View menu, click Resource Usage. On the View menu, point to Table, and then click Work.

Review total work values in the sheet portion of the view. In addition to the Resource Name field, the table shows % Comp. (percent complete), Work, Overtime, Baseline, Variance, Actual, and Remaining fields. The summary rows show the total work values for each resource, while the italicized entries show the individual work values for each assignment.

Review timephased values of work for each resource and assignment in the timesheet portion of the view under each time period.

Note   Resource data is baselined at the project level. As a result, baselined resource data can vary widely depending on a number of factors. For example, you have a project with many tasks, and many resources allocated to those tasks. When you save a baseline, the resource allocation data is captured at the project level. If you add a task at a later time and configure the new task to roll up to the project level, the resource allocation baseline will not change.

Top of Page

View project work over time

By viewing work broken down by time period, you can see work within periods ranging from one minute to one year.

  1. On the View menu, click Task Usage or Resource Usage.

  2. On the Format menu, click Timescale, and then click the Top Tier, Middle Tier, or Bottom Tier tab.

  3. On the tab for the displayed timescale tier, in the Units box, click the time unit you want to use.

    For example, if you want to see work broken down by weeks and then by days, click Weeks in the Units box on the Top Tier tab, and then click Days in the Units box on the Middle Tier tab.

    Note   To show fewer than three timescales, select the timescales you want to appear in the Show list.

  4. To format the appearance of the timescale, enter the values you want to use in the Label, Align, and Count boxes. Select or clear the Use fiscal year and Tick lines check boxes, and then click OK.

  5. On the Format menu, point to Details, and then click Work, Actual Work, Cumulative Work, or Baseline Work in the Task Usage view. Or, in the Resource Usage view, click Work, Actual Work, Cumulative Work, or Overallocation.

Note   You can also view the work associated with a selected task using a combination view. To create a combination view, select the view that you want to appear on the top pane of the view, and then, on the Window menu, click Split. Click the bottom pane, and then select the view that you want to appear on the bottom pane. The view in the bottom pane shows detailed information about the tasks or resources in the top pane view. For example, when you display any task view in the top pane and the Resource Usage view in the bottom pane, the view in the bottom pane shows the resources assigned to the tasks selected in the top pane, along with information about those resources. The resource information shown pertains to all assigned tasks for each resource, not just to the tasks selected in the top pane.

Top of Page

Identify tasks that are behind schedule

If you have set a baseline for your project, you can see how tasks progress over time and see whether their start and finish dates are slipping. You can track progress by comparing baseline and scheduled or actual start and finish dates.

  1. On the View menu, click Tracking Gantt.

  2. On the View menu, point to Table, and then click Variance.

    If the variance fields are not visible, adjust the view splitter or press TAB to move through the fields to display them.

The Tracking Gantt view displays two task bars, one on top of the other, for each task. The lower bar shows baseline start and finish dates, and the upper bar shows scheduled start and finish dates so that you can see the difference between your plan and the current schedule.

You can also see whether the start and finish dates for task assignments are slipping, using the Slipping Assignments filter. This filter shows resources that are assigned to tasks that are not yet complete and that have been delayed from the finish date of the baseline. To use this filter, you must have saved a baseline plan.

  1. On the View menu, click Resource Usage.

  2. On the Project menu, point to Filtered for, and then click More Filters.

  3. In the Filters list, click Slipping Assignments.

  4. If you want to show only those assignments that are slipping, click Apply. If you want to show all assignments with a colored highlight on the slipping assignments, click Highlight.

Top of Page

Find slack in my schedule

The amount of slack in your schedule tells you how much you can delay tasks before other tasks or the project end date is affected.

  1. On the View menu, click More Views.

  2. In the Views list, click Detail Gantt, and then click Apply.

  3. On the View menu, point to Table, and then click Schedule.

    In the chart portion of the view, slack appears as thin bars to the right of tasks, with slack values adjoining the regular Gantt bars.

    Press TAB to move to the Free Slack and Total Slack fields if they are not visible in the sheet portion of the view.

Note   

  • If you know where slack exists in your schedule, you can move tasks when certain phases of the schedule have no slack and other phases have too much.

  • Slack values may also indicate a schedule inconsistency. For example, a negative slack value occurs when one task has a finish-to-start dependency with a successor task, but the successor task has a Must Start On constraint that is earlier than the end of the first task. Negative slack can also occur when a task is scheduled to finish after its deadline date.

Top of Page

Applies To: Project 2007 Standard



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language