Outline tasks into subtasks and summary tasks

You can break down your task list to make it appear more organized and readable by just indenting and outdenting the project's tasks to create an outline of the summary tasks (sometimes called "hammock tasks") and subtasks.

Note   You can also create a work breakdown structure (WBS) to help you create a task list by taking a high-level description of the work and breaking it into components by using task IDs or alphanumeric codes. For more information, see Create work breakdown structure (WBS) codes.

Choose a method to organize your tasks

When organizing the tasks for a project, you can group the tasks that share characteristics or that will be completed in the same time frame under a summary task. Project managers sometimes call summary tasks "hammock tasks." You can use the summary tasks to show the major phases and subphases in the project. Summary tasks summarize the data of their subtasks, which are the tasks that are grouped beneath them. You can indent the tasks as many levels as you need to reflect the organization of your project.

There are two methods for organizing your task list:

  • With the top-down method, you identify the major phases first and then break the phases down into individual tasks. The top-down method gives you a version of the plan as soon as you decide on the major phases.

    Note   If you can think of tasks that don't fit under the phases that you defined, you are probably missing a phase.

  • With the bottom-up method, you list all the possible tasks first, and then you group them into phases.

After you decide on a method for organizing your tasks, you can begin outlining them into summary tasks and subtasks in Project 2007.

Top of Page

Create summary tasks and subtasks

Create an outline for your tasks by indenting and outdenting them to create the summary tasks and subtasks. By default, the summary tasks are bold and outdented, and the subtasks are indented beneath them.

Note   You can insert other projects into your project to create a master project and subprojects. For more information, see Insert a project into a master project. Subprojects appear as summary tasks within the master project. Microsoft Office Project Professional 2007 and Microsoft Office Project Server 2007 have built-in reporting and analysis features that may provide you with information that was formerly available only from a master project.

How are the summary task values calculated?

Not all summary task values show the combined total of your subtask values. Although some summary task values (such as cost and work) represent the total subtask values, others (such as duration and baseline) do not. For example, Project 2007 calculates the duration of a summary task as the total work time between the earliest start date and latest finish date of its subtasks.

Summary task

Button image This summary task information summarizes the period between the earliest start date and latest finish date of all the included subtasks. It does not show the sum of all the subtask durations.

Because Project 2007 calculates the summary task values, most of them cannot be edited. If you need to change a summary task's values, such as duration, update the individual subtasks. Summary task values are then recalculated.

  1. On the View menu, click Gantt Chart.

  2. Click the row for the task that you want to indent as a subtask or outdent as a summary task.

  3. Click Indent Button image to indent the task, making it a subtask.

    Click Outdent Button image to outdent the task, making it a summary task.

    Tip   You can indent or outdent a task quickly with the mouse. Point to the first letter of the task name. When the pointer changes to a double-headed arrow, drag right to indent the task or drag left to outdent the task.

    The task I selected doesn't move when I click one of the outline buttons. What's happening?

    If you are unable to indent or outdent your tasks:

    • You may be trying to outdent a first-level task     Tasks at the first outline level cannot be outdented. Instead, indent those tasks that you want to include as subtasks to the first-level summary task.

    • You may be trying to move a task within a consolidated project     When working with consolidated projects, you cannot outdent a task beyond the level of the subtask of a summary task.

    • You may be trying to indent or outdent assignments, not tasks     The Resource Usage and Task Usage views display task and resource assignments with indentations similar to those of subtasks. Although assignments may be shown or hidden along with subtasks, they cannot be indented or outdented.

    • You may be working in a view that doesn't use the outline buttons     Outline buttons (such as Outdent Button image or Indent Button image) work only when the Gantt Chart, Task Sheet, or Task Usage view is the active view. If you are using one of these views and the outline buttons don't work, make sure that your summary tasks are displayed.

      To display the summary tasks, click Options on the Tools menu, click the View tab, and then select the Show summary tasks check box. For more information, see Display outlined subtasks and summary tasks.

    • You may have your tasks sorted without retaining their outline structure     If your tasks are currently sorted without their outline structure, the outline buttons aren't available.

      To keep the outline structure when sorting your tasks, point to Sort on the Project menu, click Sort by, and then select the Keep outline structure check box.

    • You may have your tasks grouped     If you selected a criterion in the Group By box Group box, tasks are grouped and outlining is not available. The Show Subtasks Button image and Hide Subtasks Button image buttons collapse and expand the grouped tasks, rather than the outline structure of the summary tasks and subtasks.

      To remove grouping, click No Group in the Group By box.


  • To undo outlining, outdent all of the subtasks and lower-level summary tasks until all tasks are at the same outline level.

  • You can easily rearrange the project phases in your outlined schedule. When you move or delete a summary task, you automatically move or delete all the subtasks associated with it.

  • When you delete a summary task, Project 2007 will automatically delete its subtasks. To delete a summary task and retain its subtasks, you need to first outdent the subtasks to the same level as the summary task.

  • When you rearrange a task list, the outline numbers for the listed items will change. Outline numbers are updated automatically when you move, add, or delete tasks, because they reflect the current structure of the task list. If you are using a custom numbering system that you entered manually, your numbers are not updated automatically. You need to manually adjust the numbers to reflect the task's new location if you move it.

  • Placing tasks in a hierarchical order does not automatically create task dependencies. To create task dependencies, the tasks must be linked. After you rearrange the linked tasks in your outlined schedule, the task dependencies that you set previously may no longer be relevant, and you may need to update them.

Top of Page

Applies To: Project Standard 2007, Project 2007

Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Change language