Options dialog box, Security tab

Use the Security tab in the Options dialog box to enter, review, or change preferences for project file privacy and security. You can:

  • Remove personal information from the project file.

  • Adjust the security level for macros.

  • Add or remove trusted sources for macros.

  • Add your Project Server or Workspace address to your list of Windows Internet Explorer Trusted Sites.

Dialog box location

On the Tools menu, click Options, and then click the Security tab.

Details

Privacy options section

Remove information from file properties on save     Selecting this check box specifies that when you save your project file, the Author, Manager, Company, and Last Saved By fields are cleared from the Properties dialog box (File menu). This helps protect your privacy and that of your company if you are distributing your project file, or if unauthorized individuals access the project file. By default, this check box is cleared.

Selecting this check box applies only to the active project file, and not to any existing or newly created document. You need to select this check box for each individual project file whose personal information you want to remove. Note that only the four fields are removed. Other personal information may still be present in the file and might need to be deleted manually.

Macro security section

Macro Security     Opens the Security dialog box, which you can use to set the security level (Very High, High, Medium, or Low). By default, the security level for macros is High, indicating that only signed macros from trusted sources are allowed to run. Any unsigned macros are automatically disabled. You can also use the Security dialog box to view, add, and remove trusted sources for macros and other add-ins used in the active project file.

Require Project Server and Workspace sites to be added to the Internet Explorer Trusted Sites list check box

Require Project Server and Workspace sites to be added to the Internet Explorer Trusted Sites list     Selecting this check box ensures that any Project Server or Workspace sites you specify on the Collaborate tab of the Options dialog box will be added to the Windows Internet Explorer Trusted Sites list. This prevents access problems to your Project Server or Workspace due to your security settings. To see the list of Web sites that you trust not to damage your computer, in any Windows Internet Explorer window, click Internet Options on the Tools menu. On the Security tab, click Trusted sites, and then click Sites.

Legacy Formats section

Options in this section enable you to define how Microsoft Office Project 2007 should handle legacy and non-default file formats.

  • Legacy file formats include the project (MPP), template (MPT), and workspace (MPW) formats from Microsoft Project 98. Legacy formats also include all MPW formats from versions prior to Microsoft Office Project 2007.

  • Non-default file formats include Microsoft Office Excel spreadsheet (XLS), comma-separated values (CSV), text (TXT), Microsoft Project Exchange (MPX), Microsoft Project Database (MPD), Microsoft Office Access database (MDB), and Open Database Connectivity (ODBC) file formats.

Do not load file with legacy or non default file formats in Project      Click this button to prevent files that use legacy or non-default formats from opening in Office Project 2007.

Prompt when loading files with legacy or non default file format      Click this button to open a dialog box when trying to open files in Office Project 2007 that use legacy or non-default formats.

Allow loading files with legacy or non default file formats      Click this button to allow Office Project 2007 to automatically try to open files that use legacy or non-default formats.

Note: The MPW format from versions prior to Microsoft Office Project 2007will not open in Office Project 2007, even with this setting selected.

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×