Open, insert, convert, and save DWG and DXF (AutoCAD) drawings

If you have AutoCAD objects that you would like to use in your Visio drawing, you can use Visio to open them and convert them to Visio shapes. You can also convert Visio drawings to AutoCAD files.

Open an AutoCAD drawing in Visio

  1. Click File > Open.

  2. Find the folder in which the drawing that you want is kept. Click the folder or click Browse.

  3. Click the All Visio Files list, and then click AutoCAD Drawing.

  4. Browse to the file and click Open.

Insert a DWG or DXF file into an existing Visio diagram

  1. On the Insert tab, click CAD Drawing.

  2. Browse to the file and click Open.

Convert DWG and DXF objects into Visio shapes

After you import or open an AutoCAD drawing, you can convert it into shapes that you can manipulate in Visio. Please note that converting to Visio shapes cannot be undone.

  1. Click an empty space on the diagram to deselect anything that may be already selected.

  2. Rest your cursor on the outside edge of the AutoCAD drawing until your cursor changes to this icon:
    Arrow cursor with move icon

  3. Right-click, and then click CAD Drawing Object > Convert.

  4. In the Convert CAD Object dialog box, select the AutoCAD layers you want to convert into Visio shapes.

  5. Click Advanced for more options. For example, you can choose to delete the converted layers, convert dimensions into dimension shapes, or convert hatch line patterns into shapes.

When you convert a drawing in DWG or DXF format, you convert the last saved spatial view of the CAD drawing. A CAD drawing may have been saved in model space or paper space:

  • Model space    is the primary drawing workspace in which CAD drafters create drawings. When you convert a drawing saved in model space, all objects and text on the layers you select are converted into Visio shapes.

  • Paper space    is a workspace that is analogous to a sheet of paper, in which CAD drafters can arrange different views of the drawing.

    The following image shows a DWG drawing saved in paper space.

    A CAD drawing saved in paper space that shows two views of the same floor plan

    The drawing contains two rectangular viewports. A viewport is a window into the three-dimensional CAD drawing. Each viewport can be set to a different scale or angle.

    When you convert a drawing saved in paper space, only the objects that are not cut off (clipped) by the edge of the viewport are converted into Visio shapes. Objects and text that are cut off are converted into lines. For example, a circle that is completely enclosed by a viewport is converted into a Visio circle shape. A circle that is clipped by the viewport is converted into a series of lines.

Save a Visio diagram as a DWG or DXF file

  1. Click File > Save As.

  2. Browse to find the location or folder where you want to save the drawing.

  3. In the Save as type list, click the file type you want:

    • AutoCAD Drawing (*.dwg)

    • AutoCAD Interchange (*.dxf)

If your Visio file has more than one drawing page, you must save each page separately.

See also

Introduction to working with AutoCAD drawings in Visio

Prepare for an AutoCAD import

Import an AutoCAD drawing

Convert multiple AutoCAD drawings

Open an AutoCAD drawing in Visio

  1. Click File > Open.

  2. Find the folder in which the drawing that you want is kept. Click the folder.

  3. Click the All Visio Files list, and then click AutoCAD Drawing.

  4. Browse to the file and click Open.

Insert a DWG or DXF file into an existing Visio diagram

  1. On the Insert tab, click CAD Drawing.

  2. Browse to the file and click Open.

Convert DWG and DXF objects into Visio shapes

After you import or open an AutoCAD drawing, you can convert it into shapes that you can manipulate in Visio. Please note that converting to Visio shapes cannot be undone.

  1. Right-click the CAD drawing, point to CAD Drawing Object, and then click Convert.

  2. In the Convert CAD Object dialog box, select the check boxes for the AutoCAD layers that contain the CAD objects you want to convert.

    Note: To keep your drawing file size small and speed the conversion process, convert only the layers or levels that you need.

  3. Click Advanced for more options. For example, you can choose to delete or hide the converted layers, convert dimensions into dimension shapes, or convert hatch line patterns into shapes.

  4. Click OK.

When you convert a drawing in DWG or DXF format, you convert the last saved spatial view of the CAD drawing. A CAD drawing may have been saved in model space or paper space:

  • Model space    is the primary drawing workspace in which CAD drafters create drawings. When you convert a drawing saved in model space, all objects and text on the layers you select are converted into Visio shapes.

  • Paper space    is a workspace that is analogous to a sheet of paper, in which CAD drafters can arrange different views of the drawing.

    The following image shows a DWG drawing saved in paper space.

    A CAD drawing saved in paper space that shows two views of the same floor plan

    The drawing contains two rectangular viewports. A viewport is a window into the three-dimensional CAD drawing. Each viewport can be set to a different scale or angle.

    When you convert a drawing saved in paper space, only the objects that are not cut off (clipped) by the edge of the viewport are converted into Visio shapes. Objects and text that are cut off are converted into lines. For example, a circle that is completely enclosed by a viewport is converted into a Visio circle shape. A circle that is clipped by the viewport is converted into a series of lines.

Save a Visio diagram as a DWG or DXF file

  1. Click File > Save As.

  2. Browse to find the location or folder where you want to save the drawing.

  3. In the Save as type list, click the file type you want:

    • AutoCAD Drawing (*.dwg)

    • AutoCAD Interchange (*.dxf)

If your Visio file has more than one drawing page, you must save each page separately.

Connect with an expert
Contact us
Expand your skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×