Link or embed Excel data into Project

You can insert data from Microsoft Office Excel into Microsoft Office Project as a linked object that will be updated dynamically by changes made in the source file. You can also embed the data independent of its original file.

  1. In Excel, select the data (such as fields, cells, records, or rows) that you want to link or embed, and then click Copy Button image.

  2. In Project, on the View menu, click the view that you want.

    To use a view that is not on the View menu, click More Views, click the view that you want to use in the Views list, and then click Apply.

  3. Select the location where you want to insert the data.

  4. On the Edit menu, click Paste Special.

  5. Do one of the following:

    • To embed the data independently, without a link to the source document, click Paste.

    • To link the inserted data to the data in the source document, click Paste Link.

  6. Under As, click Text Data.

Applies To: Project 2007

Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Change language