Sign in

Keyboard shortcuts for Microsoft Office Visio

The keyboard shortcuts described in this Help topic refer to the U.S. keyboard layout. Keys on other layouts may not correspond exactly to the keys on a U.S. keyboard.

To print this topic, press TAB to select Show All, press ENTER, and then press CTRL+P.

Online Help

Keyboard shortcuts for using the Help window

The Help window provides access to all Office Help content. The Help window displays topics and other Help content.

In the Help window

To do this

Press

Open the Help window.

F1

Close the Help window.

ALT+F4

Switch between the Help window and the active program.

ALT+TAB

Go back to Program Name Home.

ALT+HOME

Select the next item in the Help window.

TAB

Select the previous item in the Help window.

SHIFT+TAB

Perform the action for the selected item.

ENTER

In the Browse Program Name Help section of the Help window, select the next or previous item, respectively.

TAB or SHIFT+TAB

In the Browse Program Name Help section of the Help window, expand or collapse the selected item, respectively.

ENTER

Select the next hidden text or hyperlink, including Show All or Hide All at the top of a topic.

TAB

Select the previous hidden text or hyperlink.

SHIFT+TAB

Perform the action for the selected Show All, Hide All, hidden text, or hyperlink.

ENTER

Move back to the previous Help topic (Back button).

ALT+LEFT ARROW or BACKSPACE

Move forward to the next Help topic (Forward button).

ALT+RIGHT ARROW

Scroll small amounts up or down, respectively, within the currently displayed Help topic.

UP ARROW or DOWN ARROW

Scroll larger amounts up or down, respectively, within the currently displayed Help topic.

PAGE UP or PAGE DOWN

Change whether the Help window appears connected to (tiled) or separate from (untiled) the active program.

ALT+U

Display a menu of commands for the Help window. This requires that the Help window have the active focus (click in the Help window).

SHIFT+F10

Stop the last action (Stop button).

ESC

Refresh the window (Refresh button).

F5

Switch among areas in the Help window; for example, switch between the toolbar, Type words to search for box, and Search list.

F6

In a Table of Contents in tree view, select the next or previous item, respectively.

UP ARROW or DOWN ARROW

In a Table of Contents in tree view, expand or collapse the selected item, respectively.

LEFT ARROW or RIGHT ARROW

Microsoft Office basics

Display and use windows

To do this

Press

Switch to the next window.

ALT+TAB

Switch to the previous window.

ALT+SHIFT+TAB

Close the active window.

CTRL+W or CTRL+F4

Move to a task pane from another pane in the program window (clockwise direction). You may need to press F6 more than once.

Note: If pressing F6 doesn't display the task pane you want, try pressing ALT to place focus on the menu bar, and then pressing CTRL+TAB to move to the task pane.

F6

When a document window is not maximized, perform the Size command (on the Control menu for the window). Press the arrow keys to resize the window, and when you finish, press ESC.

CTRL+F8

Minimize a window to an icon (works for only some Microsoft Office programs).

CTRL+F9

Maximize a selected window.

CTRL+F10

Restore the size of the Visio program window after you maximized it.

CTRL+F5

Copy a picture of the screen to the Clipboard.

PRINT SCREEN

Copy a picture of the selected window to the Clipboard.

ALT+PRINT SCREEN

For any window with an icon in its title bar (for example, a shapes window), display the window shortcut menu.

ALT+SPACEBAR

Open the Reorder Pages dialog box.

CTRL+ALT+P

Cycle the focus through open drawings.

CTRL+TAB or CTRL+F6

Cycle the focus through open drawings in reverse order.

CTRL+SHIFT+TAB or CTRL+SHIFT+F6

Cycle the focus through pages in a drawing, including any visible markup overlays.

CTRL+PAGE DOWN or CTRL+ALT+TAB

Cycle the focus through pages in a drawing in reverse order.

CTRL+PAGE UP or CTRL+ALT+SHIFT+TAB

When a menu or toolbar is active, move to a task pane. (You may need to press CTRL+TAB more than once.)

CTRL+TAB

When a task pane is active, select the next or previous option in the task pane.

TAB or SHIFT+TAB

Change or resize the font

To do this

Press

Increase the font size of the selected text.

CTRL+SHIFT+>

Decrease the font size of the selected text.

CTRL+SHIFT+<

Move around in text or cells

To do this

Press

Move one character to the left.

LEFT ARROW

Move one character to the right.

RIGHT ARROW

Move one line up.

UP ARROW

Move one line down.

DOWN ARROW

Move one word to the left.

CTRL+LEFT ARROW

Move one word to the right.

CTRL+RIGHT ARROW

Move to the end of a line.

END

Move to the beginning of a line.

HOME

Move up one paragraph.

CTRL+UP ARROW

Move down one paragraph.

CTRL+DOWN ARROW

Move to the end of a text box.

CTRL+END

Move to the beginning of a text box.

CTRL+HOME

In Microsoft Office PowerPoint, move to the next title or body text placeholder. If it is the last placeholder on a slide, this will insert a new slide with the same slide layout as the original slide.

CTRL+ENTER

Repeat the last Find action.

SHIFT+F4

Access and use task panes

To do this

Press

Move to a task pane from another pane in the program window. (You may need to press F6 more than once.)

Note: If pressing F6 doesn't display the task pane you want, try pressing ALT to place the focus on the menu bar and then pressing CTRL+TAB to move to the task pane.

F6

When a menu or toolbar is active, move to a task pane. (You may need to press CTRL+TAB more than once.)

CTRL+TAB

When a task pane is active, select the next or previous option in the task pane.

TAB or SHIFT+TAB

Display the full set of commands on the task pane menu.

CTRL+DOWN ARROW

Move among choices on a selected submenu; move among certain options in a group of options in a dialog box.

DOWN ARROW or UP ARROW

Open the selected menu, or perform the action assigned to the selected button.

SPACEBAR or ENTER

Open a shortcut menu; open a drop-down menu for the selected gallery item.

SHIFT+F10

When a menu or submenu is visible, select the first or last command, respectively, on the menu or submenu.

HOME or END

Access and use smart tags

To do this

Press

Display the menu or message for a smart tag. If more than one smart tag is present, switch to the next smart tag and display its menu or message.

ALT+SHIFT+F10

Select the next item on a smart tag menu.

DOWN ARROW

Select the previous item on a smart tag menu.

UP ARROW

Perform the action for the selected item on a smart tag menu.

ENTER

Close the smart tag menu or message.

ESC

Resize and move toolbars, menus, and task panes

  1. Press ALT to select the menu bar.

  2. Press CTRL+TAB repeatedly to select the toolbar or task pane that you want.

  3. Do one of the following:

    Resize a toolbar

    1. On the toolbar, press CTRL+SPACEBAR to display the Toolbar Options menu.

    2. Click the Size command, and then press ENTER.

    3. Press the arrow keys to resize the toolbar. Press CTRL+ the arrow keys to resize 1 pixel at a time.

    Move a toolbar

    1. On the toolbar, press CTRL+SPACEBAR to display the Toolbar Options menu.

    2. Click the Move command, and then press ENTER.

    3. Press the arrow keys to position the toolbar. Press CTRL+ the arrow keys to move 1 pixel at a time. To undock the toolbar, press DOWN ARROW repeatedly. To dock the toolbar vertically on the left or right side, press LEFT ARROW or RIGHT ARROW, respectively, when the toolbar is all the way to the left or right side.

    Resize a task pane

    1. In the task pane, press CTRL+SPACEBAR to display a menu of additional commands.

    2. Press the DOWN ARROW key to select the Size command, and then press ENTER.

    3. Press the arrow keys to resize the task pane. Press CTRL+ the arrow keys to resize 1 pixel at a time.

    Move a task pane

    1. In the task pane, press CTRL+SPACEBAR to display a menu of additional commands.

    2. Press the DOWN ARROW key to select the Move command, and then press ENTER.

    3. Press the arrow keys to position the task pane. Press CTRL+ the arrow keys to move 1 pixel at a time.

  4. When you finish moving or resizing, press ESC.

Use dialog boxes

To do this

Press

Move to the next option or option group.

TAB

Move to the previous option or option group.

SHIFT+TAB

Switch to the next tab in a dialog box.

CTRL+TAB

Switch to the previous tab in a dialog box.

CTRL+SHIFT+TAB

Move between options in an open drop-down list, or between options in a group of options.

Arrow keys

Perform the action assigned to the selected button; select or clear the selected check box.

SPACEBAR

Open the list if it is closed and move to that option in the list.

First letter of an option in a drop-down list

Select an option; select or clear a check box.

ALT+ the letter underlined in an option

Open a selected drop-down list.

ALT+DOWN ARROW

Close a selected drop-down list; cancel a command and close a dialog box.

ESC

Perform the action assigned to a default button in a dialog box.

ENTER

Use edit boxes within dialog boxes

An edit box is a blank in which you type or paste an entry, such as your user name or the path to a folder.

To do this

Press

Move to the beginning of the entry.

HOME

Move to the end of the entry.

END

Move one character to the left or right.

LEFT ARROW or RIGHT ARROW

Move one word to the left.

CTRL+LEFT ARROW

Move one word to the right.

CTRL+RIGHT ARROW

Select or cancel selection one character to the left.

SHIFT+LEFT ARROW

Select or cancel selection one character to the right.

SHIFT+RIGHT ARROW

Select or cancel selection one word to the left.

CTRL+SHIFT+LEFT ARROW

Select or cancel selection one word to the right.

CTRL+SHIFT+RIGHT ARROW

Select from the insertion point to the beginning of the entry.

SHIFT+HOME

Select from the insertion point to the end of the entry.

SHIFT+END

Use the Open and Save As dialog boxes

To do this

Press

Go to the previous folder. Button image

ALT+1

Up One Level Button image button: Open the folder one level above the open folder.

ALT+2

Delete Button image button: Delete the selected folder or file.

ALT+3

Create New Folder Button image button: Create a new folder.

ALT+4

Views Button image button: Switch among available folder views.

ALT+5

Tools button: Show the Tools menu.

ALT+L

Display a shortcut menu for a selected item such as a folder or file.

SHIFT+F10

Move between options or areas in the dialog box.

TAB

Open the Look in list.

F4 or ALT+I

Update the file list.

F5

Text

Edit text

To do this

Press

Move to the next or previous character, respectively, in a line of text.

RIGHT ARROW or LEFT ARROW

Move to the next or previous line of text, respectively.

DOWN ARROW or UP ARROW

Move to the next or previous word, respectively, in a line of text.

CTRL+RIGHT ARROW or CTRL+LEFT ARROW

Move to the next or previous paragraph, respectively.

CTRL+DOWN ARROW or CTRL+UP ARROW

Select all the text in a text block.

CTRL+A

Select the next or previous character, respectively.

SHIFT+RIGHT ARROW or SHIFT+LEFT ARROW

Select the next or previous word, respectively.

CTRL+SHIFT+RIGHT ARROW or CTRL+SHIFT+LEFT ARROW

Select the next or previous line, respectively.

SHIFT+DOWN ARROW or SHIFT+UP ARROW

Select the next or previous paragraph, respectively.

CTRL+SHIFT+DOWN ARROW or CTRL+SHIFT+UP ARROW

Delete the previous word.

CTRL+BACKSPACE

Replace the selected text with the field height. If no text is selected, replace all text with the field height for the selected shape.

CTRL+SHIFT+H

Replace the selected text with the field width. If no text is selected, replace all text with the field width for the selected shape.

CTRL+SHIFT+W

Format text

To do this

Press

Turn bold (Button image) on or off.

CTRL+B

Turn italic (Button image) on or off.

CTRL+I

Turn underline (Button image) on or off.

CTRL+U

Turn double underline on or off.

CTRL+SHIFT+D

Turn all caps on or off.

CTRL+SHIFT+A

Turn small caps on or off.

CTRL+SHIFT+K

Turn subscript (Button image) on or off.

CTRL+=

Turn superscript (Button image) on or off.

CTRL+SHIFT+=

Increase the font size of the selected text.

CTRL+SHIFT+>

Decrease the font size of the selected text.

CTRL+SHIFT+<

Align text

To do this

Press

Align text left.

CTRL+SHIFT+L

Center text horizontally.

CTRL+SHIFT+C

Align text right.

CTRL+SHIFT+R

Justify text horizontally.

CTRL+SHIFT+J

Top-align text vertically.

CTRL+SHIFT+T

Center text vertically.

CTRL+SHIFT+M

Bottom-align text vertically.

CTRL+SHIFT+V

Zoom and navigation

Navigate menus and toolbars

To do this

Press

Select the menu bar, or close an open menu and submenu at the same time.

F10 or ALT

Display the shortcut menu for the selected item.

Application (button image)

When a toolbar or menu bar is selected, select the next or previous button or menu, respectively.

TAB or SHIFT+TAB

Select a task pane or toolbar after pressing F10 or ALT to select the menu bar. Pressing the keys repeatedly moves the focus among the open toolbars, menu bars, and task pane.

CTRL+TAB or CTRL+SHIFT+TAB

Open the selected menu, or perform the action for the selected button or command.

ENTER

Display the title bar shortcut menu.

ALT+SPACEBAR

When a menu or submenu is open, select the next or previous command, respectively.

DOWN ARROW or UP ARROW

When a toolbar or menu bar is selected, select the next or previous button or menu, respectively. When a submenu is open, switch between the main menu and the submenu.

LEFT ARROW or RIGHT ARROW

Select the first or last command, respectively, on the menu or submenu, or the first or last button on a toolbar.

HOME or END

Close an open menu. When a submenu is open, close only the submenu.

ESC

Open the selected menu.

DOWN ARROW

When a shortened menu is open, display the full set of commands.

Note: You can use the keyboard to select any menu command on the menu bar. Press ALT to select the menu bar. Press the letter that is underlined in the menu name that contains the command you want. In the menu that appears, press the letter underlined in the command name that you want.

CTRL+DOWN ARROW

Display the full set of commands on the task pane menu.

CTRL+SPACEBAR

Zoom

To do this

Press

Zoom in.

ALT+F6

Zoom out.

ALT+SHIFT+F6

Move around in full-screen view

Use these keyboard shortcuts to move between Visio and another program or page when you are in full-screen view.

To do this

Press

Open the next page.

Note: Do not use PgDn on the numeric keypad.

PAGE DOWN or DOWN ARROW or RIGHT ARROW

Open the previous page.

Note: Do not use PgUp on the numeric keypad.

PAGE UP or UP ARROW or LEFT ARROW

Move around a Web page drawing

To do this

Press

Cycle the focus through the left frame, the drawing, and shapes on the drawing that contain shape data, hyperlinks, and the address bar.

TAB

Activate the hyperlink for the shape or hyperlink on the drawing that has focus.

ENTER

Visio-specific menus

Format menu

To do this

Press

Open the Font tab in the Text dialog box (Format menu, Text).

F11

Open the Paragraph tab in the Text dialog box (Format menu, Text).

SHIFT+F11

Open the Tabs tab in the Text dialog box (Format menu, Text).

CTRL+F11

Open the Fill dialog box for the selected shape (Format menu, Fill).

F3

Open the Line dialog box (Format menu, Line).

SHIFT+F3

Tools menu

To do this

Press

Open the General tab in the Snap & Glue dialog box (Tools menu, Snap & Glue).

ALT+F9

Select or clear the Snap check box on the General tab in the Snap & Glue dialog box; snaps shapes to items selected in the Snap to section of the dialog box (Tools menu, Snap & Glue).

SHIFT+F9

Select or clear the Glue check box on the General tab in the Snap & Glue dialog box; glues shapes to items selected in the Glue to section of the dialog box (Tools menu, Snap & Glue).

F9

Shape menu

To do this

Press

Group the selected shapes (Shape menu, Grouping submenu, Group).

CTRL+G or CTRL+SHIFT+G

Ungroup shapes in the selected group (Shape menu, Grouping submenu, Ungroup).

CTRL+SHIFT+U

Bring the selected shape to the front (Shape menu, Order submenu, Bring To Front).

CTRL+SHIFT+F

Send the selected shape to the back (Shape menu, Order submenu, Send To Back).

CTRL+SHIFT+B

Rotate the selected shape to the left (Shape menu, Rotate or Flip submenu, Rotate Left).

CTRL+L

Rotate the selected shape to the right (Shape menu, Rotate or Flip submenu, Rotate Right).

CTRL+R

Flip the selected shape horizontally (Shape menu, Rotate or Flip submenu, Flip Horizontal).

CTRL+H

Flip the selected shape vertically (Shape menu, Rotate or Flip submenu, Flip Vertical).

CTRL+J

Open the Align Shapes dialog box for the selected shape (Shape menu, Align Shapes).

F8

Window menu

To do this

Press

Display the open drawing windows tiled vertically (Window menu, Tile).

SHIFT+F7

Display the open drawing windows tiled horizontally.

CTRL+SHIFT+F7

Display the open drawing windows so that you can see the title of every window (Window menu, Cascade).

ALT+F7 or CTRL+ALT+F7

Visio-specific toolbars

Standard toolbar

To do this

Press

Switch the Format Painter tool on or off (Button image).

CTRL+SHIFT+P

Select the Pointer Tool (Pointer button).

CTRL+1

Select the Connector Tool (Button image).

CTRL+3

Select the Connection Point Tool (Connection point image - blue X).

CTRL+SHIFT+1

Select the Text Tool (Text tool button).

CTRL+2

Select the Text Block Tool (Button image).

CTRL+SHIFT+4

Select the Stamp Tool (Button image).

CTRL+SHIFT+3

Drawing toolbar

To do this

Press

Select the Rectangle Tool (Button image).

CTRL+8

Select the Ellipse Tool (Button image).

CTRL+9

Select the Line Tool (Button image).

CTRL+6

Select the Arc Tool (Button image).

CTRL+7

Select the Freeform Tool (Button image).

CTRL+5

Select the Pencil Tool (Button image).

CTRL+4

Picture toolbar

To do this

Press

Select the Crop Tool (Button image).

CTRL+SHIFT+2

Visio shapes and stencils

Move from shape to shape in a drawing page

To do this

Press

Move from shape to shape on the drawing page. A dotted rectangle indicates the shape that has the focus.

Note: You cannot move to shapes that are protected against selection or on a locked layer.

TAB

Move from shape to shape on the drawing page in reverse order.

SHIFT+TAB

Select a shape that has focus.

Note: To select multiple shapes, press the TAB key to bring focus to the first shape you want to select, and then press ENTER. Hold down SHIFT while you press the TAB key to bring focus to another shape. When the focus rectangle is over the shape you want, press ENTER to add that shape to the selection. Repeat for each shape you want to select.

ENTER

Clear selection of or focus on a shape.

ESC

Switch between text edit mode and shape selection mode on a selected shape.

F2

Nudge a selected shape.

Arrow keys

Nudge a selected shape 1 pixel at a time.

Note: SCROLL LOCK must be turned off.

SHIFT+Arrow keys

Cycle through visible smart tags.

ALT+SHIFT+F10

Work with master shapes in a stencil

To do this

Press

Move between master shapes in a stencil.

Arrow keys

Move to the first master shape in a row of a stencil.

HOME

Move to the last master shape in a row of a stencil.

END

Move to the first master shape in a column of a stencil.

PAGE UP

Move to the last master shape in a column of a stencil.

PAGE DOWN

Copy the selected master shapes to the Clipboard.

CTRL+C

Paste the contents of the Clipboard to a custom stencil.

Note: The custom stencil must first be opened for editing.

CTRL+V

Select all the master shapes in a stencil.

Note: To select multiple master shapes, press the arrow keys to bring focus to the first master shape you want. Hold down SHIFT while you press the arrow keys to bring focus to another master. When the focus rectangle is over the master you want, press ENTER to add that master to the selection. Repeat for each master you want to select.

CTRL+A

Select or cancel selection of a master shape that has focus.

SHIFT+ENTER

Cancel the selection of master shapes in a stencil.

ESC

Insert the selected master shapes into the drawing.

Note: To automatically insert and connect a master shape to an existing shape in your drawing, first select the shape you want the new shape to be connected to in the drawing. Select the Connector Tool Button image on the Standard toolbar, and then select the master shape on the stencil and press CTRL+ENTER.

CTRL+ENTER

Work with stencils in edit mode

To do this

Press

Delete the selected master shape.

DELETE

Cut the selected master shape from the custom stencil and place it on the Clipboard.

CTRL+X

Rename the selected master shape.

F2



Was this information helpful?

How can we improve it?

How can we improve it?

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!