Keyboard shortcuts for Access

You can use keyboard shortcuts for quick access to frequently used commands or operations. The following sections list the keyboard shortcuts available in Microsoft Office Access 2007. You can also use keyboard shortcuts to move the focus to a menu, command, or control without using the mouse.

General shortcut keys

Global Access shortcut keys

Opening databases

To do this

Press

Open a new database

CTRL+N

Open an existing database

CTRL+O

Printing and saving

To do this

Press

Print the current or selected object

CTRL+P

Open the Print dialog box from Print Preview

P or CTRL+P

Open the Page Setup dialog box from Print Preview

S

Cancel Print Preview or Layout Preview

C or ESC

Save a database object

CTRL+S or SHIFT+F12

Open the Save As dialog box

F12

Using a combo box or list box

To do this

Press

Open a combo box

F4 or ALT+DOWN ARROW

Refresh the contents of a Lookup field list box or combo box

F9

Move down one line

DOWN ARROW

Move down one page

PAGE DOWN

Move up one line

UP ARROW

Move up one page

PAGE UP

Exit the combo box or list box

TAB

Finding and replacing text or data

To do this

Press

Open the Find tab in the Find and Replace dialog box (Datasheet view and Form view only)

CTRL+F

Open the Replace tab in the Find and Replace dialog box (Datasheet view and Form view only)

CTRL+H

Find the next occurrence of the text specified in the Find and Replace dialog box when the dialog box is closed (Datasheet view and Form view only)

SHIFT+F4

Working in Design view

To do this

Press

Switch between Edit mode (with insertion point displayed) and Navigation mode in a datasheet. When working in a form or report, press ESC to leave Navigation mode.

F2

Switch to the property sheet (Design view in forms and reports in both Access databases and Access projects)

F4

Switch to Form view from form Design view

F5

Switch between the upper and lower portions of a window (Design view of queries, and the Advanced Filter/Sort window)

F6

Cycle through the field grid, field properties, Navigation Pane, access keys in the Keyboard Access System, Zoom controls, and the security bar (Design view of tables)

F6

Open the Choose Builder dialog box (Design view window of forms and reports)

F7

Open the Visual Basic Editor from a selected property in the property sheet for a form or report

F7

Switch from the Visual Basic Editor back to form or report Design view

SHIFT+F7 or ALT+F11

Editing controls in form and report Design view

To do this

Press

Copy the selected control to the Clipboard

CTRL+C

Cut the selected control and copy it to the Clipboard

CTRL+X

Paste the contents of the Clipboard in the upper-left corner of the selected section

CTRL+V

Move the selected control to the right (except controls that are part of a layout)

RIGHT ARROW or CTRL+RIGHT ARROW

Move the selected control to the left (except controls that are part of a layout)

LEFT ARROW or CTRL+LEFT ARROW

Move the selected control up

UP ARROW or CTRL+UP ARROW

Move the selected control down

DOWN ARROW or CTRL+DOWN ARROW

Increase the height of the selected control

SHIFT+DOWN ARROW

Increase the width of the selected control

Note   If used with controls that are in a layout, the entire layout is resized

SHIFT+RIGHT ARROW

Reduce the height of the selected control

SHIFT+UP ARROW

Reduce the width of the selected control

Note   If used with controls that are in a layout, the entire layout is resized

SHIFT+LEFT ARROW

Window operations

Note   By default, Microsoft Office Access 2007 databases display as tabbed documents. To use windowed documents, click the Microsoft Office Button Office button image, and then click Access Options. In the Access Options dialog box, click Current Database and, under Document Window Options, click Overlapping Windows.

To do this

Press

Toggle the Navigation Pane

F11

Cycle between open windows

CTRL+F6

Restore the selected minimized window when all windows are minimized

ENTER

Turn on Resize mode for the active window when it is not maximized; press the arrow keys to resize the window

CTRL+F8

Display the Control menu

ALT+SPACEBAR

Display the shortcut menu

SHIFT+F10

Close the active window

CTRL+W or CTRL+F4

Switch between the Visual Basic Editor and the previous active window

ALT+F11

Working with Wizards

To do this

Press

Toggle the focus forward between controls in the wizard

TAB

Move to the next page of the wizard

ALT+N

Move to the previous page of the wizard

ALT+B

Complete the wizard

ALT+F

Miscellaneous

To do this

Press

Display the complete hyperlink address for a selected hyperlink

F2

Check spelling

F7

Open the Zoom box to conveniently enter expressions and other text in small input areas

SHIFT+F2

Display a property sheet in Design view

ALT+ENTER

Exit Access

ALT+F4

Invoke a Builder

CTRL+F2

Toggle forward between views when in a table, query, form, report, page, PivotTable list, PivotChart report, stored procedure, or Access project (.adp) function. If there are additional views available, successive keystrokes will move to the next available view.

CTRL+RIGHT ARROW or CRTL+COMMA (,)

Toggle back between views when in a table, query, form, report, page, PivotTable list, PivotChart report, stored procedure, or .adp function. If there are additional views available, successive keystrokes will move to the previous view.

Note   CTRL+PERIOD (.) does not work under all conditions with all objects.

CTRL+LEFT ARROW or CRTL+PERIOD (.)

Navigation Pane shortcut keys

Editing and navigating the Object list

To do this

Press

Rename a selected object

F2

Move down one line

DOWN ARROW

Move down one window

PAGE DOWN

Move to the last object

END

Move up one line

UP ARROW

Move up one window

PAGE UP

Move to the first object

HOME

Navigating and opening objects

To do this

Press

Open the selected table or query in Datasheet view

ENTER

Open the selected form or report

ENTER

Run the selected macro

ENTER

Open the selected table, query, form, report, data access page, macro, or module in Design view

CTRL+ENTER

Display the Immediate window in the Visual Basic Editor

CTRL+G

Work with menus

To do this

Press

Show the shortcut menu

SHIFT+F10

Show the access keys

ALT or F10

Show the program icon menu (on the program title bar)

ALT+SPACEBAR

With the menu or submenu visible, select the next or previous command

DOWN ARROW or UP ARROW

Select the menu to the left or right; or, when a submenu is visible, to switch between the main menu and the submenu

LEFT ARROW or RIGHT ARROW

Select the first or last command on the menu or submenu

HOME or END

Close the visible menu and submenu at the same time

ALT

Close the visible menu; or, with a submenu visible, to close the submenu only

ESC

Work in windows and dialog boxes

Using a program window

To do this

Press

Switch to the next program

ALT+TAB

Switch to the previous program

ALT+SHIFT+TAB

Show the Windows Start menu

CTRL+ESC

Close the active database window

CTRL+W

Switch to the next database window

CTRL+F6

Switch to the previous database window

CTRL+SHIFT+F6

Restore the selected minimized window when all windows are minimized

ENTER

Using a dialog box

To do this

Press

Switch to the next tab in a dialog box

CTRL+TAB

Switch to the previous tab in a dialog box

CTRL+SHIFT+TAB

Move to the next option or option group

TAB

Move to the previous option or option group

SHIFT+TAB

Move between options in the selected drop-down list box, or to move between some options in a group of options

Arrow keys

Perform the action assigned to the selected button; select or clear the check box

SPACEBAR

Move to the option by the first letter in the option name in a drop-down list box

Letter key for the first letter in the option name you want (when a drop-down list box is selected)

Select the option, or to select or clear the check box by the letter underlined in the option name

ALT+letter key

Open the selected drop-down list box

ALT+DOWN ARROW

Close the selected drop-down list box

ESC

Perform the action assigned to the default button in the dialog box

ENTER

Cancel the command and close the dialog box

ESC

Editing in a text box

To do this

Press

Move to the beginning of the entry

HOME

Move to the end of the entry

END

Move one character to the left or right

LEFT ARROW or RIGHT ARROW

Move one word to the left or right

CTRL+LEFT ARROW or CTRL+RIGHT ARROW

Select from the insertion point to the beginning of the entry

SHIFT+HOME

Select from the insertion point to the end of the entry

SHIFT+END

Change the size of the selection by one character to the left

SHIFT+LEFT ARROW

Change the size of the selection by one character to the right

SHIFT+RIGHT ARROW

Change the size of the selection by one word to the left

CTRL+SHIFT+LEFT ARROW

Change the size of the selection by one word to the right

CTRL+SHIFT+RIGHT ARROW

Work with the Open, File New Database, and Save As dialog boxes

To do this

Press

Go to the previous folder (Button image)

ALT+1

Open the folder up one level from the open folder (Up One Level button Button image)

ALT+2

Delete the selected folder or file (Delete button Button image)

DEL

Create a new subfolder in the open folder (Create New Folder button Button image)

ALT+4

Switch between Thumbnails, Tiles, Icons, List, Details, Properties, and Preview views

ALT+5

Show the Tools menu (Tools button)

ALT+L

Work with property sheets

Using a property sheet with a form or report

To do this

Press

Toggle the property sheet tab

F4

Move among choices in the control drop-down list one item at a time

DOWN ARROW or UP ARROW

Move among choices in the control drop-down list five items at a time

PAGE DOWN or PAGE UP

Move to the property sheet tabs from the control drop-down list

TAB

Move among the property sheet tabs with a tab selected, but no property selected

LEFT ARROW or RIGHT ARROW

With a property already selected, move down one property on a tab

TAB

With a property selected, move up one property on a tab; or if already at the top, move to the control drop-down list

SHIFT+TAB

Toggle forward between tabs when a property is selected

CTRL+TAB

Toggle backward between tabs when a property is selected

CTRL+SHIFT+TAB

Using a property sheet with a table or query

To do this

Press

Toggle the property sheet tab

F4

With a tab selected, but no property selected, move among the property sheet tabs

LEFT ARROW or RIGHT ARROW

Move to the property sheet tabs when a property is selected

CTRL+TAB

Move to the first property of a tab when no property is selected

TAB

Move down one property on a tab

TAB

Move up one property on a tab; or if already at the top, select the tab itself

SHIFT+TAB

Toggle forward between tabs when a property is selected

CTRL+TAB

Toggle backward between tabs when a property is selected

CTRL+SHIFT+TAB

Work with the Field List pane

To do this

Press

Toggle the Field List pane

ALT+F8

Add the selected field to the form or report detail section

ENTER

Move up or down the Field List pane

UP ARROW or DOWN ARROW

Move to the upper Field List pane from the lower pane

SHIFT+TAB

Move to the lower Field List pane from the upper pane

TAB

Keyboard shortcuts for using the Help window

To do this

Press

Select the next hidden text or hyperlink, or Show All or Hide All at the top of a topic

TAB

Select the previous hidden text or hyperlink, or the Browser View button at the top of a Microsoft Office Web site article

SHIFT+TAB

Perform the action for the selected Show All, Hide All, hidden text, or hyperlink

ENTER

Move back to the previous Help topic

ALT+LEFT ARROW

Move forward to the next Help topic

ALT+RIGHT ARROW

Open the Print dialog box

CTRL+P

Scroll small amounts up and down, respectively, within the currently-displayed Help topic.

UP ARROW AND DOWN ARROW

Scroll larger amounts up and down, respectively, within the currently-displayed Help topic.

PAGE UP AND PAGE DOWN

Display a menu of commands for the Help window; requires that the Help window have active focus (click an item in the Help window).

SHIFT+F10

Send e-mail messages

To do this

Press

Send the active database object (the object selected in the Navigation Pane) as an e-mail message

ALT+F+E

Open the Address Book from within Outlook

CTRL+SHIFT+B

Check the names in the To, Cc, and Bcc boxes against the Address Book

ALT+K or CTRL+K

Select the next box in the e-mail header or the body of the message when the last box in the e-mail header is active

TAB

Select the previous field or button in the e-mail header

SHIFT+TAB

Keys for working with text and data

Select text and data

Selecting text in a field

To do this

Press

Change the size of the selection by one character to the right

SHIFT+RIGHT ARROW

Change the size of the selection by one word to the right

CTRL+SHIFT+RIGHT ARROW

Change the size of the selection by one character to the left

SHIFT+LEFT ARROW

Change the size of the selection by one word to the left

CTRL+SHIFT+LEFT ARROW

Selecting a field or record

Note   To cancel a selection, use the opposite arrow key.

To do this

Press

Select the next field

TAB

Switch between Edit mode (with insertion point displayed) and Navigation mode in a datasheet. When using a form or report, press ESC to leave Navigation mode.

F2

Switch between selecting the current record and the first field of the current record, in Navigation mode

SHIFT+SPACEBAR

Extend selection to the previous record, if the current record is selected

SHIFT+UP ARROW

Extend selection to the next record, if the current record is selected

SHIFT+DOWN ARROW

Select all records

CTRL+A or CTRL+SHIFT+SPACEBAR

Extending a selection

To do this

Press

Turn on Extend mode (in Datasheet view, Extended Selection appears in the lower-right corner of the window); pressing F8 repeatedly extends the selection to the word, the field, the record, and all records

F8

Extend a selection to adjacent fields in the same row in Datasheet view

LEFT ARROW or RIGHT ARROW

Extend a selection to adjacent rows in Datasheet view

UP ARROW or DOWN ARROW

Undo the previous extension

SHIFT+F8

Cancel Extend mode

ESC

Selecting and moving a column in Datasheet view

To do this

Press

Select the current column or cancel the column selection, in Navigation mode only

CTRL+SPACEBAR

Select the column to the right, if the current column is selected

SHIFT+RIGHT ARROW

Select the column to the left, if the current column is selected

SHIFT+LEFT ARROW

Turn on Move mode; then press the RIGHT ARROW or LEFT ARROW key to move selected column(s) to the right or left

CTRL+SHIFT+F8

Edit text and data

Note   If the insertion point is not visible, press F2 to display it.

Moving the insertion point in a field

To do this

Press

Move the insertion point one character to the right

RIGHT ARROW

Move the insertion point one word to the right

CTRL+RIGHT ARROW

Move the insertion point one character to the left

LEFT ARROW

Move the insertion point one word to the left

CTRL+LEFT ARROW

Move the insertion point to the end of the field, in single-line fields; or to move it to the end of the line in multi-line fields

END

Move the insertion point to the end of the field, in multiple-line fields

CTRL+END

Move the insertion point to the beginning of the field, in single-line fields; or to move it to the beginning of the line in multi-line fields

HOME

Move the insertion point to the beginning of the field, in multiple-line fields

CTRL+HOME

Copying, moving, or deleting text

To do this

Press

Copy the selection to the Clipboard

CTRL+C

Cut the selection and copy it to the Clipboard

CTRL+X

Paste the contents of the Clipboard at the insertion point

CTRL+V

Delete the selection or the character to the left of the insertion point

BACKSPACE

Delete the selection or the character to the right of the insertion point

DELETE

Delete all characters to the right of the insertion point

CTRL+DELETE

Undoing changes

To do this

Press

Undo typing

CTRL+Z or ALT+BACKSPACE

Undo changes in the current field or current record; if both have been changed, press ESC twice to undo changes, first in the current field and then in the current record

ESC

Entering data in Datasheet or Form view

To do this

Press

Insert the current date

CTRL+SEMICOLON (;)

Insert the current time

CTRL+SHIFT+COLON (:)

Insert the default value for a field

CTRL+ALT+SPACEBAR

Insert the value from the same field in the previous record

CTRL+APOSTROPHE (')

Add a new record

CTRL+PLUS SIGN (+)

In a datasheet, delete the current record

CTRL+MINUS SIGN (-)

Save changes to the current record

SHIFT+ENTER

Switch between the values in a check box or option button

SPACEBAR

Insert a new line

CTRL+ENTER

Refreshing fields with current data

To do this

Press

Recalculate the fields in the window

F9

Requery the underlying tables; in a subform, this requeries the underlying table for the subform only

SHIFT+F9

Refresh the contents of a Lookup field list box or combo box

F9

Keys for navigating records

Navigate in Design view

To do this

Press

Switch between Edit mode (with insertion point displayed) and Navigation mode

F2

Toggle the property sheet

F4

Switch to Form view from form Design view

F5

Switch between the upper and lower portions of a window (Design view of macros, queries, and the Advanced Filter/Sort window) Use F6 when the TAB key does not take you to the section of the screen you want.

F6

Toggle forward between the design pane, properties, Navigation Pane, access keys, and Zoom controls (Design view of tables, forms, and reports)

F6

Open the Visual Basic Editor from a selected property in the property sheet for a form or report

F7

Invokes the Field List pane in a form, report, or data access page. If the Field List pane is already open, focus moves to the Field List pane.

ALT+F8

When you have a code module open, switch from the Visual Basic Editor to form or report Design view

SHIFT+F7

Switch from a control's property sheet in form or report Design view to the design surface without changing the control focus

SHIFT+F7

Display a property sheet

ALT+ENTER

Copy the selected control to the Clipboard

CTRL+C

Cut the selected control and copy it to the Clipboard

CTRL+X

Paste the contents of the Clipboard in the upper-left corner of the selected section

CTRL+V

Move the selected control to the right by a pixel along the page's grid

RIGHT ARROW

Move the selected control to the left by a pixel along the page's grid

LEFT ARROW

Move the selected control up by a pixel along the page's grid

Note   For controls in a stacked layout, this switches the position of the selected control with the control directly above it, unless it is already the uppermost control in the layout.

UP ARROW

Move the selected control down by a pixel along the page's grid

Note   For controls in a stacked layout, this switches the position of the selected control with the control directly below it, unless it is already the lowermost control in the layout.

DOWN ARROW

Move the selected control to the right by a pixel (irrespective of the page's grid)

CTRL+RIGHT ARROW

Move the selected control to the left by a pixel (irrespective of the page's grid)

CTRL+LEFT ARROW

Move the selected control up by a pixel (irrespective of the page's grid)

Note   For controls in a stacked layout, this switches the position of the selected control with the control directly above it, unless it is already the uppermost control in the layout.

CTRL+UP ARROW

Move the selected control down by a pixel (irrespective of the page's grid)

Note   For controls in a stacked layout, this switches the position of the selected control with the control directly below it, unless it is already the lowermost control in the layout.

CTRL+DOWN ARROW

Increase the width of the selected control (to the right) by a pixel

Note   For controls in a stacked layout, this increases the width of the whole layout.

SHIFT+RIGHT ARROW

Decrease the width of the selected control (to the left) by a pixel

Note   For controls in a stacked layout, this decreases the width of the whole layout.

SHIFT+LEFT ARROW

Decrease the height of the selected control (from the bottom) by a pixel

SHIFT+UP ARROW

Increase the height of the selected control (from the bottom) by a pixel

SHIFT+DOWN ARROW

Navigate in Datasheet view

Going to a specific record

To do this

Press

Move to the record number box; then type the record number and press ENTER

F5

Navigating between fields and records

To do this

Press

Move to the next field

TAB or RIGHT ARROW

Move to the last field in the current record, in Navigation mode

END

Move to the previous field

SHIFT+TAB, or LEFT ARROW

Move to the first field in the current record, in Navigation mode

HOME

Move to the current field in the next record

DOWN ARROW

Move to the current field in the last record, in Navigation mode

CTRL+DOWN ARROW

Move to the last field in the last record, in Navigation mode

CTRL+END

Move to the current field in the previous record

UP ARROW

Move to the current field in the first record, in Navigation mode

CTRL+UP ARROW

Move to the first field in the first record, in Navigation mode

CTRL+HOME

Navigating to another screen of data

To do this

Press

Move down one screen

PAGE DOWN

Move up one screen

PAGE UP

Move right one screen

CTRL+PAGE DOWN

Move left one screen

CTRL+PAGE UP

Navigate in subdatasheets

Going to a specific record

To do this

Press

Move from the subdatasheet to move to the record number box; then type the record number and press ENTER

ALT+F5

Expanding and collapsing subdatasheet

To do this

Press

Move from the datasheet to expand the record's subdatasheet

CTRL+SHIFT+DOWN ARROW

Collapse the subdatasheet

CTRL+SHIFT+UP ARROW

Navigating between the datasheet and subdatasheet

To do this

Press

Enter the subdatasheet from the last field of the previous record in the datasheet

TAB

Enter the subdatasheet from the first field of the following record in the datasheet

SHIFT+TAB

Exit the subdatasheet and move to the first field of the next record in the datasheet

CTRL+TAB

Exit the subdatasheet and move to the last field of the previous record in the datasheet

CTRL+SHIFT+TAB

From the last field in the subdatasheet to enter the next field in the datasheet

TAB

From the datasheet to bypass the subdatasheet and move to the next record in the datasheet

DOWN ARROW

From the datasheet to bypass the subdatasheet and move to the previous record in the datasheet

UP ARROW

Note   You can navigate between fields and records in a subdatasheet with the same shortcut keys used in Datasheet view.

Navigate in Form view

Going to a specific record

To do this

Press

Move to the record number box; then type the record number and press ENTER

F5

Navigating between fields and records

To do this

Press

Move to the next field

TAB

Move to the previous field

SHIFT+TAB

Move to the last control on the form and remain in the current record, in Navigation mode

END

Move to the last control on the form and set focus in the last record, in Navigation mode

CTRL+END

Move to the first control on the form and remain in the current record, in Navigation mode

HOME

Move to the first control on the form and set focus in the first record, in Navigation mode

CTRL+HOME

Move to the current field in the next record

CTRL+PAGE DOWN

Move to the current field in the previous record

CTRL+PAGE UP

Navigating in forms with more than one page

To do this

Press

Move down one page; at the end of the record, moves to the equivalent page on the next record

PAGE DOWN

Move up one page; at the end of the record, moves to the equivalent page on the previous record

PAGE UP

Navigating between the main form and subform

To do this

Press

Enter the subform from the preceding field in the main form

TAB

Enter the subform from the following field in the main form

SHIFT+TAB

Exit the subform and move to the next field in the master form or next record

CTRL+TAB

Exit the subform and move to the previous field in the main form or previous record

CTRL+SHIFT+TAB

Navigate in Print Preview and Layout Preview

Dialog box and window operations

To do this

Press

Open the Print dialog box

P (for forms and reports) or CTRL+P (for datasheets, forms, and reports)

Open the Page Setup dialog box (forms and reports only)

S

Zoom in or out on a part of the page

Z

Cancel Print Preview or Layout Preview

C or ESC

Viewing different pages

To do this

Press

Move to the page number box; then type the page number and press ENTER

ALT+F5

View the next page (when Fit To Window is selected)

PAGE DOWN or DOWN ARROW

View the previous page (when Fit To Window is selected)

PAGE UP or UP ARROW

Navigating in Print and Layout Preview

To do this

Press

Scroll down in small increments

DOWN ARROW

Scroll down one full screen

PAGE DOWN

Move to the bottom of the page

CTRL+DOWN ARROW

Scroll up in small increments

UP ARROW

Scroll up one full screen

PAGE UP

Move to the top of the page

CTRL+UP ARROW

Scroll to the right in small increments

RIGHT ARROW

Move to the right edge of the page

END

Move to the lower-right corner of the page

CTRL+END

Scroll to the left in small increments

LEFT ARROW

Move to the left edge of the page

HOME

Move to the upper-left corner of the page

CTRL+HOME

Navigate in the Database Diagram window in an Access project

To do this

Press

Move from a table cell to the table's title bar

ESC

Move from a table's title bar to the last cell you edited

ENTER

Move from table title bar to table title bar, or
from cell to cell inside a table

TAB

Expand a list inside a table

ALT + DOWN ARROW

Scroll through the items in a drop-down list from top to bottom

DOWN ARROW

Move to the previous item in a list

UP ARROW

Select an item in a list and move to the next cell

ENTER

Change the setting in a check box

SPACEBAR

Go to the first cell in the row, or
to the beginning of the current cell

HOME

Go to the last cell in the row, or
to the end of the current cell

END

Scroll to the next "page" inside a table, or
to the next "page" of the diagram

PAGE DOWN

Scroll to the previous "page" inside a table, or
to the previous "page" of the diagram

PAGE UP

Navigate in the Query Designer in an Access project

Any Pane

To do this

Press

Move among the Query Designer panes

F6, SHIFT+F6

Diagram Pane

To do this

Press

Move among tables, views, and functions, (and to join lines, if available)

TAB, or SHIFT+TAB

Move between columns in a table, view, or function

Arrow keys

Choose the selected data column for output

SPACEBAR or PLUS key

Remove the selected data column from the query output

SPACEBAR or MINUS key

Remove the selected table, view, or function, or join line from the query

DELETE

Note   If multiple items are selected, pressing SPACEBAR affects all selected items. Select multiple items by holding down the SHIFT key while clicking them. Toggle the selected state of a single item by holding down CTRL while clicking it.

Grid Pane

To do this

Press

Move among cells

Arrow keys or TAB or SHIFT+TAB

Move to the last row in the current column

CTRL+DOWN ARROW

Move to the first row in the current column

CTRL+UP ARROW

Move to the top left cell in the visible portion of grid

CTRL+HOME

Move to the bottom right cell

CTRL+END

Move in a drop-down list

UP ARROW or DOWN ARROW

Select an entire grid column

CTRL+SPACEBAR

Toggle between edit mode and cell selection mode

F2

Copy selected text in cell to the Clipboard (in edit mode)

CTRL+C

Cut selected text in cell and place it on the Clipboard (in edit mode)

CTRL+X

Paste text from the Clipboard (in edit mode)

CTRL+V

Toggle between insert and overstrike mode while editing in a cell

INS

Toggle the check box in the Output columnNote    If multiple items are selected, pressing this key affects all selected items.

SPACEBAR

Clear the selected contents of a cell

DELETE

Remove row containing selected data column from the query Note    If multiple items are selected, pressing this key affects all selected items.

DELETE

Clear all values for a selected grid column

DELETE

Insert row between existing rows

INS ( after you select grid row)

Add an Or … column

INS ( after you select any Or ... column)

SQL Pane

You can use the standard Windows editing keys when working in the SQL pane, such as CTRL+ arrow keys to move between words, and the Cut, Copy, and Paste commands on the Edit menu.

Note    You can only insert text; there is no overstrike mode.

Work with PivotTable views

PivotTable view

Keys for selecting elements in PivotTable view

To do this

Press

Move the selection from left to right, and then down

The TAB key

Move the selection from top to bottom, and then to the right

ENTER

Select the cell to the left. If the current cell is the leftmost cell, SHIFT+TAB selects the last cell in the previous row.

SHIFT+TAB

Select the cell above the current cell. If the current cell is the topmost cell, SHIFT+ENTER selects the last cell in the previous column.

SHIFT+ENTER

Select the detail cells for the next item in the row area

CTRL+ENTER

Select the detail cells for the previous item in the row area

SHIFT+CTRL+ENTER

Move the selection in the direction of the arrow key. If a row or column field is selected, press DOWN ARROW to move to the first item of data in the field, and then press an arrow key to move to the next or previous item or back to the field. If a detail field is selected, press DOWN ARROW or RIGHT ARROW to move to the first cell in the detail area.

Arrow keys

Extend or reduce the selection in the direction of the arrow key

SHIFT+arrow keys

Move the selection to the last cell in the direction of the arrow key

CTRL+arrow keys

Move the selected item in the direction of the arrow key

SHIFT+ALT+arrow keys

Select the leftmost cell of the current row

HOME

Select the rightmost cell of the current row

END

Select the leftmost cell of the first row

CTRL+HOME

Select the last cell of the last row

CTRL+END

Extend selection to the leftmost cell of the first row

SHIFT+CTRL+HOME

Extend selection to the last cell of the last row

SHIFT+CTRL+END

Select the field for the currently selected item of data, total, or detail

CTRL+SPACEBAR

Select the entire row containing the currently selected cell

SHIFT+SPACEBAR

Select the entire PivotTable view

CTRL+A

Display the next screen

PAGE DOWN

Display the previous screen

PAGE UP

Extend the selection down one screen

SHIFT+PAGE DOWN

Reduce the selection by one screen

SHIFT+PAGE UP

Display the next screen to the right

ALT+PAGE DOWN

Display the previous screen to the left

ALT+PAGE UP

Extend the selection to the page on the right

SHIFT+ALT+PAGE DOWN

Extend the selection to the page on the left

SHIFT+ALT+PAGE UP

Keys for carrying out commands

To do this

Press

Display Help topics

F1

Display the shortcut menu for the selected element of the PivotTable view. Use the shortcut menus to carry out commands in the PivotTable view.

SHIFT+F10

Carry out a command on the shortcut menu

Underlined letter

Close the shortcut menu without carrying out a command

ESC

Display the Properties dialog box

ALT+ENTER

Cancel a refresh operation in progress

ESC

Copy the selected data from the PivotTable view to the Clipboard

CTRL+C

Export the contents of the PivotTable view to Microsoft Office Excel 2007Office Excel 2007

CTRL+E

Keys for displaying, hiding, filtering, or sorting data

To do this

Press

Show or hide the expand indicators (Plus box and Minus box boxes) beside items

CTRL+8

Expand the currently selected item

CTRL+PLUS SIGN (on the numeric keypad)

Hide the currently selected item

CTRL+MINUS SIGN (on the numeric keypad)

Open the list for the currently selected field

ALT+DOWN ARROW

Alternately move to the most recently selected item, the OK button, and the Cancel button in the drop-down list for a field

The TAB key

Move to the next item in the drop-down list for a field

Arrow keys

Select or clear the check box for the current item in the drop-down list for a field

SPACEBAR

Close the drop-down list for a field and apply any changes you made

ENTER

Close the drop-down list for a field without applying your changes

ESC

Turn AutoFilter on or off

CTRL+T

Sort data in the selected field or total in ascending order (A – Z 0 – 9)

CTRL+SHIFT+A

Sort data in the selected field or total in descending order (Z – A 9 – 0)

CTRL+SHIFT+Z

Move the selected member up or left

ALT+SHIFT+UP ARROW or ALT+SHIFT+LEFT ARROW

Move the selected member down or right

ALT+SHIFT+DOWN ARROW or ALT+SHIFT+RIGHT ARROW

Keys for adding fields and totals and changing the layout of a PivotTable view

Keys for working with the Field List pane

To do this

Press

Display the Field List pane, or activate it if it is already displayed

CTRL+L

Move to the next item in the Field List pane

Arrow keys

Move to the previous item and include it in the selection

SHIFT+UP ARROW

Move to the next item and include it in the selection

SHIFT+DOWN ARROW

Move to the previous item, but don't include the item in the selection

CTRL+UP ARROW

Move to the next item, but don't include the item in the selection

CTRL+DOWN ARROW

Remove the item from the selection, if the item that has focus is included in the selection, and vice versa

CTRL+SPACEBAR

Expand the current item in the Field List pane to display its contents. Or expand Totals to display the available total fields.

PLUS SIGN (numeric keypad)

Collapse the current item in the Field List pane to hide its contents. Or collapse Totals to hide the available total fields.

MINUS SIGN (numeric keypad)

Alternately move to the most recently selected item, the Add to button, and the list next to the Add to button in the Field List pane

The TAB key

Open the drop-down list next to the Add to button in the Field List pane. Use the arrow keys to move to the next item in the list, and then press ENTER to select an item.

ALT+DOWN ARROW

Add the highlighted field in the Field List pane to the area in the PivotTable view that is displayed in the Add to list

ENTER

Keys for adding fields and totals

To do this

Press

Add a new total field for the selected field in the PivotTable view by using the Sum summary function

CTRL+SHIFT+S

Add a new total field for the selected field in the PivotTable view by using the Count summary function

CTRL+SHIFT+C

Add a new total field for the selected field in the PivotTable view by using the Min summary function

CTRL+SHIFT+M

Add a new total field for the selected field in the PivotTable view by using the Max summary function

CTRL+SHIFT+X

Add a new total field for the selected field in the PivotTable view by using the Average summary function

CTRL+SHIFT+E

Add a new total field for the selected field in the PivotTable view by using the Standard Deviation summary function

CTRL+SHIFT+D

Add a new total field for the selected field in the PivotTable view by using the Standard Deviation Population summary function

CTRL+SHIFT+T

Add a new total field for the selected field in the PivotTable view by using the Variance summary function

CTRL+SHIFT+V

Add a new total field for the selected field in the PivotTable view by using the Variance Population summary function

CTRL+SHIFT+R

Turn subtotals and grand totals on or off for the selected field in the PivotTable view

CTRL+SHIFT+B

Add a calculated detail field

CTRL+F

Keys for changing the layout

Note   The following four shortcuts do not work if you press the keys 1, 2, 3, or 4 from the numeric pad of your keyboard.

To do this

Press

Move the selected field in the PivotTable view to the row area

CTRL+1

Move the selected field in the PivotTable view to the column area

CTRL+2

Move the selected field in the PivotTable view to the filter area

CTRL+3

Move the selected field in the PivotTable view to the detail area

CTRL+4

Move the selected row or column field in the PivotTable view to a higher level

CTRL+LEFT ARROW

Move the selected row or column field in the PivotTable view to a lower level

CTRL+RIGHT ARROW

Keys for formatting elements in PivotTable view

To use the following shortcuts, first select a detail field or a data cell for a total field.

The first seven keyboard shortcuts change the number format of the selected field.

To do this

Press

Apply the general number format to values in the selected total or detail field

CTRL+SHIFT+~ (tilde)

Apply the currency format, with two decimal places and negative numbers in parentheses, to values in the selected total or detail field

CTRL+SHIFT+$

Apply the percentage format, with no decimal places, to values in the selected total or detail field

CTRL+SHIFT+%

Apply the exponential number format, with two decimal places, to values in the selected total or detail field

CTRL+SHIFT+^

Apply the date format, with the day, month, and year, to values in the selected total or detail field

CTRL+SHIFT+#

Apply the time format, with the hour, minute, and AM or PM, to values in the selected total or detail field

CTRL+SHIFT+@

Apply the numeric format, with two decimal places, thousands separator, and a minus sign for negative values, to values in the selected total or detail field

CTRL+SHIFT+!

Make text bold in the selected field of the PivotTable view

CTRL+B

Make text underlined in the selected field of the PivotTable view

CTRL+U

Make text italic in the selected field of the PivotTable view

CTRL+I

PivotChart view

Keys for selecting items in a chart

To do this

Press

Select the next item in the chart

RIGHT ARROW

Select the previous item in the chart

LEFT ARROW

Select the next group of items

DOWN ARROW

Select the previous group of items

UP ARROW

Keys for working with properties and options

To do this

Press

Display the Properties dialog box

ALT+ENTER

When the Properties dialog box is active, select the next item on the active tab

The TAB key

When a tab in the Properties dialog box is active, select the next tab

RIGHT ARROW

When a tab in the Properties dialog box is active, select the previous tab

LEFT ARROW

Display a list or palette when a button that contains a list or palette is selected

DOWN ARROW

Display the shortcut menu

SHIFT+F10

Carry out a command on the shortcut menu

Underlined letter

Close the shortcut menu without carrying out a command

ESC

Keys for working with fields

To do this

Press

Open the list for the currently selected field

ALT+DOWN ARROW

In the drop-down list for a field, alternately move to the most recently selected item, the OK button, and the Cancel button

The TAB key

In the drop-down list for a field, move to the next item

Arrow keys

In the drop-down list for a field, select or clear the check box for the current item

SPACEBAR

Close the drop-down list for a field and apply any changes you made

ENTER

Close the drop-down list for a field without applying your changes

ESC

Keys for working with the Field List pane

To do this

Press

Display the Field List pane, or activate it if it is already displayed

CTRL+L

Move to the next item in the Field List pane

Arrow keys

Move to the previous item and include it in the selection

SHIFT+UP ARROW

Move to the next item and include it in the selection

SHIFT+DOWN ARROW

Move to the previous item, but don't include the item in the selection

CTRL+UP ARROW

Move to the next item, but don't include the item in the selection

CTRL+DOWN ARROW

Remove the item from the selection if the item that has focus is included in the selection, and vice versa

CTRL+SPACEBAR

Expand the current item in the Field List pane to display its contents, or expand Totals to display the available total fields

PLUS SIGN (numeric keypad)

Collapse the current item in the Field List pane to hide its contents, or collapse Totals to hide the available total fields.

MINUS SIGN (numeric keypad)

In the Field List pane, alternately move to the most recently selected item, the Add to button, and the list next to the Add to button

The TAB key

Open the drop-down list next to the Add to button in the Field List pane. Use the arrow keys to move to the next item in the list, and then press ENTER to select an item.

ALT+DOWN ARROW

Add the highlighted field in the Field List pane to the drop area that is displayed in the Add to list

ENTER

Microsoft Office Fluent Ribbon

Office Fluent Ribbon

  1. Press ALT.

    The KeyTips are displayed over each feature that is available in the current view. The following example is from Office Word 2007.

  2. Press the letter shown in the KeyTip over the feature that you want to use.

  3. Depending on which letter you press, you might be shown additional KeyTips. For example, if the Home tab is active and you press I, the Insert tab is displayed, along with the KeyTips for the groups on that tab.

  4. Continue pressing letters until you press the letter of the command or control that you want to use. In some cases, you must first press the letter of the group that contains the command.

    Note   To cancel the action that you are taking and hide the KeyTips, press ALT.

Online Help

Keyboard shortcuts for using the Help window

The Help window provides access to all Office Help content. The Help window displays topics and other Help content.

In the Help window

To do this

Press

Open the Help window.

F1

Switch between the Help window and the active program.

ALT+TAB

Go back to Program Name Home.

ALT+HOME

Select the next item in the Help window.

TAB

Select the previous item in the Help window.

SHIFT+TAB

Perform the action for the selected item.

ENTER

In the Browse Program Name Help section of the Help window, select the next or previous item, respectively.

TAB or SHIFT+TAB

In the Browse Program Name Help section of the Help window, expand or collapse the selected item, respectively.

ENTER

Select the next hidden text or hyperlink, including Show All or Hide All at the top of a topic.

TAB

Select the previous hidden text or hyperlink.

SHIFT+TAB

Perform the action for the selected Show All, Hide All, hidden text, or hyperlink.

ENTER

Move back to the previous Help topic (Back button).

ALT+LEFT ARROW or BACKSPACE

Move forward to the next Help topic (Forward button).

ALT+RIGHT ARROW

Scroll small amounts up or down, respectively, within the currently displayed Help topic.

UP ARROW, DOWN ARROW

Scroll larger amounts up or down, respectively, within the currently displayed Help topic.

PAGE UP, PAGE DOWN

Display a menu of commands for the Help window. This requires that the Help window have the active focus (click in the Help window).

SHIFT+F10

Stop the last action (Stop button).

ESC

Refresh the window (Refresh button).

F5

Print the current Help topic.

Note   If the cursor is not in the current Help topic, press F6 and then press CTRL+P.

CTRL+P

Change the connection state.

F6, and then press ENTER to open the list of choices

Switch among areas in the Help window; for example, switch between the toolbar and the Search list.

F6

In a Table of Contents in tree view, select the next or previous item, respectively.

UP ARROW, DOWN ARROW

In a Table of Contents in tree view, expand or collapse the selected item, respectively.

LEFT ARROW, RIGHT ARROW

Microsoft Office basics

Display and use windows

To do this

Press

Switch to the next window.

ALT+TAB

Switch to the previous window.

ALT+SHIFT+TAB

Close the active window.

CTRL+W or CTRL+F4

Move to a task pane from another pane in the program window (clockwise direction). You might need to press F6 more than once.

Note   If pressing F6 doesn't display the task pane you want, try pressing ALT to place focus on the menu bar or Microsoft Office Fluent Ribbon and then pressing CTRL+TAB to move to the task pane.

F6

When more than one window is open, switch to the next window.

CTRL+F6

Switch to the previous window.

CTRL+SHIFT+F6

When a document window is not maximized, perform the Size command (on the Control menu for the window). Press the arrow keys to resize the window, and, when finished, press ENTER.

CTRL+F8

Minimize a window to an icon (works for only some Microsoft Office programs).

CTRL+F9

Maximize or restore a selected window.

CTRL+F10

Copy a picture of the screen to the Clipboard.

PRINT SCREEN

Copy a picture of the selected window to the Clipboard.

ALT+PRINT SCREEN

Move around in text or cells

To do this

Press

Move one character to the left.

LEFT ARROW

Move one character to the right.

RIGHT ARROW

Move one line up.

UP ARROW

Move one line down.

DOWN ARROW

Move one word to the left.

CTRL+LEFT ARROW

Move one word to the right.

CTRL+RIGHT ARROW

Move to the end of a line.

END

Move to the beginning of a line.

HOME

Move up one paragraph.

CTRL+UP ARROW

Move down one paragraph.

CTRL+DOWN ARROW

Move to the end of a text box.

CTRL+END

Move to the beginning of a text box.

CTRL+HOME

In Microsoft Office PowerPoint 2007, move to the next title or body text placeholder. If it is the last placeholder on a slide, this will insert a new slide with the same slide layout as the original slide.

CTRL+ENTER

Repeat the last Find action.

SHIFT+F4

Move around in and work in tables

To do this

Press

Move to the next cell.

TAB

Move to the preceding cell.

SHIFT+TAB

Move to the next row.

DOWN ARROW

Move to the preceding row.

UP ARROW

Insert a tab in a cell.

CTRL+TAB

Start a new paragraph.

ENTER

Add a new row at the bottom of the table.

TAB at the end of the last row

Access and use task panes

To do this

Press

Move to a task pane from another pane in the program window. (You might need to press F6 more than once.)

Note   If pressing F6 doesn't display the task pane you want, try pressing ALT to place focus on the menu bar and then pressing CTRL+TAB to move to the task pane.

F6

When a menu or toolbar is active, move to a task pane. (You might need to press CTRL+TAB more than once.)

CTRL+TAB

When a task pane is active, select the next or previous option in the task pane.

TAB or SHIFT+TAB

Display the full set of commands on the task pane menu.

CTRL+DOWN ARROW

Move among choices on a selected submenu; move among certain options in a group of options in a dialog box.

DOWN ARROW or UP ARROW

Open the selected menu, or perform the action assigned to the selected button.

SPACEBAR or ENTER

Open a shortcut menu; open a drop-down menu for the selected gallery item.

SHIFT+F10

When a menu or submenu is visible, select the first or last command on the menu or submenu.

HOME or END

Scroll up or down in the selected gallery list.

PAGE UP or PAGE DOWN

Move to the top or bottom of the selected gallery list.

CTRL+HOME or CTRL+END

Access and use smart tags

To do this

Press

Display the menu or message for a smart tag. If more than one smart tag is present, switch to the next smart tag and display its menu or message.

ALT+SHIFT+F10

Select the next item on a smart tag menu.

DOWN ARROW

Select the previous item on a smart tag menu.

UP ARROW

Perform the action for the selected item on a smart tag menu.

ENTER

Close the smart tag menu or message.

ESC

Tips

  • You can ask to be notified by a sound whenever a smart tag appears. To hear audio cues, you must have a sound card. You must also have Microsoft Office Sounds installed on your computer.

  • If you have access to the World Wide Web, you can download Microsoft Office Sounds from the Microsoft Office Online Web site. After you install the sound files, do the following in Access, Office Excel 2007, and Office Word 2007:

    1. Click the Microsoft Office Button Office button image, and then click Program Options.

    2. Click Advanced.

    3. Under General, select the Provide feedback with sound check box, and then click OK.

      Note   When you select or clear this check box, the setting affects all Office programs that support sound.

Resize and move toolbars, menus, and task panes

  1. Press ALT to select the menu bar.

  2. Press CTRL+TAB repeatedly to select the toolbar or task pane that you want.

  3. Do one of the following:

    Resize a toolbar

    1. On the toolbar, press CTRL+SPACEBAR to display the Toolbar Options menu.

    2. Click the Size command, and then press ENTER.

    3. Use the arrow keys to resize the toolbar. Press CTRL+ the arrow keys to resize one pixel at a time.

    Move a toolbar

    1. On the toolbar, press CTRL+SPACEBAR to display the Toolbar Options menu.

    2. Click the Move command, and then press ENTER.

    3. Use the arrow keys to position the toolbar. Press CTRL+ the arrow keys to move one pixel at a time. To undock the toolbar, press the DOWN ARROW repeatedly. To dock the toolbar vertically on the left or right side, press the LEFT ARROW or the RIGHT ARROW, respectively, when the toolbar is positioned all the way to the left or the right side.

    Resize a task pane

    1. In the task pane, press CTRL+SPACEBAR to display a menu of additional commands.

    2. Use the DOWN ARROW key to select the Size command, and then press ENTER.

    3. Use the arrow keys to resize the task pane. Use CTRL+ the arrow keys to resize one pixel at a time.

    Move a task pane

    1. In the task pane, press CTRL+SPACEBAR to display a menu of additional commands.

    2. Use the DOWN ARROW key to select the Move command, and then press ENTER.

    3. Use the arrow keys to position the task pane. Use CTRL+ the arrow keys to move one pixel at a time.

  4. When you finish moving or resizing, press ESC.

Use dialog boxes

To do this

Press

Move to the next option or option group.

TAB

Move to the previous option or option group.

SHIFT+TAB

Switch to the next tab in a dialog box.

CTRL+TAB

Switch to the previous tab in a dialog box.

CTRL+SHIFT+TAB

Move between options in an open drop-down list, or between options in a group of options.

Arrow keys

Perform the action assigned to the selected button; select or clear the selected check box.

SPACEBAR

Open the list if it is closed and move to that option in the list.

First letter of an option in a drop-down list

Select an option; select or clear a check box.

ALT+ the letter underlined in an option

Open a selected drop-down list.

ALT+DOWN ARROW

Close a selected drop-down list; cancel a command and close a dialog box.

ESC

Perform the action assigned to a default button in a dialog box.

ENTER

Use edit boxes within dialog boxes

An edit box is a blank in which you type or paste an entry, such as your user name or the path to a folder.

To do this

Press

Move to the beginning of the entry.

HOME

Move to the end of the entry.

END

Move one character to the left or right.

LEFT ARROW or RIGHT ARROW

Move one word to the left.

CTRL+LEFT ARROW

Move one word to the right.

CTRL+RIGHT ARROW

Select or cancel selection one character to the left.

SHIFT+LEFT ARROW

Select or cancel selection one character to the right.

SHIFT+RIGHT ARROW

Select or cancel selection one word to the left.

CTRL+SHIFT+LEFT ARROW

Select or cancel selection one word to the right.

CTRL+SHIFT+RIGHT ARROW

Select from the insertion point to the beginning of the entry.

SHIFT+HOME

Select from the insertion point to the end of the entry.

SHIFT+END

Use the Open and Save As dialog boxes

To do this

Press

Go to the previous folder. Button image

ALT+1

Up One Level Button image button: open the folder up one level above the open folder.

ALT+2

Search the Web Button image button: close the dialog box and open your Web search page

ALT+3

Delete Button image button: delete the selected folder or file.

ALT+3

Create New Folder Button image button: create a new folder.

ALT+4

Views Button image button: switch among available folder views.

ALT+5

Tools button: show the Tools menu.

ALT+L

Display a shortcut menu for a selected item such as a folder or file.

SHIFT+F10

Move between options or areas in the dialog box.

TAB

Open the Look in list.

F4 or ALT+I

Refresh the file list.

F5

Applies To: Access 2007



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language