Import text from another file into a publication

In Microsoft Office Publisher 2007, you have different options for importing text into a publication. The option that you choose depends on how much text you want to import and what you want to do with the text after it is imported.

To

Do this

Import a selected text or a chart from a document created in another program

Copy and paste the selected text or chart.

Convert a Microsoft Office Word document into a Publisher publication

Import a Word document.

Import all of the text from a file that was created in another program

Insert the file.

Create a batch of address labels, postcards, or similar publications

Use mail merge to import names, addresses, or other information that is stored in a data file.

Import table text from a Microsoft Windows–based program

Copy and paste the table text.

What do you want to do?

Copy and paste the selected text or chart

Import a Word document

Insert a file

Use mail merge to import information

Copy and paste the table text

Copy and paste the selected text or chart

  1. Open the file that contains the text or chart that you want to add.

  2. Select the text.

  3. Right-click the selected text or chart, and then click Copy.

  4. Open the Office Publisher 2007 publication in which you want to insert the text or chart.

  5. On the Edit menu, click Paste.

    A new text box that contains the text that you pasted appears in the publication.

Tip    You can also paste the text that you copied into an existing text box. In the text box, click where you want to paste the text before you click Paste.

Note   

  • By default, the text that you paste will be formatted according to the font scheme of the publication. If the Paste Options button appears below the text that you pasted into the publication, the text uses a different font style. If you want the text to keep its original formatting, click the Paste Options button and then click Keep Source Formatting.

    Keep Source Formatting option

  • If the pasted text doesn't fit in the text box, Publisher asks whether you want to use autoflow for the remaining text. If you click Yes, Publisher finds an empty text box or creates a new text box to hold the extra text, and then Publisher automatically connects the text boxes. If you click No, Publisher pastes the text, but some of it is hidden. Drag an Adjust handle on the text box to make it larger so that you can see all the text that you pasted.

  • If you copy a chart into a Publisher file, it will be copied as a bitmap and you will not be able to edit it in Publisher.

Top of Page

Import a Word document

You have a Word document, but you need to add graphics — and you want to take advantage of the superior graphics-handling capabilities of Publisher. Or you want to convert a report that you typed in Word into a publication so that it can be branded the same way as all your other business publications.

Fortunately, converting Word documents that were created in Microsoft Office Word into Publisher publications is easy. All you have to do is choose the publication design that you want and then locate the Word document that you want to convert.

  1. Start Publisher.

  2. In the Publication Types list, click Import Word Documents.

  3. Click the design that you want, and then click Create.

  4. In the Import Word Document dialog box, locate and click the file that you want to import, and then click OK.

  5. Review the publication to make sure that everything looks the way that you want, and then save the publication.

Find links to more information about how to import Word documents in the See Also section.

Top of Page

Insert a file

  1. In your publication, create a text box if you have not already done so.

    How?

    1. On the Objects toolbar, click Text Box Button image.

    2. In the publication, point to where you want one corner of the text to appear, and then drag diagonally until the box is the size that you want.

  2. In the text box, click where you want to paste the text.

  3. On the Insert menu, click Text File.

  4. Locate and click the file that you want to import.

  5. Click OK.

    Note   If the inserted text doesn't fit in the text box, Publisher asks whether you want to use autoflow for the remaining text. If you click Yes, Publisher finds an empty text box or create a new text box to hold the extra text, and then Publisher automatically connects the text boxes. If you click No, Publisher pastes the text, but some of it is hidden. Drag an Adjust handle on the text box to make it larger so that you can see all the text that you pasted.

Top of Page

Use mail merge to import information

If you have customer addresses or other information stored in a data file, such as a Microsoft Office Excel worksheet or your Microsoft Office Outlook Contacts file, you can use mail merge to create a set of individually addressed mailing labels, postcards, or other publications.

Using mail merge, you can specify which rows (records) from the data file and which text from each row that you want to merge into a publication.

To start a mail merge, point to Mailings and Catalogs on the Tools menu, and then click Mail Merge. The task pane will guide you through the three-step process. Find links to more information about mail merge in the See Also section.

Top of Page

Copy and paste the table text

  1. Open the Microsoft Windows–based program that contains the text that you want.

    If the text isn't already in a table, press TAB between each entry in a row, and press ENTER at the end of each row.

  2. Select the text that you want.

  3. Right-click the selected text, and then click Copy.

    Note   If your text is already in a table, click where you want to insert the table in your Publisher file, and then right-click Paste.

  4. In Publisher, click Insert Table Button image on the Objects toolbar.

  5. In your publication, click where you want the table to appear.

    The Create Table dialog box will appear.

  6. Select the options that you want, and then click OK.

  7. Click inside the table where you want the upper-left cell of the copied text to appear.

  8. On the Edit menu, click Paste Special.

  9. In the As list, click Table Cells Without Cell Formatting, and then click OK.

Top of Page

Applies To: Publisher 2007



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language