Import or insert AutoCAD drawings, pictures, and clip art

There are two ways to work with graphics files in Visio: you can import them to start a new Visio drawing, or you can insert them into an existing Visio drawing.

What do you want to do?

Import a graphics file to start a new Visio drawing

Insert a graphics file into an existing Visio drawing

Import a graphics file to start a new Visio drawing

You can import graphics files of different formats to start a new Visio drawing by using the Open command on the File menu.

The following graphics file formats are supported:

  • AutoCAD Drawing File Format (.dwg, .dxf)

  • Compressed Enhanced Metafile (.emz)

  • Enhanced Metafile (.emf)

  • Graphics Interchange Format (.gif)

  • JPEG File Interchange Format (.jpg)

  • Portable Network Graphics (.png)

  • Scalable Vector Graphics Drawing (.svg, .svgz)

  • Tag Image File Format (.tif, .tiff)

  • Windows Bitmap (.bmp, .dib)

  • Windows Metafile (.wmf)

Note   File formats may vary slightly between language versions. You may not get exactly the same results if you import files created in different language versions.

  1. On the File menu, click Open.

  2. In the Files of type box, click the file format of the file you want to import.

If you don't see the file format listed, Visio doesn't have a file filter for that format. Try saving the document in a format Visio can open.

Top of Page

Insert a graphics file into an existing Visio drawing

You can insert AutoCAD drawings, pictures, and clip art into an existing Visio drawing by using commands on the Insert menu.

Insert an AutoCAD drawing

  1. On the Insert menu, click CAD Drawing.

  2. Locate the CAD file and click Open.

  3. To accept the default CAD drawing settings, click OK.

    Note   The default CAD drawing settings are designed to ensure optimal results when you insert a CAD drawing. It is best to avoid adjusting the default settings unless you have a specific aim in mind.

When you insert a drawing in AutoCAD DWG or DXF format, you insert the last saved spatial view of the CAD drawing. A CAD drawing may have been saved in model space or paper space.

  • Model space     is the primary drawing workspace in which CAD drafters create drawings.

  • Paper space     is a workspace that is analogous to a sheet of paper, in which CAD drafters can arrange different views of the drawing.

A CAD drawing saved in paper space that shows two views of the same floor plan

A DWG drawing saved in paper space. The drawing contains two rectangualr viewports. A viewport is a window into the three-dimensional CAD drawing. Each viewport can be set to a different scale or angle.

Insert a picture from a graphics file

  1. On the Insert menu, point to Picture, and then click From File.

  2. Locate the folder that contains the picture you want to insert, click the picture file, and then click Open.

    Tip    You can also open graphics files from the File menu. On the File menu, click Open. In the Files of type list, click the graphics file format you want, and then locate the file. Click Open. Most files that you import into Visio drawings as graphic images appear as metafiles. However, bitmap files, such as .dib, .bmp, .pcx, and so on, remain bitmaps in the Visio drawing.

Insert clip art

  1. On the Insert menu, point to Picture, and then click Clip Art.

  2. In the Clip Art task pane, in the Search for box, type a word or phrase that describes the clip art you want.

  3. Click Go.

    When you search for clip art and pictures online, you'll be directed to Bing. You're responsible for respecting copyright, and the license filter in Bing can help you choose which images to use.

  4. In the Results list, click the clip art to insert it.

Top of Page

Applies To: Visio 2007, Visio 2007 Standard



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language