Import Access 2.0 and Access 95 databases into current versions

If you use an existing database in the Access 2.0 format (.mdb), or the Access 95 format (.mdb) in some cases you can import tables, queries, and macros from that database into a more current version of Access that uses the .accdb file format.

To import forms and reports that contain VBA code (and also modules), first convert your Access 2.0 or Access 95 database to the Access 2002 - 2003 or Access 2000 file format by using Microsoft Office Access 2003, Access 2002, or Access 2000. You can then use a more current version such as Access 2007 to convert that file to the .accdb file format which can then be opened by Access 2010, Access 2013, or Access 2016

The following sections in this article explain how to perform these tasks.

Are you using Access 2010, Access 2013, or Access 2016?

Access 2007 was the last version to support opening, importing, linking or exporting to Access 2.0 and Access 95. You will need Access 2007 in order to be able to export, import or link data from Access 1.0 and 2.0 (Red 2, or Jet 2) files and Access 95 databases. In this case, you'll have to use Access 2007 as an intermediary step to fully convert an Access 2.0 database to one of these versions.

What do you want to do?

Open an Access 2.0 database in Access 2007

Import data from an Access 2.0 database into Access 2007

Import data from an Access 95 database into Access 2007

Convert an Access 2.0 or Access 95 database by using Access 2003, Access 2002, or Access 2000

Open an Access 2.0 database in Access 2007

When you open an Access 2.0 database in Access 2007, Access displays a number of prompts that, when followed, end with the message This database was saved in the Microsoft Access 2.0 file format.

This database was saved in the Microsoft Access 2.0 file format.

You can import tables, queries, and macros from an Access 2.0 database into an Access 2007 database (.accdb). To import forms, reports, or modules into an Access 2007 database, you first convert the database by using an earlier version of Access, then open the converted database by using Access 2007, and then convert the database into an Access 2007 .accdb file format database. See the section Convert an Access 2.0 or Access 95 database by using Access 2003, Access 2002, or Access 2000 for more information.

Import data from an Access 2.0 database into Access 2007

When you import objects from another database, copies of the objects that you import are created in the destination database. The source is not altered. To import data from an Access 2.0 database into Access 2007, you first open the database that you want to import the data into. You then use commands on the External Data tab to proceed with the import process, which includes invoking the Import Wizard.

  1. Open Access 2007, click the Microsoft Office Button, and then click Open.

  2. In the Open dialog box, select and open the database that you want to import the tables, queries, or macros into.

  3. On the External Data tab, in the Import group, click Access.

  4. In the File name text box of the Get External Data Wizard, type the name of the source database, or click Browse to display the File Open dialog box and then choose or type the name of the source database.

  5. Click Import tables, queries, forms, reports, macros, and modules into the current database, and then click OK.

  6. In the Import Objects dialog box, click each tab and select the objects that you want. Remember that you can only import tables, queries, and macros from an Access 2.0 database into Access 2007.

    Import Objects dialog box

    To cancel a selected object, click the object again.

  7. Click Options to specify additional settings.

    The following table describes how each option impacts the results of the operation.

    Element

    Description

    Relationships check box

    Imports the relationships between the selected tables.

    Menus and Toolbars check box

    Imports any custom menus and toolbars that exist in the source database. The menus and toolbars are displayed on a tab named Add-Ins.

    Import/Export Specs check box

    Imports any saved import or export specifications that exist in the source database.

    Nav Pane Groups check box

    Imports any custom Navigation Pane groups that exist in the source database.

    Definition and Data button

    Imports the structure and data of all selected tables.

    Definition Only button

    Imports only the fields in the selected tables. The source records are not imported.

    As Queries button

    Imports the selected queries as queries. In this case, remember to import all the underlying tables along with the queries.

    As Tables button

    Imports queries as tables. In this case, you need not import the underlying tables.

  8. Click OK to finish the operation.

    Access copies the data and displays error messages if it encounters any problems. If the operation succeeds in importing the data, the final page of the wizard allows you to save the details of the operation as an import specification for future use.

Import data from an Access 95 database into Access 2007

To import data from an Access 95 database into Access 2007, you first open the Access 2007 database that you want to import the data into. You then use commands on the External Data tab, which involves invoking the Import Wizard.

You can import tables, queries, and macros from an Access 95 format (.mdb) database into an Access 2007 database (.accdb). You can also import forms and reports that do not use VBA code. To import forms and reports that contain VBA code (and also modules), first convert your Access 95 database to the Access 2002 - 2003 or Access 2000 file format by using Microsoft Office Access 2003, Access 2002, or 2000, and then use Access 2007 to convert that file to the Access 2007 .accdb file format.

  1. Open Access 2007, click the Microsoft Office Button, and then click Open.

  2. In the Open dialog box, select and open the database that you want to import the tables, queries, or macros into.

  3. On the External Data tab, in the Import group, click Access.

  4. In the File name box of the Get External Data Wizard, type the name of the source database, or click Browse to display the File Open dialog box and then choose or type the name of the source database.

  5. Click Import tables, queries, forms, reports, macros, and modules into the current database and then click OK.

  6. In the Import Objects dialog box, click each tab and select the objects that you want to import.

    To cancel the selection of an object, click the object again.

  7. Click Options to specify additional settings. These additional settings will appear in groups below the list of objects.

  8. Click OK to finish the operation.

    Access copies the data and displays error messages if it encounters any problems. If the operation succeeds in importing the data, the final page of the wizard allows you to save the details of the operation as an import specification for future use.

Convert an Access 2.0 or Access 95 database by using Access 2003, Access 2002, or Access 2000

You can convert an Access 2.0 database to the Access 2000 or Access 2002 - 2003 file format by using one of the versions of Access listed in the following table, provided that you purchased that version of Access and installed it on your computer. Depending on your version of Access, the Access 2.0 converter should already be installed.

Version

Access 2.0 Converter

Microsoft Office Access 2003

This version requires downloading and installing the Access 2.0 Converter for Access 2003. However, this tool is no longer available on Microsoft Download Center because Access 2003 is out of extended support.

Microsoft Access 2002

Included in the product.

Microsoft Access 2000

Included in the product.

You should convert the Access 2.0 or Access 95 file to the Access 2000 or Access 2002 - 2003 .mdb file format. You can then use Access 2007 to convert the resulting file to the Access 2007 .accdb file format. You can then use the database in Access 2007 or open it in Access 2010, Access 2013, or Access 2016. Depending on your older version of Access, take the following steps:

  1. Start Access 2003, Access 2002, or Access 2000.

  2. On the File menu, click Open, and then click the file name for the Access 95 database that you want to convert.

  3. On the Tools menu, click Database Utilities, click Convert Database, and then click To Access 2000 File Format.

  4. In the Convert Database Into dialog box, enter a filename for the new file, and then click Save.

    You might see an informational message warning that you will not be able to use the converted database in earlier versions of Access. If this message appears, click OK.

    The file is saved in the Access 2000 file format.

  5. Start Access 2007.

  6. Click the Microsoft Office Button, and then click Open.

  7. In the Open dialog box, select and open the converted database.

  8. Click the Microsoft Office Button, and then click Convert.

  9. In the Save As dialog box, enter a filename for the Access 2007 file, or accept the file name that is provided, and then click Save.

    The file is saved in the Access 2007 .accdb file format.

Top of Page

Connect with an expert
Contact us
Expand your skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×