If the Open in OneNote command doesn’t work, enable the add-on

If the Open in OneNote or Edit in OneNote command in OneNote Online doesn’t work, it means there’s something wrong with the add-on that this command uses. There are several things you can do to get the add-on working, and we’ll step through them here. First of all, make sure you have Microsoft OneNote 2010 or later installed on your computer because earlier versions of OneNote do not work with this command.

Use another browser

You might need to switch to a supported browser.

The add-on works only in 32-bit Internet Explorer, Chrome, Firefox, or Safari (Mac). If you’re using some other browser—for example, if you’re using 64-bit IE—you won’t be able to use the Open in OneNote or Edit in OneNote command. If you saw a message about the Office Web Apps Browser Plugin, go ahead and download and install the plugin.

Let the add-on run

If you have the right kind of browser and a recent version of OneNote, your security settings might be too strong. Or, the add-on got turned off. Here are instructions for correcting both problems:

Set security in Internet Explorer

  1. Go to Tools > Internet Options, and then on the Security tab click Trusted Sites.

  2. If the security slider is at High, move it down to Medium-High.

Give permission in Chrome

If you see an External Protocol Request message in Chrome, check Remember my choice for all links of this type, and then click Launch Application. The next time you use the Open in OneNote or Edit in OneNote command, it should work with no issues.

Turn the add-on back on

In Internet Explorer:

  1. Go to Tools > Manage Add-ons.

  2. There’s a drop-down labeled Show. Open that, and click All add-ons.

  3. Scroll through the add-ons until you see the ones from Microsoft, and click SharePoint OpenDocuments Class.

  4. Towards the bottom of the dialog box, click Enable, and then close the dialog box.

In Firefox:

  1. Go to the Firefox dropdown, click Add-ons, and then go to Plugins.

  2. Look for the Microsoft Office 2010 plugin. It says (disabled) after its name.

  3. Click Enable.

Run OS X Lion in 32-bit mode

If you use Safari or Firefox and your Mac is running OS X Lion, switch to 32-bit mode:

  1. Close the browser.

  2. Go to the Finder, go to Applications, and select the Safari or Firefox icon.

  3. In the browser, go to File > Get Info, and check Open in 32-bit mode.

  4. Close the browser and open it again.

If you still need help getting notebooks to open on your Mac, visit the OneNote for Mac forum at http://answers.microsoft.com/en-us/office/forum/onenote_mac.

Applies To: OneNote Online, OneNote Web App

Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Change language