I cannot save my replicated database in Access 2007 format


In Microsoft Office Access 2007, replicated databases that were created in earlier versions of Access (.MDB format) cannot be saved in the new .ACCDB file format. The option appears dimmed (unavailable) when you try to use the Save Database As command (click the Microsoft Office Button Office button image, and then click the arrow next to Save As).


The .ACCDB file format does not support replication.


Use the replicated database in the .MDB file format

You can continue to use your replicated database in the .MDB file format. Replication functionality is still supported for the .MDB file format.

Manually re-create the database in Office Access 2007 file format

If you decide that the new file format offers benefits that outweigh the benefits you get from replication, you can create a new database in Office Access 2007 format, and manually re-create the replicated database.

Note   This method will work on any replicated database, but unless you are working with a full replica that has been synchronized with all other replicas in the replica set, any data and projects that are not already in your replica will not be in the new database.

Before you begin re-creating your database, you should make sure that all of the hidden and system objects in the replica are visible. This is to ensure that you can access the replica-specific fields in the replica when you re-create it.

  1. Open the replica that you want to convert. You must open the replica by using the same version of Access that was originally used to create the replica, to display the hidden and system fields.

  2. On the Tools menu, click Options. The Options dialog box opens.

  3. On the View tab, in the Show section, select Hidden objects and System objects. Click OK to apply the new settings and close the Options dialog box.

Manually re-create the database

  1. Create a blank database and open it.

    Note   Access creates a new, empty table named Table1. You should delete this table — you can do this by immediately closing it before you make any changes to it. Right-click its object tab and then click Close on the shortcut menu.

  2. On the External Data tab, in the Import group, click Access.

    The Get External Data - Access Database dialog box appears.

  3. Click Browse to locate the replicated database.

  4. Click the replicated database that contains the database objects that you want to recreate in the new database, and then click Open.

  5. In the Get External Data - Access Database dialog box, click Import tables, queries, forms, reports, macros, and modules into the current database, and then click OK.

  6. Click the database objects that you want to import into the new database. If you want to import all the objects, click Select All on each tab.

    Important    Do not select any tables at this point. You will re-create the tables in a later step.

  7. After you have finished selecting objects, click OK to import them.

    On the last page of the wizard, you have the option to save the import steps for future use. To do so, select the Save import steps check box, enter the appropriate information, and then click Save Import.

  8. Open the replicated database in Office Access 2007. For each table in the replicated database, create a Make Table query that takes all the data in the old table and creates a table in the new database with the same data.

    Note   If the s_GUID is a primary key (and foreign keys in other tables refer to it), you should include the s_GUID field in the new table. If the s_GUID field is not used as a primary key, there is no reason to preserve it in the new table. Don't copy the s_Lineage and s_Generation fields to the new table.

    By default, the s_GUID, s_Lineage, and s_Generation fields are hidden. To display these fields, use the following procedure:

    1. In the replicated database, make sure all tables are closed.

    2. Right-click the top of the Navigation Pane, and then click Navigation Options. The Navigation Options dialog box opens.

    3. In the Display Options section, select Show System Objects, and then click OK.


      1. Create a query, selecting the tables that contain the records you want to put in the new table.


        1. On the Create tab, in the Other group, click Query Design.

        2. In the Show Table dialog box, click the tab that lists the tables whose data you want to work with.

        3. Double-click the name of each object you want to add to the query, and then click Close.

        4. Add fields to the Field row in the design grid.

        5. To view the query's results, click the View menu, then click Datasheet View.

      2. In query Design view, on the Design tab, in the Query Type group, click Make Table. The Make Table dialog box appears.

      3. In the Table Name box, enter the name of the table you want to create or replace.

      4. Click Another Database, and then either type the path of the database where you want to put the new table or click Browse to locate the database.

      5. Click OK.

      6. On the Design tab, in the Results group, click Run. This will make the new table.

        Note   The new table you create does not inherit the field properties or the primary key setting from the original table.

  9. For each table in the new database, create the same index and primary key used in the replica's table.


    1. Open a table in Design view.

    2. In the upper portion of the window, click the field that you want to create an index for.

    3. In the lower portion of the window, click in the Indexed property box, and then click Yes (Duplicates OK) or Yes (No Duplicates).

    4. Select the field or fields that comprise the primary key.

    5. On the Design tab, in the Tools group, click Primary Key.

  10. For each table in the new database, create the relationships that existed for the replica's table.


    When you create a relationship between tables, the related fields don't have to have the same names. However, related fields must have the same data type unless the primary key field is an AutoNumber field. You can match an AutoNumber field with a Number field only if the FieldSize property of both of the matching fields is the same. For example, you can match an AutoNumber field and a Number field if the FieldSize property of both fields is Long Integer. Even when both matching fields are Number fields, they must have the same FieldSize property setting.

    Define a one-to-many or a one-to-one relationship

    1. Close any tables you have open. You can't create or modify relationships between open tables.

    2. On the Database Tools tab, in the Show/Hide group, click Relationships.

    3. If you haven't yet defined any relationships in your database, the Show Table dialog box is automatically displayed.

      If you need to add the tables you want to relate and the Show Table dialog box isn't displayed, invoke it: On the Design tab, in the Show/Hide group, click the Show Table button.

    4. Double-click the names of the tables you want to relate, and then close the Show Table dialog box. To create a relationship between a table and itself, add that table twice.

    5. Drag the field that you want to relate from one table to the related field in the other table.

      To drag multiple fields, press the CTRL key, click each field, and then drag them.

      In most cases, you drag the primary key field (which is displayed in bold text) from one table to a similar field (often with the same name) called the foreign key in the other table.

    6. The Edit Relationships dialog box is displayed. Check the field names displayed in the two columns to ensure they are correct. You can change them if necessary.

      Set the relationship options if necessary.

    7. Click the Create button to create the relationship.

    8. Repeat steps 4 through 7 for each pair of tables you want to relate.

      When you close the Relationships window, Microsoft Access asks if you want to save the layout. Whether you save the layout or not, the relationships you create are saved in the database.

    Define a many-to-many relationship

    1. Create the two tables that will have a many-to-many relationship.

    2. Create a third table, called a junction table, and add to the junction table new fields with the same definitions as the primary key fields from each of the other two tables. In the junction table, the primary key fields function as foreign keys. You can add other fields to the junction table, just as you can to any other table.

    3. In the junction table, set the primary key to include the primary key fields from the other two tables. For example, in an Order Details junction table, the primary key would be made up of the OrderID and ProductID fields.


      1. Open the table in Design view.

      2. Select the field or fields you want to define as the primary key.

        To select one field, click the row selector for the desired field.

        To select multiple fields, hold down the CTRL key and then click the row selector for each field.

      3. On the Design tab, in the Tools group, click Primary Key.

        Note   If you want the order of the fields in a multiple-field primary key to be different from the order of those fields in the table, click the Indexes button in the Show/Hide group to display the Indexes window, and then reorder the field names for the index named PrimaryKey.

    4. Define a one-to-many relationship between each of the two primary tables and the junction table.

  11. Save your new database.

Applies To: Access 2007

Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Change language