Format a network diagram

The Network Diagram view shows dependencies between project tasks by using boxes, or nodes, that are linked with lines. You can adjust the layout of the boxes, the style of the link lines, and the information that is displayed in the view.

What do you want to do?

Adjust the box layout

Why aren't the boxes positioned the way I want?

Change the link line style

Change what task information is displayed

Adjust the box layout

Depending on the structure of your project, the number of summary tasks and subtasks, and the number and types of task links, the Network Diagram boxes may not be arranged as you expected. You can modify the layout by applying different box arrangements, adjusting various layout parameters, and applying one of two different link styles.

  1. On the View menu, click Network Diagram.

  2. On the Format menu, click Layout.

  3. Under Box Layout, in the Arrangement list, click how you want the boxes to be arranged.

  4. For rows and columns, specify alignment, spacing, height, and width in the corresponding boxes.

    To space boxes evenly, click Fixed in the Height and Width boxes.

  5. If you want to keep summary tasks and subtasks together, select the Keep tasks with their summaries check box.

Note   

  • If you have grouped tasks in the Network Diagram view, all boxes are positioned automatically. You won't be able to manually position or change the arrangement of boxes. Summary tasks and their subtasks are arranged according to options you set before you applied the group. These options can't be changed until you undo grouping.

  • You can also use your mouse to display the Box Styles dialog box. Simply double-click a blank area of the Network Diagram view, and the Box Styles dialog box appears.

  • You can more easily see the effect of your changes by selecting the Hide all fields except ID check box under Diagram Options.

  • If you can't arrange Network Diagram boxes the way you want using the default selection of Automatically position all boxes under Layout Mode, you may want to position them manually. Click Allow manual box positioning, click OK, and then drag the boxes to the location you want.

  • You can zoom in and out to see more or less of the project in the Network Diagram view. On the View menu, click Zoom. Under Zoom To, click the percentage you want, or click Entire project to display the entire project within the window. If you zoom the view to 75% or less, you can position the pointer over the Network Diagram boxes to view task details at 100%.

Top of Page

Why aren't the boxes positioned the way I want?

If you have changed the layout mode of the Network Diagram view to allow manual box positioning, Microsoft Office Project doesn't lay out the Network Diagram according to the settings under Box Layout in the Layout dialog box (Format menu) until you reapply the layout.

If Allow manual box positioning in the Layout dialog box is selected, you can change the layout as follows:

  • If you manually repositioned a task or tasks, you can change the layout of all Network Diagram boxes to the layout that is defined in the Layout dialog box by clicking Layout Now (Format menu).

  • If you manually repositioned a task, you can change the layout of the linked tasks or subtasks in relation to the task that you moved. Right-click the task and then click Layout Related Tasks Now on the shortcut menu to move the related tasks while keeping the task that you repositioned previously in the same place.

  • If you manually repositioned multiple tasks, you can reposition the tasks to the positions that are defined in the Layout dialog box. To select adjacent tasks, hold down SHIFT, and then click the first and last tasks that you want. To select nonadjacent tasks, hold down CTRL, and then click the tasks that you want. Right-click, and then click Layout Selection Now on the shortcut menu.

  • To display the Network Diagram toolbar containing the Layout Now Button image and Layout Selection Now Button image buttons, right-click the background of any toolbar and then click Network Diagram on the shortcut menu.

  • To automatically reposition the Network Diagram boxes by using a specific box arrangement, click Layout (Format menu). Under Layout Mode, click Automatically position all boxes. Under Box Layout, select an arrangement in the Arrangement list. Under Row, in the Alignment, Spacing, and Height boxes, select how you want the horizontal rows of Network Diagram boxes to be displayed. Under Column, in the Alignment, Spacing, and Width boxes, select how you want the vertical columns of Network Diagram boxes to be displayed.

Note   When a group is applied in the Network Diagram view, the layout options you specified take effect; however, you are not able to change box arrangement options. If layout changes need to be made, you need to temporarily remove grouping from the Network Diagram in order to specify the layout options you want.

Top of Page

Change the link line style

If you have many tasks that are linked to a predecessor or successor task, the link lines can overlap and be difficult to read in the Network Diagram view. You can change the style of the link lines and arrange them how you want. You can also display task dependency labels on the link lines.

  1. On the View menu, click Network Diagram.

  2. On the Format menu, click Layout.

  3. Do one of the following:

    • To display link lines as straight lines between predecessor and successor task boxes, under Link style, click Straight.

    • To display link lines as horizontal and vertical line segments connected at right angles between predecessor and successor task boxes, under Link style, click Rectilinear.

  4. To display labels on link lines identifying the task dependency and any lead or lag time, under Link style, select the Show link labels check box.

  5. To display link lines with arrows indicating the predecessor and successor of tasks, under Link style, select the Show arrows check box.

Tip   If Allow manual box positioning is selected and you manually reposition a task, you can change the layout of linked tasks or subtasks in relation to the task that you moved. Right-click the task and then click Layout Now on the shortcut menu to move the related tasks while keeping the task that you repositioned previously in the same place.

Top of Page

Change what task information is displayed

To meet your different information needs, you can change the task information in the Network Diagram boxes to display what is most important to you.

  1. On the View menu, click Network Diagram.

  2. On the Format menu, click Box Styles.

  3. In the Style settings for list, click the task category whose content and appearance you want to change.

  4. Under Border, choose the shape, color, width, and gridline options to create the look you want.

  5. Do one of the following:

    • To modify or create a data template, click More Templates and continue to step 6.

    • To apply an existing template, go to step 12.

  6. In the Data Templates dialog box, do one of the following:

    • To edit an existing template, select one, and then click Edit.

    • To base a new template on an existing template, select one, and then click Copy.

    • To create a new template, click New.

      Note   You can also import a template from another project. In the Data Templates dialog box, click Import, and then in the Import Template dialog box, under Project, click the project from which you want to import a template. In the Template box, click the template you want, and then go to step 11.

  7. In the Template name box, type a name for the new or revised template.

  8. In the Show data from task ID box, type or select the task ID number of the task you want to display in the preview window.

  9. To change how cells are displayed, click Cell layout, select the display options you want, and then click OK.

  10. Under Choose cell(s), type or select the fields you want to display.

  11. Click OK, and then click Close.

  12. To apply the new or revised template, click it in the Templates list.

Note   You can also use your mouse to display the Box Styles dialog box. Simply double-click a blank area of the Network Diagram view, and the Box Styles dialog box appears.

Top of Page

Applies To: Project 2007



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language