Editor - your writing assistant

Editor checks your document or email message for spelling and grammar errors, and offers suggestions that can refine your document.

Editor can spot misspellings, grammatical mistakes, writing style issues as you type with Word or Outlook. Editor marks the errors as you write: red squiggles are for spelling, blue double underlines are for grammar, and gold dotted lines are for places where Editor has writing assistance suggestions.

Complete functionality of Editor is available only if you have an Office 365 subcription.

Editor Overview pane is a new functionality that was added and it is currently available only to Office Insiders.

Editor checks for spelling errors as you type or when you proofread your whole document you get an overview highlighting spelling corrections that are required in your document. Select Spelling corrections in the Editor pane to, correct spellos in your document. When you see a red squiggle below a word, right-click the word and choose one of the suggestions to fix the error.

Showing Spelling error in a Word document

  • Spelling suggestions are accompanied by synonyms (when available) to help you choose the most appropriate one that matches what you want to say. 

  • The following options are visible if you click the arrow on the context menu:

    1. Choose Read Aloud if you'd like to hear the current suggestion.

    2. Choose Change All if you want to replace with the current suggestion every time the same spelling error appears in the current document.

    3. Select Add to AutoCorrect for a suggestion you always want Editor to substitute for the word it found. (You can also get to AutoCorrect Options from the context menu. For more information on how to use the options see, choose AutoCorrect options.)

  • To add the word to the default dictionary so that Editor stops marking it as misspelled, choose Add to Dictionary.

  • To skip the word in this document or email without adding it the spelling dictionary, choose Ignore All.

  • To see more information and all available actions for resolving spelling errors, choose See More to open the Editor pane. In the Editor pane,

    1. A detailed explanation of the grammatical issue can be seen in the upper part of the Editor pane.

    2. You can have the sentence containing the grammar error read to you by selecting the Speaker icon. If you select a portion of the sentence within that text box before selecting the speaker icon, just that portion will be read.

    3. Each grammar suggestion in the pane is a split-button. Select the split-button's main button to choose that suggestion and insert it into the document. Alternatively, you can select the arrow button of the split-button to open a submenu containing the following additional actions you can take on that suggestion: You can hear each suggestion out loud, choose Read Aloud and as well as listen to it being spelled letter-by-letter, choose Spell Out.

Editor checks for grammatical issues as you type or when you proofread (Press F7) your whole document you get an overview highlighting all the grammatical corrections that are required in your document. Select Grammar corrections in the Editor pane to, correct the grammatical issues in your document. When you see a blue double underline, right click the word or phrase to learn more.

Showing grammar error

  • Grammar suggestions are accompanied by a brief  description, to help you make an informed decision on whether and how to resolve the issue.

  • The following options are visible if you click the arrow on the context menu:

    1. Choose Read Aloud to hear the selected suggestion.

    2. To ignore the word or phrase and move to next one, choose Ignore Once

    3. Choose Don't check for this issue, to ignore this error at this time for the whole document.

    4. To see more detailed explanation of the grammatical issue as well as writing examples, choose See More to open the Editor pane. In the Editor pane,

      • A detailed explanation of the grammatical issue can be seen in the upper part of the pane.

      • You can have the sentence containing the grammar error read to you by selecting the Speaker icon. If you select a portion of the sentence within that text box before selecting the speaker icon, just that portion will be read.

      • Each grammar suggestion in the pane is a split-button. Select the split-button's main button to choose that suggestion and insert it into the document. Alternatively, you can select the arrow button of the split-button to open a submenu containing the following additional actions you can take on that suggestion: You can hear each suggestion out loud, choose Read Aloud and as well as listen to it being spelled letter-by-letter, choose Spell Out.

Editor checks for style and other advanced writing issues and highlights the word or phrase with a dotted gold underline. Right click on the underlined word or phrase and consider one of the alternative suggestions or when you proofread (Press F7) your whole document you get an overview highlighting all the writing refinements that are required in your document.

Note: The gold dotted lines are currently available only for English and Spanish languages.

Showing writing styel error

Writing style suggestions are accompanied by a brief description to help you make an informed decision on whether and how to resolve the issue. 

Editor checks for the following:

  • Complex words*

  • Contractions*

  • Clichés*

  • Informal Language*

  • Double Negation*

  • Jargon*

  • Nominalizations

  • Passive Voice*

  • Passive voice with Unknown Actor (No suggestions available)*

  • Wordiness

  • Words in split infinitives* (more than one)

  • Gender-specific language*

  • Words expressing uncertainty*

  • Slang*

  • Oxford comma*

  • Punctuation Required With Quotes*

  • Space between Sentences*

Important: Enable the style options by going to Proofing options and choosing Grammar & more settings in the Writing Style drop down. See, How to change the Editor proofing settings, below.

  • Each writing style suggestion in the right-click menu is a split-button. Select the split-button's main button to choose that suggestion and insert it into the document. Alternatively, you can select the arrow button of the split-button to open a submenu containing the following additional actions you can take on that suggestion:

    1. Choose Read Aloud to hear the selected suggestion

    2. To ignore the style issue and move to next one, choose Ignore Once

    3. Choose Don't check for this issue, to ignore this error at this time for the whole document.

  • To see more detailed explanation of the writing style issue as well as writing examples, choose See More to open the Editor pane. In the Editor pane,

    1. A detailed explanation of the writing style suggestion can be seen in the upper part of the pane.

    2. You can have the sentence containing the writing style suggestion read to you by selecting the Speaker icon. If you select a portion of the sentence within that text box before selecting the speaker icon, just that portion will be read.

    3. Each writing style suggestion in the pane is a split-button. Select the split-button's main button to choose that suggestion and insert it into the document. Alternatively, you can select the arrow button of the split-button to open a submenu containing the following additional actions you can take on that suggestion:

    4. You can hear each suggestion out loud, choose Read Aloud as well as listen to it being spelled letter-by-letter choose Spell Out.

To learn in detail about writing style errors and suggestions see, Select grammar and writing style options.

Proofread the whole document with Editor overview

Editor overview presents a breakdown of the kind of errors that are present in your document, and gives you a choice of fixing the errors that are most relevant to you.

  1. In Word, proofread your whole document by pressing F7, or by selecting Check Document on the Review tab.

    Showing Check Document under Review tab
  2. Editor pane shows you an overview of the number of errors and the kind of errors (spelling, grammar and style) found in the document.

    Showing Overview of proofing issues
  3. Click on any category to fix just those issues in the document.

You can see any misspellings, grammatical mistakes and writing style issues as you type with Word or Outlook 2016. Editor marks the errors as you write: red squiggles are for spelling, blue double underlines are for grammar, and writing style.

Editor checks for spelling errors as you type. When you see a red squiggle below a word, right-click the word and choose one of the suggestions to fix the error.

Showing Spelling error context menu
  • Spelling suggestions are accompanied by synonyms (when available) to help you choose the most appropriate one that matches what you want to say. 

  • The following options are visible if you click the arrow on the context menu:

    1. Choose Read Aloud if you'd like to hear the current suggestion.

    2. Select Add to AutoCorrect for a suggestion you always want Editor to substitute for the word it found. (You can also get to AutoCorrect Options from the context menu. For more information on how to use the options see, choose AutoCorrect options.)

  • To add the word to the default dictionary so that Editor stops marking it as misspelled, choose Add to Dictionary.

  • To skip the word in this document or email without adding it the spelling dictionary, choose Ignore All.

  • To see more information and all available actions for resolving spelling errors, choose See More to open the Editor pane.

    Note: Editor pane is available only for Word.

Editor checks for grammatical issues as you type or when you proofread (Press F7) your whole document you get an overview highlighting all the grammatical corrections that are required in your document.

Showing grammar error context menu

  • Grammar suggestions are accompanied by a brief description just above it in the right-click menu, to help you make an informed decision on whether and how to resolve the issue.

  • The following options are visible if you click the arrow on the context menu:

    1. Choose Read Aloud to hear the selected suggestion.

    2. To ignore the word or phrase and move to next one, choose Ignore Once

    3. To see more detailed explanation of the grammatical issue as well as writing examples, choose See More to open the Editor pane.

      Note: Editor pane is available only for Word.

See also

Run spelling and grammar checker manually

  • Spellchecking is available for 89 languages.

  • Context Sensitive Spelling is available for 7 languages (English, Spanish, French, German, Brazilian Portuguese, Italian, Norwegian)

  • Grammar Checking is available in 22 languages (7 languages above plus Russian, Japanese, Dutch, Danish, Finnish, Swedish, Portuguese [European], Polish, Arabic, Czech, Turkish. Korean, Chinese [simplified], Chinese [Traditional], Hungarian)

  • Writing Assistance (gold dotted line) is available for English and Spanish languages only.

In Word, change the proofing settings by using the Grammar Settings dialog box. You can choose the various grammar and style settings depending on which settings suits your document the best.

Note: By default Editor proofing options are set to Grammar & more and have Wordiness and Nominalizations style options selected.

  1. Choose File > Options > Proofing to open proofing options.

  2. Under When correcting spelling and grammar in Word, choose Settings.

    The Writing style menu in the Grammar Settings dialog box offers two options: Grammar or Grammar & more. You can choose either option depending on which settings you want to work with.

  3. Choose Grammar & more to use the style options.

    Scroll down to see all of the options available, and select or clear any rules that you want the grammar checker to flag or ignore. Any changes that you make to these settings apply to all the documents or items that you edit, not just the current document you are working in.

    Tip: To go back to the default editor proofing settings, choose Reset All.

In Outlook, Editor can flag words or phrases for grammar or style issues as you type an email and provide suggestions to fix the issue. To use Editor proofing services,

  1. Create or open an email.

  2. Choose the File tab, and select Options.

  3. Select Mail, and then choose Editor Options....

  4. Choose Proofing.

  5. Under When correcting spelling in Outlook, do the following:

    • Select Mark grammar errors as you type. This marks both grammar (blue) and style (gold) errors as you type.

    • Choose Settings.

      The Writing style menu in the Grammar Settings dialog box offers two options: Grammar or Grammar & more. You can choose either option depending on which settings you want to work with.

    • Choose Grammar & more to use the style options.

      Scroll down to see all of the options available, and select or clear any rules that you want the grammar checker to flag or ignore. Any changes that you make to these settings apply to all the documents or items that you edit, not just the current document you are working in.

      Tip: To go back to the default editor proofing settings, choose Reset All.

  6. Choose OK

Keyboard shortcuts

Within the document, use Alt + underlined letter to select the listed command.

Inside the Editor pane, use only the underlined letter to select the command.

See Also

Select grammar and writing style options in Office 2016

Check spelling and Grammar in Office 2010 and later

Select grammar and style options in Office 2013 and earlier

Connect with an expert
Contact us
Expand your skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×