Draw or delete a line, connector, or freeform shape

You can add lines to connect shapes, add pointers and freeform shapes, or use a line to point to a piece of information, and you can delete lines.

Draw a line with connection points

A connector is a line with connection points at each end that stays connected to the shapes you attach it to. Connectors can be straight, elbow (angled), or curved. When you choose a connector, dots appear on the shape outline. These dots indicate where you can attach a connector.

Important: In Word and Outlook, connection points work only when the lines and the objects they are connecting are placed on a drawing canvas. To insert a drawing canvas, click the Insert tab, click Shapes, and then click New Drawing Canvas at the bottom of the menu.

To add a line that connects to other objects in Excel, Outlook, PowerPoint, or Word, follow these steps.

  1. If you haven't already, add a drawing canvas to your document by clicking Insert > Shapes > New Drawing Canvas.

  2. On the Insert tab, in the Illustrations group, click Shapes.

    The Shapes group on the Insert tab.

  3. Under Lines, click the line or connector that you want to add.

  4. To draw a line connecting shapes, on the first shape, rest your mouse pointer over the shape or object to which you want to attach the connector.

    Connection dots will appear, indicating that your line can be connected to the shape.

    Shape with connection points

    Note: If no connection points appear, you've either chosen a line style that is not a connector (such as Curve), or you are not working on a drawing canvas.

    Click anywhere on the first shape, and then drag the cursor to the second connection object.

    Note: When you rearrange shapes that are joined with connectors, the connectors remain attached to and move with the shapes. If you move either end of a connector, that end detaches from the shape, and you can then attach it to another connection site on the same shape or attach it to another shape. After the connector attaches to a connection site, the connector stays connected to the shapes no matter how you move each shape.

Draw a line without connection points in Excel, Outlook, PowerPoint, or Word

To add a line that is not connected to other objects in Excel, Outlook, PowerPoint, or Word, follow these steps.

  1. On the Insert tab, in the Illustrations group, click Shapes.

    The Shapes group on the Insert tab.

  2. Under Lines, click any line style you like.

  3. Click one location in the document, move your pointer to a different location, and then click again.

  4. Double-click when you are finished drawing the line.

What else do you want to do?

Draw a line or arrow in Project

Draw the same line or connector multiple times

Add or remove an arrowhead on a line

Draw a freeform shape

Draw a polygon in Project

Edit points in a shape

Delete lines, connectors, or a freeform shape

Draw a line or arrow in Project

  1. On the Format tab, click Drawing, and then click Arrow or Line.

  2. Place your cursor at the start of your line or arrow, then click and drag to draw your line or arrow.

Draw the same line or connector multiple times

Note:  This feature isn't available in Project.

If you need to add the same line repeatedly, you can do so quickly by using Lock Drawing Mode.

  1. On the Insert tab, in the Illustrations group, click Shapes.

    The Shapes group on the Insert tab.

  2. Under Lines, right-click the line or connector that you want to add, and then click Lock Drawing Mode.

    Lock Drawing Mode

  3. Click where you want to start the line or connector, and then drag the cursor to where you want the line or connector to end.

  4. Repeat step 3 for each line or connector you want to add.

  5. When you finish adding all of the lines or connectors, press ESC.

Add or remove an arrowhead on a line

Note:  This feature isn't available in Project.

  1. Select the line you want to change.
    If you want to add or delete arrowheads on multiple lines, select the first line, and then press and hold Ctrl while you select the other lines.

  2. On the Format tab, click the arrow next to Shape Outline.

    The Shape Styles group on the Format tab
    If you don't see the Format tab, make sure you selected the line. You might have to double-click the line.

  3. Point to Arrows, and then click the arrow style that you want.

    To create a custom arrow style, click More Arrows, and then choose the options that you want.

    To remove an arrowhead, click Arrow Style 1 (no arrowheads).

Draw a freeform shape

  1. On the Insert tab, in the Illustrations group, click Shapes.

    The Shapes group on the Insert tab.

  2. Under Lines, do one of the following:

    • To draw a shape that has both curved and straight segments, click Freeform Button image .

    • To draw a shape that looks like it was drawn with a pen by hand, or to create smooth curves, click Scribble Button image .

  3. Click anywhere in the document, and then drag to draw.
    To draw a straight segment with the Freeform tool, click one location, move your pointer to a different location, and then click again; to draw a curved segment, keep your mouse button pressed as you drag to draw.

  4. To finish drawing the shape, do one of the following:

    • To leave the shape open, double-click at any time.

    • To close the shape, click near its starting point.

      Notes: 

      • To edit the points of a shape, see Edit points in a shape.

      • To make it easier to draw details, increase the magnification to 200 percent. On the View tab, in the Zoom group, click Zoom, and then click 200%.

Draw a polygon in Project

  1. On the Format tab, click Drawing, and then click Polygon.

  2. Click anywhere in the document, drag to draw, and click to stop drawing that line.

  3. Move your pointer to a different location and click again.

  4. To finish drawing the shape, do one of the following:

    • To leave the shape open, double-click at any time.

    • To close the shape, click near its starting point.

Edit points in a shape

You can edit the points of most shapes. For example, you edit points when you need to lean a triangle over to the right.

  1. Select the shape that you want to edit.

  2. On the Format tab, click Edit Shape Edit shape button image , and then click Edit Points.

    The Insert Shapes group on the Format tab.

    -or-
    If you're working in Project, on the Format tab, click Drawing, and then click Edit Points.

  3. Drag one of the vertexes that outline the shape. A vertex is the point, indicated by a black dot, where a curve ends or the point where two line segments meet in a freeform shape.

    Editing a point on a shape by dragging a vertex

Working with editing points

  • To add a point, click the shape outline while pressing Ctrl.

  • To delete a point, click the point while pressing Ctrl.

  • To have the point treated as a smooth point, press Shift while dragging either of the handles attached to the point. Once you stop dragging, the point will be changed to a smooth point. A smooth point joins two line segments of equal length.

  • To have the point treated as a straight point, press Ctrl while dragging either of the handles attached to the point. Once you stop dragging the point will be changed to a straight point. A straight point joins two line segments of different lengths.

  • To have the point treated as a corner point, press Alt while dragging either of the handles attached to the point. Once you stop dragging the point will be changed to a corner point. A corner point joins two line segments with one segment going off in a different direction.

  • To cancel the change to the point and line segments, press Esc before releasing the mouse button.

  • To open Edit Points mode with keyboard shortcuts, select the shape and then press Alt + JD, E, E.
    -or-
    If you're working in Project, press Alt+, D, E.

Note:  To make it easier to draw details, increase the magnification to 200 percent. On the View tab, in the Zoom group, click Zoom, and then click 200%.

Delete lines, connectors, or a freeform shape

  • Click the line, connector, or shape that you want to delete, and then press Delete.
    If you want to delete multiple lines or connectors, select the first line, press and hold Ctrl while you select the other lines, and then press Delete.

If you find that you can't select a line to delete it, it might not be a line but a border. You can remove borders by clicking the arrow next to the Borders button (in the Paragraph group in Word and Outlook; in the Font group in Excel), and then clicking No Border.

Removing a border with the Borders button

You can learn more about how lines work in borders by reading Add borders to text.

See Also

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×