Distribute project work evenly (level resource assignments)

Do some of your work resources have too much work assigned? You can resolve resource conflicts or overallocations by using the resource-leveling feature in Microsoft Office Project. Leveling works by splitting tasks or by adding delay to tasks until the resources that are assigned to those tasks are no longer overloaded. Because of these changes to the tasks, leveling can delay the finish date of some tasks and consequently also the project's finish date.

When it is leveling, Project does not change who is assigned to each task. Project levels only the work resources, generic resources, and committed resources. It does not level the material resources, cost resources, or proposed resources.

Tip   You can quickly find an overallocated resource in any resource view, where the names of overallocated resources are highlighted in red.

Prior to leveling, you may want to set the task priorities, which are an indication of a task's importance and its availability for leveling. The priority value that you enter is a subjective value between 1 and 1000, which enables you to specify the amount of control you have over the leveling process. For example, if you don't want Project to level a particular task, set its priority level to 1000. By default, priority values are set at 500, or a medium level of control. Tasks that have lower priority are delayed or split before those that have higher priority.

You can also set an entire project's availability for leveling by setting the project's priority. For example, if you are sharing resources with another project that serves as a resource pool, and if you don't want to level the tasks in one of the sharer files, then set that sharer file's priority level to 1000.

What do you want to do?

Set the task priorities

Set the project priorities

Distribute the project work by leveling

Set the task priorities

  1. On the View menu, click Gantt Chart.

  2. In the Task Name field, select the task whose priority you want to change, and then click Task Information Button image.

  3. Click the General tab, and then type or select a priority in the Priority box.

Top of Page

Set the project priorities

  1. On the Project menu, click Project Information.

  2. Type or select a priority in the Priority box.

Top of Page

Distribute the project work by leveling

  1. On the Tools menu, click Level Resources.

  2. Under Leveling calculations, click Automatic or Manual.

    Manual leveling (the default) occurs only when you click Level Now. Automatic leveling occurs instantaneously whenever you change a task or resource. Use automatic leveling if you want to reschedule tasks whenever resources are assigned more work than they have the capacity to complete.

  3. If you choose automatic leveling, clear the Clear leveling values before leveling check box. When this check box is cleared, Project levels only new and unleveled assignments. This check box is selected by default, but when leveling automatically, leaving it selected can significantly slow down your work in the schedule because all tasks are leveled. In the Look for overallocations on a box, click a time period, or basis, for the sensitivity with which leveling will recognize overallocations. Day by Day is the default. This setting establishes the point at which you want leveling to intervene: when you have an overallocation within just one minute, one day, one week, or one month.

  4. Under Leveling range for, select to level the entire project or to level only those tasks falling within a specific time range.

  5. In the Leveling order box, select the leveling order that you want:

    • Select ID Only to level tasks in ascending order of their ID numbers before considering any other criteria.

    • Select Standard to first examine predecessor dependencies, slack, dates, priorities, and constraints to discover whether and how tasks should be leveled. (This is the default setting.)

    • Select Priority, Standard to check task priorities first and only then examine the standard criteria.

  6. To prevent the finish date of your project from being delayed, select the Level only within available slack check box.

    Note   If you select this check box, you may get error messages indicating that Project can't level the entire schedule. Project may not level the schedule because there is seldom enough slack in a schedule to reschedule assignments without running out of slack time.

  7. To allow leveling to adjust when a resource works on a task independently of other resources that are working on the same task, select the Leveling can adjust individual assignments on a task check box.

  8. If you want leveling to interrupt tasks by creating splits in the remaining work on tasks or resource assignments, select the Leveling can create splits in remaining work check box. If a resource is assigned to tasks concurrently beyond what the resource's schedule can handle, then a task that has remaining work can be split and worked on when the resource's schedule will allow it.

  9. To include proposed resources, select the Level tasks with the proposed booking type check box.

  10. If you want to clear the previous leveling results before leveling again, then click Clear Leveling.

  11. If you are leveling manually, then click Level Now. If you are leveling automatically, click OK.

    The Level Now dialog box appears if a resource view that has selected resources was showing when you opened the Resource Leveling dialog box. Click Selected resources if you want to level only the selected resources. Otherwise, click Entire pool.

Note   

  • To clear leveling immediately before doing any other action, click Undo Level. If you don't undo the leveling, you can also click Clear Leveling to clear the previous leveling results.

  • If you level tasks in projects that are scheduled from a finish date, then negative delay values are applied from the end of the task or assignment, causing the task or resource assignment's finish date to occur earlier.

  • To see the changes made to tasks by leveling, on the View menu, click More Views, click Leveling Gantt, and then click Apply.

Top of Page

Applies To: Project 2007



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language