Create, change, or delete an OLE object

You can use Object Linking and Embedding (OLE) to include content from other programs, such as Microsoft Office Excel 2007, in Microsoft Office PowerPoint 2007, Microsoft Office Word 2007, or Microsoft Office Outlook 2007.

What do you want to do?

Learn more about OLE

Link or embed content from another program by using OLE

Change the way that an OLE object is displayed

Change content from an OLE program

Break the link

When I double-click a linked or embedded object, a "cannot edit" message appears

When I try to insert an object, a "Cannot start the application required" message appears

Learn more about OLE

OLE is supported by many different programs, and OLE is used to make content that is created in one program available in another program. For example, you can insert an Excel 2007 worksheet in an PowerPoint 2007 presentation. To see what types of content that you can insert, click Object in the Text group on the Insert tab. Only programs that are installed on your computer and that support OLE objects appear in the Object type box. If you do not see the program you want listed here, you need to install the program to insert content from it.

Top of Page

Linked or embedded objects

If you copy information between PowerPoint, Word, or any other program that supports OLE, such as Excel, you can copy the information as either a linked object or an embedded object. The main differences between linked objects and embedded objects are where the data is stored and how the object is updated after you place it in the destination file. Embedded objects are stored in the document that they are inserted in, and they are not updated. Linked objects remain as separate files, and they can be updated.

Linked and embedded objects in a document
Linked and embedded objects in a document

1. An embedded object has no connection to the source file.

2. A linked object is linked to the source file.

3. The source file updates the linked object.

For more information about embedded and linked sound files in PowerPoint 2007, see Embedded and linked sound files in a presentation.

Top of Page

When to use linked objects

If you want the information in your destination file to be updated when the data in the source file changes, use linked objects.

With a linked object, the original information remains stored in the source file. The destination file displays a representation of the linked information but stores only the location of the original data (and the size if the object is an Excel chart object). The source file must remain available on your computer or network to maintain the link to the original data.

The linked information can be updated automatically if you change the original data in the source file. For example, if you select a paragraph in a Word document and then paste the paragraph as a linked object in an PowerPoint presentation, the information can be updated in PowerPoint if you change the information in your Word document.

Top of Page

When to use embedded objects

If you don't want to update the copied data when it changes in the source file, use an embedded object. The version of the source is embedded entirely in the document or presentation. If you copy information as an embedded object, the destination file requires more disk space than if you link the information.

When the file is opened on another computer, the embedded object can be viewed without having access to the original data. Because an embedded object has no links to the source file, the object is not updated if you change the original data.

Top of Page

Link or embed content from another program by using OLE

You can link or embed all or part of the content from another program.

Create a link to content from another program

Which 2007 Microsoft Office system program are you using?

Outlook

PowerPoint

Word

Outlook

  1. Click in the document or e-mail where you want to place the linked object.

  2. On the Insert tab, in the Text group, click Object.

    Word Ribbon Image

  3. Click the Create from File tab.

  4. In the File name box, type the name of the file, or click Browse to select from a list.

    If you browse to the file, once you locate it, click Insert.

  5. Select the Link to file check box.

  6. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.

      To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

PowerPoint

  1. Click in the slide where you want to place the linked object.

  2. On the Insert tab, in the Text group, click Object.

    PowerPoint Ribbon Image

  3. Click Create from File.

  4. In the File name box, type the name of the file, or click Browse to select from a list.

    If you browse to the file, once you locate it, click Insert.

  5. Select the Link check box.

  6. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.

      To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

Note   You cannot use the Object command to insert graphics or pictures. To insert a graphic or picture, on the Insert tab, in the Illustrations group, click Picture.

Word

  1. Click in the document or e-mail where you want to place the linked object.

  2. On the Insert tab, in the Text group, click Object.

    Word Ribbon Image

  3. Click the Create from File tab.

  4. In the File name box, type the name of the file, or click Browse to select from a list.

    If you browse to the file, once you locate it, click Insert.

  5. Select the Link to file check box.

  6. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.

      To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

Top of Page

Embed content from another program

Which 2007 Microsoft Office system program are you using?

Outlook

PowerPoint

Word

Outlook

  1. Click in the document or e-mail where you want to place the embedded object.

  2. On the Insert tab, in the Text group, click Object.

    Excel Ribbon Image

  3. If the document does not already exist, click the Create New tab. In the Object type box, click the type of object that you want to create.

    If the document already exists, click the Create from File tab. In the File name box, type the name of the file, or click Browse to select from a list.

  4. Clear the Link to file check box.

  5. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

PowerPoint

  1. Click in the slide where you want to place the embedded object.

  2. On the Insert tab, in the Text group, click Object.

    Excel Ribbon Image

  3. If the document does not already exist, click Create new. In the Object type box, click the type of object that you want to create.

    If the document already exists, click Create from File. In the File name box, type the name of the file, or click Browse to select from a list.

  4. Clear the Link check box.

  5. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

Word

  1. Click in the document or e-mail where you want to place the embedded object.

  2. On the Insert tab, in the Text group, click Object.

    Excel Ribbon Image

  3. If the document does not already exist, click the Create New tab. In the Object type box, click the type of object that you want to create.

    If the document already exists, click the Create from File tab. In the File name box, type the name of the file, or click Browse to select from a list.

  4. Clear the Link to file check box.

  5. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

Top of Page

Link or embed partial content from another program

Which 2007 Microsoft Office system program are you using?

Outlook

PowerPoint

Word

Top of Page

Outlook

  1. From a program other than Outlook, select the information that you want to copy as a linked or embedded object.

  2. On the Home tab, in the Clipboard group, click Copy.

    The Clipboard group on the Home tab

  3. Switch to the document or e-mail that you want to place the information in, and then click where you want the information to appear.

  4. On the Home tab, in the Clipboard group, click the arrow below Paste, and then click Paste Special.

  5. Do one of the following:

    • To paste the information as a linked object, click Paste link.

    • To paste the information as an embedded object, click Paste. In the As box, click the entry with the word "object" in its name. For example, if you copied the information from a Excel worksheet, click Microsoft Excel Worksheet Object.

PowerPoint

  1. From a program other than PowerPoint, select the information that you want to copy as a linked or embedded object.

  2. On the Home tab, in the Clipboard group, click Copy.

    The Clipboard group on the Home tab

  3. Switch to the slide that you want to place the information in, and then click where you want the information to appear.

  4. On the Home tab, in the Clipboard group, click the arrow below Paste, and then click Paste Special.

  5. Do one of the following:

    • To paste the information as a linked object, click Paste link.

    • To paste the information as an embedded object, click Paste. In the As box, click the entry with the word "object" in its name. For example, if you copied the information from a Word document, click Microsoft Word Document Object.

Word

  1. From a program other than Word, select the information that you want to copy as a linked or embedded object.

  2. On the Home tab, in the Clipboard group, click Copy.

    The Clipboard group on the Home tab

  3. Switch to the document or e-mail that you want to place the information in, and then click where you want the information to appear.

  4. On the Home tab, in the Clipboard group, click the arrow below Paste, and then click Paste Special.

  5. Do one of the following:

    • To paste the information as a linked object, click Paste link.

    • To paste the information as an embedded object, click Paste. In the As box, click the entry with the word "object" in its name. For example, if you copied the information from a Excel worksheet, click Microsoft Excel Worksheet Object.

Top of Page

Change the way that an OLE object is displayed

You can display a linked object or embedded object in a document, slide, or e-mail exactly as it appears in the source program or as an icon. If the document or presentation will be viewed online, and you don't intend to print it, you can display the object as an icon. This minimizes the amount of display space that the object occupies. Viewers who want to display the information can double-click the icon.

  1. Right-click the icon or object, point to object typeObject (for example, Document Object), and then click Convert.

  2. Do one of the following:

    • To display the content, clear the Display as icon check box.

    • To display an icon, select the Display as icon check box.

      To change the default icon image or label, click Change Icon, and then click the icon that you want from the Icon list, or type a label in the Caption box.

Top of Page

Change content from an OLE program

While you are in Word, PowerPoint or Outlook, you can change the content linked or embedded from another program.

Change a linked object in the source program

Which 2007 Microsoft Office system program are you using?

Outlook

PowerPoint

Word

Outlook

  1. Right-click the icon or object, point to object typeObject (for example, Linked Worksheet Object), and then click Links.

  2. Click Open Source.

  3. Make the changes that you want to the linked object.

Tip   You can also change the source file, after clicking Links, click Change Source instead of Open Source. Locate the new source file and then click Open.

PowerPoint

  1. Click the linked object on the slide.

  2. Click the Microsoft Office Button Office button image, point to Prepare, and then click Edit Links to Files.

    If you do not see Edit Links to Files, click the downward pointing arrow at the bottom of the Prepare the document for distribution list to scroll to the bottom of the list.

    Prepare menu image

  3. In the Links list, select the link, and then click Open Source.

  4. Make the changes you want to the linked object.

  5. Exit the source program to return to the destination file.

Word

  1. Right-click the icon or object, point to object typeObject (for example, Linked Worksheet Object), and then click Links.

  2. Click Open Source.

  3. Make the changes that you want to the linked object.

Tip   You can also change the source file, after clicking Links, click Change Source instead of Open Source. Locate the new source file and then click Open.

Top of Page

Change an embedded object in the source program

To change an embedded object, double-click the object to open and edit it in the source program. The source program (or another program capable of editing the object) must be installed on your computer.

  1. Double-click the embedded object to open it.

  2. Make the changes that you want to the object.

  3. If you are editing the object in place within the open program, click anywhere outside of the object to return to the destination file.

    If you edit the embedded object in the source program in a separate window, exit the source program to return to the destination file.

Note    Double-clicking certain embedded objects, such as video and sound clips, plays the object instead of opening a program. To edit one of these embedded objects, right-click the icon or object, point to object typeObject (for example, Media Clip Object), and then click Edit.

Top of Page

Edit an embedded object in a program other than the source program

  1. Select the embedded object that you want to edit.

  2. Right-click the icon or object, point to object typeObject (for example, Document Object), and then click Convert.

  3. Do one of the following:

    • To convert the embedded object to the type that you specify in the list, click Convert to.

    • To open the embedded object as the type that you specify in the list without changing the embedded object type, click Activate as.

Top of Page

Break the link

Which 2007 Microsoft Office system program are you using?

Outlook

PowerPoint

Word

Top of Page

Outlook

  1. Right-click the icon or object, point to object typeObject (for example, Linked Worksheet Object), and then click Links.

  2. Click Break Link.

Note   After you break the connection to a linked object, you must reinsert it into your file to reconnect.

PowerPoint

  1. Click the linked object on the slide.

  2. Click the Microsoft Office Button Office button image, point to Prepare, and then click Edit Links to Files.

    If you do not see Edit Links to Files, click the downward pointing arrow at the bottom of the Prepare the document for distribution list to scroll to the bottom of the list.

    Prepare menu image

  3. In the Links list, select the link, and then click Break Link.

  4. Click Close.

Note   After you break the connection to a linked object, you must reinsert it into your file to reconnect.

Word

  1. Right-click the icon or object, point to object typeObject (for example, Linked Worksheet Object), and then click Links.

  2. Click Break Link.

Note   After you break the connection to a linked object, you must reinsert it into your file to reconnect.

Top of Page

When I double-click a linked or embedded object, a "cannot edit" message appears

This message appears when the source file or source program can't be opened.

Make sure that the source program is available     If the source program is not installed on your computer, convert the object to the file format of a program that you do have installed.

Note   If you want to link to or embed an object created in a third-party program, check that program’s Help documentation first to find out if it supports OLE.

Ensure that memory is adequate     Make sure that you have enough memory to run the source program. Close other programs to free up memory, if necessary.

Close all dialog boxes     If the source program is running, make sure that it doesn't have any open dialog boxes. Switch to the source program, and close any open dialog boxes.

Close the source file     If the source file is a linked object, make sure that another user doesn't have it open.

Ensure that the source file name has not changed     If the source file that you want to edit is a linked object, make sure that it has the same name as it did when you created the link and that it has not been moved. To change the source file:

Which 2007 Microsoft Office system program are you using?

Outlook

PowerPoint

Word

Outlook

  1. Right-click the icon or object, point to object typeObject (for example, Linked Worksheet Object), and then click Links.

  2. Click Change Source.

  3. Locate the new source file and reconnect the link.

PowerPoint

  1. Click the linked object on the slide.

  2. Click the Microsoft Office Button Office button image, point to Prepare, and then click Edit Links to Files.

    If you do not see Edit Links to Files, click the downward pointing arrow at the bottom of the Prepare the document for distribution list to scroll to the bottom of the list.

    Prepare menu image

  3. In the Links list, select the link, and then click Change Source.

  4. Locate the new source file and reconnect the link.

Word

  1. Right-click the icon or object, point to object typeObject (for example, Linked Worksheet Object), and then click Links.

  2. Click Change Source.

  3. Locate the new source file and reconnect the link.

Top of Page

When I try to insert an object, a "Cannot start the application required" message appears

You may receive this message if the source program can’t be opened, probably because of interference from another program on your computer, such as an antivirus program. The error message prompts you to repair the source program. If the problem persists after you repair the source program, try starting Windows in Safe mode before you insert the object. For more information, see the Help documentation for your version of Windows.

Top of Page

Applies To: Outlook 2007, PowerPoint 2007, Word 2007



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language