Create and print labels using mail merge

When you want to use labels to send a bulk mailing to people on your address list, you can use mail merge to create a sheet of address labels. Each label contains an address from your list. You can also create and print labels without using mail merge.

Note: If you want to mail merge directly to envelopes, see Mail merge with envelopes.

Three files in the mail merge process, which is a main document plus a mailing list that produces sets of letters or email messages, envelopes, or labels.

These are the documents involved in creating and printing labels using the mail merge process:

  • Your main document
    This is the document you use to set up the layout of the labels in the mail merge. You can also set up any content that you want repeated on each label, such as a company logo or your return address on shipping labels.

  • Your mailing list
    Your mailing list is the data source that Word uses in the mail merge. It's a file that contains the addresses to be printed on the labels.

When you combine those two documents, you'll have your address labels.

Step 1: Set up your mailing list

The mailing list can be an Excel spreadsheet, a directory of Outlook contacts, an Access database, or an Office address list. It contains the records Word pulls information from to build the addresses for the labels.

  • If you don’t yet have a mailing list, you can create a new list in Word during mail merge.

  • If you're using an Excel spreadsheet, make sure the column for ZIP Codes or postal codes is formatted as text so that you don't lose any zeros. For more information, see Prepare your Excel data source for a Word mail merge.

  • If you want to use your Outlook contacts, make sure Outlook is your default email program.

Step 2: Prepare the main document for the labels

  1. In Word, choose File > New > Blank Document.

  2. On the Mailings tab, in the Start Mail Merge group, choose Start Mail Merge > Labels.

    Click Start Mail Merge and choose Labels to create a sheet of labels to merge to.

  3. In the Label Options dialog box, under Label Information, choose your label supplier in the Label vendors list.

    Label vendor and product number options

  4. In the Product number list, choose the number that matches the product number on your package of labels.

    Note: If you’re using a continuous-feed printer, you’ll have a different list of product numbers. Be sure to choose Continuous-feed printers under Printer information to see the relevant list.

  5. Choose OK.

    Your document should display the dimension and shape of your chosen labels. If it doesn't, on the Layout tab, in the Table group, choose View Gridlines.

    A page of blank labels in Word 2016

Step 3: Link your mailing list to your labels

  1. On the Mailings tab, in the Start Mail Merge group, choose Select Recipients, and then choose one of the following:

    Type a New List command

    • If you don’t have a mailing list, choose Type a New List and create one.

      or

    • If your mailing list is in an Excel spreadsheet, an Access database, or another type of data file, choose Use an Existing List. Then browse to your list and choose Open.

      or

    • If you’re using your Outlook contacts, choose Choose from Outlook Contacts.

  2. Do one of the following:

    • To make labels for your entire mailing list, go to "Step 4: Add the addresses to the labels."

      or

    • To make labels for only some of the names in your list, on the Mailings tab, choose Edit Recipient List.

      As part of Word mail merge, on the Mailings tab, in the Start Merge Group, choose Edit Recipient List.

  3. In the Mail Merge Recipients box, choose the names you want to add to your labels.

    Select rows by checking the check box

    Note: You can also sort or filter the list to make finding names and addresses easier.

Step 4: Add the addresses to the labels

The address block is a mail merge field. Also known as a placeholder, you use the merge field to mark the place where you want addresses to appear on the label.

Tip: If you want to add a picture—a logo, for example—to the label and have it appear before the address block, it's best to do so now. Follow the guidelines in the "Add a picture to the label" subsection of Step 4.

  1. On the Mailings tab, in the Write & Insert Fields group, choose Address Block.

    As part of Word mail merge, on the Mailings tab, in the Write & Insert Fields group, choose Address Block.

  2. In the Insert Address Block dialog box, choose a format for the recipient's name as it will appear on the label.

    Address block options

    Note: Choose Preview Results, and then choose the Next Next record button for mail merge preview results record button or choose the Previous Previous record button for mail merge preview results record button to move through records in your data source and view how an address will appear on the label.

  3. Choose OK.

    Tip: To change how your address block is aligned on the labels, choose the address block, and on the Home tab. in the Paragraph group, choose Align Left, Center, Align Right, or Justify.

  4. In the Write & Insert Fields group, choose Update Labels to apply the change to each label.

    Click the Update Labels button on the Ribbon to apply changes across the entire sheet of labels.

    Note: If you don't see your addresses, choose Preview Results.


Add a picture to the label

You can insert a picture—a logo, for example, into the label. Once inserted, you can manipulate the size, format, and style of the picture.

  1. After you choose a label format in the Insert Address Block dialog box, place your cursor to the left of the «AddressBlock» field code.

    In Layout Options, you can position the picture by choosing Square or Tight.

  2. On the Insert tab, choose Pictures, find the file you want, select it, and then choose Insert.

  3. If necessary, do one of the following to adjust the image:

    • Manually resize (choose a handle), change the orientation (choose rotate), or move (drag) the picture.

      or

    • Choose Layout Options The Layout Options button and work with any of the available options.

  4. Choose Mailings > Update Labels to see the picture on each label.

For tips about working with pictures, see Insert pictures in Office 2013 and Office 2016.


Verify merge field names

Make sure Word finds the names and addresses in your mailing list.

  1. On the Mailings tab, in the Write & Insert Fields group, choose Match Fields.

  2. In the Match Fields box, the column on the left are the field names that Word uses in an Address Block. The column on the right lets you match up fields in your data source to those field names. Verify that the field names that appear on the left side match the names of column headings for records in your mailing list so Word can put the correct data in the correct place on your label.

    Match Fields dialog box
  3. Do one of the following:

    • If the field names shown match column headings you used for records in your mailing list data source, do nothing.

      or

    • If (not matched) appears in a field name that you expected to match a column heading in your data source, choose the drop-down arrow, and then choose the field name in your mailing list data source. Repeat as necessary.

  4. Choose OK.

Step 5: Preview and print the labels

Do a final check before you print the labels.

  1. On the Mailings tab, choose Preview Results.

    In Word, on the Mailings tab, the Preview Results group.

  2. Choose the Next Next record button for mail merge preview results record button or the Previous Previous record button for mail merge preview results record button to make sure the names and addresses on all the labels look right.

    Tip:  To go to the start of the list, choose the First First record button for mail merge preview results record button, and to go to the end of the list, choose the Last Last record button for mail merge preview results record button.

  3. Choose Finish & Merge > Print Documents.

    Screenshot of the Mailings tab in Word, showing the Finish & Merge command and its options.

Step 6: Save your labels document

When you save the mail merge document, it stays connected to your mailing list so that you can use it for your next bulk mailing. Next time you open the mail merge document, choose Yes when Word prompts you to keep the connection.

To change the addresses for the labels in the mail merge document

  • Open the mail merge document for labels and choose Edit Recipient List to sort, filter, and choose specific addresses.

See also

Do you have a question about Word mail merge that we didn't answer here?

Post a question in the Word community forum

Help us improve Word

Do you have suggestions about how we can improve mail merge (or any other feature) of Word? If so, please visit Word User Voice and let us know!

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×