Create a timeline in Project

A timeline can really help you out when you need to report “big picture” project information. It’s a professional-looking snapshot of key tasks and milestones that’s good to go in any status meeting — just drop it into a PowerPoint slide or Word doc, print it, or email it to your boss.

Tip   The timeline is on by default most of the time. It appears above the current view.

  1. Click View, and then select Timeline.

    Timeline check box in Project

  2. Right-click a task, and then click Add to Timeline. Repeat this for each task or milestone you want to add.

Keep reading for more about timelines:

New in Project 2016: Multiple timelines

If you're using Project 2016, you can create a second timeline bar, to show multiple timelines, and then you can change the start and end dates for each timeline.

Multiple timelines with custom start and finish dates

To add another timeline bar

  1. Click the Timeline view, and then click Format > Timeline Bar.

    Timeline Bar

  2. Right-click a timeline and choose Date Range to choose custom start and finish dates.

    Date Range

Top of Page

Rearrange tasks, change colors, and more

You can use the timeline as-is, or you can rearrange the tasks any way you want, add text, and even change their colors to make them stand out.

Before:

Basic timeline in Project

After:

Formatted timeline in Project

Here's how! Click anywhere in the timeline, and then click Format to see all your options for making the timeline look better.

Format tab for the Timeline view

Arrange tasks

  1. Click a task in the timeline.

  2. Click Format > Display as Callout. The task now points to the timeline from above or below.

  3. Drag the task to where you want it.

  4. Click a callout and then click Display as Bar to turn it back into a bar.


Display as Callout button in Project

Add rows

Drag tasks up or down within the timeline to show them on different rows. If you're working with multiple timelines in Project 2016, you can drag tasks between timelines, as well.


Drag tasks between rows and timelines

Change colors

Click the task you want to change in the timeline. To pick a bunch of tasks at the same time, hold down Ctrl and click each one.

  1. Click Background Color (the little paint bucket) and pick the color you want.

  2. Use the other options in the Font group to change the look of the task. This works the same as in other Office programs.


Timeline Font group in Project

Change the date format

Click anywhere on the timeline, click Format > Date Format, and pick the format you want. This list is also where you go to get rid of dates on the timeline altogether.


Timeline Date Format button and menu in Project

Tip    When you paste a timeline into Word, PowerPoint, Outlook, Excel, or Visio, you get even more advanced formatting options. You can add reflections, 3D effects, gradients, and more to your timeline.

Project timeline formatted in PowerPoint

Top of Page

Share the timeline

  1. Click anywhere in the timeline.

  2. Click Format > Copy Timeline, and pick a size:

    Copy Timeline button and menu in Project

    • For E-mail. Small. Fits easily in an Outlook email message.

    • For Presentation. Medium. Designed to work in a PowerPoint slide.

    • Full Size. Large. The same size it appears in Project.

  3. Paste the timeline into any program that displays graphics.

Top of Page

Print the timeline

  1. Drag the line underneath the timeline to the bottom of the screen.

  2. Click File > Print.

To return to the split view, click View and then select Timeline.

Top of Page

Applies To: Project Standard 2016 Preview, Project Professional 2013, Project Standard 2010, Project 2010, Project Professional 2016 Preview, Project Standard 2013



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language