Create a mail or e-mail merge in Publisher

You can use mail or email merge when you want to create a large number of documents that are mostly identical but include some unique information. For example, you can use mail merge to create individually customized publications with personalized notes or unique addresses and salutations. You also can use mail merge to create a product announcement that you want to customize before sending to specific people. The text of the publication is always the same, but the name and address are different for each recipient.

In this article

Choose Mail Merge or Email Merge

Create or connect to the recipient list

Prepare your publication

Create the merged publication

Cancel a merge

Choose Mail Merge or Email Merge

The first thing to do is choose if you are creating a mail merge for printing or an email merge for online distribution.

  • Click the Mailings tab and choose either Mail Merge or E-Mail Merge.

Create or connect to the recipient list

To perform a mail merge, you'll need to open a new or existing publication and then connect to a data source (a file containing the unique information that you want to include). A data file may contain a list of names and addresses, product data, or pictures. The data file can be in a variety of formats, including:

  • Outlook Contacts list

  • Excel worksheets

  • Word tables

  • Access database tables

  • Text files in which tabs or commas separate the columns, and paragraph returns separate the rows

You can connect to an existing list or data source, or you can create a new recipient list. If you want to use only certain entries in your list, you can filter your list by a specific criterion. You can also sort the items in alphabetical order.

Note   If you want to merge pictures into your publication pages, your data source must include either file names or paths for the picture files that you want to merge. Don't include the actual pictures or images in your data source.

Select Recipients from the ribbon

Use an existing list

  1. Click Mailings > Select Recipients > Use Existing List.

    By default, Publisher stores data sources in the My Data Sources folder. You may need to browse to locate your data source.

  2. In the Select Data Source dialog box, click the data source that you want, and click Open.

    Depending on the type of data source that you select, other dialog boxes may appear requesting specific information. For example, if your data source is an Excel workbook with info on multiple worksheets, you'll need to select the worksheet containing the info you want.

Select from Outlook Contacts

  1. Click Mailings > Select Recipients > Select from Outlook Contacts.

    If you're prompted to choose a mail profile, click the profile that you want, and then click OK.

  2. In the Select Contacts dialog box, click the contact list that you want, and then click OK.

    All of the contacts in the folder appear in the Mail Merge Recipients dialog box, where you can filter and sort the list of recipients to include in the merge.

Type a new list

If you don't have an existing list to connect to, you can create a new list.

  1. Click Mailings > Select Recipients > Type New List.

  2. In the New Address List dialog box, type the info for the first entry in the fields relevant for your mailing.

    Note    To change the default columns, click Customize Columns and add, delete, rename, and reorder the columns in the list.

  3. When you've finished entering info for the first entry, click New Entry.

  4. Repeat step 2 and step 3 until you have finished adding entries, and then click OK.

  5. In the Save Address List dialog box, type a name for the address list in the File name box, and save it.

    Note   By default, Publisher saves address lists in the My Data Sources folder. It's best to keep the address list here because this is also the default folder where Publisher looks for data sources.

    All of the contacts in your new list appear in the Mail Merge Recipients dialog box, where you can filter and sort the list of recipients to include in the merge.

Select recipients

In the Mail Merge Recipients dialog box, you can select the recipients that you want to include in the merge. Select the check boxes next to the recipients that you want to include, and clear the check boxes next to the recipients that you want to exclude.

If you want to use only certain entries in your list, you can filter your list by a specific field or criterion. After you filter the list, you can use the check boxes to include and exclude records.

Filter items in the list:

  1. Click the arrow next to the column heading of the item you want to filter by.

  2. Click any of the following:

    • (Blanks) displays all the records in which the corresponding field is blank.

    • (Nonblanks) displays all the records in which the corresponding field contains information.

    • (Advanced) opens the Filter and Sort dialog box, which you can use to filter on multiple criteria. You also can click Filter under Refine recipient list in the Mail Merge Recipients dialog box to open the Filter and Sort dialog box.

    • To quickly select or clear all items, select or clear the check box column heading.

      Tip   If your data source contains records that share the same information, and there are ten or fewer unique values in the column, you can filter by specific information. For example, if there are multiple addresses that list Australia as the country/region, you can filter on Australia.

      The Mail Merge Recipients dialog box displays only the designated records. To display all the records again, click (All).

If you want to see items in alphabetical order, you can sort the items in your list.

Sort items in the list:

  • In the Mail Merge Recipients dialog box, click the column heading of the item you want to sort by. For example, if you want to display the list alphabetically by last name, click the Last Name column heading.

  • To sort using multiple criteria, in the Mail Merge Recipients dialog box, click Sort. In the Filter and Sort dialog box that appears, select the criteria you want to sort by.

Top of Page

Prepare your publication

A mail merge creates many documents from a single template using placeholder info and unique information that is added to the placeholder info on each document. After getting the recipient list together, you can get the main template ready.

Insert a text box

  1. Click Insert > Draw Text Box Button image.

  2. In your publication, point to where you want one corner of the text box to appear, and then drag diagonally until you have the text box size you want.

Add the text you want in every version

  • Click inside the text box, and then type the text you want to appear in every version of your mail merge publication.

Add data fields to your publication

Insert mail merge fields

  1. In your mail merge publication, click inside the text box where you want to insert the data field.

  2. Insert any of the following:

    • Address block with name, address, and other information:

      1. In the Write & Insert Fields group, click Address block.

      2. In the Insert Address Block dialog box, click the address elements that you want to include, and then click OK.

        Note   If the names of the data fields in your data source don't match the names of the fields that Publisher uses for the address block, you may need to click Match Fields in the Insert Address Block dialog box. In the Match Fields dialog box, use the drop-down lists to select the fields from your data source that correspond to the Publisher fields.

    • Greeting line

      1. In the Write & Insert Fields group, click Greeting line.

      2. In the Greeting Line dialog box, select the greeting line format, which includes the salutation, name format, and following punctuation.

      3. Select the that text you want to appear in cases where Publisher cannot interpret the recipient's name; for example, when the data source contains no first or last name for a recipient, but only a company name, and click OK.

        Note    If the names of the data fields in your data source don't match the names of the fields that Publisher uses for the greeting line, you may need to click Match Fields in the Greeting Line dialog box. In the Match Fields dialog box, use the drop-down lists to select the fields from your data source that correspond to the Publisher fields.

    • Picture

      1. In the Write & Insert Fields group, click Picture, and then click Insert Picture Field.

      2. In the Insert Picture Field dialog, select the picture field to insert.

      3. Note   If you want to merge pictures into your publication pages, your data source must include either file names or paths for the picture files that you want to merge. Do not include the actual pictures or images in your data source.

    • Individual fields of information

      • In the Write & Insert Fields group, select Insert Merge Field, and click the fields that you want to include in the text box.

Format the data fields

You can apply formats to the data fields and any other text you've added (such as a greeting of Hello or a salutation like Dear...) to change the appearance of the merged data. To format the merged data, you'll need to format the data fields in your mail merge publication.

In your mail merge publication, select the field containing the information that you want to format.

  • If the field is an Address Block or Greeting Line, in the Write & Insert Fields group select Format.

  • If the field is an individual data field, on the Text Box Tools Format menu, click Font, and then select the options that you want.

  • If the field selected is recognized by Publisher as being a number, currency, date or time, click Format and change the formatting of how those kinds of fields are displayed.

Preview recipient data in the data fields in your publication

You can review how your publication will appear with actual data in the merged fields.

To preview your publication, click Preview Results, and then do any of the following:

  • To preview entries in order, click the navigation buttons Forward buttons Back button to see how each entry will appear in your merged publication.

    The information from the first record of your data source populates the merge fields. You cannot edit your data source entries on your publication pages, but you can format, move, or delete data fields there.

  • To find and preview a specific entry in your data source, click Find a recipient, and then enter the search criteria in the Find Entry dialog box.

If you need to, you can make changes to your recipient list. Do any of the following:

  • To exclude a particular recipient from the merge, click Exclude this recipient.

  • To change the list of recipients, click Edit recipient list, and then make your changes in the Mail Merge Recipients dialog box.

After you complete your mail merge publication and insert all of the merge fields, File > click Save As, name your publication, and click Save.

Top of Page

Create the merged publication

To create the merged publication, click the Finish & Merge button and follow the directions below to print, preview, save it, add the merged pages to another publication, or send them in email.

Complete the mail merge

Print your merged publication

  1. Click Merge to Printer.

  2. In the Print space, select the options that you want, and then click OK.

    Important   To print different sets of merge data—for example, different names and addresses—on each sheet of paper, click Multiple pages per sheet in the Printing options section. If you choose Multiple copies per sheet, each sheet of paper will contain multiple copies of the same data.

    Print multiple pages per sheet

Save the merged publication for later

If you want to edit your merged pages, save them for later use, or print them at a later time, you can collect and save all of your merged pages as a single new merged publication that contains the actual data instead of merge fields.

  1. Click Merge to New Publication.

  2. In your new publication, in the Mail Merge task pane, click Save this publication. Name your new publication, and click Save.

Add the merged pages to an existing publication

If you plan to add your merged pages to the end of an existing publication, make sure that your mail merge publication matches the existing publication in the following ways:

  • Page size (height and width)

  • Page view (one-page spread or two-page spread)

  • Publication type (web or print)

  • Page order (left-to-right or right-to-left)

Publisher adds merged pages to a new or existing publication but can't add them to an open publication. If a publication that you want to merge to is open, be sure to save and close it before you complete the merge.

  1. Click Add to Existing Publication.

  2. In the Open Publication dialog box, locate the publication to which you want to add the merged pages, and then click Open.

  3. In the existing publication, click Save this publication in the Mail Merge task pane to save your updates.

Send email messages

If you are creating an email merge the only option available under Finish & Merge will be Send Email Message.

  1. Click Send Email Message.

  2. In the Merge to Email dialog box, select the recipient field from the To drop-down list. In most cases this will be Email Address.

  3. Under Subject, type the subject line. Under Items to insert, click any data fields that you want to insert in the subject line.

  4. Click Options to specify any other options that you want, such as Cc or Bcc recipients or message attachments, and click Send.

Save the mail merge publication

If you also save the publication containing the merged fields, you can go back and edit the fields and create a new merged publication. To save your merged publication, do the following:

  1. Click File > Save.

  2. Give the publication a name, and click Save.

Top of Page

Cancel a merge

You can cancel a merge to disconnect a mail merge publication or a catalog merge template from its data source.

  1. Click Mailings tab > Select Recipients, and then click Cancel Merge.

    Cancel mail merge

  2. When asked if you want to cancel the merge, click Yes.

    Note   If you cancel a mail merge, fields other than Address Fields, Greeting Lines, and Address Blocks are converted to regular text.

Top of Page

Applies To: Publisher 2013, Publisher 2010



Was this information helpful?

Yes No

How can we improve it?

255 characters remaining

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!

Support resources

Change language