Create a basic network diagram

Basic network diagrams show the primary pieces of your network and how those pieces are connected. This article describes how to quickly create a basic network diagram in either Microsoft Office Visio Standard or Microsoft Office Visio Professional. If you have Visio Professional installed, you can create a more detailed network diagram by using the Detailed Network Diagram template. The difference between the basic and detailed network diagram templates is that the Detailed Network Diagram template comes with more network shapes.

The following illustration shows a basic network diagram.

This is an image of a network created with the Basic Network solution.

  1. On the File menu, point to New, point to Network, and then click Basic Network Diagram.

  2. From Network and Peripherals, drag a Ring network or Ethernet shape onto the drawing page.

  3. From Computers and Monitors or Network and Peripherals, drag network device shapes onto the drawing page.

  4. Attach devices to the Ring network or Ethernet shape by using the shape's built-in connectors:

    1. Click the Ring network or Ethernet shape.

    2. Place the pointer over a control handle Control handle image - yellow diamond . When the pointer changes to a four-headed arrow, drag it to a connection point Connection point image - blue X on one of the device shapes.

      When the device shape is correctly connected to the Ring network or Ethernet shape, the connection point turns red, indicating that it is glued.

      Tip: To hide an unused connector, drag the control handle Control handle image - yellow diamond back to the Ring network or Ethernet shape.

  5. To add text to a network shape, click the shape and type. To move the text, drag the control handle Control handle image - yellow diamond .

  6. To store data with a shape, on the View menu, click Shape Data Window, and in the Shape Data window, type values for the data that you want to store.

Tip: To number the shapes in your diagram, on the Tools menu, point to Add-Ons, point to Visio Extras, and then click Number Shapes. On the General tab, choose the options that you want, click OK, and then select the shapes that you want to number.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!